Upgrading from Evergreen 1.6.0.8 to 1.6.1.8

These notes are still very much a work in progress!

  1. Recommended to match a fresh installation, but not required: Upgrade to the latest version of OpenSRF 1.6.x.
  2. Install new prerequisites. You can use the prerequisite installation makefile (Open-ILS/src/extras/Makefile.install) to install a complete set of prerequisites for your distribution. At a minimum, you need to install the Perl module UUID::Tiny (cpan install UUID::Tiny should do the trick.)
  3. Run the SQL upgrade scripts to update your database schema, substituting your database user name for <user> and database hostname for <hostname> in the following commands:
    psql -U <user> -h <hostname> -f Open-ILS/src/sql/Pg/1.6.0.4-1.6.1.0-upgrade-db.sql
    psql -U <user> -h <hostname> -f Open-ILS/src/sql/Pg/1.6.1.0-1.6.1.1-upgrade-db.sql
    psql -U <user> -h <hostname> -f Open-ILS/src/sql/Pg/1.6.1.1-1.6.1.2-upgrade-db.sql
    psql -U <user> -h <hostname> -f Open-ILS/src/sql/Pg/1.6.1.2-1.6.1.3-upgrade-db.sql
    psql -U <user> -h <hostname> -f Open-ILS/src/sql/Pg/1.6.1.3-1.6.1.4-upgrade-db.sql
    psql -U <user> -h <hostname> -f Open-ILS/src/sql/Pg/1.6.1.4-1.6.1.5-upgrade-db.sql
    psql -U <user> -h <hostname> -f Open-ILS/src/sql/Pg/1.6.1.5-1.6.1.6-upgrade-db.sql
    psql -U <user> -h <hostname> -f Open-ILS/src/sql/Pg/1.6.1.6-1.6.1.7-upgrade-db.sql
    psql -U <user> -h <hostname> -f Open-ILS/src/sql/Pg/1.6.1.7-1.6.1.8-upgrade-db.sql

    It is normal for some of these upgrades to report errors if previous upgrades or local fixes/customizations have already created some of the database objects.

  4. Update opensrf.xml and opensrf_core.xml to add the new entries related to the open-ils.booking service that you'll find in the corresponding opensrf.xml.example and opensrf_core.xml.example files.
  5. Update the Apache configuration files to match the changes you will find in the Open-ILS/examples/apache directory, primarily for PasswordReset functionality.
  6. As the opensrf user, run autogen to refresh the static JavaScript files:
    cd /openils/bin
    ./autogen.sh -c /openils/conf/opensrf_core.xml -u
upgrading/evergreen/1.6.0.8_to_1.6.1.2.txt · Last modified: 2011/03/18 02:29 by bshum
 
Except where otherwise noted, content on this wiki is licensed under the following license: CC Attribution-Share Alike 3.0 Unported
Recent changes RSS feed Donate Powered by PHP Valid XHTML 1.0 Valid CSS Debian Driven by DokuWiki

© 2008-2013 GPLS and others. Evergreen is open source software, freely licensed under GNU GPLv2 or later.
The Evergreen Project is a member of Software Freedom Conservancy.