12:01:43 <bshum> #startmeeting
12:01:43 <pinesol_green> Meeting started Tue Dec 20 12:01:43 2011 US/Eastern.  The chair is bshum. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:01:43 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic.
12:02:06 <jbondharris> I got the postgresql-plperl package - do I need to reinstall PostgreSQL, or can I just pick it up at the eg_db_config command?
12:02:28 <bshum> Meeting Agenda: http://evergreen-ils.org/dokuwiki/doku.php?id=dev:meetings:2011-12-06
12:02:41 <bshum> I think dbs might be adding some stuff to it.
12:02:56 <bshum> Oops
12:03:00 <bshum> That's the old one
12:03:06 <bshum> http://evergreen-ils.org/dokuwiki/doku.php?id=dev:meetings:2011-12-20
12:03:16 <eeevil> jbondharris: just start from that command
12:03:33 <jbondharris> Thanks, I'll give it a go.
12:03:36 <bshum> #topic Review Past Action Items
12:03:38 * dbs just added the two things I wanted to get on here
12:04:07 <bshum> #info moodaepo to send out the revised proposed time-based release schedule and support cycle for feedback.
12:04:31 <moodaepo> bshum: Just hit send on that action item : )
12:04:38 <dbs> moodaepo++
12:05:06 <bshum> #meetingtopic Dev meeting agenda: http://evergreen-ils.org/dokuwiki/doku.php?id=dev:meetings:2011-12-20
12:05:20 <bshum> moodaepo++
12:05:31 <bshum> Sorry folks, playing with the bot commands as I learn
12:05:33 <jbondharris> Just ran perl...eg_db_config.pl, and got same error.
12:06:16 <bshum> #info 2. moodaepo to move OpenSRF 1.6 to code museum from downloads page
12:06:17 <moodaepo> jbondharris: We are currently in a meeting could you try again in about an hour? Thanks
12:06:31 <dbs> jbondharris: "sudo ldconfig; sudo /etc/init.d/postgresql restart" maybe -- good luck
12:06:34 <jbondharris> OK, it's about lunch time anyway.
12:06:53 <moodaepo> bshum: Completed
12:07:16 <moodaepo> Well haven't moved it to code museum just took it off the downloads page.
12:07:32 <bshum> moodaepo: I think I have it on the code museum already in anticipation.
12:07:43 <bshum> So I guess we're set there too.
12:08:23 <bshum> #info 3. bshum to ask DIG about finding a representative to join the Release Team (and review related processes)
12:08:34 <bshum> #action bshum to follow up on that in early 2012, if not sooner.
12:08:57 <bshum> Anything else to do before we move to new business?
12:09:12 <dbs> point of order: isn't #info for stuff you want recorded in the minutes? so, "#info moodaepo has removed OpenSRF 1.6 from the downloads page; bshum has added it to the code museum" ?
12:09:42 <bshum> dbs: Hmm, yes.  Though I'm not sure how that all lines up now that I think about it, doh :S
12:09:47 <dbs> heh
12:09:49 <bshum> I probably messed up the process.
12:09:54 <bshum> Oh well, fun first minutes for sure.
12:09:55 <berick> good practice run
12:10:01 <dbs> it's the first time through, we'll learn :)
12:10:02 <dbs> right!
12:10:06 <tsbere> How about a "learn how to use meetbot" action item, with a dokuwiki page for quick tips?
12:10:21 <bshum> #info moodaepo has removed OpenSRF 1.6 from the downloads page; bshum has added it to the code museum
12:10:41 <dbs> #idea Link to http://wiki.debian.org/MeetBot from dev:meetings ?
12:11:24 <moodaepo> #info moodaepo has sent out a revised release/EOL policy discussed during the last developer's meeting and requested feedback.
12:11:44 <eeevil> #info eeevil added a request for 2.2a2 discussion to the agenda
12:11:58 <bshum> #topic New Business
12:12:15 <bshum> #chair dbs eeevil
12:12:15 <pinesol_green> Current chairs: bshum dbs eeevil
12:12:32 <moodaepo> #idea Link to http://meetbot.debian.net/Manual.html on dev:meetings for advanced use?
12:12:32 <bshum> That lets you do more commands I think.
12:13:07 <dbs> #info Get release notes into docs/ directory (see user/dbs/relnotes_22 in working repo)
12:13:16 * tsbere pre-emptively notes he can cut another 2.2 alpha if desired.....as he runs out the door to grab his lunch. <_<
12:13:55 <dbs> Any further thoughts on that since approximately 9:58 Eastern today?
12:14:29 <dbs> if not, I'll take an #action to open a bug - and then maybe we can commit to the release notes as we go (to help out with that whole release process thing)
12:14:29 <eeevil> #agree
12:15:34 <dbs> #action dbs to open a bug that points to user/dbs/relnotes_22 for a merge
12:16:03 <dbs> Probably should document this somewhere, perhaps in "contributing code"?
12:17:21 <dbs> so if there's no dissent...
12:17:29 <bshum> +1 to new notes
12:17:33 <moodaepo> +1
12:17:59 <berick> #agreed
12:18:06 <dbs> #agreed Maintain running release notes in docs/RELEASE_NOTES_x_y.txt files in source
12:18:17 <moodaepo> #agreed
12:18:45 <eeevil> #agreed
12:18:49 <dbs> (I think #agreed is for noting final agreement on a given item, not for replacing +1 / -1, but am entirely likely to be wrong!)
12:18:54 <eeevil> since I spelled it r0ng
12:19:08 <berick> dbs: yr probably right..
12:19:15 <berick> yeah, "only for chairs"
12:19:26 <dbs> Fun :)
12:19:34 <berick> #info +1 ;)
12:19:42 <moodaepo> berick++
12:19:47 <bshum> Heh
12:19:53 <dbs> Cool. okay,
12:20:05 <dbs> #info Get “version_upgrade” directory into master: in short, one directory that contains the authoritative version of all point-to-point upgrades at release boundaries
12:20:47 <dbs> https://bugs.launchpad.net/evergreen/+bug/894052 contains the arguments I'm making for this approach; not sure if there's any concern about it though
12:20:47 <pinesol_green> Launchpad bug 894052 in Evergreen "Point-to-point version upgrade scripts should be kept in master and backported through applicable releases" (affected: 1, heat: 6) [Undecided,New]
12:21:33 <bshum> #idea Next meeting, I guess we should format things so that the #topic = things to be talked about, and #info = things we say about said agenda item.
12:22:07 <dbs> #agreed Next meeting, #topics will be #topics and #info will be #info and #ideas will be #ideas
12:22:25 <dbs> oh the power of the chair!
12:23:22 <bshum> #info I like that suggestion about having all upgrades in one place.
12:23:28 <dbs> If there's no discussion, +1 / -1s?
12:23:30 <moodaepo> I was going to say should there be more than one chair? Logs might get awkward if one chair feels a topic is finished and starts another...or does that happen ONLY after #agreed (as policy)
12:23:43 <moodaepo> +1 # all upgrades in one place
12:24:03 <berick> +1
12:24:26 * moodaepo should probably discuss meetbot stuff after the meeting.
12:24:56 <dbs> If we're for it, I'll need to find the right spot to document the process too - I guess in the release process doc
12:25:53 <bshum> Sounds good.
12:25:57 <bshum> action item!
12:26:04 <dbs> eeevil: +1 / 0 / -1?
12:26:44 <eeevil> sorry, looked away
12:26:54 <eeevil> +1
12:27:19 <dbs> Okay, sounds like
12:27:39 <dbs> #action dbs to update the release process doc with a mention of the version_upgrade directory
12:27:49 <eeevil> hopefully that will lead to the "it's all just upgrades from a baseline of 'CREATE DATABASE'" nirvana I dream of ;)
12:27:51 <dbs> anyone want to take on the "merge the branch" action?
12:28:04 <eeevil> dbs: I'll merge it
12:28:08 <dbs> that would be awesome ;)
12:28:27 <dbs> #action eevil to merge the branch with the version_upgrade directory
12:29:07 <eeevil> that's user/dbs/lp894052-version-upgrade, to be clear
12:29:11 <dbs> #agreed Henceforth we shall maintain release point-to-point database upgrade scripts in Open-ILS/src/sql/Pg/version_upgrade in master, and backport where applicable
12:29:29 <dbs> correctamundo
12:29:41 <dbs> at least if the bug description is accurate :)
12:30:02 <dbs> #topic Time to cut another 2.2 alpha?
12:30:13 <dbs> heh
12:30:20 <bshum> #info tsbere had offered to cut one before he left for lunch ;P
12:30:22 <dbs> #info tsbere offered to cut the alpha
12:30:27 <bshum> Oops
12:30:32 <dbs> hee
12:30:38 <bshum> moodaepo: You're right, one chair to rule them all.
12:30:39 * tsbere has returned with said lunch, took less time than anticipated
12:30:42 <dbs> who's the chair of this dang meeting :)
12:30:51 * dbs subsides
12:31:03 <gmcharlt> dbs: I believe the meeting has a couch
12:31:04 <moodaepo> heh
12:31:10 <bshum> dbs: Have the reigns, I don't mind.
12:31:18 <bshum> dbs: Good that we all get some practice
12:32:14 <dbs> I guess, I've got to chair the oversight board meeting in 1/2 an hour (by _voice_, how archaic!)
12:32:29 <bshum> pinesol_green++ :)
12:32:30 <pinesol_green> bshum: Error: ":)" is not a valid command.
12:32:41 <bshum> Or maybe not.
12:32:42 * dbs relinquishes chairship, but has discussion
12:32:49 <eeevil> who wants to go on a merging binge? this cold I have won't let me get motivated enough.
12:32:53 <moodaepo> So what do the other devs think about 2.2 alpha2?
12:33:18 <bshum> #unchair eeevil dbs
12:33:18 <pinesol_green> Current chairs: bshum
12:33:32 * tsbere has been hoping for a merging binge of some of his stuff. Specifically holds-related stuff. <_<
12:33:34 <eeevil> the sooner 2.2 is out, the better, IMO. tsbere: how's master working out for you now-a-days?
12:33:39 <dbs> http://goo.gl/3EAzQ shows a number of bugs targeted for 2.2.0-alpha2
12:34:07 <tsbere> master is working out fine-ish right now. Still lots of problems. Lots of coding to be done. Lots of waiting on existing code to be approved before I build on it ;)
12:34:07 <eeevil> dbs: indeed, hence my curiosity about merge binging :)
12:34:14 <dbs> including 896405 (Fixes for 2.1-2.2 upgrade script (alpha1))
12:34:30 * dbs kind of hates merge binging if it means not-very-tested merging
12:35:04 <dbs> of course, /me is on a roll of apparently committing entirely new directories after careful testing
12:35:06 <eeevil> dbs: well, we see what the alternative is -- no testing and no new code ;)
12:36:01 <dbs> I would rather have a release with less new code - but what new code there is, having been tested before being merged
12:36:28 <eeevil> dbs: of course, but that's not happening (afaict)
12:37:42 <dbs> It is happening, it's just happening slowly. And by having testbeds like the concerto.sql (which now has conjoined items and monograph parts), it becomes easier to test things more completely.
12:37:43 <eeevil> anyway, I'll refrain from my traditional monthly binge
12:38:11 <djfiander> that makes it sound like we need to stage an intervention
12:38:48 <berick> djfiander++ # dropping in from nowhere w/ a joke bomb
12:38:56 <dbs> I think it's important to note that testing and sign-off can be done by people who don't have a commit bit for the origin repo - we haven't seen a lot of that, but some recently, which is encouraging
12:39:09 <eeevil> if non-committers were testing and signing off ... right
12:39:31 <eeevil> anyway, the  point is, 2.2 FTW!
12:41:32 <dbs> Maybe there's something more we can do to help others test and sign-off on branches; I know tsbere documented a complete workflow with expected results for me once, which helped significantly
12:42:46 <dbs> Sounds like an appropriate use for #help
12:42:58 <eeevil> maybe so; a test plan would obv be a good thing. but regardless of committing outstanding features, can we agree to push hard on 2.2a2 targeted /bugs/ and get a2 out asap?
12:43:07 <bshum> dbs: Good idea
12:43:57 <dbs> eeevil: I'm +1 to that; I guess that means that tsbere should set the milestone for his bugs, as they currently don't get pulled into that query I posted
12:44:08 <bshum> dbs: I don't think that's a restricted chairs command, you should be able to use it.
12:44:21 * tsbere tries to remember to milestone *bugs*, features on the other hand....
12:44:25 <eeevil> dbs: ideally, yes, everyone should, that can anyway
12:44:42 <dbs> eeevil: on that note, your unapi_subobject branch vs. a few of my branches - how do you want to proceed?
12:45:18 <dbs> tsbere: I generally set the "next major release" milestone for new features when I add the "pullrequest" tag
12:45:29 <bshum> #help dbs is looking for some better ways to help others test and sign-off on branches
12:46:11 <dbs> eeevil: I've been trying to merge some of the equivalent changes from my standalone branches on top of your collab branch, but as I noted in an email, that doesn't scale well
12:46:28 <eeevil> dbs: if you're generally happy with it, and it helps at least some with the control problems (granularity, etc) then I'm for getting it in
12:46:31 <eeevil> right
12:46:47 <eeevil> it needs to go somewhere -- the graveyard or master
12:47:17 <dbs> eeevil: so you should have a pullrequest bug w/ milestone :)
12:48:24 <eeevil> dbs: assigned to me, you mean?
12:49:22 <dbs> eeevil: I wasn't able to find a bug for that branch
12:49:53 <eeevil> dbs: there wasn't one ... I thought you were saying you'd create one while I merged your stuff in.  sorry I misunderstood
12:49:56 <eeevil> I'll make one
12:49:59 <dbs> heh - okay :)
12:51:29 <bshum> #agreed Noted by eeevil: devs agree to push hard on 2.2a2 targeted /bugs/ and get a2 out asap
12:52:06 <bshum> Anything else on this topic for right now?  Or for the meeting generally.
12:52:09 <dbs> where "asap" means "probably in the new year"?
12:52:19 <eeevil> dbs: can you point me to the bug for the branch of yours that I merged in, please
12:52:34 <dbs> uh, which branch?
12:52:38 * tsbere goes and targets all his pullrequests just so that dbs stops saying they aren't showing up on his list :P
12:52:43 <eeevil> dbs: wow, really? you don't think we can cut an alpha in the next 2 weeks?
12:53:00 <eeevil> dbs: the circ due date thing
12:53:20 <tsbere> eeevil: How many people do you think are fully available during the holiday period we are practically in?
12:53:33 <dbs> eeevil: the holidays might get in the way of testing and merging all those targeted bugs
12:53:59 <eeevil> ahh... we're going to get to 0 bugs before cutting ... oooooooooooooook
12:54:01 * dbs has a father-in-law coming to visit for a week, starting in about 30 minutes :)
12:54:37 <dbs> eeevil: https://bugs.launchpad.net/evergreen/+bug/901976
12:54:37 <pinesol_green> Launchpad bug 901976 in Evergreen "TPAC: Use in-db unapi for copy display in record summary" (affected: 1, heat: 6) [Undecided,New]
12:55:12 <eeevil> dbs: thanks
12:57:36 <dbs> #help If you are capable of setting up a clean Evergreen environment on master, have the ability to push branches to the working repository, and can cherry-pick commits from branches, we need _you_ to help us test and sign-off on branches listed at http://goo.gl/3EAzQ
12:57:53 * dbs needs to run
12:58:01 <dbs> bshum++
12:58:04 <dbs> moodaepo++
12:58:06 <dbs> meetbot++
12:58:08 <bshum> Okay, unless there's anything else, ending this meeting then.
12:58:21 <eeevil> +1
12:58:24 <bshum> #topic MeetBot is here.
12:58:28 <moodaepo> #agreed # Even though it counts for nada
12:58:44 <bshum> #action moodaepo and bshum to poke at writing up a wiki page on how to use MeetBot better next time.
12:58:47 <bshum> #endmeeting