12:00:32 <bshum> #startmeeting Developer Meeting
12:00:32 <pinesol_green> Meeting started Tue Jan 31 12:00:32 2012 US/Eastern.  The chair is bshum. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:00:32 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic.
12:00:52 <bshum> #link Agenda: http://evergreen-ils.org/dokuwiki/doku.php?id=dev:meetings:2012-01-31
12:01:04 <bshum> Anyone else around?
12:01:12 * Dyrcona raises his hand.
12:01:19 <Dyrcona> tsbere will be here shortly.
12:01:35 <tsbere> I am here
12:01:42 <berick> present
12:02:02 <senator> here
12:02:37 <denials> here, prepping to leave
12:02:55 <bshum> Alright, we'll try to make this quick I guess.
12:03:04 <bshum> #topic Review past action items
12:03:25 * moodaepo is now here
12:03:42 <bshum> Looks like everything is all completed from last time except for one.
12:03:44 <moodaepo> kmlussier: Around?
12:04:05 <bshum> #info dbs to update the release process doc with a mention of the version_upgrade directory
12:04:11 <bshum> Deferred for now?
12:05:13 <denials> aye
12:05:24 <bshum> #action dbs to finish that soon-ish
12:05:34 <bshum> #topic New Business
12:06:06 <bshum> #topic Developer Meeting Schedule
12:06:27 <bshum> #link Mailing thread discussion: http://markmail.org/message/vthecxz4pwa7pinn
12:06:38 <tspindler> kathy is getting onnow
12:06:48 <moodaepo> tspindler++
12:06:54 * kmlussier is Kathy Lussier, MassLnc
12:06:55 <bshum> So, we got a few replies about when we're having meetings.  This time is proving more difficult for everyone it seems.
12:07:12 <bshum> Well, not everyone, but several.
12:07:27 * mtcarlson is now here
12:07:57 <Dyrcona> the time isn't that important to me. I don't have a lot of regularly scheduled things.
12:07:59 <tsbere> I find it annoying when we have meetings at noon on Tuesdays. Beyond that, I find the meeting over lunch isn't a bad thing, personally. If I recall it and get lunch first.
12:08:10 <tsbere> and by "we" I mean "the office"
12:08:18 <Dyrcona> tsbere++ # for getting lunch
12:08:45 <berick> that's kind of what I'm hoping to avoid... scrambling to eat
12:08:48 <Dyrcona> yeah. sometime in the early afternoon would be better.
12:08:51 <berick> there's just no need for it
12:09:48 <Dyrcona> someone had a problem with 2:00pm EST, didn't they?
12:09:51 <moodaepo> How does 3PM (1500) CST sound?
12:10:11 <bshum> Dyrcona: I think dbs/denials has a work conflict.
12:10:16 <bshum> On Tuesdays
12:10:26 <bshum> But perhaps we can suggest a different day of the week.
12:10:37 * phasefx_ would prefer times other than noon
12:10:40 <tsbere> We could do the meeting before lunch.
12:10:40 <bshum> (also I think the governance committee meets in the afternoons on Tuesdays too)
12:10:44 <tsbere> instead of after lunch
12:11:00 <Dyrcona> I agree, if dbs has a conflct, we should do our best to accomodate him.
12:11:06 <bshum> I think we suggested after 12 pm EST to give west coast folks an opportunity to attend too.
12:11:12 * bshum waves at mtcarlson
12:11:15 <kmlussier> Does it have to be Tuesday?
12:11:28 <Dyrcona> no, it doesn't have to be tuesday.
12:11:53 * moodaepo waves at mcarlson
12:12:34 * denials will do his best to interact via email in advance or IRC whenever the meeting ends up getting scheduled
12:12:43 <bshum> Well, in order to get some more input, perhaps we should put out some sort of survey to try getting some input about when to have meetings.
12:12:54 <berick> +1
12:12:54 <mtcarlson> 12pm EST or after would be helpful for us on the west coast
12:13:32 <bshum> But generally, I think we can safely agree that 12 noon isn't best anymore?  And afternoon EST would be helpful for west coast.
12:13:47 <bshum> So we're looking at 1-4 pm time on perhaps a different day than Tuesdays.
12:14:04 <denials> alternatively, have rotating meeting times / days and just accept that some people aren't going to be able to make some meetings
12:14:20 <bshum> #action bshum and others to continue thread discussion about developer meeting times.
12:14:28 <Dyrcona> moodaepo suggested 1500 CST, which is 2100 UTC. That time works for me.
12:14:34 <denials> IRC meetings shouldn't be the only form of communication / decision making
12:14:46 <Dyrcona> denials: true on both counts.
12:14:50 <bshum> denials: Very good point.
12:18:39 <Dyrcona> next week?
12:18:43 <bshum> (well that's not a good sign... stupid pinesol)
12:19:13 <denials> +1 to next week
12:19:28 <Dyrcona> we should have our issues worked out by then. :)
12:19:47 <Dyrcona> question is: which day?
12:19:56 <kmlussier> +1 to next week
12:20:03 <moodaepo> +1 # if denials says so!
12:20:24 <tsbere> +1 to next week if some of the higher priority 2.2 tagged items are in
12:21:52 <bshum> #save
12:21:55 <kmlussier> tsbere: Are those enhancements or bug fixes?
12:22:16 <tsbere> kmlussier: I am thinking the bug fixes
12:22:42 <Dyrcona> i said next week so there'd be time to get the more important things in.
12:22:53 <Dyrcona> my stuff can wait. :)
12:23:41 <denials> per http://evergreen-ils.org/dokuwiki/doku.php?id=versioning enhancements can continue until beta is cut
12:25:11 <Dyrcona> yep. I see some medium bugs that I think should by high priority.
12:25:54 <denials> mmm yay network
12:26:02 <bshum> Indeed
12:26:17 <tsbere> Side note: This may be an argument against meetbot. >_>
12:26:27 <bshum> tsbere: Also noted ;)
12:27:16 <denials> bah, if the network is fine then meetbot works, otherwise the notes can be combed from the meetbot commands in the logs
12:27:28 <senator> the good thing about meetbot and similar is that if it fails, all you really have to do is grep your IRC logs to recover the things you wanted meetbot to note, as opposed to carefully reading for context
12:27:33 <senator> what denials said
12:27:42 * denials heads out
12:28:32 <moodaepo> denials++
12:28:44 <Dyrcona> so, an alpha release next week, after "patch Tuesday"?
12:29:08 <moodaepo> Dyrcona: alpha2 or beta1?
12:29:16 <bshum> alpha2, preferred
12:29:28 <bshum> Unless there aren't anything new being finished, but I suspect there are?
12:29:34 <Dyrcona> yes, alpha2, i'd think, so we have a last chance for features.
12:29:44 <frank> Hi everybody, I have a problem when I want to check out a book with an specific due date, It doesn´t work when I select a month that doesn´t have 31 days, could someone help me please?
12:29:44 <moodaepo> Will do
12:29:48 <Dyrcona> i have a couple of small branches.
12:29:53 <berick> +1 to alpha2 next week
12:30:02 <bshum> #info Evergreen 2.2 alpha2 target for next week.
12:30:10 <moodaepo> frank: We are in a meeting could you please try in about 20 minutes or so?
12:30:25 <bshum> #info "patch Tuesday" to go over and review bug fixes waiting to go in.
12:30:31 <frank> moodaepo: oh sorry, yes
12:30:39 <kmlussier> How long do you expect there to be between alpha2 and beta?
12:30:54 <moodaepo> frank: No worries and thanks!
12:31:08 <Dyrcona> i'd like to see 1-2 weeks tops, but it isn't really up to me.
12:31:35 <kmlussier> Just wondering if there should be a deadline for when new features are added.
12:31:54 <Dyrcona> before the beta goes out, is usual deadline, right?
12:32:37 <Dyrcona> do we want to say alpha2 is the deadline or beta1?
12:32:47 <Dyrcona> where's eeevil when you need him?
12:32:58 <senator> pretty sure eeevil would say beta1 is the deadline
12:33:11 <berick> yeah, beta is the deadline for new features
12:33:16 <tsbere> We could say "no new features targeted at 2.2, only existing targeted features and bug fixes" to make it easier to decide. Then only things already targeted on launchpad need apply, new feature wise, as being "blocking" for 2.2 beta?
12:33:54 <Dyrcona> beta works for me.
12:34:38 <Dyrcona> so, alpha2 tentatively next Wednesday, and beta the Wednesday or 2 following?
12:35:25 <kmlussier> Dyrcona++ having an approx date for beta is helpful, whatever the date may be.
12:36:56 <bshum> Maybe 2 following, if there's alot to get added.
12:37:23 <tsbere> Of course, I think someone from MVLC is obligated at this point to say "or we just skip 2.2 and tell everyone to run off of master" ;)
12:37:32 * Dyrcona groans.
12:37:58 <Dyrcona> i'm hoping there isn't a whole lot to add after the alpha. I don't see any really big stuff that is pending.
12:39:17 <kmlussier> And with the level of testing from MVLC, hopefully beta will be in fairly good shape.
12:39:26 <bshum> Alright, is there anything else we should add about 2.2 release right now?
12:39:42 <moodaepo> bshum: I think action item has been decided and we can move on?
12:40:09 <bshum> Okay.
12:40:13 <kmlussier> A general idea of timelines is what I was looking for, and that's been addressed.
12:40:22 <bshum> #topic Google Summer of Code 2012
12:40:33 <moodaepo> Is gmcharlt around?
12:40:40 <Dyrcona> bshum: how 'bout the action items?
12:40:43 <bshum> Since that hasn't been announced yet, I assume dbs just wanted to get a general sense of whether folks would be interested in doing that again.
12:40:58 <moodaepo> Dyrcona: I think he posted it as #info earlier
12:41:00 <bshum> I noted them as "info" previously.
12:41:09 <Dyrcona> ok. thanks.
12:41:14 <bshum> But next time I suppose I should make them action items once we know who they are assigned for.
12:41:20 <bshum> Or just make them open action items :(
12:41:24 <bshum> Oops.
12:41:44 <Dyrcona> sorry for the diversion. back to GSOC.
12:41:50 <bshum> Since dbs isn't here, I'm going to make it an action item for him next time to talk about GSOC stuff.
12:42:04 <Dyrcona> works for me.
12:42:18 <moodaepo> +1
12:42:20 <Dyrcona> I was going to say, I think it is a good idea, but not sure I could mentor anybody.
12:42:23 <bshum> #action dbs to talk about GSOC stuff next time (or send thoughts to -dev mailing list)
12:43:05 <bshum> #help Start thinking about mentoring/projects
12:43:21 <bshum> Any announcements?
12:43:26 <bshum> #topic Announcements
12:43:53 <bshum> Probably not, but I guess that's a remnant from old agendas :S
12:44:09 <Dyrcona> Guess I could announce we're running after our update and fixing bugs.
12:44:17 <moodaepo> Dyrcona++
12:44:42 <bshum> #info Post-conference developer meetup on Saturday afternoon/evening at EG 2012.
12:44:50 <tsbere> See most of my branches from the past 48 hours for "fixing bugs" <_<
12:45:30 <bshum> Alright then.
12:46:20 <bshum> Anything else we should talk about today before we close this meeting?  (next meeting will be determined based on further mailing list feedback)
12:47:15 <Dyrcona> i don't have anything.
12:47:27 <bshum> Alright then, thanks everyone.
12:47:30 <berick> bshum++
12:47:37 <bshum> #endmeeting