#evergreen: 2012-02-27 - Developer Meeting

Meeting started by bshum at 15:00:09 US/Eastern (full logs).

Meeting summary

    1. Agenda: http://evergreen-ils.org/dokuwiki/doku.php?id=dev:meetings:2012-02-27&#agenda (moodaepo, 15:01:08)

  1. Who's here? (sound off with #info if you are!) (bshum, 15:01:50)
    1. bshum is Ben Shum, Bibliomation (bshum, 15:02:03)
    2. mrpeters-isl is Michael Peters, Evergreen Indiana (mrpeters-isl, 15:02:13)
    3. phasefx is Jason Etheridge, Equinox (phasefx_, 15:02:14)
    4. tsbere is Thomas Berezansky, MVLC (tsbere, 15:02:17)
    5. kmlussier is Kathy Lusser, MassLNC (kmlussier, 15:02:19)
    6. Tim Spindler, C/W MARS (tspnidler, 15:02:24)
    7. berick, Bill Erickson, Equinox (berick, 15:02:29)
    8. dbwells is Dan Wells, Calvin College (dbwells, 15:02:34)
    9. csharp is Chris Sharp, GPLS (csharp, 15:02:46)
    10. moodaepo is Anoop Atre, PALS (moodaepo, 15:02:46)
    11. senator is Lebbeous Fogle-Weekley, Equinox (senator, 15:02:57)
    12. eeevil = Mike Rylander, Equinox (eeevil, 15:03:02)
    13. kivilaht1o is Olli-Antti Kivilahti, Library of Joensuu (kivilaht1o, 15:03:07)
    14. dbs = Dan Scott, Laurentian University (denials, 15:03:11)
    15. Dyrcona is Jason Stephenson, MVLC (Dyrcona, 15:04:05)

  2. Review past action items (bshum, 15:04:37)
    1. dbs to update the release process doc with a mention of the version_upgrade directory (bshum, 15:04:46)
    2. jamesrf is James Fournie, BC Libraries Cooperative (jamesrf, 15:06:55)
    3. HELP: Need to find volunteers / assigned developers to manage and establish the parts of the upgrade process for the release checklist. (bshum, 15:08:57)
    4. Need to find missing team members for 2.1 release team and 2.2 release team. (bshum, 15:12:02)
    5. ACTION: moodaepo to start mailing list discussion for to seek volunteers for release team (bshum, 15:13:15)
    6. Other two agenda items are done, so... moving on. (bshum, 15:14:54)

  3. Google Summer of Code 2012 (bshum, 15:15:54)
    1. http://evergreen-ils.org/dokuwiki/doku.php?id=dev:summer_of_coding_ideas (bshum, 15:16:05)
    2. mrpeters-isl has a new VM based on master with instructions on how to upgrade it. (bshum, 15:18:36)
    3. HELP: Find volunteers to test the VM in different virtual environments. (bshum, 15:18:48)
    4. Any GSOC mentor volunteers, please contact dbs for further details. (bshum, 15:35:48)
    5. Correction: Contact dbs/gmcharlt for more details if willing to be a GSoC mentor. (bshum, 15:37:19)
    6. HELP: Request dev list to update wiki pages, add project ideas & submit bite size bugs to launchpad for GSoC. (moodaepo, 15:40:24)

  4. Evergreen 2.2 alpha2 / beta1 / RC ? (bshum, 15:44:25)
    1. http://evergreen-ils.org/meetings/evergreen/2011/evergreen.2011-12-20-12.01.txt (dbs, 15:48:08)
    2. https://bugs.launchpad.net/evergreen/+bug/924367 (tsbere, 16:04:33)
    3. https://bugs.launchpad.net/evergreen/+bug/758982 (dbs, 16:08:50)
    4. ACTION: tsbere to cut Evergreen 2.2 alpha2 this week, pending his tests for make release script, etc. (bshum, 16:11:46)
    5. Final features will need to be merged in before 2.2 alpha3 / beta1. (bshum, 16:12:45)
    6. Correction: dbs notes that alpha3 is not feature-freeze, only beta and beyond (bshum, 16:14:13)
    7. master.evergreen.lib.in.us updated with master as of 2/27 (mrpeters-isl, 16:15:05)
    8. Indiana will put up a server with alpha2 when available (mrpeters-isl, 16:15:23)
    9. AGREED: Generally agreed that decision on alpha3 / beta1 will come after a round of testing alpha2 release. (bshum, 16:15:49)
    10. master.evergreen.lib.in.us staff clients always at: http://master.evergreen.lib.in.us/updates/manualupdate.html (mrpeters-isl, 16:16:34)
    11. Round 1 will last approximately 1 week, but let's see how alpha2 testing goes first, then re-evaluate release schedule. (bshum, 16:25:55)

  5. Applying Xulrunner/Firefox 4+ (bshum, 16:26:24)
    1. Firefox/XULRunner 4+ bug at https://bugs.launchpad.net/evergreen/+bug/942134 - Needs testing. Lots of it. (tsbere, 16:27:13)
    2. HELP: Please help to test the new xulrunner branch. (bshum, 16:27:34)

  6. Next Developer Meeting (bshum, 16:31:35)
    1. ACTION: kmlussier to help setup another Doodle poll to find a good time/date for the next developer meeting week starting on March 5 (bshum, 16:35:45)


Meeting ended at 16:39:02 US/Eastern (full logs).

Action items

  1. moodaepo to start mailing list discussion for to seek volunteers for release team
  2. tsbere to cut Evergreen 2.2 alpha2 this week, pending his tests for make release script, etc.
  3. kmlussier to help setup another Doodle poll to find a good time/date for the next developer meeting week starting on March 5


Action items, by person

  1. kmlussier
    1. kmlussier to help setup another Doodle poll to find a good time/date for the next developer meeting week starting on March 5
  2. moodaepo
    1. moodaepo to start mailing list discussion for to seek volunteers for release team
  3. tsbere
    1. tsbere to cut Evergreen 2.2 alpha2 this week, pending his tests for make release script, etc.


People present (lines said)

  1. bshum (90)
  2. dbs (57)
  3. tsbere (35)
  4. moodaepo (25)
  5. berick (20)
  6. eeevil (18)
  7. mrpeters-isl (16)
  8. kmlussier (10)
  9. kivilaht1o (10)
  10. Dyrcona (8)
  11. pinesol_green (7)
  12. jamesrf (4)
  13. tspnidler (4)
  14. phasefx_ (3)
  15. senator (3)
  16. dbwells (2)
  17. gmcharlt (1)
  18. csharp (1)
  19. denials (1)
  20. yboston (1)


Generated by MeetBot 0.1.4.