#evergreen: 2012-03-08 - Developer Meeting

Meeting started by bshum at 14:05:10 US/Eastern (full logs).

Meeting summary

  1. Who's here? (bshum, 14:05:25)
    1. Ben Shum, Bibliomation (bshum, 14:05:33)
    2. Thomas Berezansky, MVLC (tsbere, 14:05:41)
    3. Bill Erickson, Equinox (berick, 14:05:42)
    4. James Fournie, BC Libraries Cooperative / Sitka (jamesrf, 14:05:45)
    5. Jason Stephenson, MVLC (Dyrcona, 14:06:01)
    6. Lebbeous Fogle-Weekley, Equinox (senator, 14:06:10)
    7. Kathy Lussier, MassLNC (kmlussier, 14:06:13)
    8. Anoop Atre, PALS (moodaepo, 14:06:46)
    9. Mike Rylander, Equinox (eeevil, 14:06:47)
    10. Dan Scott, Laurentian University (denials, 14:07:07)
    11. Chris Sharp, GPLS (csharp, 14:08:39)

  2. Review past action items (bshum, 14:08:50)
    1. All of them appear to be done or mostly done. (bshum, 14:09:04)
    2. ACTION: moodaepo (and others) to reply to rsoullierre's questions about DIG contributions to the release team. (bshum, 14:09:26)
    3. Action item 2 leads to next topic. (bshum, 14:10:15)

  3. Evergreen 2.2 alpha2/alpha3/beta (bshum, 14:10:35)
    1. Michael Peters, Evergreen Indiana (mrpeters-isl, 14:10:47)
    2. tsbere was to cut 2.2 alpha2 last week (bshum, 14:10:52)
    3. http://evergreen-ils.org/dokuwiki/doku.php?id=dev:evergreen:release_checklist is looking pretty moribund when it comes to ownership :) (denials, 14:14:54)
    4. ACTION: tsbere to cut alpha3 once upgrade script procedure decided (see next topic) (bshum, 14:15:27)
    5. ACTION: bshum to update website download pages for alpha3 (bshum, 14:15:38)
    6. ACTION: mrpeters-isl will install Alpha 3 to testing.evergreen.lib.in.us for public testing (mrpeters-isl, 14:16:52)
    7. HELP: Revise release checklist with your roles. (bshum, 14:16:54)
    8. ACTION: moodaepo to do the blog post (moodaepo, 14:17:35)

  4. Upgrade scripts and what we are *supposed* to be doing in making/updating/whatever them. (bshum, 14:19:14)
    1. Decide approach for 2.2 now, then discuss/come up with new upgrade script handling in 3.0+ (bshum, 14:41:24)
    2. ACTION: Core team to update LP with alpha3 target (bshum, 14:48:53)
    3. ACTION: Bug wranglers to help retarget things appropriately. (bshum, 14:49:05)
    4. Monday 3/12 is expected 2.2 alpha3. We'll aim to test throughout next week, hopefully others can help there too. Then set for another dev meeting week starting 3/19 to discuss either alpha4/beta1. (bshum, 14:57:16)

  5. Time zone proposal (jamesrf) (bshum, 14:58:48)
    1. http://www.mail-archive.com/open-ils-general@list.georgialibraries.org/msg05855.html (jamesrf, 15:06:50)

  6. GSoC update (bshum, 15:07:29)
    1. from earlier: (01:18:58 PM) ***denials offers a GSoC update: nobody has touched the "Summer of Coding" page at http://open-ils.org/dokuwiki/doku.php?id=dev:summer_of_coding_ideas since Feb. 27, maybe we should not apply this year. (bshum, 15:08:06)
    2. ACTION: denials & gmcharlt will go ahead with GSoC application for this year. (moodaepo, 15:32:05)

  7. Developer Meeting Schedule - Should we move to Thursday afternoons or continue polling for meeting dates? (moodaepo, 15:33:02)
    1. kmlussier will setup/send out doodle poll for next week's dev meeting (moodaepo, 15:38:28)
    2. ACTION: kmlussier will setup/send out doodle poll for the next dev meeting for the week starting March 12th (moodaepo, 15:39:50)
    3. ACTION: Update previous action for kmlussier to the week starting March 19th (moodaepo, 15:43:19)

  8. Announcements (moodaepo, 15:43:34)


Meeting ended at 15:45:01 US/Eastern (full logs).

Action items

  1. moodaepo (and others) to reply to rsoullierre's questions about DIG contributions to the release team.
  2. tsbere to cut alpha3 once upgrade script procedure decided (see next topic)
  3. bshum to update website download pages for alpha3
  4. mrpeters-isl will install Alpha 3 to testing.evergreen.lib.in.us for public testing
  5. moodaepo to do the blog post
  6. Core team to update LP with alpha3 target
  7. Bug wranglers to help retarget things appropriately.
  8. denials & gmcharlt will go ahead with GSoC application for this year.
  9. kmlussier will setup/send out doodle poll for the next dev meeting for the week starting March 12th
  10. Update previous action for kmlussier to the week starting March 19th


Action items, by person

  1. bshum
    1. bshum to update website download pages for alpha3
  2. denials
    1. denials & gmcharlt will go ahead with GSoC application for this year.
  3. kmlussier
    1. kmlussier will setup/send out doodle poll for the next dev meeting for the week starting March 12th
    2. Update previous action for kmlussier to the week starting March 19th
  4. moodaepo
    1. moodaepo (and others) to reply to rsoullierre's questions about DIG contributions to the release team.
    2. moodaepo to do the blog post
  5. mrpeters-isl
    1. mrpeters-isl will install Alpha 3 to testing.evergreen.lib.in.us for public testing
  6. tsbere
    1. tsbere to cut alpha3 once upgrade script procedure decided (see next topic)
  7. UNASSIGNED
    1. Core team to update LP with alpha3 target
    2. Bug wranglers to help retarget things appropriately.


People present (lines said)

  1. bshum (71)
  2. moodaepo (46)
  3. denials (46)
  4. eeevil (45)
  5. tsbere (31)
  6. jamesrf (30)
  7. kmlussier (7)
  8. senator (7)
  9. pinesol_green (6)
  10. mrpeters-isl (5)
  11. Dyrcona (4)
  12. csharp (3)
  13. berick (1)
  14. phasefx_ (1)


Generated by MeetBot 0.1.4.