14:10:49 <eeevil> #startmeeting 2012-04-02 - Developer Meeting
14:10:49 <pinesol_green> Meeting started Mon Apr  2 14:10:49 2012 US/Eastern.  The chair is eeevil. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:10:49 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:11:21 <eeevil> #info eeevil is Mike Rylander, ESI
14:11:24 <dbwells> eeevil: I was just checking out http://www.evergreen-ils.org/irc_logs/evergreen/2012-03/%23evergreen.19-Mon-2012.log for reference on past meeting commands.
14:11:44 <tsbere> #info tsbere is Thomas Berezansky, MVLC
14:11:50 <kivilahtio1> #info kivilahtio is Olli-Antti Kivilahti, Library of Joensuu
14:11:58 <phasefx> #info phasefx is Jason Etheridge, ESI
14:12:06 <jeff> #info jeff is Jeff Godin, Traverse Area District Library (TADL)
14:12:09 <dbwells> #info dbwells is Dan Wells, Calvin College
14:12:12 <eeevil> denials: good idea, thanks!
14:12:24 <kmlussier> #info kmlussier is Kathy Lussier, MassLNC
14:12:30 <bshum> #info bshum is Ben Shum, Bibliomation
14:12:31 <swills_> #info swills is Steve Wills
14:12:37 <berick> #info berick is Bill Erickson, Equinox
14:12:55 <bshum> eeevil++ # wrestling the bot
14:12:55 <eeevil> #link Agenda: http://evergreen-ils.org/dokuwiki/doku.php?id=dev:meetings:2012-04-02
14:13:12 <eeevil> bshum! you want the chair, don't you!
14:13:21 * denials is Dan Scott, Laurentian University
14:13:27 <jamesrf> #info jamesrf is James Fournie, BC Libraries Cooperative
14:13:30 <bshum> eeevil: Nah, you totally got this :)
14:14:31 <eeevil> ok ... first up: denials to respond to rsoulliere with some ideas about DIG participation in release process
14:15:02 <tsbere> eeevil: Topic command?
14:15:03 <denials> I have done no such thing. Sorry.
14:15:12 <eeevil> tsbere: ahh ... sure
14:15:24 <eeevil> #topic denials to respond to rsoulliere with some ideas about DIG participation in release process
14:16:18 <denials> #info denials still needs to do that
14:16:41 <eeevil> #topic bshum to help update the release checklist page
14:17:03 <bshum> #info bshum defers to next meeting to work on that further.
14:17:27 <eeevil> #topic tsbere to cut 2.2 Beta1 on April 2
14:17:42 <eeevil> #info YOU'RE SOAKING IN IT
14:17:44 * tsbere appears to have files to upload on that front
14:17:47 <tsbere> :D
14:18:09 <tsbere> #info tsbere is in the middle of that but should be done shortly
14:18:14 <eeevil> super ... on to new biz
14:18:31 <eeevil> #topic JSPAC deprecation and removal: schedule proposal
14:18:57 <eeevil> is 1 year enough?
14:19:41 <mrpeters-isl> seems like plenty of time
14:19:52 <bshum> I like the proposed timeline.  +1 from us
14:20:01 <eeevil> mrpeters-isl: heh ... recall ACQ's timeline, originally ;)
14:20:03 <jeff> +1 on the proposed timeline
14:20:05 <eeevil> just sayin'
14:20:07 <kivilahtio1> +1 if my vote has any weight
14:20:23 <mrpeters-isl> should we set some kind of goal that says "90%" or some other number, of features existing in jspac must be available in ttpac before discontinuing?
14:20:38 <mrpeters-isl> just to be sure we don't lose any features
14:20:43 <denials> What if a feature is deemed useless?
14:20:53 <phasefx> if someone champions a feature, it should get migrated
14:20:55 <eeevil> mrpeters-isl: that (cataloging the differences, culling what's actually desired) is the first step
14:20:55 <mrpeters-isl> i'd say a community vote on that would be acceptable
14:21:06 <phasefx> unless the feature is "use a lot of Javascript" :)
14:21:07 <kivilahtio1> do you have any kind of a requirements specification regarding OPAC?
14:21:17 <jeff> Shoot for feature parity, clearly communicate intended loss of features, solicit squeaky wheels / champions.
14:21:19 <eeevil> phasefx: shush!
14:21:21 <denials> kivilahtio1: Not a comprehensive one, no
14:21:29 <denials> jeff++
14:22:00 <eeevil> ok ... who wants to diff them? :)
14:22:20 <eeevil> but, I'm really just playing devil's advocate here
14:22:35 <eeevil> +1 from me, I think it can be done if it's a stated goal
14:22:43 <eeevil> and, therefore...
14:22:45 <jeff> A list of features in jspac and their status in ttpac would be a good starting point.
14:23:06 <bshum> jeff:  Might be easier to walk through each screen in jspac and tpac and see "what's different"
14:23:11 <jeff> (and said list if compiled before conference might generate additional hackfest ideas)
14:23:12 <bshum> (and/or missing)
14:23:13 <denials> Who wants to volunteer to build that list?
14:23:14 <kivilahtio1> I wonder if we could help with that
14:23:29 <mrpeters-isl> maybe it'd be easier to list the features NOT yet in TTPAC
14:23:31 <kmlussier> Is this a good place to start? http://www.open-ils.org/dokuwiki/doku.php?id=dev:opac:template-toolkit:release_notes&s[]=template&s[]=toolkit
14:23:33 <kivilahtio1> we are currently working on our requiremetns specification and one sections is about web-library aka. OPAC
14:23:38 <mrpeters-isl> rather than listing all of the features of JSpac
14:23:48 <denials> Such a comprehensive list might be useful in terms of building a mapping of apache redirects from jspac to tpac as well
14:23:59 <eeevil> #agreed Deprecate JSPAC at 2.2+1, remove at 2.2+2
14:24:02 <denials> kivilahtio1++
14:25:19 <kivilahtio1> our accuracy so far has been very low
14:25:21 <bshum> Maybe we can make this a hackfest topic.
14:25:30 <mrpeters-isl> thats a good idea, bshum
14:25:34 <kivilahtio1> but we could do a feature match
14:25:35 * bshum vaguely remembers denials poking me about tpac dev session
14:26:52 <eeevil> well, we ended up sliding right into the next ...
14:26:59 <eeevil> #topic Preparing for the Evergreen Conference hackfest
14:27:53 <eeevil> I added an idea just a moment ago, too.  gmcharlt may be interested to list his name for that?
14:28:30 * dbwells is getting called away from his desk
14:29:31 * denials would take an action item on publicizing the "EG2012 hackfest project list" on the mailing list
14:29:46 <eeevil> very well, sir:
14:30:04 <eeevil> #action denials will publicize the "EG2012 hackfest project list" on the mailing list
14:31:18 <eeevil> anything else we should go over right now? volunteers to "officially" test 2.2-b1?
14:31:37 <eeevil> #topic announcements/general
14:31:37 <bshum> eeevil: We'll be testing the upgrade SQL later tonight/tomorrow
14:32:42 <eeevil> bshum: cool. report of a positive result on-list would be a GoodThing(TM) I think
14:33:07 <eeevil> or negative, but it's less often that we see a "that worked as expected" report ;)
14:33:34 <bshum> Heh
14:33:38 <bshum> Will do.
14:34:17 <eeevil> any announcements from/for the community at large?
14:34:39 <kivilahtio1> good work with the 2.2
14:34:44 <kivilahtio1> I am liking the changes
14:35:23 <eeevil> reminder for DIG, ESI will be putting up piles of docs for 2.2 features RSN, with more to come over the following weeks during beta
14:35:55 <kmlussier> eeevil++
14:36:07 <bshum> ESI++
14:36:08 <eeevil> kivilahtio1: from the whole core team, thanks ... this is a big one
14:36:14 * tsbere found a root-owned readonly folder screwing up his make release run, thinks he has gotten his dev machine to play nice now <_<
14:36:53 <eeevil> ok ... I think that's it ... onward to 2.2, folks!
14:36:57 <eeevil> #endmeeting