#evergreen: 2012-06-05 - Developer Meeting

Meeting started by bshum at 14:09:06 US/Eastern (full logs).

Meeting summary

    1. https://launchpad.net/evergreen/+milestone/2.1.2 is such a nice clean url :) (denials, 14:09:14)

  1. Releases (bshum, 14:09:37)
  2. OpenSRF Release (bshum, 14:11:35)
    1. OpenSRF 2.1.0 is available for download at http://evergreen-ils.org/opensrf.php as of yesterday (denials, 14:12:13)
    2. IDEA: Try to sync OpenSRF releases with Evergreen ones, one month ahead or something like that. (bshum, 14:17:18)

  3. Evergreen Releases (bshum, 14:17:24)
    1. Evergreen 2.2.0 real soon now, pending help in verifying readiness of i18n stuff (senator, 14:17:40)
    2. Anyone can say #info and it gets recorded in the minutes. (berick, 14:18:19)
    3. ACTION: denials to review i18n branch from senator prior to 2.2.0 release (bshum, 14:21:15)
    4. HELP: Need more eyes on i18n work (bshum, 14:21:31)

  4. Sign-offs for branch merges (bshum, 14:25:36)
    1. See dbwells notes on http://evergreen-ils.org/dokuwiki/doku.php?id=dev:meetings:2012-06-05 about sign-offs (bshum, 14:27:27)
    2. AGREED: Avoid merge commits if reasonably possible, and work collectively to come up with good techniques to do so. (bshum, 14:37:04)
    3. ACTION: denials to write up "How to set up an alias for cherry-picking w/ signoff in tig" (denials, 14:37:30)
    4. IDEA: Disallow merges on master? (bshum, 14:42:36)

  5. GSOC updates (bshum, 14:43:41)
    1. pranjal has working php code for straightforward requests through the translator, working on improvements, blogging & showing a bigger community presence (senator, 14:45:08)
    2. C-port of db stored procs: I'll be shoving Swenuy out onto the list soon -- today or tomorrow -- with his first round of code (search/naco normalizer) (eeevil, 14:45:40)
    3. danielR is making good progress on the Android project. He has successfully used the relatively recent Java Gateway code to make a basic search and display interface. He has made some progress in integrating the IDL appropriately. (dbwells, 14:46:45)
    4. Dojo upgrade: Joseph has been making some progress and has run into his first unexpected issues (and started resolving them) (tsbere, 14:46:56)
    5. first Android app bits are here http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/drizea/android (dbwells, 14:48:09)

  6. Evergreen 2.1 release (bshum, 14:51:09)
    1. ACTION: denials will stop moaning about schema conflicts and move 0691 out of the main xact for the 2.1.1-2.1.2 upgrade (and senator shall do likewise for 2.1-2.2) (denials, 15:06:52)


Meeting ended at 15:15:41 US/Eastern (full logs).

Action items

  1. denials to review i18n branch from senator prior to 2.2.0 release
  2. denials to write up "How to set up an alias for cherry-picking w/ signoff in tig"
  3. denials will stop moaning about schema conflicts and move 0691 out of the main xact for the 2.1.1-2.1.2 upgrade (and senator shall do likewise for 2.1-2.2)


Action items, by person

  1. denials
    1. denials to review i18n branch from senator prior to 2.2.0 release
    2. denials to write up "How to set up an alias for cherry-picking w/ signoff in tig"
    3. denials will stop moaning about schema conflicts and move 0691 out of the main xact for the 2.1.1-2.1.2 upgrade (and senator shall do likewise for 2.1-2.2)
  2. senator
    1. denials to review i18n branch from senator prior to 2.2.0 release
    2. denials will stop moaning about schema conflicts and move 0691 out of the main xact for the 2.1.1-2.1.2 upgrade (and senator shall do likewise for 2.1-2.2)


People present (lines said)

  1. bshum (53)
  2. denials (47)
  3. berick (28)
  4. senator (17)
  5. eeevil (13)
  6. dbwells (10)
  7. tsbere (6)
  8. pinesol_green (4)
  9. jeff (4)
  10. moodaepo (1)


Generated by MeetBot 0.1.4.