14:31:38 <jenny> #startmeeting Evergreen Reports Task Force.  The agenda is posted: http://open-ils.org/dokuwiki/doku.php?id=evergreen-reports:meetings:2012-06-21-agenda
14:31:38 <pinesol_green> Meeting started Thu Jun 21 14:31:38 2012 US/Eastern.  The chair is jenny. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:31:38 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:32:12 <jeff> jenny: i will be unable to devote much attention to today's meeting, but i would be interested in hearing feedback on the jasperreports presentation and will look back on logs to see who else is interested in jasperreprots. i'll follow up on the reports mailing list.
14:32:25 <jenny> If you are here for the Reports Task Force meeting, please fo ahead and introduce yourself.
14:32:29 <jenny> jeff: ok!
14:32:41 <jeff> me is Jeff Godin, Traverse Area District Library (TADL)
14:32:44 * jenny is Jenny Turner, PALS
14:33:01 <b_bonner> I'm Bradley Bonner, King County Libray System
14:33:08 * afterl is Amy Terlaga, Bibliomation
14:33:49 * bshum is Ben Shum, Bibliomation
14:34:11 <jenny> also, we're going to try to use Meetbot for minutes.  So, if you know the commands, please go ahead and use them! #info for informational times is maybe helpful to most people
14:34:16 * collum = Garry Collum, Kenton County Public Library
14:35:40 <jenny> Thanks for joining the meeting, everyone.  It was great to see people at conference - and I'm sorry for taking so long to get this meeting scheduled!
14:36:18 <jenny> #topic Review and approval of the  Notes from the conference.
14:36:38 <jenny> #info the notes from our meeting at conference are http://open-ils.org/dokuwiki/doku.php?id=evergreen-reports:meetings:2012-04-25
14:37:05 <jenny> it was a great turnout and a lively conversation, I think.
14:37:47 <afterl> I agree.
14:38:11 <b_bonner> although I was late, I also agree :)
14:38:12 <jenny> the report wireframes for upcoming (in progress?) development at pines were shared with the group.  They are posted here: http://open-ils.org/dokuwiki/doku.php?id=evergreen-reports:reports_wireframes
14:38:24 <jenny> b_bonner: better late than never!
14:39:14 <jenny> Anyone else have any thoughts on the task force/interest group meeting in Indianapolis? Questions?
14:41:30 <bshum> Just commenting, the wireframes look pretty neat.
14:41:38 <jenny> there were several ideas about reports that came out of the conference for development.  How could we best capture these and pass them along?
14:42:45 <jenny> and yes, I am excited to hear more about the pines development if/when possible.  Though I just realized I should probably have put this on the agenda and asked csharp if there are any updates.
14:43:58 <afterl> He was here just a moment ago.  Wondering if he can provide an impromptu update?
14:45:14 <afterl> Or we add it to next month's agenda
14:46:55 <afterl> jenny:  these ideas for development.  Are they summarized anywhere?
14:47:34 <jenny> Well, I was just skimming through the notes I posted and some of them seemed development-y
14:48:15 <jenny> we have a wishlist for the task force, but I don't know how many of the members of this taskforce are actually doing development.
14:48:53 <jenny> the wishlists are here:
14:48:55 <jenny> http://open-ils.org/dokuwiki/doku.php?id=evergreen-reports:taskforce_wish_lists
14:48:56 <b_bonner> I've primarily abandoned the official report builder myself and am approaching things via SQL.  Also toying with Jasper too..
14:49:13 <b_bonner> so, I haven't been looking at dev...
14:49:57 <mrpeters-isl> those wireframes are awesome
14:50:00 <jenny> #action jenny to add pines development to next agenda and contact csharp.
14:50:04 <b_bonner> ah, I missed that wish list page..
14:50:06 <mrpeters-isl> emerald++
14:50:56 <mrpeters-isl> we have some SQL reports for money owed to other libraries, but it may require a bit of work to convert.  can share them if someone wants to try.
14:51:50 <jenny> I think one problem is that the people who can do sql do sql and those of us that don't have sql access are kind of stuck.
14:52:13 <mrpeters-isl> yeah, it needs to be someone who understands the fieldmapper.  we have report > sql but not vice versa.
14:52:43 <mrpeters-isl> Also, some of those needed reports might be impossible at this time.  Like, average use.  I don't think we can do averages in the reports module.  you'd have to use excel, etc.
14:53:06 <jenny> afterl created a page for sharing sql, btw: http://open-ils.org/dokuwiki/doku.php?id=evergreen-reports:sql
14:53:37 <mrpeters-isl> Something like "Missing data report: what records are missing x field" needs some expansion.  It would be easy to build a report that says "Missing day-phone's" and generate a list of patorns.
14:53:49 <jenny> mrpeters-isl: agreed.  but how do we move from impossible?
14:53:54 <mrpeters-isl> I don't know if that is what is desired thoguh.
14:54:07 <mrpeters-isl> paid development
14:54:23 <mrpeters-isl> if 10 libraries need this feature, pool financial resources and get it developed
14:54:35 <jenny> is there anything the taskforce can do to facilitate this, though?
14:54:37 <mrpeters-isl> that's the FAST way
14:55:03 <mrpeters-isl> jenny: i would reccomend getting development quotes from the various entities
14:55:20 <mrpeters-isl> and then you can start building groups of orgs willing to contribute to the cost
14:55:52 <mrpeters-isl> you have the same barrier for data validation -- i dont think you can do much of that currently, so "Missing/inaccurate patron data fields" would be difficult
14:56:42 <mrpeters-isl> I'll be happy to walk someone through the "Missing data report: what records are missing x field" though.  It is rather simple, it will just require many reports.
14:57:05 <jenny> good idea.  do we have anyone willing to assist with this?  I guess I don't have the greatest handle on what libraries need from reports...I just helped compile the list from things people have mentioned at past meetings and at conferences.
14:57:20 <jenny> That last comment was about getting quotes, etc.
14:57:38 <mrpeters-isl> jenny:  the list serves are good, once you have a quote.  just simply ask "who's interested in contributing"
14:57:52 <mrpeters-isl> i think we all have similar problems :)
14:59:13 <jenny> mrpeters-ils: so someone would just ask "how much would it cost to develop the stuff on this list?"
14:59:28 <jenny> and vendors would know what to do with that?
14:59:32 <mrpeters-isl> no, you would need to contact Equinox or any other company who provides EG development
14:59:45 <jenny> I meant someone would just ask the vendors
15:00:02 <mrpeters-isl> yes, just make sure you have a fully fleshed out description of what you need
15:00:12 <jenny> therein lies the problem
15:00:14 <jenny> :)
15:00:29 <mrpeters-isl> meaning, "We need averages in reports" may not be enough.  You need to describe why you need them, examples of how it would be used, etc.
15:00:51 <jenny> I am just trying to facilitate this group :)  I didn't come up with the list.  So I would definitely need volunteers to step up and help
15:01:08 <mrpeters-isl> certainly
15:01:47 <jenny> so, any volunteers willing to help detail the improvements listed in the wishlist and contact vendors?
15:02:11 <jenny> even if someone just had a pet project/dream, you could start with that
15:02:53 <jenny> mrpeterl-isl: excellent idea to get some movement, by the way. thanks!
15:03:01 <mrpeters-isl> no problem
15:03:07 <mrpeters-isl> finishing up the example for "empty data" right now
15:03:13 <mrpeters-isl> not sure how to share it, but ill figure something out
15:03:23 <jenny> mrpeters-isl++
15:03:31 <afterl> jenny:  wondering if you'd get more volunteers if you post your plan to the list along with the link to the wishlist
15:03:43 <mrpeters-isl> i'd also call out for help on the lists
15:04:54 <jenny> good plans both.  If the task force agrees that this is an initiative we want to proceed with. Again, I am facilitating, not dictating
15:05:02 <jenny> at least trying not to
15:06:12 <jenny> So, are those of you here for the reports task force meeting on board with this plan?  Or do we want to table the idea and discuss ideas for moving forward more at the next meeting?
15:07:28 <afterl> The thing is, we'd need to make it clear that the taskforce has no money to make this happen.  We should be clear about that upfront.
15:07:35 <jenny> exactly
15:08:18 <afterl> And are any of these reports reports that might have been developed somewhere by someone willing to share?
15:08:40 <afterl> Or has it already been determined some major work would need to occur to get the results?
15:08:43 <jenny> we'd need to be clear both with volunteers to write up spec and with the vendors - these are posible projects, not planned projects
15:08:53 <jenny> I don't know if we have a good handle on that.
15:09:40 <jenny> and I think some of the people that proposed the initial reports and circled out of this group.  I know at least one has.
15:10:27 <jenny> but the module/interface improvement ideas are probably pretty well verified.
15:11:56 <afterl> Wondering about the timeframe of the PINES project
15:12:58 <jenny> I know at the conference they were hoping to be done by March 2013, but I assume that is for a PINES implementation...not sure about roll out to the wider community.
15:13:05 <jenny> also not sure about current status.
15:13:28 <afterl> okay
15:13:38 <jenny> I'll ask csharp to brief us at the next meeting.  Unless there is super exciting news; then maybe I'll ask him to post to the list.
15:14:06 <mrpeters-isl> http://pastie.org/4128015 -- that will cover "Missing data report: what records are missing x field" for patron data
15:14:54 <mrpeters-isl> The same principal could be applied to item records.  Whatever field you put a "NULL" filter on will be the field you're looking for missing data on.
15:15:05 <jenny> mrpeters-isl: very nice; thanks!
15:15:16 <mrpeters-isl> is that easy enough to follow or do you want screenshots too?
15:15:29 <jenny> I know someone in this group was wondering about NULL at some point.
15:15:31 <mrpeters-isl> i can also put it on the wiki, but i wasn't sure where
15:15:57 <mrpeters-isl> Filters: http://img836.imageshack.us/img836/3299/filters.png
15:16:07 <mrpeters-isl> Displayed Fields: http://img834.imageshack.us/img834/8792/displayedfields.png
15:16:12 <jenny> For now, we can just link it somewhere probably.
15:16:27 <mrpeters-isl> I don't know if that paste will remain forever or not.
15:16:43 <jenny> ahh. yes, there's that
15:16:59 <mrpeters-isl> i see http://open-ils.org/dokuwiki/doku.php?id=evergreen-reports:posting_guidelines
15:17:01 <moodaepo> mrpeters-isl: Screen shots are a bit tiny to make out things. Or is it just me...
15:17:11 <jenny> kinda tiny
15:17:16 <mrpeters-isl> i agree, moodaepo, but some people are visual
15:17:20 <mrpeters-isl> click them, they will go full screen
15:17:29 <mrpeters-isl> oh wait, no they wont
15:17:30 <mrpeters-isl> hang on
15:17:37 <afterl> There's something called Sample Report Templates on the wiki
15:17:45 <afterl> It's linked from here:  http://open-ils.org/dokuwiki/doku.php?id=evergreen-reports
15:17:55 <afterl> Not sure if that's a place for it or not.
15:18:01 <mrpeters-isl> those are SQL dumps
15:18:08 <afterl> Oh sorry
15:18:17 <mrpeters-isl> i could do it that way too, but i think the textual list helps people find the filters easier
15:18:23 <afterl> Maybe we could create another link off of the main page
15:18:35 <jenny> afterl: was just typing the same thing
15:18:40 <mrpeters-isl> Filter: http://img10.imageshack.us/img10/3783/filterst.png
15:18:50 <afterl> These pages aren't used much, is my guess.  Would like to promote them more
15:18:57 <mrpeters-isl> Displayed Fields: http://img406.imageshack.us/img406/8792/displayedfields.png
15:19:07 <mrpeters-isl> sorry about the small images before
15:19:32 <jenny> afterl: agreed. Our page isn't really easy to get to from anywhere.
15:20:04 <mrpeters-isl> ugh, it got cut off.  i am failing bad -- http://img690.imageshack.us/img690/8792/displayedfields.png
15:20:13 <afterl> Maybe we could get Ben to make a more direct link to them - that is after we do more work to improve
15:20:24 <afterl> or rather, bshum
15:20:25 <mrpeters-isl> ill create a new page on the wiki
15:21:17 <jenny> would it make sense to get a volunteer from our group to write up a little promo piece for our taskforce offerings? (this could be me, but I am going to be perfectly honest and say that if it is, I will not even start on it until August, probably)
15:21:32 <jenny> mrpeters-isl: thanks
15:22:17 <afterl> jenny: what did you have in mind?
15:24:04 <jenny> I don't know, exactly - the Evergreen newsletter could be a good place to point people to our report templates, wishlist, etc...and we sent info about our taskforce out when we started, I think, and maybe when we added the listserv...
15:24:42 <mrpeters-isl> http://open-ils.org/dokuwiki/doku.php?id=evergreen-reports:wishlist_reports
15:25:29 <mrpeters-isl> perhaps Brian Feifarek can do the same
15:25:34 <afterl> mpeters-isl:  say, that looks good
15:25:40 <mrpeters-isl> (assuming those are still in progress)
15:25:52 <jenny> I had planned on writing up a summary of the taskforce meeting for the newsletter, but I think a lot of people might skip over it.  Perhaps something more targeted to the resources we could offer.
15:25:59 <jenny> mrpeters-ils++
15:26:00 <mrpeters-isl> if he's no longer working on them, i can work on those next week
15:26:12 <afterl> okay
15:27:16 <jenny> #info mrpeters-isl created a sample report for one of our wishlist reports: http://open-ils.org/dokuwiki/doku.php?id=evergreen-reports:wishlist_reports.
15:27:28 <afterl> jenny:  if I can help out, just let me know
15:27:39 <mrpeters-isl> anyone know who created the http://open-ils.org/dokuwiki/doku.php?id=scratchpad:sample_reporter_templates reports?  if someone can fill me in on how those were generated, ill include the ones i write
15:27:47 <jenny> afterl: I'll let you know.  :)  thanks
15:28:00 <mrpeters-isl> last modified by phasefx_
15:28:04 <afterl> I have to leave now, sorry I can't stay
15:29:08 <jenny> I am going to table the discussion on what we can do to further the ideas brainstormed at conferences, but keep it on the agenda.
15:29:32 <jenny> #topic old business and updates - documentation
15:30:02 <jenny> we are approaching the hour mark, so I will probably move quickly through this, unless anyone has anything to share
15:30:46 <jenny> #info remember to contribute any documentation you might have.  If it doesn't fit into the existing documentation, it can be linked to the DocuWiki Page.
15:31:08 <jenny> #topic old business and updates - conference review.
15:31:14 <jenny> We kind of covered this above
15:31:42 <jenny> Are there any ideas we should capture now for consideration at the 2013 conference?
15:33:27 <jenny> Or - in addition to the stuff we kind of discussed earlier - ideas for the time between now and the next conference?
15:33:56 <jenny> #topic jasperreports
15:34:36 <jenny> jeff isn't able to join us today, but he was interested in hearing peoples' thoughts on the jasperreports presentation at the conference
15:35:28 <jenny> he was also interested in seeing who else might be interested in jasperreports
15:35:47 <b_bonner> Sorry for lurking, dealing with an issue that ironically needed reports run urgently.  Anyway, I am very interested in Jasper, I've put together a test server and done very basic canned queries, still investigating dynamic stuff
15:36:36 <jenny> b_bonner: no need to apologize
15:37:17 <b_bonner> I hope to be spending more time with Jasper soon, but spare time is hard to find.
15:37:35 <b_bonner> The Jasper sales people call me often though, that might help keep me on track :)
15:37:56 <jenny> they are quite good for that. :)
15:38:14 <jenny> I think there aren't many of us left on this meeting, so...
15:38:25 <jenny> #topic Anything else from past meetings?
15:38:54 <jenny> or any new business?
15:39:17 <jenny> #topic Review of trial meeting time.
15:40:26 <jenny> I'm thinking this meeting time wasn't much better than the past meeting times (formerly on Wed).
15:42:04 <jeff> b_bonner: good to hear you're interested. i'll try to touch base with you later this week or next. :-)
15:42:22 <jenny> Our next meeting is scheduled for 7/19.  I will be training a library that week, so won't be available to facilitate.
15:42:55 <jenny> any volunteers from the stragglers?
15:43:03 <b_bonner> jeff: thanks, although the Jasper project is somewhat back-burnered unless I magically run out of other stuff to do.
15:44:02 <jenny> otherwise I will put out a call on the list about a meeting time and the future of our task force.
15:45:07 <jenny> #action Jenny to email reports list on future meetings.
15:45:17 <jenny> anything else?
15:46:26 <jenny> thanks, folks.
15:46:32 <jenny> #endmeeting