14:08:05 <dbwells> #startmeeting 2012-07-16 - Developer Meeting
14:08:05 <pinesol_green> Meeting started Mon Jul 16 14:08:05 2012 US/Eastern.  The chair is dbwells. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:08:05 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:08:12 <denials> dbwells++
14:08:16 <berick> dbwells++
14:09:05 <denials> #info denials is Dan Scott, Laurentian University
14:09:16 <berick> #info berick is Bill Erickson, Equinox
14:09:32 <dbwells> #info dbwells is Dan Wells, Calvin College
14:09:44 <jamesrf> #info jamesrf is James Fournie, BC Libraries Cooperative / Sitka
14:10:01 <tsbere> #info tsbere is Thomas Berezansky, MVLC
14:10:17 <Dyrcona> #info Dyrcona is Jason Stephenson, MVLC
14:10:28 <senator> #info senator is Lebbeous Fogle-Weekley
14:10:42 <bshum> #info bshum is Ben Shum, Bibliomation
14:10:57 <bshum> Sorry I'm late.
14:11:11 <wolf29> #info wolf29 is Wolf Halton, LYRASIS
14:11:23 <remingtron> #info remingtron is Remington Steed, Calvin College
14:11:44 <dbwells> #topic Action Items from Last Meeting
14:12:03 <j_scott> #info jon_scott is Jon Scott, LYRASIS
14:13:14 <dbwells> #info denials to review i18n branch from senator prior to 2.2.0 release - DONE
14:13:57 <j_scott> s/jon_/j_/ ... grin
14:14:53 <dbwells> #action denials still going to write up �How to set up an alias for cherry-picking w/ signoff in tig�
14:14:56 <denials> The .tigrc alias for cherry-picking w/ sign-off was to help with the "avoid merge" workflow, IIRC. I'll still do that
14:15:24 <dbwells> denials: thanks, sorry to jump the gun a bit
14:15:31 * tsbere throws http://pastebin.com/QZT3EYUW out as well
14:15:50 <denials> #info echo "bind generic C !git cherry-pick -s %(commit)" > ~/.tigrc # adds a cherry-pick alias to tig for "C" key
14:17:14 <denials> I think it's pretty rare that we have branches with more than a couple of commits anyway
14:17:57 * denials notes that that echo command will blow away an existing .tigrc - heh
14:18:18 <denials> anyway, next...
14:18:32 <dbwells> #info denials and senator will work out schema conflicts re:0691 - DONE
14:19:02 <dbwells> or is that only done for 2.2?
14:19:45 <denials> It's all done, as far as I can tell
14:19:57 <denials> 0691 got moved out of the main transaction
14:20:01 <dbwells> #link http://git.evergreen-ils.org/?p=Evergreen.git;a=commitdiff;h=b28f3a10
14:20:01 <pinesol_green> [evergreen|Lebbeous Fogle-Weekley] In the 2.1-2.2 upgrade script, move 0691 into a failures-are-ok zone - <http://git.evergreen-ils.org/?p=Evergreen.git;a=commit;h=b28f3a1>
14:20:27 <dbwells> alright, cool
14:20:31 <denials> samw for 7f46dc3a
14:20:31 <pinesol_green> [evergreen|Lebbeous Fogle-Weekley] In the 2.1-2.2 upgrade script, move 0691 into a failures-are-ok zone - <http://git.evergreen-ils.org/?p=Evergreen.git;a=commit;h=7f46dc3>
14:20:34 <senator> (concurs fwiw)
14:20:55 <dbwells> #info berick to review OpenSRF CORS patch - Pending
14:21:19 <berick> yep, just need to do it.
14:21:23 <dbwells> berick: can you remind me (and others) what that is talking about?
14:22:06 <berick> dbwells: IIRC, cross-domain javascript support for the opensrf gateway
14:22:16 <berick> there's a link somewhere.. sec
14:23:26 <berick> #info CORS https://bugs.launchpad.net/opensrf/+bug/1002028
14:23:26 <pinesol_green> Launchpad bug 1002028 in OpenSRF "Cross Origin Resource Sharing (CORS) Support" (affected: 1, heat: 6) [Undecided,New]
14:23:40 <dbwells> berick++ thanks
14:24:53 <dbwells> #topic GSoC Reports
14:25:33 <denials> #info All the students passed their mid-term evaluations!
14:25:57 <denials> Were any students able to make today's meeting?
14:27:15 <senator> i think no
14:28:12 <senator> #info Pranjal has a reasonably working general purpose opensrf php binding including fieldmapperized/encoding decoding. remaining work to be done: cleanup, corner cases, suitable packaging for PEAR or similar repository
14:28:31 <senator> meh, slash in the wrong place, but you all know what i meant
14:30:24 <denials> PEAR is a non-starter if it's GPL, fwiw
14:30:39 <denials> but we could create our own channel
14:30:49 <dbwells> #link https://github.com/pranjal710/osrf Pranjal's repo
14:30:54 <senator> ah, well, whatever. i haven't looked into that. just some place where php things get published.
14:31:15 <senator> denials: thanks for that info
14:32:56 <dbwells> #drizea has moved development from his user branch to a much cleaner collab branch http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/collab/drizea/android
14:32:59 <dbwells> oops
14:33:14 <denials> senator: I would recommend giving PHP_CodeSniffer a run, to check for PEAR coding convention compliance at some point
14:33:14 <dbwells> #info drizea has moved development from his user branch to a much cleaner collab branch http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/collab/drizea/android
14:34:20 <dbwells> #info we are targeting what amounts to a '0.1' release at some point this week
14:35:33 <dbwells> #info what works - basic search, org_unit limit selection, authentication, checkouts, holds
14:36:08 <berick> nice
14:37:07 <dbwells> #info what needs work - UI consistency, other search limiters, renews, copy displays (and general bug fixes)
14:38:27 <dbwells> tsbere: anything to report for your student?
14:38:55 * tsbere should probably pay more attention to the meeting
14:40:50 <tsbere> #info Joseph has made it through most of the dojo grids and should be looking into broken widgets soon, including building unit tests to figure out where they are broken. He has started pushing his work into branches on the repo made for him last year: http://git.evergreen-ils.org/?p=evergreen/joelewis.git
14:42:30 <denials> tsbere: you might want to give jlewis some guidance on how to mark bugs as pullrequests, etc, based on https://bugs.launchpad.net/evergreen/+bug/1020665 ?
14:42:30 <pinesol_green> Launchpad bug 1020665 in Evergreen "Dojo attributes should be updated" (affected: 1, heat: 6) [Undecided,New]
14:43:33 * denials hopes we can integrate code sooner rather than later :)
14:43:48 * tsbere will poke him about some of that, hopefully later today
14:44:05 <dbwells> eeevil didn't check in for the meeting, does anyone else know of the progress for his student?
14:45:26 <denials> beyond seeing Sy asking for logs & data last week, and the passing evaluation, dunno
14:46:23 * berick has no info to add
14:46:32 <berick> but can ping
14:47:18 <berick> (i mean for possible later update; don't wait on me)
14:47:30 <dbwells> #action eeevil will report via the list on GSoC student progress
14:47:38 <dbwells> seems fair :)
14:48:16 <dbwells> #topic Releases
14:48:49 <dbwells> Opinions on cutting another alpha of 2.3 today?
14:49:42 <denials> I was trying to knock down the outstanding pull requests for 2.3 last week
14:49:52 <denials> ended up adding some that probably balanced my efforts out :/
14:50:08 <berick> maybe we should postpone to end of the week
14:50:42 <berick> though, i'm happy to cut today
14:50:44 <denials> dbwells: did you have a chance to poke at my commit & comments on bug 1013672
14:50:44 <pinesol_green> Launchpad bug 1013672 in Evergreen "TPAC: Enable LDAP authentication" (affected: 1, heat: 6) [High,New] https://launchpad.net/bugs/1013672
14:51:40 * denials will assign himself to bug 1020646
14:51:40 <pinesol_green> Launchpad bug 1020646 in Evergreen "TPAC: Search wrapper spacing" (affected: 2, heat: 10) [Wishlist,Triaged] https://launchpad.net/bugs/1020646
14:51:50 <dbwells> denials: I have an open window for it, but that is about as far as I got.  If we target end of week, I can work that in.
14:52:48 <denials> dbwells: not to go into too much detail this meeting, but one thing I noticed is that if an LDAP server stops responding, then the auth request times out; it doesn't fall back to built-in auth because of the time out, methinks
14:53:31 <denials> so might be worthwhile either explicitly testing for that, or setting "LDAP server disabled" memcache setting for a five-minute block, or something
14:53:51 <denials> (but that's not specific to TPAC, probably deserves a separate bug)
14:55:19 <dbwells> denials: Sounds like a plan worth pursuing.  I'm also looking at pushing your journal title search feature ASAP.
14:57:03 <berick> i should be able to merge a bug or two this week.  i'll also be opening some new ones, wee
14:58:30 <dbwells> So, how about a Wednesday release?  If anything, I would prefer that all releases (even alphas) have at least *some* warning for the devs.
14:59:35 <dbwells> (and maybe we did, and I am just not remembering)
14:59:45 <berick> dbwells: it was mentioned in the alpha1 release email
14:59:54 <berick> but it could certainly use its own announcement msg
15:00:06 <berick> well, it was mentioned as tentative
15:00:45 <berick> IOW, releasing wednesday is not a delay, and right here and now is the official decision to release it! :)
15:01:10 <berick> #action berick to announce alpha2 release on general/dev list
15:01:49 <berick> i'm fine w/ Wednesday
15:03:59 <dbwells> berick: I didn't mean to sound accusatory, if I did.  I did miss it in the alpha1 email.
15:04:32 <dbwells> Anyone want to weigh in for a different release day before I mark Wednesday as 'agreed'?
15:05:06 <berick> dbwells: oh, no, that's just me agreeing I should have said something
15:05:33 <dbwells> #agreed 2.3 alpha2 to be released on Wedneday, July 18
15:05:40 <berick> i get the distinct impression no one cares about the alpha date because no one is going to test until Beta
15:05:43 * berick ducks
15:06:24 <berick> good release practice/smoothing, though
15:06:28 <dbwells> #topic Evergreen Issues
15:06:52 <dbwells> Who wants to say something about locales support in TPAC?
15:08:37 <berick> i'm unclear on what's needed based on that topic header
15:09:53 * tsbere thinks that issues include no selector for locale.....but isn't really sure
15:10:48 <bshum> I think that's right.  kmlussier and others were mentioning something about locale needing a selector dropdown of some kind.  I think denials said something about cookies.
15:11:06 <berick> it uses the browser's language header
15:11:26 <denials> berick: yeah, parsr is looking for something to switch based on a selector, I pointed at the cookie but noted that nothing is built in yet
15:11:29 <berick> it can use cookies, but would need a slector
15:11:38 <denials> most people don't really use the browser language header
15:11:49 <berick> that's unfortunate
15:12:07 <senator> shared computers in libraries
15:12:07 <denials> s'ok, it's something we'll need to address here (Conifer) anyway
15:12:12 <senator> would definitely need the selector
15:12:21 <berick> yeah
15:12:46 <denials> Don't know if we have a bug open for that but I would be happy to have my name associated with it :)
15:13:02 * berick does not recall seeing one
15:13:57 <denials> nothing coming up for "tpac locale" or "tpac language", I'll open one
15:14:04 <berick> denials++
15:14:41 <dbwells> #action denials will open bug to track TPAC locale selector needs
15:15:39 <dbwells> Next up 'vandelay is extremely slow on multiple matchpoints - jamesrf'
15:16:07 <dbwells> https://bugs.launchpad.net/evergreen/+bug/1024095
15:16:07 <pinesol_green> dbwells: Error: Could not gather data from Launchpad for bug #1024095 (https://launchpad.net/bugs/1024095). The error has been logged
15:16:29 * bshum stabs pinesol_green
15:17:03 <jamesrf> er yeah not much to say but this is an issue with sitka, masslnc and kcls we're hoping for some help with
15:17:35 <senator> i will update that bug with an outline of what could be changed for more speed
15:17:37 <denials> jamesrf: any SQL statement logs / explain queries?
15:17:44 <senator> action me dbwells
15:17:51 <kmlussier> Yes, C/W MARS in particular has had big problems with their upload times.
15:17:53 <denials> hard to debug without data :/
15:18:01 <dbwells> senator: yes sir
15:18:04 <jamesrf> yes i'm not looking at the issue myself but was asked to raise it here, but jeffdavis may have something to contribute there
15:18:22 <dbwells> #action senator will update the bug with an outline of what could be changed for more speed
15:18:41 <jamesrf> senator++
15:19:37 <dbwells> senator: is there any aspect of it worth discussing right now, in your opinion?
15:21:23 <dbwells> I'll move along, but feel free to chime in if needed.
15:21:24 <senator> well, it's a heavy topic, but basically match sets become crazy slow in scale with the number of bibs in your catalog. redevelopment could make things somewhat faster for cases where your match points are tag/subfield combos plus record attributes, and much faster when your match points are all record attributes
15:21:51 <denials> mra! mra!
15:22:07 <senator> redevelopment being kind of a big word. "some refactoring", let's call it
15:22:13 <senator> denials++
15:23:06 <dbwells> senator: thanks for the further explanation.
15:23:35 <dbwells> Last agenda item, "Mark 2.0.x as �Deprecated� on Downloads page?"
15:23:54 <bshum> Just a simple vote for it.
15:23:55 <jamesrf> #agreed
15:23:56 <bshum> +1/-1
15:24:14 <denials> +1
15:24:19 <bshum> And also any styling suggestions.  I just noticed that alphas are in red highlighting, sigh.
15:24:24 * bshum pokes moodaepo on that.
15:25:07 <dbwells> I'd vote grey for a color, like old bones.
15:25:18 <bshum> Sounds reasonable.
15:25:21 <berick> heh
15:25:40 <denials> Add some animations so that when someone tries to click on the download link, the link dodges out of the way
15:26:09 <dbwells> I have code for that from a workshop I did on using the "tab" key :)
15:26:13 <bshum> I've also thought about just locking up all the 2.0 stuff into the Code Museum page :)
15:26:18 <tsbere> Interruption page. "This is an ancient version. You don't want to download it. If you think you know better than us and want to anyway, the link is hidden in the lorum ipsum text below somewhere."
15:26:36 <wolf29> lol
15:26:59 <dbwells> anyway, +1
15:27:58 <dbwells> Any nay sayers?
15:28:41 <dbwells> #agreed Evergreen 2.0.x to be marked as deprecated on downloads page
15:29:39 <bshum> Alright
15:29:44 <dbwells> #action bshum / moodaepo will mark Evergreen 2.0.x as deprecated, and style it to look as dead and unappealing as possible
15:29:57 <bshum> dbwells++ :)
15:30:16 <denials> "And 1.4 is RIGHT OUT"
15:30:26 <bshum> denials: Was that Tasmania?
15:30:53 * denials will stay mum
15:31:18 <dbwells> That ends the agenda.  Anyone with anything else to say, say it fast.
15:31:30 <bshum> Just a minor note, I'm still tweaking our IRC bots
15:31:35 <bshum> We do have a new paste tool
15:31:43 <bshum> And commits are being linked to by pinesol now.
15:32:16 <bshum> If anyone has suggestions or requests for new things, let me know while I poke and prod.
15:32:20 <dbwells> #topic Announcements
15:33:56 <dbwells> #info bshum has customized IRC bots (new paste tool, commit auto links), and is looking for feedback
15:34:20 <dbwells> #endmeeting