14:01:25 <yboston> #startmeeting 2012-08-02 - DIG Monthly Meeting Evergreen Documentation Interest Group (DIG) Monthly Meeting. The agenda can be found here http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:dig_meeting_20120802-agenda
14:01:25 <pinesol_green> Meeting started Thu Aug  2 14:01:25 2012 US/Eastern.  The chair is yboston. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:25 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:01:39 <yboston> I plan to again use Meetbot to run this meeting. Just participateas normal if you want, but don't be thrown off by my use of the special Meetbot"#command" syntax. More information here:
14:01:39 <yboston> http://www.open-ils.org/dokuwiki/doku.php?id=community:using-meetbot
14:01:46 <yboston> #topic Introductions
14:02:00 <krvmga> jim keenan c/w mars
14:02:00 <yboston> Please feel free to start introducing yourselves...
14:02:03 * tspindler is Tim Spindler C/W MARS
14:02:11 <kmlussier> /me is Kathy Lussier, MassLNC
14:02:19 * rsoulliere is Robert Soulliere, Mohawk College
14:02:26 * raynerj is June Rayner eiNetwork
14:02:32 * safortin is Sally Fortin, Equinox Software
14:03:06 <yboston> BTW, I plan to again use Meetbot to run this meeting. Just participateas normal if you want, but don't be thrown off by my use of the special Meetbot"#command" syntax. More information here:
14:03:07 <yboston> http://www.open-ils.org/dokuwiki/doku.php?id=community:using-meetbot
14:03:31 * yboston Yamil Suarez @ Berklee college of Music
14:04:14 <yboston> #topic Updates from Content Coordinators
14:04:23 <yboston> please type "#info" for every post/line
14:04:33 <yboston> #topic this is a test report first post/line
14:04:33 <yboston> #topic this is a test report second post/line
14:04:39 <yboston> who would like to give the next content coordinator report?
14:04:54 <rsoulliere> May I go first?
14:05:06 <yboston> go ahead
14:05:11 <rsoulliere> #topic Conversion Coordinator Report
14:05:19 <rsoulliere> #info The rel_2_2 branch of the Evergreen repository now includes the documentation. yay!
14:05:30 <rsoulliere> #info Processing documentation for 2.2 is now pulling from the rel_2_2 branch.
14:05:34 <kmlussier> rsoulliere++
14:05:40 <rsoulliere> denials++ for setting up the branch, resolving merge issues and answering lots of my questions.
14:05:48 <yboston> rsoulliere++
14:06:00 <rsoulliere> #info I made quite a few documentation commits during July.
14:06:07 <rsoulliere> I have not received any negative feedback or cease-and-disist letters from developers, so I assume that my commits and backports to rel_2_2 are OK. ;-)
14:06:35 <rsoulliere> #info Converted and added Reports. http://docs.evergreen-ils.org/2.2/_reports_2.html
14:06:46 <rsoulliere> jenny++ for reviewing the Reports area.
14:07:01 <yboston> jenny++
14:07:04 <rsoulliere> #info Added Patron Management Chapter. http://docs.evergreen-ils.org/2.2/_circulation_patron_record.html
14:07:11 <rsoulliere> jenny++ for contributing the content.
14:07:26 <kmlussier> jenny++
14:07:26 <rsoulliere> #info Added Staff Accounts section today. http://libdog.mohawkcollege.ca/evergreen_documentation/2.2/_user_and_group_permissions.html
14:07:36 <rsoulliere> jenny++ for reviewing that section.
14:07:46 <rsoulliere> #info  Added Group Serials Issues in OPAC Display Chapter. http://docs.evergreen-ils.org/2.2/_group_serials_issues_in_the_template_toolkit_opac.html
14:08:04 <rsoulliere> safortin++ and ESI++ for contributing the documentation.
14:08:17 <rsoulliere> #info In July, we had a few bug reports related to the upgrade instructions for 2.2. I have fixed and updated bug reports.
14:08:29 <rsoulliere> #help Please continue to report any bugs in the documentation using launchpad.
14:08:46 <rsoulliere> #info If you notice any issues with the documentation, either send a note to the DIG list or enter it as a bug in launchpad.
14:08:59 <rsoulliere> #help Please review and update the outline for 2.2: http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs_2.2:outline
14:09:21 <rsoulliere> #help Also begin to review and update the outline for 2.3 documentation:  http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs_2.3:outline
14:09:37 <rsoulliere> #info It looks like the rel_2_3 branch has been recently created in the Evergreen git repository.
14:09:51 <rsoulliere> berick++ nice release notes!
14:10:08 <rsoulliere> #action I will put together a basic build of the 2_3 documentation in the few weeks to be processed from that branch.
14:10:21 <rsoulliere> #info It will be available in the official docs site: http://docs.evergreen-ils.org/
14:10:30 <rsoulliere> #info If you have any suggestions for improving the documentation, please send a note to the DIG list for discussion.
14:10:58 <rsoulliere> That is all. I'll let you digest and comment. ;-)
14:11:10 <yboston> rsoulliere:++
14:11:18 <tspindler> rsoulliere++
14:11:59 * jenny is Jenny Turner, PALS
14:12:05 <tspindler> I was just wondering when 2.3 is released should we focus getting documentaiton for 2.3 or 2.2?  I know there is still a lot missing for end user docs
14:12:15 <jenny> Sorry, folks, in the middle of a conversion. :)
14:12:51 <yboston> I suspect it would be great to know all the functionality in 2.2. that remains the same in 2.3 so it can be carried over
14:13:23 <tspindler> I'll have to say our migration has consumed me and I have done no work on this
14:13:53 <rsoulliere> Release notes in rel_2_3 branch might give us some hints about differences.
14:13:58 <berick> rsoulliere: thanks.  dev_team++ (echoing the karma around to all the devs who wrote feature release notes)
14:14:08 <kmlussier> In many cases, I suspect the documentation would be the same for 2.2 and 2.3, and since they both use asciidoc, it should be fairly easy to add it to both.
14:14:13 <rsoulliere> dev_team++
14:14:39 <kmlussier> Is more work needed for the release notes?
14:15:00 <kmlussier> I notice kpac is missing from there, and I suspect there might be other missing features.
14:15:13 <berick> kmlussier: for 2.3?  yes.  some features are not documented
14:15:25 <berick> we also need to document the ugprade admin tasks
14:17:44 <rsoulliere> Yes, I would consider 2.3 documentation to be a work in progress. Are there some new twists to the upgrade steps for 2.3 or do they follow similar pattern as before?
14:18:28 <tspindler> kmlussier: I'm assuming ESI will have the documentation related to edi invoices etc.?
14:19:51 <kmlussier> tspindler: I think so. Much of the acquisitions work is already in the release notes.
14:20:09 <Rogan> There are some new workflows and those will be documented.
14:20:12 <berick> rsoulliere: no new upgrade twists.. the "ugprade admin tasks" I'm refering to are the normal configuration file changes that we need to bring attention to (see the top of docs/RELEASE_NOTES_2_2.txt for example)
14:20:51 <safortin> tspindler: yes, i'll be writing documentation on EDI invoices
14:21:01 <rsoulliere> berick: OK, thanks.
14:21:10 <kmlussier> safortin++
14:21:27 <jenny> safortin++
14:21:31 <rsoulliere> safortin++
14:21:39 <yboston> safortin++
14:21:42 <yboston> Within DIG we have spoken about preparing a minimum core set of instructions for each new release. So should we just focus on that minimum for 2.3 and the rest of our efforts on 2.2 until 2.3 is released.
14:21:42 <tspindler> safortin++
14:21:50 <yboston> Or should we only focus on 2.3, with the hope that documentation that works in 2.2 will be moved over by volunteers
14:22:13 <yboston> like myself since I am on 2,2
14:22:50 <yboston> BTW, we can bring this up on the list and we can move on with the meeting for now
14:22:54 <tspindler> I haven't gone through it in a while but is there still other stuff that can be reworked from 2.1 documentation int ASCII Doc for 2.2?
14:23:16 <jenny> My guess is yes, tspindler.
14:23:22 <yboston> my guess too
14:24:26 <rsoulliere> We need reviewers... and update the outline for 2.2 re: what can be brought into 2.2 from any previous version.
14:25:57 <yboston> #action decide if DIG should focus on EG 2.2 and/or 2.3
14:26:23 <yboston> #action review older documentation to find documentation that can be moved to 2.2 and 2.3
14:26:58 <tspindler> I have to say i'm hesitant to focus on 2.3 since we don't have a test install internally, it would be easier for me to look at 2.2
14:27:06 <kmlussier> yboston: You can add my name to that action item for staff client and OPAC tasks.
14:27:25 <kmlussier> The action item for reviewing older documentation.
14:27:55 <yboston> {not sure how :) }
14:28:28 <kmlussier> yboston: ah, well it will be in the chat logs then. :)
14:29:16 <yboston> it appears that a lot of us DIG members are in the middle of migrations (me included), but hopefully we can contribute more in the next couple of weeks
14:29:38 <kmlussier> yboston: Yes, and that's about the crux of my content coordinator report.
14:29:58 <kmlussier> Migrations have been consuming my life, so I don't have much to report.
14:30:10 <yboston> should we move on to the other reports, even if they are very brief?
14:30:15 <kmlussier> But I'm still on the lookout for anyone who is interested in contributing end user documentation for tpac.
14:30:44 <krvmga> i have been documenting things that i've been doing as i've been going along but i don't know if it's of use to anyone
14:31:16 <safortin> kmlussier: i don't have anything for tpac, but i will be submitting docs for kpac
14:31:30 <krvmga> i have an overview of the TPAC page structures
14:31:42 <kmlussier> krvmga: is this end user documentation for performing searches in the catalog, using my account, etc.?
14:32:01 <kmlussier> safortin++ I'm looking forward to that.
14:32:10 * yboston though kpac was a misspelling aka Kids pac
14:32:46 <krvmga> kmlussier: i think it's more in the line of being helpful in changing and customizing pages, knowing what all parts make up a page and what each part does, where it is, etc.
14:33:33 <kmlussier> krvmga: that would be useful too.
14:33:42 <kmlussier> I'm looking for a tpac version of http://docs.evergreen-ils.org/1.6/draft/html/opac.html.
14:33:43 <yboston> krvmga: I already have a feeling that your notes on installation are helpful and probably similar to mine, I still hope we can find a place for them
14:34:16 <krvmga> yboston: :)
14:34:20 <kmlussier> I asked for volunteers a while ago, but it was before many people were using tpac, so it might worthwhile if I send out another one.
14:35:03 <jenny> kmlussier: gentle reminders are good.
14:35:15 <yboston> should we make it an action item?
14:35:31 <kmlussier> krvmga, yboston: those docs may fit in well with what denials already did at http://docs.evergreen-ils.org/2.2/_tpac_configuration_and_customization.html
14:35:46 <kmlussier> yboston: yes, please do. Or can I do my own action items?
14:35:59 <yboston> yes you can, just type #action
14:36:18 <kmlussier> #action kmlussier will put out a call for volunteers to do end-user tpac documentation
14:36:53 <yboston> For the record, anyone can use any of the basic meetbot tags like  #action #agreed #help #info #idea #link #topic.
14:37:11 <krvmga> kmlussier: yes, you're right. i think i tend to take a little more of a "for newbies" approach and so i've kind of made eight-by-ten colour glossy photographs with circles and arrows and a paragraph on the back of each tt2 file explaining what each one is. :)
14:37:50 <yboston> I  would love to see those!
14:38:03 <krvmga> yboston: i would be happy to share.
14:38:07 <rsoulliere> #idea Could notes be shared using the DIG list?
14:39:48 <yboston> For the record, we are past the 30 minute mark. I think we are having a good informal discussion, but I want to hear from other coordinators (if they have reports today), if not email the DIG list with the report
14:40:05 <yboston> rsoulliere: I don't understand what you mean?
14:40:59 <rsoulliere> krvmka: yboston: could you post your notes on the list? The ones you made for customizing, installation etc...
14:42:01 <krvmga> rsoulliere: i haven't put them in asciidoc format yet but i can unless everyone's happy to see them in other formats.
14:42:24 <yboston> we can start on the list, and we can them create some placeholder EG wiki pages with edited notes for others to look and contribute to
14:42:31 <rsoulliere> krvmga: I was thinking in any format.
14:43:08 <krvmga> rsoullier: it will be my pleasure.
14:43:25 <rsoulliere> krvmga++
14:44:13 <yboston> #action krvmga & yboston will share notes on DIG list
14:44:47 <krvmga> rsoulliere yboston: i will not be able to do it before monday. i'm in the middle of something that has to get done first.
14:44:57 <yboston> no problem
14:46:08 <yboston> we are at the 45 minute mark, I am curious if any one has any reports they are dying to give.
14:46:10 <yboston> I also want to see if there are any community questions for DIG at this point
14:46:13 <jenny> #info Reports report: Not much to share since our last meeting; the complete set of reports documentation has been moved forward from 2.1 to 2.2.  Always looking for additions, though.
14:46:28 <yboston> jenny++
14:46:43 <jenny> rsoulliere++
14:46:48 <yboston> any other quick reports?
14:47:06 <raynerj> #topic System Admin
14:47:06 <raynerj> #info No update from System Admin documentation, still trying to catch up from vacation.
14:47:56 <yboston> raynerj: thanks
14:48:12 <yboston> any one else?
14:48:38 <alexlazar> I have a question.
14:49:04 <yboston> alexlazar: go ahead
14:49:27 <alexlazar> Are there any ideas/plans for improving how the HTML documentation is presented on the web?
14:50:00 <yboston> My guess is no because
14:50:10 <yboston> I think our biggest issue is lack of content, but
14:50:31 <yboston> becuase of the use of ASCIIDoc and HTML/CSS it should be easy to have someone
14:50:32 <kmlussier> alexlazar: Improving in what way? Structure? Design?
14:50:46 <yboston> just improve the "style" of docs easily
14:51:08 <rsoulliere> alexlazar: Are you volunteering for the "Style Coordinator" position which is vacant? http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:digparticipants
14:51:20 <alexlazar> kmlussiter: I would say presentation.
14:52:03 <alexlazar> rsoulliere: let me think about that
14:52:14 <alexlazar> Specifically
14:53:16 <alexlazar> I find it difficult to find information using keywords, because the content is split in multiple pages.
14:53:32 <kmlussier> alexlazar: I would concur with yboston that most of the active participants have been more focused on getting content in there, but I don't think anyone would object to a volunteer tending to style issues. :)
14:54:05 * denials is Dan Scott, Conifer, returning from another meeting
14:54:17 <yboston> alexlazar: I have had that issue too
14:54:42 <denials> alexlazar: I'd suggest doing something like we did by adding ePub - get a working proof of concept and point people at it & ask for adoption?
14:54:47 <alexlazar> There is no internal search, and I can't use browser in-page search, so that gets in the way of finding what I need.
14:55:00 <alexlazar> denials: ok
14:55:16 <yboston> alexlazar: it would be great to have some type of search engine. I end up searching keywords on the PDF, then I go back to the HTML version to send out links, etc
14:55:33 <alexlazar> yboston: exactly what I do too.
14:55:34 <yboston> alexlazar: I would like to hear your ideas on this
14:56:08 <yboston> alexlazar: maybe we can just create a custom google search widget for the HTML docs, or some other similar solution
14:56:36 <alexlazar> yboston: ok. let me think about that some more.  For now I just wanted to see if anybody else sees particular issue as a problem.
14:56:39 <denials> eclipse information center is reasonable infrastructure for this sort of thing
14:57:31 <alexlazar> denials: new to me
14:57:46 <yboston> denials: never heard of if (which is a knock on me)
14:58:09 <denials> http://publib.boulder.ibm.com/infocenter/db2luw/v8/index.jsp is an example; dates back about 7 years
14:58:36 <denials> (just a possibility, I'm sure there are lots of options!)
14:58:44 <yboston> is it FOSS?
14:59:01 <denials> yboston: yeah, it's part of eclipse
14:59:07 <yboston> oh!
14:59:20 <alexlazar> I really enjoy using PostgreSQL documentation, e.g., http://www.postgresql.org/docs/9.1/static/index.html. They have reasonable breadcrumbds, it's easy to jump from version to version, and they have comments that can be enable per topic. That's really nice.
14:59:23 <denials> contents pane is defined by one or more XML files that point to a set of topics
14:59:45 <denials> alexlazar: sure. lots of options
15:00:40 <yboston> alexlazar: I would not be surprised id AsciiDoc can be customized to have somewhat similar functionality like breadcrumbs, and we can try other approaches too
15:00:53 <denials> http://help.eclipse.org/indigo/index.jsp?topic=%2Forg.eclipse.platform.doc.isv%2Fguide%2Fua_help_setup_infocenter.htm fwiw :)
15:01:22 <yboston> alexlazar: do you want to continue this on the DIG list since we are reaching the hour mark?
15:01:37 <alexlazar> yboston: sure
15:01:51 <yboston> alexlazar: thank you for bringing this up
15:02:55 <yboston> #action explore improving the keyword searching and presentation of the HTML version of documentation
15:03:55 <yboston> Before we start wrapping up, though I am free to keep going longer, I wanted to quickly bring up an idea I had recently
15:04:27 <yboston> Should DIG somehow collaborate with or imitate the 2012 Evergreen “Hack-A-Way” event in October?
15:04:56 <kmlussier> yboston: Are you thinking of an online version of a hackfest or an in-person event?
15:04:58 <yboston> I can bring this up on the list, but I wanted to throw it out there now
15:05:11 <yboston> kmlussier: both
15:05:29 <alexlazar> yboston: sounds interesting
15:05:30 <yboston> kmlussier: or some type of hybrid
15:05:48 <krvmga> kmlussier: both or some type of hybrid
15:05:51 <tspindler> #agreed
15:06:22 <yboston> or just a simple excuse to set aside some time to have some of us work collectively on IRC or skype or face to face
15:06:29 <kmlussier> I like the idea of dig hackfests because it forces me to set aside time for DIG work.
15:06:48 <kmlussier> I don't think I could travel to anything though, unless yboston were hosting it. :)
15:07:02 <krvmga> agrees with kmlussier
15:07:30 <yboston> we do have a couple of DIG people in Massachusetts, we could try to come up with something. I do have a library conference room we could use
15:07:55 <denials> Last year Google funded some projects to bring writers together, around the same time as the Google Summer of Code Mentors' Summit (October)
15:07:58 <kmlussier> yboston++
15:08:10 <alexlazar> yboston: maybe conference call?
15:08:30 <raynerj> I agree with kmlussier and yboston - it's helpful to have a designated time to work on docs
15:08:36 <tspindler> gotomeeting or gotwebinar
15:08:56 <yboston> alexlazar: yes, we use that room for conference calls and there is a projector
15:09:30 <raynerj> Maybe a combination of in person and gotomeeting or gotowebinar
15:09:47 <denials> hangouts :)
15:10:10 <alexlazar> denials: google+?
15:10:23 <yboston> #action explore a DIG hackfest inspired by the 2012 Evergreen “Hack-A-Way” event in October. date/Location/format to be determined
15:10:27 <kmlussier> denials: The GSOC thing sounds interesting.
15:10:35 <alexlazar> raynerj: sounds good
15:11:09 <yboston> this might be a good time to start wrapping up
15:11:30 <denials> kmlussier: http://google-opensource.blogspot.ca/2011/09/sprinting-for-open-source.html was what they did last year, I can poke to see if they're planning on repeating it
15:12:03 <yboston> denials: thanks
15:12:43 <yboston> quick meeting recap:
15:12:43 <yboston> - we need to decide on what version to focus on, and what older content can be moved to newer versions.
15:12:44 <yboston> - we will look for more TPAC documentation.
15:12:44 <yboston> - we will share notes with each other. explore a DIG hackfest inspired by the 2012 Evergreen “Hack-A-Way” event in October. date/Location/format to be determined
15:12:44 <yboston> anything else?
15:14:00 <yboston> forgot to mention, think of ways to improve keyword search/presentation of HTML docs
15:14:43 <yboston> OK everybody, thanks for a great meeting!
15:14:52 <krvmga> bye all :)
15:14:56 <alexlazar> yboston: thank you.
15:14:59 <kmlussier> yboston++
15:15:14 <rsoulliere> yboston++
15:15:46 <denials> yboston++
15:15:49 <jenny1> yboston++
15:15:57 <csharp> yboston++
15:16:27 * csharp recommends "site:docs.evergreen-ils.org <keyword>" on the GOOG in the meantime
15:16:29 <denials> quick response on whether there will be a doc sprint this year: "probably" :) so keep your eyes glued to http://google-opensource.blogspot.ca or the country code of your choice :)
15:16:34 <denials> csharp++
15:17:08 * denials recommends cataloguing the individual web pages in an Evergreen instance
15:17:24 <yboston> FYI, following our regular meeting pattern, next meeting will be Thursday  September 7th
15:17:26 <csharp> denials++
15:17:29 <kmlussier> denials++
15:17:33 <denials> Facet by genre -> installation :)
15:17:38 <yboston> csharp: thanks
15:19:18 <yboston> sorry, Thursday  September 6th
15:20:23 <senator> so for anyone who might like to help vet a 2.2.1 release, see this: http://nox.esilibrary.com/~lebbeous/only-a-test/
15:20:39 <senator> i have two observations/questions up front
15:21:17 <senator> 1) the source tarball is *way* bigger now, but that seems only to be because of all the docs in the same repo as source, which iiuc happened after 2.2.0. so maybe it's fine?
15:21:44 <senator> 2) we don't do/haven't done full on release notes for the minor (third digit != 0) releases so far, right?
15:21:56 <yboston> #endmeeting