#evergreen: 2012-08-29 - Developer Meeting

Meeting started by dbwells at 15:07:18 US/Eastern (full logs).

Meeting summary

    1. dbwells is Dan Wells, Hekman Library, Calvin College (dbwells, 15:08:03)
    2. denials is Dan Scott, Laurentian University (denials, 15:08:18)
    3. eeevil is Mike Rylander, Equinox (eeevil, 15:08:40)
    4. gmcharlt is Galen Charlton, Equinox (gmcharlt, 15:08:49)
    5. tsbere is Thomas Berezansky, MVLC (tsbere, 15:09:31)
    6. senator is Lebbeous Fogle-Weekley, Equinox (senator, 15:10:02)
    7. danielR is Daniel Rizea, Gsoc student on project: Android client for EG (danielR, 15:10:08)
    8. jeff is Jeff Godin, TADL (jeff, 15:10:10)

  1. Action Items from Last Meeting (dbwells, 15:10:43)
    1. denials still going to write up �How to set up an alias for cherry-picking w/ signoff in tig� (dbwells, 15:11:23)
    2. STATUS: denials is still going to write that up, in more than the one-line .tigrc he posted to IRC (dbwells, 15:12:42)
    3. GSoC reports are deferred for later in the meeting (dbwells, 15:13:32)
    4. berick to announce alpha2 release on general/dev list. STATUS: Done, along with beta1 and beta2 (dbwells, 15:15:43)
    5. ACTION: berick will make sure the rc1 release actually gets some kind of announcement (dbwells, 15:16:19)
    6. denials will open bug to track TPAC locale selector needs -- STATUS: done, and implemented, and merged back through 2.2 with the assistance of senator and berick (I'denials'RC), LP bugs 1025921 and 1033003 (dbwells, 15:20:40)
    7. (pranjal710, 15:24:55)
    8. senator will update the bug with an outline of what could be changed for more speed -- STATUS: senator and dbwells have made some progress on understanding the issue, and expect to have it resolved soon (dbwells, 15:26:00)
    9. bug in question is LP 1024095 (dbwells, 15:26:21)
    10. ACTION: senator and dbwells will work out the remaining details on bug 1024095 (dbwells, 15:27:00)
    11. bshum / moodaepo will mark Evergreen 2.0.x as deprecated, and style it to look as dead and unappealing as possible -- STATUS: Done. (dbwells, 15:27:31)
    12. a howto for tig cherry-picking with sign-off is at http://www.evergreen-ils.org/dokuwiki/doku.php?id=dev:git:tig (denials, 15:27:31)

  2. GSoC Reports (dbwells, 15:29:18)
    1. danielR reports "To make a quick summary the project is an Android EG client (it has all the OPAC web functionalities: search, checkout, holds and bookbags) + barcode ISBN scan (and search based on the barcode) + notifications (notify the user when a checkout is about to expire)" (dbwells, 15:43:23)
    2. eeevil reported on behalf of his student (swenyu) -- Converted string normalizing functions led to small speed improvements and a good template for ICU-based string manipulation in C-based stored procs. swenyu also started some MARC handling code, and is interested in continuing to work on search in evergreen. (dbwells, 15:56:12)
    3. senator and pranjal710 report that pranjal710 completed PHP client bindings for OpenSRF. This essentially means PHP users now have an easy and consistent way to call any opensrf method using fieldmapper objects in the parameters and getting them in results, too, based on the IDL published by the host being contacted. pranjal710 is working on getting it into PEAR for PHP users' convenience. (dbwells, 15:58:42)
    4. https://github.com/pranjal710/osrf (dbwells, 15:59:00)
    5. http://evergreengsoc.blogspot.ca/2012/08/little-shoves.html is joseph's most recent blog post, which sounds like he made a huge amount of progress. and unit tests! (denials, 16:01:11)
    6. tsbere reported on behalf of his student (joelewis) -- joelewis seems to have everything working up through dojo 1.6, and started dealing with the massively annoying changes that were made for 1.7 on. For reference, apparently dojo no longer supports the require syntax used up through 1.6, which breaks any hope of compatibility without major rewriting. (dbwells, 16:03:09)

  3. Release Info (dbwells, 16:05:13)
    1. OpenSRF - no release info to report (dbwells, 16:17:04)
    2. 2.3.x.. RC1 Friday, probably friday night (dbwells, 16:19:16)
    3. 2.2.3 should be due in late september. that gives it a little time to accumulate bugfixes since 2.2.2, i should think. that's barring anything to accelerate the release, like any security bugs that should turn up (dbwells, 16:22:25)
    4. denials will try to sync up with senator on the next 2.1.x release as well (denials, 16:22:34)
    5. ACTION: denials to patch make_release so that it sets the eg_version var on the upgrade scripts (denials, 16:25:10)

  4. Hack-a-way (dbwells, 16:26:02)


Meeting ended at 16:34:56 US/Eastern (full logs).

Action items

  1. berick will make sure the rc1 release actually gets some kind of announcement
  2. senator and dbwells will work out the remaining details on bug 1024095
  3. denials to patch make_release so that it sets the eg_version var on the upgrade scripts


Action items, by person

  1. berick
    1. berick will make sure the rc1 release actually gets some kind of announcement
  2. dbwells
    1. senator and dbwells will work out the remaining details on bug 1024095
  3. denials
    1. denials to patch make_release so that it sets the eg_version var on the upgrade scripts
  4. senator
    1. senator and dbwells will work out the remaining details on bug 1024095


People present (lines said)

  1. dbwells (55)
  2. denials (38)
  3. senator (22)
  4. eeevil (21)
  5. jeff (17)
  6. gmcharlt (13)
  7. danielR (10)
  8. berick (10)
  9. pinesol_green (8)
  10. tsbere (7)
  11. JoeLong_UDJ (6)
  12. pranjal710 (6)
  13. pwaak (1)


Generated by MeetBot 0.1.4.