14:01:03 <yboston> #startmeeting 2012-09-06 - DIG Monthly Meeting Evergreen Documentation Interest Group (DIG) Monthly Meeting. The agenda can be found here http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:dig_meeting_20120906-agenda
14:01:03 <pinesol_green> Meeting started Thu Sep  6 14:01:03 2012 US/Eastern.  The chair is yboston. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:03 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:01:16 <yboston> #topic Introductions
14:01:22 <yboston> Please feel free to start introducing yourselves...
14:01:33 * yboston Yamil Suarez @ Berklee college of Music
14:03:10 * tspindler Tim Spindler@ C/W MARS
14:03:26 <ericar> #info Erica Rohlfs@Equinox
14:03:37 * kmlussier is Kathy Lussier, MassLNC
14:04:04 <raynerj> raynerj is June Rayner, eiNetwork
14:04:29 * denials is Dan Scott, Laurentian University (but probably won't be able to participate much)
14:06:10 <yboston> #topic Updates from Content Coordinators
14:06:19 <yboston> Btw, I want to continue experiment with having the content corrdinators try out the "#topic" AND "#info" Meetbot commands for their reports
14:06:26 <yboston> So content coordinators, please use "#topic" for the first post/line of your report
14:06:32 <yboston> then use "#info" for every other chat post/line of your report.
14:06:38 <yboston> for example...
14:06:44 <yboston> #topic this is a test report first post/line
14:06:51 <yboston> #info this is a test report second post/line
14:07:04 <yboston> who who like to go first?
14:07:20 <kmlussier> I can.
14:07:36 <yboston> (also, whenusing #topic, give your report  at title
14:07:41 <yboston> go ahead...
14:07:43 <kmlussier> #topic Public OPAC/staff tasks content coordinator report.
14:08:46 <kmlussier> #info Unfortunately, I haven't done much since the last meeting.
14:09:13 <kmlussier> #info I still need to put out a message to get a volunteer to do tpac documentation. I'll send it out before this meeting is done.
14:09:39 <kmlussier> Sorry that I don't have more to report at this time.
14:10:04 <tspindler> #topic Co-Release Coordinator Report
14:10:22 <tspindler> #info I'm afraid I'm in the same boat as Kathy and havent done much
14:10:25 <yboston> thanks kmlussier, ho ahead TIm
14:11:11 <yboston> thanks tspindler
14:11:19 <yboston> who would like to go next?
14:11:41 <raynerj> i can go
14:11:48 <yboston> go ahead
14:12:02 <raynerj> #topic  System Administration - no report.
14:12:11 <raynerj> I am interested in participating in a documentation hackfest virtually since having a scheduled time seems to be the only way to get time to work on docs.
14:12:48 <tspindler> +1,  I think if I had time that I was forced to carve out it would work better
14:12:57 <yboston> thanks raynerj, we will talk about the kack-a-way in a bit :)
14:13:08 <kmlussier> raynerj++ agreed.
14:13:33 <yboston> BTW, if there are no content  coordinators left, this is a good time for non coordinators to ask a question or make a report
14:14:44 <yboston> I guess it is time to move to old business
14:15:42 <yboston> I am going to skip the 2.3 related old business item and skip to Tim's old agenda item
14:15:59 <yboston> #topic Discuss what DIG thinks the role of the DIG release coordinator should be (suggested by Tim Spindler)
14:16:57 <yboston> Tim do you want to talk about this issue for a bit or should we shelve it for next time?
14:17:52 <tspindler> it might be good to talk about now
14:17:59 <yboston> go ahead
14:18:56 <tspindler> #info A while ago I asked what the role of the Release Coordinator should be.  Robert Soulliere contributed some detailed thoughts on this and so did Yamil on the documentation listserv.
14:19:59 <tspindler> #info I would have to dig up what was said but I was just wondering what others thought.  One thought I originally had was making sure that previous version documentation gets upgraded to the new release.
14:20:26 <tspindler> #info I know there was also some discussion if this shouldn't be automatic since no one seems to hve the time to test it.
14:21:36 <tspindler> Anyone have an y thoughts, part of this was due to the fact I said I would be a co-release coordinator with yamil and not sure what I should all be doing
14:22:44 <yboston> My first thought thought is that most of us are having a hard time making the time to make DIG contributions,
14:22:53 <tspindler> lol
14:23:26 <yboston> but I like that we are starting to toy with the idea of having multiple DIG hackfest in a given year
14:23:44 <yboston> like the one we hope to have in October/Spetember and at the yearly conference
14:24:18 <yboston> perhaps once those two events become habit we will have a better chance to continually contribute
14:24:21 <tspindler> that may be better if people might be able to commit to a time
14:24:29 <yboston> exactly
14:24:52 <tspindler> personally, something at work always takes precedence it seems
14:26:23 <yboston> so in others words I am saying, perhaps we should revisit this topic after we (hopefully) have our hack-a-way in September/October
14:27:00 <tspindler> yboston +1
14:27:10 <yboston> Though I still wanted to bring this topic up now since it had been lingering for so long
14:27:45 <yboston> should we move on from this topic or does anyone have any other comments/quesitons?
14:28:20 <kmlussier> One thought, could the release coordinator track what's new in a given release and add anything to the release notes that have not already been added?
14:28:49 <kmlussier> I know some items are added to the release notes as the code is contributed, but there are also missing features.
14:29:08 <denials> There's the Fedora "Beats" approach to documenting new features /changes as a possible model
14:29:32 <tspindler> denials: what is that approach?
14:29:35 <denials> #info http://fedoraproject.org/wiki/Category:Documentation_beats as one possible model for keeping up-to-date
14:29:54 <denials> (but Fedora has a heck of a lot of contributors!)
14:30:34 <yboston> as co-cordinator I kept up with the dev list to keep an informal list of new features, but I could not keep up with time
14:30:43 <kmlussier> denials: Heh, I was just about to say the same thing about their abundance of contributors.
14:31:10 <yboston> I think that now that developers are trying some new approaches to keep track of new changes, this might be more doable in real life. Liek making additions to the "doc" directory and adding some AsciiDoc notes on new features(?)
14:32:22 <yboston> sorry, I mean that I believe developers were going to try to add sparse AsciiDoc notes as the added features.
14:32:38 <denials> mind you, as a developer I know I'm guilty of not adding enough
14:32:51 <yboston> If this is being done, that might be a straight ahead way to keep track of new features
14:33:46 <yboston> BTW, another cheesy reason Tim and I could not keep up is that we are both finishing or recently finished a migration to EG :(
14:34:11 <Dyrcona> Bigger new features have been getting release notes added.
14:34:32 <yboston> Dyrcona: awsome (I had not checked)
14:35:06 <tspindler> Drycona: I think that helps a lot
14:36:01 <yboston> I guess for now we can set a future action to revisit what approach we can take to better keep track of big and small new features. (specially after we have had our hack-a-ways.)
14:36:37 * denials has been thinking that a topic on "Setting up locale support in TPAC" would probably be a good addition
14:36:50 <denials> 382 lines in the 2.3 release notes at the moment
14:37:07 <denials> 60 of which describe new XULRunner development internals :)
14:37:41 <yboston> (sorry for trying to end this topic, I want to talk about the hack-a-way today)
14:39:03 <yboston> #action revisit what approach DIG release coordinators can take to better keep track of big and small new features. (specially after we have had our hack-a-ways.)
14:39:41 <yboston> any other comments or thought on this topic today? I promise that Tim or I will revive it in the near future :)
14:41:24 <yboston> moving on for now
14:41:28 <yboston> #Should DIG somehow collaborate with or imitate by the 2012 Evergreen “Hack-A-Way” event in October (proposed by Yamil)
14:42:35 <yboston> I have not gotten any feedback yet on the email that I sent yesterday to the DIG list about this topic, but most of you knew about it already.
14:43:32 <yboston> LIke the email said we can definitely host around 6 people at my library  in Boston, and
14:43:44 <yboston> others through Skype or Google hangout
14:44:19 <yboston> any here that would be interested in coming over?
14:44:55 <yboston> of course we have not discussed if we should get together at the same time as the dev hack-a-way in October
14:44:59 <tspindler> I think this is a really good idea and doing it twice a year as you suggest.
14:45:56 <yboston> BTW, I just realized that right now that the developers are shooting for two major reales a year, so two is a good minimum to shoot for
14:46:38 <raynerj> That's sounds good to me
14:47:25 <yboston> what are the dates again for the dev hack-a-way?
14:48:10 <yboston> not sure if EG 2.3 will be out by then, if not we might want to meet earlier to improve the EG 2.3 docs as ti is released
14:48:39 <kmlussier> yboston: October 10-13
14:48:48 <yboston> kmlussier: thanks
14:50:01 <raynerj> Maybe a Doodle poll to pick a date?
14:51:57 <yboston> raynerj: good idea, though I hope the UI does not get overwhelming if we try to list most days in September and all of October.
14:52:20 <yboston> would someone like to volunteer to set up the Doodle poll?
14:52:32 <tspindler> yboston: i can do it
14:52:38 <denials> avoiding the same dates as the hack-a-way also introduces the possibility of one person attending both events :)
14:52:47 <yboston> tspindler: thanks!
14:52:50 <tspindler> i need to go in when we're done for another one anyway
14:53:36 <tspindler> the hackaway is October 10-13?
14:53:38 <yboston> denials: wow I was focused on trying to have them at the same time, but now that you mention it, it might be best to keep them separate
14:54:13 <kmlussier> tspindler: yes, that's right.
14:54:32 <tspindler> ok, I can set the poll so it doesn't cover those dates
14:54:39 <yboston> BTW, the dev hack-a-way includes a Saturday. I am willing to work on a Saturday, but we collectively only want to consider work days
14:55:10 <yboston> (we collectively MAY only...)
14:55:11 <kmlussier> Yes, I can only attend if it's a work day.
14:55:25 <tspindler> have a poll to discuss what is on the poll ;) (just kidding)
14:55:37 <kmlussier> tspindler++
14:55:39 <yboston> tspindler: :)
14:56:22 <tspindler> i'll set it up for weekdays in october outside of the hackaway
14:56:32 <yboston> #action tspindler will create a Doodle poll to pick a day to have a DIG hack-a-way, that will not include weekends in September / October
14:57:21 <yboston> #idea denials said "avoiding the same dates as the hack-a-way also introduces the possibility of one person attending both events"
14:57:44 <yboston> BTW, we are almost at the hour mark
14:59:21 <yboston> I guess some of our next actions for the hack-a-way besides picking the date is coming up with rough goals and what type of tools/test servers/etc we will need to get our work done
14:59:24 <yboston> any other ideas?
14:59:47 <yboston> also I guess for now Berklee will do the physical hosting in Boston
15:01:16 <kmlussier> yboston: Berklee works for me.
15:01:27 <yboston> as we are reaching the end of the meeting I wanted to mention the two topics we will probably not cover today
15:01:34 <tspindler> works for me, i can take the train then
15:01:44 <yboston> 1) Should DIG focus on 2.2 or 2.3 documentation
15:02:08 * denials strongly suggests 2.3, as 2.2 will probably be out of support before the docs for it are done :)
15:02:19 <yboston> feel free to just reply to my very recent email to the or again we might have a better idea once we get closer to our hack-a-way
15:02:45 <yboston> denials: thanks, your thoughts carry a lot of weight
15:02:46 <tspindler> did we ever agree to just upgrade existing docs without testing,  i know there was some discussion at one point
15:02:56 <kmlussier> yboston: I prefer working on 2.3, but also backporting some of it 2.2 when it can be done.
15:03:25 <yboston> tspindler: can you mention that as a reply to my email to get the conversation started on the list?
15:03:27 <kmlussier> On the list, there was general agreement to automatically upgrade them. I don't recall seeing any objections.
15:03:40 <tspindler> yboston: yes
15:04:17 <yboston> kmlussier: I am glad you remember because I did not :)
15:04:21 <tspindler> kmlussier: I thought rsoulliere had some concerns and dan thought we should to get documentation (correct me if I'm wrong denials)
15:05:43 <yboston> I need to attend another meeting, so I would like to ask that we continue this next time and/or the DIG list :(
15:06:12 <yboston> BTW, 2) Jenny Turner will no longer be an official DIG member an we will need a replacement "DIG reports coordinator"
15:07:01 <yboston> final thoughts as I wrap up?
15:07:23 <kmlussier> yboston++ for great meeting facilitation!
15:07:25 <yboston> #topic need a replacement "DIG reports coordinator"
15:07:31 <yboston> sorry
15:07:37 <yboston> #action need a replacement "DIG reports coordinator"
15:07:49 <yboston> thanks everybody!
15:08:04 <raynerj> yboston+++
15:08:05 <tspindler> yboston ++
15:08:26 <yboston> #endmeeting