14:31:10 <jventuro> #startmeeting 2012-09-28 Evergreen Reports Task Force
14:31:10 <pinesol_green> Meeting started Fri Sep 28 14:31:10 2012 US/Eastern.  The chair is jventuro. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:31:10 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:31:40 <jventuro> Hi, everybody!  If everyone participating in the meeting could please introduce themselves.
14:31:57 <jventuro> <-is Jessica Venturo of Bibliomation
14:32:17 * csharp is Chris Sharp, GPLS
14:32:29 * jeff is Jeff Godin, TADL
14:32:47 * chtrotter is Cristina Trotter, Oconee Regional Library System (PINES)
14:33:13 <jeff> i regret to say that I'm unable to attend today -- but i'll look for minutes after the meeting and see/talk to some of you on the reports mailing list.
14:34:01 <jventuro> jeff: thanks for stopping by
14:35:27 <jventuro> Anybody else?
14:37:06 <jventuro> Small turn out today.  Do you guys think we should proceed with business as usual, or try and reschedule?
14:37:17 * csharp thinks about that
14:38:01 * chtrotter thinks we should continue on...but maybe that is because this is the first meeting I have been able to make since Spring.
14:38:22 <csharp> those who show up get to make the decisions, right? ;-)
14:38:49 <jventuro> Good point!
14:39:44 <jventuro> This is my first meeting in a while too.  And since it's the first one I'm running, probably better that it's a small audience anyway ;-)
14:40:03 <csharp> I usually lurk in these meetings, but I've recently discovered that I have a pretty good handle on creating and troubleshooting templates, so I'm here
14:40:24 * jlamos is lurking
14:40:57 <jventuro> Welcome, lurkers!
14:41:40 <jventuro> #topic Review and approval of minutes from 2012-06-21
14:42:07 <jventuro> #info Notes are here: http://evergreen-ils.org/meetings/evergreen/2012/evergreen.2012-06-21-14.31.html
14:42:48 <jventuro> The only action item from the last meeting is the update from PINES development, which is farther down the agenda
14:43:10 <csharp> looks okay to me
14:43:46 <chtrotter> they look good to me, too. I was glad to be reminded of the wishlist items.
14:44:28 <jventuro> Me too.  I might have some things to add later.
14:44:28 * chtrotter is glad to have csharp here to talk about the PINES development
14:45:17 <csharp> ;-)
14:45:21 <jventuro> Might as well move on to old business then, speaking of that
14:45:33 <jventuro> #topic Development
14:46:59 <jventuro> csharp: Did you want to talk a little bit about the PINES developments?  I know there are not starting up until October, yes?
14:47:04 <csharp> #info Elizabeth McKinney, PINES Program Director, is managing the reports development project on the PINES end
14:47:52 <csharp> #info Elizabeth: "We halted the project last year due to budget cuts and will resume the project with the beginning of the federal fiscal year on October 1.  Emerald Data will be working with us on this.  They are currently working to schedule a meeting with us to organize and plan the project."
14:48:04 <csharp> so there ;-)
14:48:23 <csharp> if you have questions, I can bring those back to her for answers
14:48:29 <jventuro> csharp++
14:48:57 <chtrotter> csharp++
14:49:05 <jventuro> I like the look of the screenshots I've seen so far
14:49:12 <chtrotter> I am no longer on the PINES reports subcommittee, but I asked Elizabeth if I could continue to participate on the reports working group to help with the development...so I should know more one it gets started up.
14:49:37 <csharp> chtrotter: I would consider your input to be essential on that
14:49:50 <jventuro> I was wondering if the wireframes would be used in building reports as well as running them?
14:50:08 * jventuro hopes that question is phrased properly
14:50:24 <csharp> #info wireframes: http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-reports:reports_wireframes
14:50:56 <csharp> jventuro: I don't know the answer to that, but I can ask
14:51:46 <jventuro> That would be great
14:52:14 <csharp> #action Chris Sharp will investigate whether the wireframes would be used in building reports as well as running them
14:52:41 <chtrotter> jventuro: that is a good question. it should would make life easier.
14:52:42 <jventuro> csharp++
14:53:42 <jventuro> chtrotter: Indeed!
14:54:23 <jventuro> Anything else on the PINES project before we move on?
14:54:32 <csharp> not from me
14:54:55 <chtrotter> not from me either
14:55:13 <jventuro> Any other development projects happening in the Evergreen world that pertain to reports?
14:56:53 <jventuro> #info Bibliomation will be developments that would alphabetize report templates and report parameters.  More information will be available as the project progresses.
14:57:13 <jventuro> #info *sponsoring
14:57:22 <chtrotter> How exciting!
14:58:18 <jventuro> I am particularly excited about those two developments :-)
14:59:36 <jventuro> #topic Anything else from past meetings?
14:59:38 <chtrotter> What do y'all think about  having a place on the evergreen-reports page to briefly list development projects and general status?
14:59:51 <csharp> good idea
15:00:10 <jventuro> I agree.  Sounds great.
15:01:15 <chtrotter> I can add it to the wiki next week, along with what we have mentioned here.  As long as y'all will proof it behind me.
15:01:20 <jventuro> chtrotter: Would you like to add that page, or shall I?
15:01:50 <jventuro> No problem. chtrotter++
15:02:18 <chtrotter> #action chtrotter will add development section to reports wiki page
15:03:48 * jventuro just realized I missed a topic.
15:04:03 <jventuro> #topic Documentation
15:04:21 <jventuro> Any documentation updates?
15:04:56 <jventuro> I have to admit, I need to set aside some time to peruse it.
15:05:20 <chtrotter> Same here.
15:05:30 <csharp> jventuro: is there a list of documentation needs?  (sorry - not been tuned in on this group in the past ;-) )
15:06:01 <csharp> or is that the DIG stuff you're referencing?
15:06:39 <jventuro> csharp: I'm not really sure, I'm following Jenny's basic outline :-)
15:06:56 <csharp> ah ok
15:07:34 <jventuro> I believe it's the DIG stuff though.  I don't recall seeing any documentation needs listed in the reports section.
15:07:38 <chtrotter> I am not sure if there is a specific list of needs. I do know that there was a shortage of advanced reporting info in the documentation last time I checked...which was a while ago.
15:08:04 * csharp peruses http://open-ils.org/dokuwiki/doku.php?id=evergreen-docs_2.3:outline
15:08:24 <jventuro> I'm sure it's probably the same.  I find it difficult to document advanced reporting.
15:09:02 <csharp> I can probably help some on that
15:09:33 * csharp finally got his head around nullability selection
15:09:43 <jventuro> The PINES advanced report documentation is super
15:09:49 <chtrotter> csharp++
15:11:09 <jventuro> chtrotter: I think I found something you wrote on nullability on the web.  It helped me tremendously.
15:11:27 <csharp> I would have to review that... the PINES doc was from like 2008, right?
15:11:55 <csharp> not that the interface has changed all that much (aside from nullability stuff)
15:12:43 <chtrotter> It was for 1.2, written by S.K. Murphy
15:12:47 <jventuro> I remember using it at least two years ago, so probably.
15:13:04 <csharp> yeah - Murph left in 2008
15:13:05 <chtrotter> And it is very helpful.
15:14:33 <csharp> funny - I remember her writing that, but I never got around to reading it
15:15:05 <chtrotter> I did post a brief intro to nullability, but it really needs to be developed. I, too, recently had a nullability break-through.
15:15:19 <chtrotter> But it still hurts my brain thinking about it.
15:15:32 <csharp> error23++
15:15:52 <chtrotter> I lack the basic SQL stuff.
15:15:56 <jventuro> I could see that.  I remember thinking "I understand!" while reading it, but don't ask me what is does now ;)
15:16:34 * chtrotter reminds herself that SQL is on her "to learn" list
15:16:57 * jventuro reminds herself of the same.
15:17:24 * csharp recommends www.w3schools.com/sql/default.asp as a place to start
15:17:33 <chtrotter> My point here is that I think knowing SQL will help reveal the underlying concept of nullability.
15:17:43 <chtrotter> Thanks, csharp.
15:17:55 <jventuro> We're getting down to the hour mark.  Anyone mind moving on to new business?
15:18:00 <csharp> it absolutely will - study up on SQL joins
15:18:07 <csharp> jventuro: please continue
15:18:54 <jventuro> #topic Possible name change
15:19:38 <jventuro> # info  There was a discussion on the list about possibly changing the name of this group from "Reports Task Force" to "Reports Interest Group."
15:19:45 <jventuro> Thoughts?
15:19:49 <chtrotter> I support the name change.
15:20:03 <csharp> +1
15:21:02 <jventuro> I'm in favor of it too.
15:21:13 <chtrotter> I find "interest group" to be a far more accurate name.  Plus, I think it is more inviting to newcomers.
15:22:11 <chtrotter> If I recall everyone on the list was very supportive of the name change, too.
15:22:40 * jventuro agrees
15:23:56 <jventuro> I guess the next thing to decide is when to change and how to go about it
15:24:32 <jventuro> Should I just send an announcement to the reports lists and general lists after the meeting?
15:24:55 <jventuro> Or announce it prior to the next meeting?
15:25:15 * chtrotter is clueless about any officials protocol or Robert's Rules of Order
15:25:18 <csharp> you might throw it out to the list for an actual vote (beyond the three of us)
15:25:34 <csharp> (list = evergreen-reports)
15:25:35 * chtrotter agrees with Chris.
15:25:50 <jventuro> Good idea.  I'll make a Doodle Poll.
15:26:01 <chtrotter> I don't think we count as a quorum.
15:26:34 <jventuro> #action jventuro will create a survey to poll members about the possible name change.
15:27:53 <jventuro> #topic New meeting schedule
15:28:51 <jventuro> #info The majority of members seem to favor a bimonthly meeting schedule, with a break in the summer.
15:29:15 <csharp> that sounds reasonable to me
15:29:40 <chtrotter> Sounds good to me, too.
15:30:27 <jventuro> The days have not worked for me in the past.  My schedule seems to be the opposite of what Jenny's was.
15:30:51 <chtrotter> Same here.
15:31:22 <jventuro> I think 2:30 is a good time, considering that we would want folks from the west coast to be able to attend, but I'm not sure about the day of the week.
15:31:42 <jventuro> Mondays, Tuesdays, and Fridays work best for me.
15:31:45 <chtrotter> 2:30 is rough on me on any day but Friday.
15:31:59 <chtrotter> I do not work on Fridays so my schedule is more open.
15:32:37 <chtrotter> All other days I am at lunch at 2:30...and not in front of a PC.
15:32:41 <csharp> my hours are very flexible so I can usually just make it whenever it's scheduled
15:32:57 * csharp spends nearly all lunches in front of a PC
15:33:20 <jventuro> I'm not sure if we didn't attract a larger group because the day is bad, or because it was short notice?
15:33:59 <jventuro> Perhaps a poll would be the best way to go about scheduling the next meeting as well.
15:34:00 <csharp> jventuro: I would assume the latter
15:34:19 <chtrotter> I think a poll would be best.
15:34:56 <chtrotter> I could always try to reschedule my lunch.
15:35:16 <jventuro> #action jventuro will poll the membership to determine the date of the next meeting.
15:35:57 <chtrotter> Woud it be possible to shift it to 3pm?
15:36:10 * chtrotter thinks it doesn't hurt to ask.
15:36:36 <jventuro> I don't have a problem with 3PM.
15:36:46 * csharp can do whenever
15:37:46 <jventuro> 3 PM it is!
15:38:03 <jventuro> Any other new business?
15:38:05 <chtrotter> Thanks, y'all.
15:38:19 <chtrotter> None from me.
15:38:39 <csharp> I'm good - thanks jventuro
15:39:03 <jventuro> Thank you both!
15:39:06 <chtrotter> jventuro++
15:39:17 <csharp> jventuro++
15:39:22 * jventuro was nervous :)
15:39:58 * csharp was cheering for you
15:40:13 * tsbere reminds jventuro to run the end meeting command ;)
15:40:24 <chtrotter> Thanks so much for taking on the role of convener.
15:40:26 * jventuro bows
15:41:29 <jventuro> I'll end the meeting now if no one objects :)
15:41:40 <csharp> +1
15:41:44 <chtrotter> Thanks for a good meeting, jventuro and csharp.
15:41:58 <csharp> have a nice weekend
15:42:14 <jventuro> Thanks again!  chtrotter++ and csharp++
15:42:35 <jventuro> #endmeeting