#evergreen: 2012-11-15 - Developer Meeting

Meeting started by bshum at 13:07:33 US/Eastern (full logs).

Meeting summary

  1. Who's here. (bshum, 13:07:50)
    1. bshum = Ben Shum, Bibliomation (bshum, 13:08:00)
    2. denials is Dan Scott, Laurentian University (denials, 13:08:04)
    3. Dyrcona is Jason Stephenson, MVLC (Dyrcona, 13:08:19)
    4. tsbere is Thomas Berezansky, MVLC (tsbere, 13:08:23)
    5. kivilahtio = Olli-Antti Kivilahti, Regional Library of Joensuu (kivilahtio, 13:08:27)
    6. jeff is Jeff Godin, Traverse Area District Library (TADL) (jeff, 13:08:37)
    7. jdouma is Justin Douma, Catalyst IT (jdouma, 13:08:42)
    8. kmlussier is Kathy Lussier, MassLNC (kmlussier, 13:08:42)
    9. davidcboyle is David Boyle, Catalyst IT Services (davidcboyle, 13:08:53)
    10. jBond Jeffrey Bond, Catalyst IT (jBond, 13:08:58)
    11. ktomita is Kyle Tomita, Catalyst IT (ktomita__, 13:09:00)
    12. moodaepo = Anoop Atre, Equinox (moodaepo, 13:09:11)
    13. acoomes is Andrew Coomes, Catalyst IT Services (acoomes, 13:09:27)
    14. smyers_ is Scott Myers, Catalyst It Services (smyers_, 13:09:30)
    15. b_bonner = Bradley Bonner, King County Library System (b_bonner, 13:09:45)
    16. Meeting agenda: http://evergreen-ils.org/dokuwiki/doku.php?id=dev:meetings:2012-11-15 (bshum, 13:09:54)
    17. dbwells is Dan Wells, Hekman Library (dbwells, 13:10:59)

  2. Previous action items (bshum, 13:11:29)
    1. paxed = Pasi Kallinen, Regional Library of Joensuu (paxed, 13:11:33)
    2. All past action items appear to be done. (bshum, 13:11:44)
    3. remingtron = Remington Steed, Hekman Library (remingtron, 13:11:55)

  3. Security release process post-mortem (bshum, 13:12:11)
    1. Benefits to be gained from setting up a more thorough automated testing process for releases (security or otherwise) (bshum, 13:19:23)
    2. http://nox.esilibrary.com/~miker/hackaway-testing-whiteboard-1.jpg (eeevil, 13:31:43)
    3. Disclose information pertaining to security-related bugs once a fix is available. This allows for testing (and fixing) to be conducted by community members outside the core team members. (bshum, 13:34:04)
    4. ACTION: Draft summary of "how we handle security-related bugs" and disseminate through appropriate channels. (bshum, 13:36:38)

  4. Ancient version of Dojo (bshum, 13:43:09)
    1. http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/tsbere/dojo_1.6_maybe (bshum, 13:45:27)
    2. ACTION: edoceo to work on setting up a dojo 1.6 test server (bshum, 13:48:37)
    3. ACTION: kmlussier to help coordinate end-user testing (bshum, 13:48:57)

  5. Only support server editions (bshum, 13:52:15)
    1. denials will support Fedora and Debian (denials, 13:57:39)
    2. berick will support Debian (berick, 13:58:11)
    3. Dyrcona will support Ubuntu (Dyrcona, 13:58:31)
    4. tsbere will support Ubuntu (tsbere, 13:58:50)
    5. edoceo will support Gentoo (edoceo, 13:58:51)
    6. dbwells will support Ubuntu (dbwells, 13:59:06)
    7. eeevil will support Debian (eeevil, 13:59:08)
    8. bshum will support Ubuntu (bshum, 13:59:18)
    9. csharp will support Ubuntu and Debian (csharp, 13:59:35)

  6. Search infrastructure progress (bshum, 14:00:55)
    1. eeevil might support Slackware (eeevil, 14:02:02)
    2. Deferred, with need to expand on bug tickets associated with queryparser / driver bug fixes (bshum, 14:04:26)

  7. Ripping out JSPAC (bshum, 14:05:41)
    1. ACTION: kmlussier, bshum (and others) to edit the TPAC plan wiki page and create appropriate bug links if necessary. (bshum, 14:10:35)
    2. HELP: People with concerns about specific features missing from TPAC should contribute and note specific blockers to ripping out JSPAC. (bshum, 14:11:13)
    3. AGREED: JSPAC can disappear in 2.4. (bshum, 14:15:54)

  8. Bug backlog (bshum, 14:16:45)
    1. Jeff's summary: "those who can, test. those who can, pull. those who can, confirm/flesh-out." (bshum, 14:24:05)
    2. Examples of test creation would be helpful to new coders. (bshum, 14:24:49)
    3. Contributors via github should still follow the guidelines set by the community for submissions (including sign-offs, launchpad entry, etc.). Preference towards using the community working repo. (bshum, 14:26:03)


Meeting ended at 14:27:49 US/Eastern (full logs).

Action items

  1. Draft summary of "how we handle security-related bugs" and disseminate through appropriate channels.
  2. edoceo to work on setting up a dojo 1.6 test server
  3. kmlussier to help coordinate end-user testing
  4. kmlussier, bshum (and others) to edit the TPAC plan wiki page and create appropriate bug links if necessary.


Action items, by person

  1. bshum
    1. kmlussier, bshum (and others) to edit the TPAC plan wiki page and create appropriate bug links if necessary.
  2. edoceo
    1. edoceo to work on setting up a dojo 1.6 test server
  3. kmlussier
    1. kmlussier to help coordinate end-user testing
    2. kmlussier, bshum (and others) to edit the TPAC plan wiki page and create appropriate bug links if necessary.


People present (lines said)

  1. denials (72)
  2. bshum (71)
  3. jeff (36)
  4. tsbere (31)
  5. csharp (29)
  6. kivilahtio (20)
  7. berick (18)
  8. mrpeters-isl (16)
  9. dbwells (14)
  10. Dyrcona (14)
  11. eeevil (13)
  12. edoceo (10)
  13. kmlussier (10)
  14. paxed (5)
  15. b_bonner (3)
  16. alexlazar (3)
  17. pinesol_green (3)
  18. senator (3)
  19. Kabi (2)
  20. acoomes (2)
  21. jBond (2)
  22. ktomita (1)
  23. jdouma (1)
  24. moodaepo (1)
  25. jlamos (1)
  26. ktomita__ (1)
  27. davidcboyle (1)
  28. remingtron (1)
  29. smyers_ (1)


Generated by MeetBot 0.1.4.