#evergreen: 2012-12017 Developer meeting

Meeting started by kmlussier at 13:03:08 US/Eastern (full logs).

Meeting summary

  1. Who's here (kmlussier, 13:03:26)
    1. Jason Stephenson, MVLC (Dyrcona, 13:03:36)
    2. Bill Erickson / Equinox (berick, 13:03:37)
    3. bshum is Benjamin Shum, Bibliomation (bshum, 13:03:38)
    4. kmlussier is Kathy Lussier, MassLNC (kmlussier, 13:03:57)
    5. jeff is Jeff Godin, Traverse Area District Library (TADL) (jeff, 13:04:12)
    6. denials is Dan Scott, Laurentian University (denials, 13:04:13)
    7. paxed is Pasi Kallinen, Regional Library of Joensuu (paxed, 13:04:17)
    8. Dan Wells, Calvin College (dbwells, 13:04:23)
    9. Jason Etheridge / Equinox (phasefx, 13:04:23)
    10. Remington Steed, Calvin College (remingtron, 13:05:02)
    11. Mike Rylander / Equinox (eeevil, 13:05:14)

  2. Action Items from Last Meeting (kmlussier, 13:06:00)
    1. Galen Charlton /Equinox (gmcharlt, 13:06:36)
    2. Meeting Agenda: http://evergreen-ils.org/dokuwiki/doku.php?id=dev:meetings:2012-12-17 (bshum, 13:06:49)
    3. jeff has drafted How the Evergreen Project Handles Security-Related bugs at http://evergreen-ils.org/dokuwiki/doku.php?id=dev:security (kmlussier, 13:08:33)
    4. Send feedback via dev list or make direct edits to wiki. (kmlussier, 13:09:19)
    5. tsbere is Thomas Berezansky, MVLC (tsbere, 13:11:19)
    6. Kyle Tomita / Catalyst IT (ktomita, 13:12:31)
    7. jdouma is Justin Douma, Catalyst IT (jdouma, 13:13:17)
    8. ACTION: bshum will remove jspacremovalblocker from bugs that are not blockers and kmlussier will send message to general list to ask people to identify blockers. (kmlussier, 13:18:38)

  3. GSoC reports - Will anything from the GSoC projects land in 2.4? (kmlussier, 13:19:30)
    1. ACTION: bshum will remove jspacremovalblocker from bugs that are not blockers and eeevil will send message to general list to ask people to identify blockers. (kmlussier, 13:21:20)
    2. http://git.evergreen-ils.org/?p=working/random.git;a=summary (berick, 13:29:51)
    3. ACTION: denials to add a mention in the docs about PHP & Android efforts (denials, 13:31:37)
    4. ACTION: GSOC_mentors to ensure related project code is moved to Evergreen git repos. (bshum, 13:36:09)

  4. Evergreen releases - bug process (bshum, 13:38:52)
  5. Evergreen releases - release cycle, team communications, etc. (bshum, 13:54:23)
    1. eeevil will be sending a provisional schedule for 2.4 alpha/beta and likely features to be merged that exist today in branches, in the near future. (bshum, 14:18:12)
    2. 2.3.2 and 2.2.4 to be cut this week. (bshum, 14:18:44)
    3. Review checklist page - http://evergreen-ils.org/dokuwiki/doku.php?id=dev:signoff_review_checklist (bshum, 14:19:29)
    4. berick to elect date the jan. 2.3.3 release soon (berick, 14:20:56)


Meeting ended at 14:23:17 US/Eastern (full logs).

Action items

  1. bshum will remove jspacremovalblocker from bugs that are not blockers and kmlussier will send message to general list to ask people to identify blockers.
  2. bshum will remove jspacremovalblocker from bugs that are not blockers and eeevil will send message to general list to ask people to identify blockers.
  3. denials to add a mention in the docs about PHP & Android efforts
  4. GSOC_mentors to ensure related project code is moved to Evergreen git repos.


Action items, by person

  1. bshum
    1. bshum will remove jspacremovalblocker from bugs that are not blockers and kmlussier will send message to general list to ask people to identify blockers.
    2. bshum will remove jspacremovalblocker from bugs that are not blockers and eeevil will send message to general list to ask people to identify blockers.
  2. denials
    1. denials to add a mention in the docs about PHP & Android efforts
  3. eeevil
    1. bshum will remove jspacremovalblocker from bugs that are not blockers and eeevil will send message to general list to ask people to identify blockers.
  4. kmlussier
    1. bshum will remove jspacremovalblocker from bugs that are not blockers and kmlussier will send message to general list to ask people to identify blockers.


People present (lines said)

  1. bshum (52)
  2. kmlussier (35)
  3. denials (33)
  4. berick (21)
  5. Dyrcona (19)
  6. jeff (15)
  7. eeevil (15)
  8. dbwells (6)
  9. gmcharlt (6)
  10. tsbere (6)
  11. pinesol_green (4)
  12. paxed (4)
  13. senator (4)
  14. jamesrf (2)
  15. ktomita (1)
  16. DPearl (1)
  17. phasefx (1)
  18. jdouma (1)
  19. bradl (1)
  20. remingtron (1)
  21. artunit (1)


Generated by MeetBot 0.1.4.