#evergreen Meeting

Meeting started by gmcharlt at 13:03:52 US/Eastern (full logs).

Meeting summary

    1. agenda is http://evergreen-ils.org/dokuwiki/doku.php?id=dev:meetings:next (gmcharlt, 13:04:12)
    2. gmcharlt = Galen Charlton, Equinox (gmcharlt, 13:04:40)
    3. tsbere = Thomas Berezansky, MVLC (tsbere, 13:05:01)
    4. denials = Dan Scott, Laurentian University (denials, 13:05:05)
    5. kivilahtio1 = Olli-Antti Kivilahti, Regional Library of Joensuu (kivilahtio1, 13:05:11)
    6. dbwells is Dan Wells, Hekman Library (dbwells, 13:05:20)
    7. remingtron is Remington Steed, Hekman Library (remingtron, 13:05:28)
    8. paxed = Pasi Kallinen, Regional Library of Joensuu (paxed, 13:05:29)
    9. kmlussier = Kathy Lussier, MassLNC (kmlussier, 13:06:14)
    10. DPearl = Dan Pearl, C/W MARS (DPearl, 13:06:20)
    11. eeevil = Mike Rylander, ESI (eeevil, 13:06:34)

  1. action item from last meeting - edoceo to work on setting up a dojo 1.6 test server (gmcharlt, 13:06:54)
    1. senator = Lebbeous Fogle-Weekley, ESI (senator, 13:07:15)

  2. action item from last meeting: kmlussier to help coordinate end-user testing (gmcharlt, 13:07:54)
  3. action item from last meeting: bshum will remove jspacremovalblocker from bugs that are not blockers and eeevil will send message to general list to ask people to identify blockers. (gmcharlt, 13:08:44)
    1. Done. (bshum, 13:08:53)
    2. ACTION: eeevil to continue to prod folks about jspac removal blockers (gmcharlt, 13:11:03)

  4. action item from last meeting - denials to add a mention in the docs about PHP & Android efforts (gmcharlt, 13:11:14)
    1. Still to be done (denials, 13:11:17)
    2. ACTION: denials to add a mention in the docs about PHP & Android efforts' (denials, 13:11:29)

  5. action item from last meeting - GSOC_mentors to ensure related project code is moved to Evergreen git repos. (gmcharlt, 13:11:44)
    1. berick Bill Erickson, ESI (berick, 13:12:11)
    2. It's all in here: http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/collab/drizea/android (dbwells, 13:12:28)
    3. need to talk to pranjal about it (senator, 13:12:54)
    4. Joseph Lewis's dojo branch is here: http://git.evergreen-ils.org/?p=evergreen/joelewis.git;a=shortlog;h=refs/heads/dojo_1.8 (tsbere, 13:13:17)

  6. OpenSRF release (gmcharlt, 13:14:49)
  7. Evergreen monthly maintenance release schedule (gmcharlt, 13:16:03)
    1. http://libmail.georgialibraries.org/pipermail/open-ils-dev/2013-January/008729.html (gmcharlt, 13:16:09)
    2. AGREED: Evergreen maintenance/point releases for supported release series will be made on the 3rd Wednesday of each month, barring exceptional situations (gmcharlt, 13:27:20)
    3. AGREED: The RC for a major Evergreen releases to be targeted for the week before point release day (gmcharlt, 13:27:26)
    4. AGREED: .0 release to be targeted for the week after point releases (gmcharlt, 13:27:37)
    5. AGREED: RM has discretion to reschedule to avoid brown-bag releases (gmcharlt, 13:27:43)
    6. the next 2.3 and 2.2 release is scheduled for January 16th. Merge while ye may. (gmcharlt, 13:28:00)

  8. Staff client memory problems (gmcharlt, 13:28:42)
    1. Memory leaks are causing major disruptions in some libraries that have upgraded to 2.3. See https://bugs.launchpad.net/evergreen/+bug/1086458 and http://markmail.org/message/eec5sha2i3pdpga4 for more info. (gmcharlt, 13:28:55)
    2. ACTION: testing to be performed by various parties with older xulrunner versions (gmcharlt, 14:11:24)
    3. ACTION: gmcharlt will call a development meet to hash out the future of the staff client, to occur before the EG conference (gmcharlt, 14:13:24)
    4. ACTION: denials will issue a call for Evergreen 2.3 users to submit detailed workstation profiles (gmcharlt, 14:15:35)

  9. proposals changing the procedure for reviewing and pushing new feature patches (gmcharlt, 14:16:29)
    1. proposal #1 from tsbere = To encourage more community communication and involvement I propose that new features (not bugfixes) require sign-offs from two or more groups in the community before being committed, regardless of commit bit status. That would prevent any single entity from pushing new features in wi (gmcharlt, 14:16:54)
    2. ... without the community looking over them just because they have one or more core committers in their employ. (gmcharlt, 14:17:06)
    3. proposal #2 from tsbere - On a similar vein, to ensure communication time with the community is possible I propose that new features need to be in a pullrequest state on Launchpad for a minimum of a week before a core committer pushes them into the system. Again, not bugfixes. (gmcharlt, 14:17:29)
    4. AGREED: accepted as recommendations - new feature patches ought to have signoffs from two or more groups in the community; new feature pull requests should wait at least a week before being pushed (gmcharlt, 14:34:56)
    5. AGREED: review of the pullrequest queue to occur by (or before) the 2013 EG conference (gmcharlt, 14:35:17)


Meeting ended at 14:35:26 US/Eastern (full logs).

Action items

  1. eeevil to continue to prod folks about jspac removal blockers
  2. denials to add a mention in the docs about PHP & Android efforts'
  3. testing to be performed by various parties with older xulrunner versions
  4. gmcharlt will call a development meet to hash out the future of the staff client, to occur before the EG conference
  5. denials will issue a call for Evergreen 2.3 users to submit detailed workstation profiles


Action items, by person

  1. denials
    1. denials to add a mention in the docs about PHP & Android efforts'
    2. denials will issue a call for Evergreen 2.3 users to submit detailed workstation profiles
  2. eeevil
    1. eeevil to continue to prod folks about jspac removal blockers
  3. gmcharlt
    1. gmcharlt will call a development meet to hash out the future of the staff client, to occur before the EG conference


People present (lines said)

  1. gmcharlt (84)
  2. denials (42)
  3. tsbere (37)
  4. kivilahtio1 (28)
  5. krvmga (27)
  6. eeevil (24)
  7. phasefx (22)
  8. bshum (20)
  9. jeff (14)
  10. kmlussier (13)
  11. senator (13)
  12. paxed (11)
  13. dbwells (11)
  14. Dyrcona (11)
  15. berick (7)
  16. jcamins (6)
  17. pinesol_green (5)
  18. DPearl (4)
  19. remingtron (1)


Generated by MeetBot 0.1.4.