14:00:59 <yboston> #startmeeting 2013-01-10 - DIG Monthly Meeting Evergreen Documentation Interest Group (DIG) Monthly Meeting. The agenda can be found here http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:dig_meeting_20130110-agenda
14:00:59 <pinesol_green> Meeting started Thu Jan 10 14:00:59 2013 US/Eastern.  The chair is yboston. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:59 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:01:18 <yboston> #topic Introductions
14:01:28 <yboston> Please feel free to start introducing yourselves...
14:01:35 * yboston is Yamil Suarez @ Berklee college of Music
14:01:36 <kmlussier> #info kmlussier is Kathy Lussier, MassLNC
14:01:42 <denials> #info denials = Dan Scott, Laurentian University
14:01:52 <krvmga> #info krvmga is Jim Keenan, C/W MARS
14:02:08 <phasefx> #info phasefx = Jason Etheridge, Equinox
14:04:06 <yboston> I will move on, but latecomers can continue to introduce themselves
14:04:12 <yboston> #topic Updates from Content Coordinators
14:04:23 <yboston> We will continue having the content corrdinators try out the "#topic" AND "#info" Meetbot commands for their reports
14:04:23 <yboston> So content coordinators, please use "#topic" for the first post/line of your report
14:04:23 <yboston> then use "#info" for every other chat post/line of your report.
14:04:24 <yboston> for example...
14:04:33 <yboston> #topic this is a test report first post/line
14:04:39 <yboston> #info this is a test report second post/line
14:05:00 <yboston> with coordinator would like to go first?
14:05:05 <kmlussier> #topic Public OPAC/staff tasks Content Coordinator
14:05:46 <yboston> go ahead, since you might be the only one besides Rob
14:06:24 <kmlussier> #info I've mostly been following up on docsprint followup activities and converted a chapter from the book to the official docs last week
14:06:52 <kmlussier> #info But, otherwise, I haven't been focusing on the public opac staff tasks docs.
14:06:57 <kmlussier> End of report.
14:07:08 <yboston> kmlussier++
14:07:33 <krvmga> kmlussier: do you want to share the link to the piratepad with the followup activities?
14:07:40 <krvmga> in case anyone else wants to join in?
14:07:49 <kmlussier> krvmga: There's another item on the agenda to talk specifically about the doc sprint.
14:09:00 <yboston> lets wait for now so I can give Robert's report
14:09:17 <krvmga> np
14:09:21 <yboston> I believe Robert is not here right now, but he preemptively sent me a copy of this report in case he could not make it.
14:09:45 <yboston> #topic Conversion Coordinator Report
14:09:54 <yboston> #info  Added a Developer Version of the docs.  E.g. Process the master branch nightly.
14:10:04 <yboston> #link http://docs.evergreen-ils.org/
14:10:17 <yboston> #info  Added the "Installing the Staff Client" chapter to 2.2, 2.3 and master repos based mostly on wiki docs.
14:10:26 <yboston> #link http://docs.evergreen-ils.org/dev/_installing_the_staff_client.html
14:10:33 <yboston> #info Added DB schema for 2.3:
14:10:41 <yboston> #link http://docs.evergreen-ils.org/2.3/schema/
14:10:48 <yboston> #info  Used postgresql_autodoc ( #link http://www.rbt.ca/autodoc/ ) to generate an asciidoc file with a asciidoc template I created...
14:10:55 <yboston> Previously used an XML DocBook template with postgresql_autodoc.
14:11:05 <yboston> Did not include the database schema asciidoc file in the repo because it is auto-generated and huge!
14:11:13 <yboston> #info Pulled in some docs from SITKA on using the staff client.
14:11:29 <yboston> SITKA++
14:11:36 <yboston> dbs++ kmlussier++ for converting and migrating lots of content from "Evergreen In Action" into the official Docs.
14:11:41 <yboston> #info The Google Doc Sprint was a great success and wonderful learning opportunity.
14:11:54 <yboston> #idea It would be great to have  Evergreen Doc Sprint type events perhaps focusing on specific content areas?
14:12:12 <yboston> (that is the end of Robert's report)
14:12:22 <yboston> Robert++
14:12:47 <kmlussier> rsoulliere++
14:13:49 <yboston> unless there are no quick questions we can move on to "old business"
14:15:11 <yboston> #topic Discuss what DIG thinks the role of the DIG release coordinator should be (suggested by Tim Spindler) - old business
14:15:32 <yboston> since Tim or Robert are not here I propose that we wait until next meeting
14:15:59 <kmlussier> yboston: Related to that...
14:16:26 <kmlussier> I'm wondering if it might be a good idea to revisit all of the DIG roles. There are a lot of roles with very few volunteers.
14:16:36 <kmlussier> Maybe something to think about for the meeting at the conference.
14:16:52 <yboston> kmlussier: good idea
14:17:07 <kmlussier> I'm also not sure if one of our content coordinators, June, is still involved in the community. So we may need to consolidate.
14:17:17 <krvmga> #agreed
14:17:32 * krvmga hopes that was the correct use of that tag.
14:18:21 <kmlussier> #action DIG to revisit roles during conference.
14:18:31 <yboston> excelent
14:19:40 <yboston> the next old business will be quick
14:20:03 <yboston> #topic Need to find a replacement for “DIG reports coordinator” - old business
14:21:03 <yboston> #info so if anyone is interested, the job is yours. Just send the DIG list an email if you are interested of have questions
14:21:16 <krvmga> in C/W MARS we're doing a lot of work on reports now.
14:22:40 <yboston> pass it along to that group in case anyone would be interested in the future
14:22:57 <krvmga> i cannot, however, volunteer without permission from Tim Spindler.
14:23:11 <yboston> no problem
14:23:28 <yboston> should we move on to the "new business"?
14:24:17 <kmlussier> +1
14:24:59 <yboston> #topic Post GSOC Doc Camp 2012 discussion (proposed by Yamil) - new business
14:25:25 <yboston> any one here that participated go ahead and speak...
14:25:31 <yboston> (or chat)
14:26:06 <krvmga> i thought it was wonderful and could be used either as-is or in a modified form to do our own docsprints
14:26:28 <kmlussier> The book is here -  evergreen-ils.org/book
14:26:49 <yboston> #link http://evergreen-ils.org/book
14:26:51 <krvmga> i also think, now that there are five people who have done it, we have in-house (so to speak) experience that can be shared widely.
14:27:04 <kmlussier> #link http://evergreen-ils.org/dokuwiki/doku.php?id=books:evergreen_in_action:help
14:27:29 <krvmga> kmlussier and I have talked a bit about how to do more.
14:27:48 <kmlussier> Yes, I think future doc sprints would be worthwhile.
14:28:23 <kmlussier> But there is also a lot of opportunity for volunteers to help with follow up from the first sprint. And the ways they can help are identified in the link I just posted.
14:29:09 <krvmga> kmlussier++
14:29:12 <kmlussier> Where the doc sprints are useful is in focusing in on one area of the system that is book worthy.
14:29:45 <yboston> interesting
14:30:28 <kmlussier> #info We are still moving chapters to the official docs. I'm also monitoring any changes to the Floss Manuals site so that any updates made there can be reflected in the official docs.
14:31:52 <kayals> I cannot remove a patron registered as SysAdminStaff from neither staff-client nor sql query
14:32:32 <kmlussier> kayals: We're in the middle of a meeting now. If you come back in about 20 minutes or so, somebody may be able to help out.
14:32:43 <kayals> no problem
14:33:07 <kmlussier> I would love to see more in-person doc sprints, at least on an annual basis.
14:33:41 <krvmga> i think we could design a day's sprint
14:33:45 <yboston> I am hoping we can in the short term shoot for two in person sprints per year, with one being at the conference
14:34:07 <kmlussier> krvmga: Actually, I think a day sprint would only be good for filling in gaps of our documentation.
14:34:11 <yboston> I can see Boston being used again becuase of the concentration of DIG folks in the general area
14:34:20 <krvmga> i wasn't so interested in taking conference time with a docsprint
14:34:32 <kmlussier> If we were to focus on in-depth content in a particular area, I think it would need to be longer.
14:34:41 <krvmga> kmlussier: i hear what you're saying but still i wonder.
14:35:10 <krvmga> five of us generated over a hundred pages in 3 days
14:35:24 <kmlussier> One thing we talked about was holding one at the same time devs are hacking.
14:35:51 <kmlussier> But, of course, that would mean that devs wouldn't be available to do any documenting, if they wanted to. And I think having a dev at the sprint was truly beneficial to the project.
14:36:00 <kmlussier> I guess it depends on the content of the sprint.
14:36:07 <krvmga> yes
14:37:14 <krvmga> for instance, i could see documentation on reports data sources...a big dent could be made in that by a team in one day
14:37:23 <kmlussier> yboston: I agree that a sprint at the conference is a good idea. For filling in the doc gaps. I would like to see if we can sprint after the DIG meeting again at this year's conference.
14:38:17 <kmlussier> krvmga: I guess I see that as part of filling in documentation gaps. Whereas a book on creating evergreen reports with good use cases would be more of a multi-day sprint.
14:38:30 <yboston> To be clear, I am open to do any type of DIG owrk at the conference, from training people about Git and AsciiDoc to just meeting and assigning roles
14:38:48 <yboston> since I did not take part in the sprint I am not sure of the pros and cons yet
14:38:54 <yboston> of doing one at the conference
14:38:58 <yboston> or outside of it
14:39:08 <krvmga> kmlussier: i hear what you're saying. i think docsprints can be more than book producers.
14:40:18 <krvmga> does someone need to do a comprehensive presentation on the structure and execution of a docsprint?
14:40:25 <kmlussier> yboston++ AsciiDoc training at the conference would be good.
14:40:48 <krvmga> AsciiDoc training would be good.
14:41:15 <kmlussier> However, if there are people willing to help with documentation at the conference who don't want to learn Asciidoc, I think we should take the help from wherever we can get it. :)
14:41:20 <yboston> my apologies, but can kmlussier and krvmga mention their personal pros and cons about the sprints?
14:41:32 <yboston> (a very quick summary for my consude sake)
14:41:37 <yboston> (confused)
14:41:51 <denials> kmlussier++ # agreed, format should be the last of our concerns
14:42:21 <kmlussier> pros: It gives a dedicated group of individuals the time to organize and document Evergreen with a specific set of goals in mind.
14:42:58 <denials> yboston: Pros: forced us to set aside worries about "is this good enough, is it technically perfect, does it format right" to just sit down and PRODUCE
14:43:02 <kmlussier> The only con I can think of is that it's written up so quickly, you may need to give up some content and do a lot of cleanup/fixing at a later date.
14:43:03 <krvmga> i had a big of an unusual experience with it since i participated remotely. my cons have to do with that remote experience and how it could have been approved.
14:43:35 <krvmga> the participants accepted quite a lot of outside control and i felt this was essential to the docsprint
14:43:36 <kmlussier> But, in an electronic environment, the fixing and cleanup is not a big deal.
14:43:36 <denials> yboston: Also, Pros: helped get egos out of the way because we were all under the gun
14:43:57 <kmlussier> denials: There are egos in the Evergreen community?
14:44:09 <denials> (and being under pressure together forged diamonds... right? kmlussier's koala ears were shiny)
14:44:11 <krvmga> denials: haven't noticed
14:44:17 <krvmga> denials: much
14:44:34 <yboston> denials:++ kmlussier++ krvmga++
14:44:39 <denials> Okay. Got my ego out of the way, then, as much as it ever leaves the room :)
14:44:43 <kmlussier> Yes, koala ears need to be shared at every sprint.
14:44:44 <krvmga> the pressure was an important pro. it's the thing about being hanged in the morning focusing your mind.
14:45:22 <kmlussier> But, back to one of krvmga's questions, I don't think a presentation on the format is particularly useful. I think the best thing is for someone(s) who was there to lead the next one.
14:45:25 <denials> one other pro: facilitator's help at focusing on documenting how to achieve specific_goals_, not producing reference info
14:45:34 <kmlussier> And then other participants can learn from the experience.
14:45:59 <krvmga> denials++
14:46:06 <krvmga> denials: yes, that was a big one
14:46:47 <krvmga> so who's volunteering to lead one? :)
14:47:06 <kmlussier> krvmga: I would lead one.
14:47:26 <krvmga> i think we have a winner.
14:47:36 <kmlussier> But I think anyone else who was there would do a fine job.
14:48:51 <yboston> so as a quick recap, we are interested in doing future doc sprints. I think there is a bit of a debate if it should always happen at the conference, but there is agreement that it should happen outside of conference. IS this correct so far?
14:49:30 <krvmga> seems so to me.
14:50:15 <yboston> There is a little bit of debate if we would produce a new "book" from a doc sprint or just focus on filling gaps with it?
14:50:48 <yboston> I dont aim to settle anything right now, but I think it is good to be having this conversation now
14:51:04 <yboston> (though we are at the 50 minute mark)
14:51:06 <kmlussier> There is always a need to fill gaps. I see that happening at the conference or even doing it by scheduling days when everyone is working on it remotely.
14:51:51 * krvmga agrees with kmlussier.
14:51:54 <kmlussier> If we were scheduling a sprint outside of the conference where people are meeting in person (which I recommend) then I think it should focus on a specific topic. Not as reference material, but as something that highlights best practices and use cases.
14:52:21 <denials> +1
14:52:30 <kmlussier> And it would be good to get opinions from the community on what topics most need this kind of documentation.
14:52:32 <denials> (+100)
14:53:04 <kmlussier> And for those who might be wondering why were talking about koala ears. a photo of them are available here: https://plus.google.com/103236088712412145040/posts
14:53:11 <kmlussier> Sorry denials. I couldn't resist. :)
14:53:51 <yboston> kmlussier: I don't see anything
14:54:08 <kmlussier> Oh darn! Wrong link.
14:54:14 <yboston> :)
14:54:37 <krvmga> i think getting community input is essential. we can't think of everything.
14:54:46 <yboston> absolutely
14:55:27 <denials> https://lh6.googleusercontent.com/-BDH5IwqFDU0/UMGGh9a_RZI/AAAAAAAAEjk/HxRRQ2JN75w/s1052/12+-+1 ?
14:55:41 <kmlussier> denials++
14:55:47 <kmlussier> That's the one.
14:55:49 <krvmga> denials = that guy
14:56:05 <krvmga> photobomb++
14:56:10 <paxed> ^
14:56:15 <yboston> we are at the 55 minute mark. should we try to wrap up or keep going a little longer. If we want to wrap, any suggestions for next actions?
14:56:46 <paxed> masterful photobomb, indeed.
14:56:47 <denials> kmlussier: have you seen many edits to the FLOSS Manuals site?
14:57:15 <kmlussier> No, not at all.  But I want to do a test edit to make sure the RSS feed is still working.
14:57:48 <kmlussier> I made a minor edit the other day, and I didn't see it come through. But that may be because I checked the "minor edit" box.
14:58:11 <denials> yboston: one more thing, lulu.com results
14:58:17 <yboston> go ahead
14:58:19 <kmlussier> Oh, actually, nm. Robert made a couple of edits yesterday.
14:58:40 <denials> #info lulu.com reports that we've sold 14 print books and 7 ebooks for a total of $235 revenue
14:58:53 <krvmga> wow
14:58:54 <kmlussier> Excellent!
14:58:58 <yboston> nice
14:59:01 <krvmga> very nice
14:59:06 * denials has no idea how many of the free downloads have been used
14:59:19 <kmlussier> I need to order a copy so that I can get one with my name on the cover.
14:59:28 * krvmga wonders if lulu provides information like that?
14:59:55 <paxed> we were joking at work today that we should order the book, and have all the authors sign it ... :)
15:00:19 <krvmga> paxed: collector's item someday
15:00:22 <kmlussier> Well, I happen to have several extra signed copies of the book that I will be bringing to the conference with me.
15:01:31 <denials> krvmga: the free downloads we'd have to pull from evergreen-ils.org/piwik I think
15:01:39 <denials> kmlussier++
15:01:43 <denials> paxed++
15:01:49 * StephenGWills wants a signed copy of that photo..the book would be nice too but that photo is a must ;)
15:01:56 <krvmga> lol
15:02:13 <yboston> should we wrap up? I am free to keep going too.
15:02:36 <krvmga> generate a copy of the book with that picture as an insert
15:02:37 <yboston> luckily we have a few more DIG monthly meetings before we get to the conference
15:02:42 <kmlussier> So, yboston, for next actions, I would say we work on filling doc gaps on the hackfest day of the next conference.
15:03:00 <kmlussier> And then plan on possibly planning a future sprint post conference.
15:03:31 <krvmga> +1
15:04:10 <yboston> I like the sound of that, but at this point should that be  just proposal or a definitive action?
15:04:39 <yboston> I am fine either way, but want to be diplomatic
15:04:58 <krvmga> i think kmlussier is making a proposal
15:05:08 <kmlussier> For the conference hacking, definitive action?
15:05:31 <kmlussier> The second piece could just be a proposal.
15:05:55 <kmlussier> But we can put it off until the next meeting too. :)
15:06:28 <yboston> yes, we can set up a page with conference plans like last year and list all ideas for now, and that should give people time to suggest alternatives
15:06:58 <krvmga> +1
15:07:05 <yboston> #action create dokuwiki page to list DIG plans during 2013 EG confernece
15:07:39 <kmlussier> That's fine, but I think it's fine for people to come up with the ideas at the conference too.
15:07:44 <kmlussier> But we can discuss ways and means next month.
15:08:17 <yboston> #action add to DIG meeting agenda: discuss planning a doc sprint post conference
15:08:35 <yboston> any last thoughts?
15:08:58 <krvmga> have the hackfest bit be for sure but the actual content be TBD?
15:09:14 <krvmga> that's what i thought i heard kmlussier say
15:10:00 <krvmga> if i heard right, yay!
15:10:12 <kmlussier> krvmga: That's my inclination, but, once again, I think there's time to discuss it at a later meeting. Since we're pushing 1 hour and 15 minutes.
15:10:30 <krvmga> yup
15:10:41 <yboston> sounds good to me
15:11:49 <yboston> OK everyone thanks for participating, and a big thanks to the doc sprinters
15:11:59 <krvmga> yboston++
15:12:04 <yboston> #endmeeting