15:01:09 <jventuro> #startmeeting 2013-1-22 Evergreen Reports Interest Group
15:01:09 <pinesol_green> Meeting started Tue Jan 22 15:01:09 2013 US/Eastern.  The chair is jventuro. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:09 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:01:33 <jventuro> Hi everybody!  Let's start with introductions
15:02:18 * jventuro is Jessica Venturo, Bibliomation
15:02:39 * jeff is Jeff Godin, Traverse Area District Library (TADL)
15:03:08 * bshum is Ben Shum, Bibliomation
15:03:17 * chtrotter is Cristina Trotter, Laurens County Library (PINES)
15:04:19 <jventuro> Thanks for coming, all
15:04:38 <jventuro> Looks like we've got a small group today, unless there are any more?
15:05:21 <jventuro> Here's the agenda for today's meeting: http://open-ils.org/dokuwiki/doku.php?id=evergreen-reports:meetings:2012-1-22-agenda
15:06:13 <jventuro> And the first item is...
15:06:30 <jventuro> #topic Review and approval of minutes from the last meeting: http://evergreen-ils.org/meetings/evergreen/2012/evergreen.2012-11-26-15.00.html
15:07:03 <jventuro> I think we did miss a few things, actually, when looking over the logs.
15:07:45 <jventuro> Most notably, Cristina's addition of the development page to the wiki
15:07:58 <jeff> good catch.
15:08:19 <chtrotter> I was wondering about that...
15:08:54 <jventuro> #info chtrotter added a page regarding developments to the wiki: http://open-ils.org/dokuwiki/doku.php?id=evergreen-reports:taskforce_reports-related_development_projects
15:09:20 <chtrotter> Also, we talked a bit about the group's name change and making the changes on the wiki
15:09:21 <jventuro> Feel free to add your own "info" tags if I forget something
15:10:31 <jventuro> #info Discussion regarding making name changes on the wiki - tabled for the next (today's) meeting.
15:10:52 <jventuro> Anything else?
15:11:16 <jeff> looks good.
15:11:20 <chtrotter> I can't think of anything else.
15:12:09 <jventuro> Awesome.  Next topic is...
15:12:20 <jventuro> #topic Documentation
15:13:28 <jventuro> #info Jim Keenan has stepped up at the reports documentation coordinator for DIG
15:13:39 <jventuro> I read that on the DIG discussion list
15:14:04 <jventuro> I does anyone know him or how to get in touch with him?
15:14:34 <jventuro> If he has a good handle on what is needed in the reports documentation, some of us may be able to contribute.
15:15:04 <chtrotter> We should sweet talk him into coming to our next meeting.
15:15:14 <bshum> krvgma I think is his IRC handle.  kmlussier should poke him.
15:15:21 <bshum> For the next meeting.
15:15:28 <krvmga> Whoa! i'm here. sorry to be late
15:15:29 <bshum> Or speak of him and he shall appear!
15:15:40 <krvmga> lol
15:15:46 <jeff> Jim is with CW/MARS. His email is findable, and reaching out on the DIG list would probably be a good idea.
15:15:46 <jventuro> That was magical!
15:15:46 <krvmga> beetlejuice
15:16:32 <jventuro> Hi krvmga.  We were just mentioning that we should get a hold of you to talk about what documentation was needed for reports.
15:16:46 <jventuro> Or improvements to the existing documentation.
15:16:59 <krvmga> i know. i was following via ESP (a special kind of IRC client)
15:17:11 <krvmga> i just stepped into this role last week, really
15:17:30 <krvmga> i haven't had a lot of time to look over the docs with a view to discovering what's missing/needs elaboration
15:17:41 <krvmga> we've been having some exciting times at cwmars
15:17:53 <krvmga> i did, however, glance through all of them.
15:18:11 <krvmga> i have a question.
15:18:23 <krvmga> i want to be able to reach out to people to invite them to contribute to the work
15:18:32 <krvmga> what's the easiest way for me to do that?
15:18:36 <krvmga> the DIG list?
15:18:59 <krvmga> my email, for those who might want it, is jkeenan@cwmars.org
15:19:16 <jventuro> I think so, and the reports list too.  That might get at some people who aren't a part of DIG.
15:19:35 <krvmga> thanks.
15:19:56 <krvmga> i know that one area we've been looking at here is working up some documentation on the data sources for reports
15:20:21 <jventuro> That would be useful.
15:20:51 <jventuro> It could also be LOT of content.
15:20:57 <krvmga> i'll call on anyone who might be willing to contribute even a little bit in this direction
15:21:19 <krvmga> jventuro: you're right. there are a lot of sources and understanding how to use them is not trivial.
15:21:31 <krvmga> for the average user, anyway
15:21:57 <jventuro> krvmga: What is the best way to get started in contributing?
15:22:32 <jventuro> Or is that still being worked out?
15:22:57 <krvmga> jventuro: this week i'll spend some time analyzing the existing docs and identifying holes and weaknesses. either the end of this week or the beginning of the next, i'll send out a summary of what i've discovered.
15:23:19 <krvmga> we can start moving forward from there. does this sound okay?
15:23:28 <jeff> krvmga++
15:23:28 <jventuro> Sounds great!
15:23:40 <jventuro> krvmga++
15:23:52 <jventuro> Can I put that down as an action item?
15:24:04 <krvmga> in the meantime, if anyone has any thoughts about that, please feel free to send them to me.
15:24:17 <krvmga> #action krvmga review docs and send out summary
15:24:43 <jventuro> Thanks.  And thanks for popping in!
15:24:53 <chtrotter> Real quick...as for documentation on data sources... you can find some info written up on the advanced reporting guide here:
15:24:54 <chtrotter> http://pines.georgialibraries.org/pines/pines-evergreen-reports-documentation
15:24:54 <krvmga> i apologize for being late.
15:25:05 <jventuro> Not a problem.
15:25:09 <krvmga> chtrotter: thanks!
15:25:36 <jventuro> I've said this before, but that PINES guide is great.
15:25:40 <chtrotter> This is specific to PINES libraries, so it mentions the "Classic" sources which are PINES-specific...but the other info is good.
15:26:06 <jventuro> Actually, we just made the "Classic" sources work for Biblio, thanks to bshum
15:26:09 <krvmga> i'm not sure how to tell how many of us are in the meeting.
15:26:38 <chtrotter> Really? Well, then, I should let you know  that the Classic Item Source has a bug.
15:26:49 <krvmga> chtrotter: important safety tip
15:27:41 <krvmga> also, if you run across likely candidates, feel free to recruit them for us. i'm sure we'll have a list of open assignments very soon.
15:27:55 * chtrotter is searching for bug link
15:27:57 <jventuro> krvmga: MeetBot only counts those who write at least one line
15:28:29 <krvmga> all right, you lurkers. type a line.
15:28:30 * jventuro is interested in contributing
15:28:31 <bshum> I think I recall reading the bug csharp filed about classic item source.  Something to do with duplication.
15:28:39 <chtrotter> aha! Here it is: https://bugs.launchpad.net/evergreen/+bug/1072892
15:28:39 <pinesol_green> Launchpad bug 1072892 in Evergreen "reporter.classic_item_list view creates repeated rows" (affected: 1, heat: 6) [Undecided,Incomplete]
15:29:23 <krvmga> jventuro++
15:29:35 <jventuro> Thanks for the info, chtrotter
15:29:40 <krvmga> chtrotter++
15:29:50 <chtrotter> Yeah, that bug really irks me because now I have to come up with another way to do my nonfiction collection analysis...and throw out previous years' info.
15:30:13 <jventuro> Ugh...
15:31:12 <chtrotter> Oh, well, poor me. I am just glad the bug has been discovered and filed for possible fixing.
15:31:27 <jventuro> Anything else on docs before we move on?
15:31:37 <krvmga> anyone?
15:32:07 <krvmga> well, done and done, then. Everyone will have something from me in the near future.
15:32:23 <jventuro> krvmga++
15:32:35 <chtrotter> krvmga++
15:32:45 <jventuro> OK, next topic...
15:32:53 <jeff> krvmga: sounds good. we'll look to the list(s) for your update. :-)
15:32:57 <jventuro> #topic Development
15:33:34 <jventuro> Anything new with the current development projects that are going on?
15:34:00 <chtrotter> The PINES project is coming along well. Also, I added a bit about the project on this page: http://open-ils.org/dokuwiki/doku.php?id=evergreen-reports:taskforce_reports-related_development_projects
15:34:59 <jventuro> Very nice
15:35:22 <jventuro> I also added an update to the Biblio developments on that same page.
15:36:10 <jventuro> We are using code that tsbere wrote and it is working wonderfully
15:36:13 <paxed> hopefully i18n is considered when doing new parts, so that strings are readily translatable.
15:37:35 <jeff> chtrotter: with the PINES project, is the interface being built in a way to support future i18n / translation from English to other languages?
15:39:18 * denials is willing to be that the developers would be willing to do so if they knew what they had to do
15:39:51 * jeff nods
15:40:44 <paxed> also hopefully without inventing Yet Another way of handling the translation :P
15:40:56 <denials> lacking someone with that knowledge, those interested in i18n get to deal with it when it is public code
15:41:02 <jeff> a little bit of a tangent, but it's probably better to do it from the start than to try to retrofit later, and as denials alludes, we might have some room for improvement with "here's a good way to do i18n in this area of Evergreen"
15:41:04 <jventuro> chtrotter: Is that something you would be able to find out?
15:43:02 <chtrotter> Sorry, y'all, I am still a bit of IRC newbie. As for the PINES project, I will have to check with the PINES staff about the support of i18n.
15:43:14 <jeff> chtrotter++ thanks!
15:44:13 <jventuro> Thanks.  I'll make a note of it.
15:44:42 <jventuro> #info Further information on PINES development project available here: http://open-ils.org/dokuwiki/doku.php?id=evergreen-reports:taskforce_reports-related_development_projects
15:45:38 <jventuro> #action chtrotter will check with PINES staff to find out if the project supports i18n
15:46:12 <jventuro> Anything else on development?
15:47:11 <jventuro> In that case...
15:47:51 <jventuro> #topic Editing wiki pages to reflect our name change from "Report Task Force" to "Reports Interest Group"
15:48:05 <jventuro> We started this discussion last week
15:48:45 <jventuro> As of right now, I think all of the headings and references to the group have been edited, but we're still working on URLs
15:49:15 <chtrotter> jventuro: Thanks for making all the changes thus far
15:49:29 <jventuro> I think last time we discussed this, it was mentioned that changing page names is fraught with problems?
15:50:07 <jventuro> chtrotter: Thanks for helping me find that last one :)
15:51:31 <jventuro> What I had planned to do was just make a new page and copy over the content, but I'm not sure if there is an easier option.  From what folks were saying, it didn't seem so.
15:52:20 <chtrotter> Maybe this is a question for the web team? Anyone know anyone on that group?
15:54:53 <jventuro> I'll...see what I can find out.
15:55:29 * chtrotter offers to help anyway I can.
15:55:30 <bshum> Probably unlikely.
15:55:41 <jventuro> #action jventuro will contact the web team to find out the best way to change the page names/URLs
15:55:50 <bshum> I don't think we would be able to offer much assistance to moving around wiki pages.
15:56:05 * bshum was wearing his webteam hat to say that.
15:56:06 <jventuro> Is there someone else we should contact, then?
15:56:09 * chtrotter dreams of universal find and replace.
15:56:52 <jventuro> I was wondering if we should just let sleeping dragons lie
15:57:07 <jventuro> ^reference from the last meeting
15:57:29 <chtrotter> jventuro: Maybe we can create a few test pages that link to each other to test out possible name change options?
15:58:05 <jventuro> I guess so. I don't like the idea of cluttering up the wiki, though.  I would like to check with someone first, but I'm not sure who to check with.
16:01:24 <jventuro> chtrotter: I'll still see what I can find out.  Even if it's not from the web team.
16:01:44 <jventuro> And I'll let you know.
16:03:08 <jventuro> OK, we're past our hour mark, but any new business before we wrap up?
16:03:46 <chtrotter> none here.
16:04:33 <jventuro> I still want to discuss ideas about what the group could be doing, but seeing as we've had some good discussion the past few meetings, maybe we're good?
16:05:45 <chtrotter> One thing we could do is review our wishlist items.
16:06:36 <chtrotter> While updating the development page, I realized I had not looked at the wishlist in a long while.
16:07:05 <jventuro> That's a good point.
16:07:31 <bwicksall> hack
16:07:39 <bwicksall> lol, wrong window
16:07:39 <jventuro> I wonder if this is a good venue for that, or if we should discuss it on the email list or at the conference?
16:07:45 <bwicksall> sorry
16:09:02 <chtrotter> Maybe on the email list we can put out a request for folks to review the wishlist. And then do some follow-up discussion at our next meeting?
16:09:32 <jventuro> Good idea
16:09:53 <jventuro> #topic Wishlist
16:11:01 <jventuro> #action jventuro will ask for people to review the wish list and discuss additions/changes at the next meeting.
16:11:12 <jventuro> Anything else?
16:12:04 <chtrotter> None here.
16:13:25 <jventuro> OK, in that case, meeting adjourned.  Thanks, everybody!
16:13:39 <jventuro> #endmeeting