#evergreen Meeting

Meeting started by gmcharlt at 13:00:29 US/Eastern (full logs).

Meeting summary

    1. Agenda is http://evergreen-ils.org/dokuwiki/doku.php?id=dev:meetings:future_of_staff_client&#agenda (gmcharlt, 13:00:45)

  1. quick round of intros (gmcharlt, 13:00:57)
    1. gmcharlt = Galen Charlton, Equinox Software (gmcharlt, 13:01:15)
    2. tsbere = Thomas Berezansky, MVLC (tsbere, 13:01:21)
    3. bshum = Ben Shum, Bibliomation (bshum, 13:01:25)
    4. berick Bill Erickson, Equinox Software (berick, 13:01:27)
    5. csharp = Chris Sharp, GPLS (csharp, 13:01:27)
    6. kmlussier = Kathy Lussier, MassLNC (kmlussier, 13:01:31)
    7. Dyrcona = Jason Stephenson, MVLC (Dyrcona, 13:01:33)
    8. senator = Lebbeous Fogle-Weekley, Equinox Software (senator, 13:01:34)
    9. jeff = Jeff Godin, Traverse Area District Library (TADL) (jeff, 13:01:35)
    10. DPearl = Dan Pearl, C/W MARS (DPearl, 13:01:35)
    11. jamesrf = James Fournie, BC Libraries Coop (jamesrf, 13:01:36)
    12. ktomita = Kyle Tomita, Catalyst IT Services (ktomita, 13:01:38)
    13. krvmga = Jim Keenan C/W MARS (krvmga, 13:01:42)
    14. Rogan_ = Rogan Hamby, SCLENDS (Rogan_, 13:01:45)
    15. paxed = Pasi Kallinen, Regional Library of Joensuu (paxed, 13:01:56)
    16. davidboyle - David Boyle, Catalyst IT Services (davidboyle, 13:01:59)
    17. dbwells = Dan Wells, Calvin College (dbwells, 13:02:04)
    18. Colin Campbell, PTFS-Europe Ltd (ColinC, 13:02:17)
    19. alexlazar = Aleksey Lazar PALS MN (alexlazar, 13:02:24)
    20. eeevil = Mike Rylander / ESI (slow, phone, driving) (eeevil, 13:03:13)
    21. Tim Spindler, C/W MARS (tspindler, 13:03:19)

  2. Do we still need a staff client? (gmcharlt, 13:03:31)
    1. denials = Dan Scott / Laurentian (denials, 13:03:39)
    2. phasefx = Jason Etheridge / ESI (phasefx, 13:03:50)
    3. bradl = Brad LaJeunesse, Equinox (bradl, 13:04:06)
    4. go (almost) entirely web-based (gmcharlt, 13:05:49)
    5. have a minimal staff client for things like printing (gmcharlt, 13:05:58)
    6. keep the staff client, but move as much as possible into chrome (gmcharlt, 13:06:11)
    7. remove Dojo from the staff client (gmcharlt, 13:06:17)
    8. implement websockets (gmcharlt, 13:06:22)
    9. perform a third-party performance analsysis (gmcharlt, 13:06:39)

  3. Move much as possible to chrome (gmcharlt, 13:16:32)
  4. Removal of Dojo from staff client (proposal by Thomas Berezansky) (gmcharlt, 13:25:30)
  5. Websockets (gmcharlt, 13:43:10)
  6. Objective third-party performance analysis to identify bottlenecks in the system. (gmcharlt, 13:51:59)
  7. Next steps? (gmcharlt, 14:17:28)
    1. ACTION: Evergreen devs are encouraged to start moving staff client interfaces away from remote XUL (gmcharlt, 14:31:10)


Meeting ended at 14:33:07 US/Eastern (full logs).

Action items

  1. Evergreen devs are encouraged to start moving staff client interfaces away from remote XUL


People present (lines said)

  1. gmcharlt (83)
  2. denials (53)
  3. jeff (47)
  4. tsbere (42)
  5. berick (28)
  6. csharp (21)
  7. phasefx (18)
  8. kmlussier (16)
  9. mrpeters-isl (16)
  10. jamesrf (15)
  11. ktomita (13)
  12. eeevil (12)
  13. Dyrcona (12)
  14. bradl (10)
  15. tspindler (9)
  16. alexlazar (9)
  17. krvmga (9)
  18. wolf29 (8)
  19. Rogan_ (8)
  20. acoomes (7)
  21. dbwells (5)
  22. paxed (4)
  23. DPearl (4)
  24. pinesol_green (4)
  25. stevenyvr2 (4)
  26. bshum (3)
  27. senator (3)
  28. jasonb_ (3)
  29. jasonb (2)
  30. moodaepo (2)
  31. JennB (2)
  32. smyers_ (2)
  33. edoceo (1)
  34. shopkins (1)
  35. ColinC (1)
  36. davidboyle (1)


Generated by MeetBot 0.1.4.