14:01:04 <yboston> #startmeeting 2013-03-07 - DIG Monthly Meeting Evergreen Documentation Interest Group (DIG) Monthly Meeting. The agenda can be found here http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:dig_meeting_20130307-agenda
14:01:04 <pinesol_green> Meeting started Thu Mar  7 14:01:04 2013 US/Eastern.  The chair is yboston. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:04 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:01:04 <pinesol_green> The meeting name has been set to '2013_03_07___dig_monthly_meeting_evergreen_documentation_interest_group__dig__monthly_meeting__the_agenda_can_be_found_here_http___evergreen_ils_org_dokuwiki_doku_php_id_evergreen_docs_dig_meeting_20130307_agenda'
14:01:20 <yboston> #topic Introductions
14:01:29 <yboston> Please feel free to start introducing yourselves...
14:01:37 <krvmga> Jim Keenan, C/W MARS
14:01:38 * yboston is Yamil Suarez @ Berklee college of Music
14:01:43 * phasefx is Jason Etheridge, Equinox
14:01:48 * rsoulliere is Robert Soulliere, Mohawk College
14:02:20 * kmlussier is Kathy Lussier, MassLNC
14:03:56 <yboston> I will continue, and hope that new arrivals will introduce themselves
14:04:21 <yboston> #topic Updates from Content Coordinators
14:04:31 <yboston> We will continue having the content corrdinators try out the "#topic" AND "#info" Meetbot commands for their reports
14:04:31 <yboston> So content coordinators, please use "#topic" for the first post/line of your report
14:04:31 <yboston> then use "#info" for every other chat post/line of your report.
14:04:31 <yboston> for example...
14:04:39 <yboston> #topic this is a test report first post/line
14:04:46 <yboston> #info this is a test report second post/line
14:04:52 <yboston> Again, for everyone else participating in the meeting, don't worry about using any Meetbot commands, participate normally
14:05:09 <krvmga> #topic reports
14:05:14 <krvmga> #info nothing new
14:05:22 <yboston> go ahead krvmga ...
14:06:06 <krvmga> i apologize but we've been in crisis mode a c/w mars for a month and my attention has been elsewhere.
14:06:25 <yboston> no problem, we can go on to the next report (no pun intended)
14:06:31 <rsoulliere> #topic Conversion Coordinator Report
14:06:35 <rsoulliere> #info Nothing new to report since last meeting.
14:07:51 <yboston> thanks rsoulliere, anybody else
14:07:54 <kmlussier> #topic Release Coordinator Report
14:08:03 <kmlussier> #info I think we're in good shape with Release Notes so far. Most of the developers have been adding them as they add enhancements, and I've been trying to post reminders to LP bugs that don't have release notes.
14:08:12 <kmlussier> #info bshum pulled together a preview of the release notes. http://git.evergreen-ils.org/?p=working/Evergreen.git;a=blob_plain;f=docs/RELEASE_NOTES_2_4.txt;hb=9abccb6caaff8d7f93b1f55b7732669bb6aaefd2
14:08:17 <kmlussier> bshum++
14:08:26 <yboston> bshum++
14:08:48 <kmlussier> #info Before beta is released, I'm going to start the process of going through the notes to see which new features needs to be incorporated into the documentation. Also, I'll be checking for general readability for the average user.
14:08:56 <kmlussier> That's all for my report.
14:09:23 <yboston> quick question, does anyone have any idea
14:09:48 <yboston> when 2.4 will be officially released, specifically will it be before or after the conference
14:10:39 <yboston> anyway, kmlussier++
14:10:45 <phasefx> kmlussier: are there any written guidelines for how to do release notes?  I've been mimicking others
14:11:06 <kmlussier> phasefx: Not that I know of, but I'm willing to create some. :)
14:11:14 <phasefx> cool deal
14:11:18 <kmlussier> I've just been mimicking others too.
14:12:23 <phasefx> I imagine it'd be useful to distinguish/segregate bug fixes, features, and technical details
14:12:24 <kmlussier> yboston: Looking at log from last dev meeting, April 3 was the date mentioned for 2.4.0
14:12:44 <krvmga> and the date of the conference?
14:12:53 <kmlussier> After April 3.
14:13:01 <kmlussier> I think it's the following week.
14:13:05 <krvmga> lol
14:13:56 <yboston> thanks kmlussier, I am just wondering if we can end up helping with the release notes during the conference if the release is not out by the conference, or even if it is
14:14:10 <kmlussier> phasefx: I agree. Technical details are very nice to have, but can be too heavy for general release notes.
14:15:09 <kmlussier> yboston: I'm hoping the release notes should be pretty finalized by the conference, but the documentation on those new 2.4 features is another thing entirely.
14:15:37 <kmlussier> There probably will be some good doc projects coming from 2.4.
14:16:43 <yboston> kmlussier: that makes sense. Converting the newly finished release notes into more thorough documentation could be a lofty DIG goal for the conference
14:18:26 <yboston> any other questions or comments on kmlussier's report?
14:19:44 <kmlussier> #action kmlussier to create guidelines for writing release notes.
14:21:17 <yboston> I just added a mention to look into working with the 2.4 release notes to the DIG conference ideas page http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:dig_hackfest
14:22:39 <yboston> unless there is something more to be added to kmlussier 's report I will move on for now
14:23:02 <kmlussier> Nothing more except bshum mentioned that the html version of alpha release notes is at http://evergreen-ils.org/documentation/previews/RELEASE_NOTES_2_4.html
14:24:37 <yboston> thanks kmlussier
14:24:48 <jeff> tsbere: alas, a hold id appears insufficient for open-ils.trigger.event.autocreate, and it wants a hold object. not impossible, just a little annoying. :-)
14:25:01 <jeff> (oops, meeting. sorry.)
14:25:30 <yboston> no problem
14:25:37 <yboston> #topic update on project to move useful information from old documentation versions to 2.4
14:25:45 <yboston> #info I wanted to give a quick update on my work with my intern to try to move content from older official docs to 2.4. So far I have mostly rained the student on EG basics, command line basics. This week we just installed EG 2.4 alpha1 so we can try to find spots were we need more up to date screen shots for older documentation content. I had hoped to have more work done by now, but my production served had a hard crash and it took me a while to
14:26:43 <yboston> #info we have also done a lot of automated textual comparisons between different sections of the existing manuals to spot sections that are exactly the same to narrow done what needs to be moved
14:27:02 <yboston> #info but we still have plenty of work left
14:27:02 <phasefx> yboston: I think you got truncated after "took me a while to"
14:27:23 <yboston> "took me a while to revover"
14:27:29 <yboston> (recover)
14:27:44 <kmlussier> yboston++
14:28:44 <yboston> that is all for this report
14:29:12 <yboston> unless there are questions or comments I was thinking of moving to old business
14:31:51 <yboston> #topic old business: Brainstorm on DIG activities at 2013 EG conference (proposed by Yamil)
14:32:20 <yboston> here are the links for the pages that we have set up to write down ideas...
14:32:35 <yboston> http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:dig_hackfest - for the hackfest
14:32:52 <yboston> http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:dig_meeting - for the DIG meeting
14:33:54 <yboston> if inspiration does not strike us now, feel free to add your ideas to that page later on.
14:35:34 <yboston> BTW, if we follow our usual schedule the next meeting might be April 4th, right before the conference, which we can use to do more last minute planning
14:35:49 <yboston> or perhaps not meet at all and wait for the conference
14:36:02 <kmlussier> I know there was a suggestion yesterday that we add some documentation on using the zips.txt file.
14:36:45 <alexlazar> kmlussiter: we have some written internally at PALS
14:36:55 <kmlussier> It's already documented on a wiki somewhere and just needs to be added to the documentation, provided the original author doesn't mind that we use it. I can't remember which wiki has that.
14:37:03 <yboston> kmlussier: I mistakenly thought that "zips.txt" had to do with a way to "register patrons"
14:37:32 <kmlussier> yboston: It is related to patron registration. It allows the city field to automatically populate based on the zip code entered.
14:38:09 <kmlussier> alexlazar: That would be a great addition. If you send it to the DIG list, I think rsoulliere could add it.
14:38:18 <yboston> kmlussier:  OK, I understand much better now.
14:38:27 <alexlazar> I would volunteer to look it up on the wiki and update as necessary, perhaps merge with our own and send it out.
14:38:35 <alexlazar> for review
14:38:53 <kmlussier> alexlazar++
14:39:16 <yboston> rsoulliere:  are you planning on going to the conference?
14:39:47 <yboston> if so I would like to work with you to get a better handle on how to submit changes to the repository
14:40:02 <rsoulliere> yboston: I will not be able to make it this year.:-(
14:40:43 <yboston> rsoulliere:  that is too bad. we can try to have you Skype to our meeting if you are free
14:41:29 <yboston> if I remember correctly, Dan Scott offered to give DIG some Git tips
14:41:31 <krvmga> or through google. that worked for me.
14:41:46 <yboston> krvmga:  absolutely
14:41:47 <kmlussier> alexlazar: http://dmagick.wordpress.com/2011/01/06/notes-on-installing-zipcode-information/. I guess it was a blog post, not a wiki.
14:42:49 <rsoulliere> yboston: good Idea I will try that. I agree with krvmga  that google hangout is great for meetings.
14:43:02 <mcooper> I was suggesting documentation on zips.txt. It's great … but I found the information on a blog post
14:43:23 <alexlazar> kmlussier: thanks
14:43:25 <mcooper> Yeah, that's the one =)
14:43:40 <yboston> kmlussier++
14:43:49 <krvmga> the only extra suggestion i'd have for google hangout is to have external speakers so the virtually present person can be heard more readily
14:44:13 <krvmga> sometimes i felt like a gremlin in the machine :)
14:44:33 <rsoulliere> yboston: We should consider using google hangout as an official remote connection tool for the DIG meeting at the conference for anyone not able to make it.
14:46:15 <yboston> rsoulliere: I like the idea. One year I used a vide streaming site for our DIG meeting with limited success, since the remote persons could not hear those speaking during the meeting becuase of lack of volume/microphones
14:47:10 <rsoulliere> krvmga: good point about the speakers. Perhaps we also need a hangout chat monitoring person in case voices are not heard or missed?
14:47:24 <krvmga> my experience; i was able to hear everyone well. i was also _mostly_ able to see what was going on.
14:47:38 <krvmga> (sometimes sticky notes were too small to read)
14:48:13 <yboston> rsoulliere: this was another issue I had, that it was impossible to point my laptop's camera to view the room and at the same time look at the screen to see if folks had questions through through chat
14:48:44 <yboston> we will need two volunteers or not worry about shooting the video at the persons speaking
14:49:50 <kmlussier> When krvmga was doing the hangout, we generally had him on a table looking at the other participants. But it meant that the laptop couldn't be used for other things.
14:49:55 * dbs used a Nexus 7 for krvmga
14:50:07 <krvmga> yes, i was lucky. i had a machine "me" at the table.
14:50:24 <dbs> Could have easily added external speakers to it, but weren't able to get ay quickly from Google campus
14:50:35 <yboston> heads up, we have reached the 50 minutes mark.
14:50:53 <krvmga> kudos to the docsprint team
14:52:46 <yboston> BTW, If we are not interested as a group on meeting again by IRC on April 4th, we might want to focus covering important things now
14:52:58 <kmlussier> So to wrap up this topic, we all just need to keep adding ideas for the conference to the wiki, right?
14:53:06 <yboston> yes
14:53:20 <kmlussier> yboston: I may not be able to make a meeting on the 4th. I'm not sure yet.
14:53:32 <yboston> kmlussier: no problem
14:55:04 <yboston> do we want to cover the new business quickly now or try to get a rough vote on meeting on the 4th?
14:55:27 <yboston> perhaps is best to ask on the list if we want to meet on the 4th
14:56:02 <kmlussier> I suggest we move on to alexlazar agenda item, even if it is just to begin discussion.
14:56:16 <yboston> OK
14:56:18 <alexlazar> Since I was a bit late to the meeting
14:56:20 * alexlazar is Aleksey Lazar, PALS
14:56:37 <alexlazar> I would like to gauge DIG opinion about separating (at some point) Evergreen documentation into systems documentation and user documentation sections. We don't have to discuss in depth now, perhaps just think about it.
14:56:50 <alexlazar> Systems documentation section would focus on system administrators and developers, user documentation would focus on support staff and librarians.
14:57:20 <krvmga> alexlazar: i think this is a good idea. probably inevitable.
14:58:27 <yboston> alexlazar:  the idea make sense, and my previous ILS was like this, but the documentation team was not volunteers :)
14:58:55 <rsoulliere> I think it was discussed a few years ago.
14:59:20 <yboston> we can expand on this more at our next IRC meeting and also at the conference meeting, and on the list
14:59:42 <dbs> Looking at the current table of contents, it looks like about five minutes of work to put together the pertinent chapters into two separate parts. at least as a proof of concept. alexlazar, why don't you do that?
14:59:44 <yboston> BTW, alexlazar  are you going to the conference? what about the DIG meeting at teh cofnernece?
15:00:00 <yboston> in case we want to discuss it then
15:00:07 <alexlazar> dbs: I will.
15:00:27 <alexlazar> yboston: nope, can't make it this year, :(
15:00:53 <yboston> alexlazar:  that is too bad, you will be missed
15:01:42 <kmlussier> It sounds like a good idea to me (the reorganization, not alexlazar missing the conference).
15:01:47 <alexlazar> yboston: thanks, I will miss not being there
15:02:16 <dbs> alexlazar++
15:02:55 <yboston> we can skip the last item about updating "evergreen in action", I just thought about it when thinking about what has changed from 2.3 and 2.4
15:03:16 <kmlussier> yboston: When I go through the release notes review, I'll keep Evergreen in Action in mind.
15:03:26 <yboston> kmlussier:  thanks
15:03:54 <yboston> btw, did we have a consensus to add a link to Evergreen in action to the official docs page?
15:04:21 <kmlussier> yboston: Was it a link or just a heading for the content that is there?
15:05:02 <yboston> I was hoping for at least a link to EIA, but a header would help
15:06:05 <yboston> BTW, it's 3:05 EST, should we wrap things up now?
15:06:16 <kmlussier> I was going to add the heading tomorrow. I can add a link too.
15:06:33 <alexlazar> I need to go, thanks yboston and everybody!
15:07:17 <yboston> thanks alexlazar
15:07:37 <yboston> and thanks kmlussier
15:07:52 <yboston> and everybody else, have a good day
15:08:04 <kmlussier> yboston++
15:08:21 <yboston> #endmeeting