#evergreen: Developer's meeting, 12 March 2013

Meeting started by gmcharlt at 14:04:05 US/Eastern (full logs).

Meeting summary

    1. Agenda: http://evergreen-ils.org/dokuwiki/doku.php?id=dev:meetings:2013-03-12 (bshum, 14:04:09)

  1. Introductions (gmcharlt, 14:04:41)
    1. gmcharlt = Galen Charlton, Equinox (gmcharlt, 14:04:50)
    2. paxed = Pasi Kallinen, Regional Library of Joensuu (paxed, 14:04:51)
    3. bshum = Ben Shum, Bibliomation (bshum, 14:05:00)
    4. senator = Lebbeous Fogle-Weekley, Equinox (senator, 14:05:08)
    5. ktomita = Kyle Tomita, Catalyst IT Services (ktomita, 14:05:09)
    6. acoomes = Andrew Coomes, Catalyst IT Services (acoomes, 14:05:16)
    7. phasefx = Jason Etheridge, Equinox (phasefx, 14:05:17)
    8. csharp = Chris Sharp, Georgia Public Library Service (csharp, 14:05:19)
    9. dbwells = Dan Wells, Calvin College (dbwells, 14:05:34)
    10. remingtron = Remington Steed, Calvin College (remingtron, 14:05:35)
    11. DPearl = Dan Pearl, C/W MARS (DPearl, 14:05:49)
    12. berick = Bill Erickson, Equinox (berick, 14:05:49)
    13. kmlussier = Kathy Lussier, MassLNC (kmlussier, 14:05:53)
    14. sseng = Srey Seng, Catalyst IT Services (sseng, 14:06:06)
    15. eeevil = Mike Rylander, Equinox (eeevil, 14:06:24)
    16. Dyrcona = Jason Stephenson, MVLC (Dyrcona, 14:06:28)
    17. j_scott = Jon Scott - Lyrasis (j_scott, 14:06:36)
    18. mrpeters = Michael Peters, Emerald Data Networks (mrpeters, 14:06:56)

  2. Action items from last meeting (gmcharlt, 14:07:11)
    1. bshum will take charge of wrangling patches to remove JSPac - status: started, see bug 1152655 (gmcharlt, 14:07:28)
    2. tsbere = Thomas Berezansky, MVLC (tsbere, 14:08:38)
    3. AGREED: commits to start removing JSPac will be available in 2.4 (gmcharlt, 14:11:13)
    4. testing.evergreen-ils.org VM and buildbot resurrection: status: IT'S ALLLIIIIIVE!!!1!!! (gmcharlt, 14:11:18)
    5. gmcharlt to do some branch management with an eye towards an OpenSRF 2.2 release in the next few weeks. STATUS: started going through patches. After testing of multi-session and service reload, can cut OpenSRF alpha later this week (gmcharlt, 14:12:44)

  3. Google Summer of Code (gmcharlt, 14:13:20)
    1. AGREED: bshum and dbwells have volunteered to be co-mentors; bshum to discuss org admin with gmcharlt (gmcharlt, 14:28:37)

  4. Release info - OpenSRF (gmcharlt, 14:29:56)
    1. looks like Evergreen 2.4 will require a mandatory OpenSRF upgrade (gmcharlt, 14:34:51)

  5. Evergreen - 2.4 release - reviewing dependencies (gmcharlt, 14:35:29)
    1. there's general agreement to deprecate legacy circ scripts in 2.4; and remove in 2.6 (gmcharlt, 14:44:34)
    2. ACTION: Dyrcona, bshum, gmcharlt to test and recommend whether XUL 15 should be included in 2.4 (gmcharlt, 14:51:40)
    3. AGREED: release checklist to be updated with steps about checking dependency versions (gmcharlt, 15:00:08)

  6. Proposed addition to release manager processes: No release tarball shall be released unless at least one person has gone through a clean install and confirmed that it actually works. (gmcharlt, 15:00:31)
  7. Proposed addition to release manager processes: clearly articulate supported platforms (i.e., OS, distro, browsers) (gmcharlt, 15:04:19)
  8. Software Performance Evaluation (gmcharlt, 15:09:50)


Meeting ended at 15:28:52 US/Eastern (full logs).

Action items

  1. Dyrcona, bshum, gmcharlt to test and recommend whether XUL 15 should be included in 2.4


Action items, by person

  1. bshum
    1. Dyrcona, bshum, gmcharlt to test and recommend whether XUL 15 should be included in 2.4
  2. Dyrcona
    1. Dyrcona, bshum, gmcharlt to test and recommend whether XUL 15 should be included in 2.4
  3. gmcharlt
    1. Dyrcona, bshum, gmcharlt to test and recommend whether XUL 15 should be included in 2.4


People present (lines said)

  1. gmcharlt (86)
  2. bshum (35)
  3. eeevil (28)
  4. kmlussier (21)
  5. Dyrcona (19)
  6. mrpeters (11)
  7. phasefx (10)
  8. berick (10)
  9. dbs (9)
  10. pinesol_green (8)
  11. csharp (5)
  12. dbwells (4)
  13. anyzh (4)
  14. ktomita (3)
  15. paxed (3)
  16. DPearl (3)
  17. tsbere (3)
  18. acoomes (2)
  19. alexlazar (2)
  20. SimonHM (2)
  21. j_scott (1)
  22. sseng (1)
  23. StephenGWills (1)
  24. krvmga (1)
  25. remingtron (1)
  26. senator (1)
  27. pmurray (1)


Generated by MeetBot 0.1.4.