15:00:40 <jventuro> #startmeeting 2013-03-26 Evergreen Reports Interest Group Meeting
15:00:40 <pinesol_green> Meeting started Tue Mar 26 15:00:40 2013 US/Eastern.  The chair is jventuro. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:40 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:00:40 <pinesol_green> The meeting name has been set to '2013_03_26_evergreen_reports_interest_group_meeting'
15:01:04 <jventuro> Hi everybody!  Please feel free to introduce yourselves.
15:01:16 <jventuro> Here's the agenda if you need it: http://open-ils.org/dokuwiki/doku.php?id=evergreen-reports:meetings:2013-03-26-agenda
15:01:32 * jventuro is Jessica Venturo, Bibliomation
15:02:09 * jeff is Jeff Godin, Traverse Area District Library (TADL)
15:02:30 * bshum is Ben Shum, Bibliomation
15:04:14 <jeff> chtrotter: greetings. you're just in time for the reports interest group meeting. feel free to introduce yourself -- introductions have just begun.
15:04:40 * chtrotter is Cristina Trotter, Laurens County Library (PINES)
15:04:40 <jventuro> Thanks, jeff
15:04:58 <chtrotter> sorry I am late, y'all
15:05:14 <jventuro> Not a problem.  It's just a small group today.
15:05:57 <jventuro> So, if it's not a problem with you all, I'd like to just quickly wiz through old business so we can talk about conference planning.  Sound good?
15:06:11 <chtrotter> Sounds good to me.
15:06:44 <jventuro> #topic Review and approval of minutes from last meeting: http://evergreen-ils.org/meetings/evergreen/2013/evergreen.2013-01-22-15.01.html
15:07:08 <jventuro> Anything get missed by MeetBot?
15:07:23 <chtrotter> Looks correct to me.
15:08:40 <jventuro> Seeing no corrections...
15:08:51 <jventuro> #agree Minutes are approved.
15:09:30 <jventuro> #topic Documentation
15:10:27 <jventuro> Jim couldn't make it today, so unless anyone has anything to say, we can table this to the next meeting.
15:10:33 <jeff> sounds good.
15:10:54 <jventuro> #info Tabled to next meeting.
15:11:18 <jventuro> #topic Development
15:11:54 <jventuro> Anyone have anything they would like to say in regards to reports development?
15:11:55 <chtrotter> Shall I give an update on the PINES development?
15:12:10 <jventuro> chtrotter: Go for it!
15:12:58 <chtrotter> The PINES Reports Working Group is now gathering the results from our surveys. We surveyed the PINES community and the Evergreen community.
15:13:38 <chtrotter> We are now in the process of trying to determine what the survey results are telling us.
15:13:42 * jventuro will be very interested in the results when they become available.
15:13:53 <JennB> Im interested too in the results
15:14:27 <chtrotter> We are also starting on a very rough draft of the requirements documentation. I have asked about i18n compliance, but do not have an answer yet.
15:14:42 <jventuro> JennB:  Hi!  Could you introduce yourself?
15:15:17 <chtrotter> I will be creating a short presentation of the Evergreen survey results for the RIG meeting in Vancouver. Two of my colleagues will be doing the presentation since I will not be attending the conference.
15:15:20 <JennB> Oh yes! Hello, Im Jennifer Bielewski from LYRASIS. I'll see you all at the Conference next month as well :)
15:16:09 <jventuro> JennB:  Great!  Welcome!
15:16:47 <chtrotter> I will also make the presentation available via the wiki after the conference.
15:17:04 <jventuro> chtrotter: Thanks for doing that.  I think it will be great!
15:17:21 <jventuro> chtrotter++
15:17:40 <paxed> chtrotter: i'll be sure to look over the stuff, from the i18n viewpoint :)
15:17:55 <chtrotter> We definitely received some report suggestions/needs that will not be covered by the PINES development...for example, needs specific to academic or school libraries.
15:18:27 <chtrotter> I think it will be interesting to hear how RIG might be able to help those needs forward...
15:18:56 <jeff> chtrotter: in advance of the conference, are any of those needs available for us to look over -- or do we need to wait for the conference?
15:20:00 <chtrotter> If I can get the presentation ready before the conference, I might able to then focus on sharing some of the results beforehand
15:20:32 <chtrotter> I know everyone is eager to see the results.
15:21:13 <chtrotter> Any questions about the development? I will answer what I can.
15:21:19 <jeff> do you expect any of the raw data to be available, either before or after the conference?
15:21:52 <jeff> chtrotter: i'm curious about timeline, and if there's been any code written and posted in working branches yet, or if the project is still in the requirements / mockups phase.
15:22:16 <chtrotter> I don't see why I can post the raw data. Let me confirm with my group first.
15:22:45 <chtrotter> As for timeline, I am uncertain. We are currently in the requirements-writing phase.
15:23:19 <jeff> sounds good. thanks!
15:23:24 <jeff> chtrotter++
15:23:26 <jeff> PINES++
15:23:30 <chtrotter> Sorry just caught the typo: I don't see why we CANNOT post the raw data.
15:24:21 <jventuro> chtrotter: Perhaps we can add those additional requirements to the wishlist once they have been defined?
15:25:06 <chtrotter> That's all from me, unless there are any more questions.
15:25:40 <jventuro> Thank you, chtrotter.
15:25:50 <jventuro> chtrotter++
15:27:03 <jventuro> So for the notes...
15:27:27 <jventuro> #info <chtrotter> The PINES Reports Working Group is now gathering the results from our surveys. We surveyed the PINES community and the Evergreen community.
15:28:07 <jventuro> #info <chtrotter> I will be creating a short presentation of the Evergreen survey results for the RIG meeting in Vancouver. Two of my colleagues will be doing the presentation since I will not be attending the conference.
15:28:26 <jventuro> Just trying to grab the basics.  Anything else for the notes?
15:29:12 <chtrotter> #action chtrotter will post raw data of survey results
15:29:44 <jventuro> Good catch, thanks.
15:30:24 <jventuro> Any other developments topics to discuss?
15:31:05 <jventuro> In that case...
15:31:16 <jventuro> #topic Editing the wiki to reflect our name change
15:31:32 <jventuro> #info This is done.
15:31:35 <bshum> jventuro++
15:31:47 <chtrotter> jventuro++
15:32:27 <jventuro> #info Any links with the word "taskforce" has been changed to "rig."
15:33:17 <jventuro> I was thinking after the conference I would take the content off the taskforce pages.  Does that sound like enough time, or should we leave them up longer?
15:33:58 <chtrotter> Sounds good to me.
15:34:36 <jventuro> OK, will do.
15:35:16 <jventuro> Anything else from past meetings?
15:36:27 <jventuro> Seeing nothing, we'll move on to new business.
15:36:39 <jventuro> #topic Conference planning
15:37:29 <jventuro> chtrotter:  How long do you think your presentation will be?
15:38:33 <chtrotter> I am expecting the presentation of survey results to last about 15 mins.
15:39:15 <chtrotter> I imagine the group will have questions about the development project, so maybe another 10 mins.
15:39:50 <jventuro> Very good.  That leaves us with another 20 minutes.
15:40:16 <jventuro> Does anyone have any suggestions about what should be discussed.
15:40:21 <jventuro> ?
15:41:03 <chtrotter> Oh, wow, I didn't realize the meeting was only an hour long....I can make my presentation shorter, esp. if the raw data will be posted.
15:41:37 <jventuro> Actually, it's just 45 minutes.
15:41:49 <jventuro> From 3-3:45 PM
15:42:26 <jventuro> (Pacific Time, btw)
15:42:42 <chtrotter> I feel like the discussion is the best part of the meeting for the attendees...so I will def. make the presentation shorter.
15:43:00 * chtrotter sighs in relief.
15:43:40 <jventuro> I bet they will be very interested in it.  Improving the UI is always mentioned in the discussions.
15:44:08 <jventuro> Would you like to have the presentation done before or after the group discussion?
15:44:51 <phasefx> adding more fieldmapper views could be useful for the native reporter, external reporters, and SQL junkies alike
15:45:01 <chtrotter> I think it would be best first, and the presentation will certainly lead to more discussion of more wishlist items.
15:46:21 <jventuro> phasefx: Could you explain fieldmapper views for the nontech folks?
15:46:57 <jventuro> chtrotter: I agree
15:47:08 <chtrotter> phasefx: the pines development will be creating a supplemental user interface for quick reporting needs. We will not be modifying or replacing the current reports module in Evergreen.
15:47:15 <phasefx> every table in the database has an abstraction, a label that programmers use, that we call a fieldmapper class
15:47:54 <phasefx> so for example, au maps to actor.usr, which is what stores patrons and staff in the database.  But it doesn't have to be a table, it can be a query
15:48:55 <phasefx> so you can make "canned" reports via a query that you enshrine as database view, and then as a fieldmapper class, and then others can make use of it, including the existing systems
15:49:10 <jeff> phasefx: fieldmapper views with underlying database views, or where the SQL is in fm_IDL.xml? guessing the former, otherwise I'm not sure if there's benefit to SQL reporting.
15:49:58 <jeff> phasefx: but if with underlying db views -- yes, agreed, including some potential materialized reporting views as appropriate. there was some discussion in #evergreen about that semi-recently.
15:50:07 <phasefx> jeff: yeah, it evolved in my head as I verbalized it.  database view would get the most win for those seeking alternatives, but an entry in the IDL would be an easy win too
15:50:33 <jeff> with both being best -- but i think that's what you're saying. :-)
15:50:40 <phasefx> yeap :D
15:50:59 * jeff is doing too many things instead of eating lunch
15:51:27 <phasefx> another way of thinking of it, is to put higher level views of the data directly in the database for re-use
15:51:58 * jventuro is not sure what any of that means, but is all for making more data available via the reporter, or anywhere else for that matter.
15:52:06 <phasefx> jventuro: so, cross-over potential between riggers and developers during say, hackfests, if there were some good views that could be worked on
15:54:09 <jventuro> phasefx:  I like where this is going.  So if we develop a good wish list, either at the conference or through the email list of both, we could potential see what are needs are to determine if any custom field mappers can be built?
15:54:50 <phasefx> jventuro: I'd think so; the closer stuff lives to the database, the easier it'll be to "upgrade" as the database schema evolves
15:55:04 <phasefx> a reporting view can hide a lot of the messy details
15:55:19 <phasefx> so you don't have to change your actual reporting templates as much, etc.
15:55:20 * jventuro knows this very well.
15:55:52 <phasefx> fieldmapper is only necessary if you want to easily expose these views to the existing reporter
15:56:10 <phasefx> and that's not hard to set up, either
15:56:13 * chtrotter scratches her head, trying to remember all the reports she wanted to create but could not....
15:56:53 <chtrotter> I definitely like the idea of updating the wishlist on the wiki, trying to find a way to make it a more active document.
15:57:36 * jventuro agrees with chtrotter.
15:58:26 * phasefx still wants to see a report Bob Molyneux mentioned once, of "predicting" lost items based on statistical analysis of checkouts, etc.
15:58:47 <chtrotter> Maybe during the RIG meeting at the conference y'all could collect more ideas, and then post-conference we could work on revising the wishlist page...
15:59:02 <jventuro> phasefx: That would blow my mind!
15:59:31 <phasefx> a statician's way of doing inventory :)
16:00:36 <jventuro> chtrotter: I thought of handing out the current Wish List at the conference and making changes/additions/improvements
16:00:48 <jventuro> Or should we just start from scratch?
16:00:59 <phasefx> s/statician/statistician/
16:01:30 <chtrotter> Looking at the current wishlist: http://open-ils.org/dokuwiki/doku.php?id=evergreen-reports:rig_wish_lists
16:02:46 <jventuro> Some of that still seems relevant to me, but other things on the list are not very clear.
16:03:09 <chtrotter> Exactly!
16:04:54 <chtrotter> I also see some wishlist needs that I believe are already possible in EG. I was at that conference meeting, and I think some of the wishlists items are from folks who just didn't know how to get the data they needed.
16:05:13 <jventuro> I think that's right
16:06:22 <jventuro> I was thinking before - wouldn't it be great if there was like a "Reports Craiglist" somewhere, were people could post what reports they are having trouble building, and other people can post how they might have built a similar report?
16:07:15 <jventuro> I'm not sure if I'm being clear about that, but I thought that would be neat.  Perhaps that need is already served by the reports list, though.
16:07:20 <chtrotter> Yes! And some way to be ask to be notified of updates on the reports you are interested in...
16:08:13 <chtrotter> I think we need to find something better than the list. Something that is organized...like bug tracker/helpdesk solution...
16:09:06 <jventuro> I agree.  The list is not used very much.  I wonder how much interest there would be in the community for something like that.
16:09:36 <jventuro> Might get more end users involved in the interest group as well.
16:10:23 <chtrotter> I think it would be a good project for RIG.
16:10:56 <jventuro> OK.  I'll bring it up as a possible project and see what kind of interest we get back.
16:11:22 <jventuro> I'm interested in what sort of things the community would like RIG to do.
16:12:10 <chtrotter> Sounds like y'all have plenty to discuss at the conference!
16:12:11 <pdurbin> what software are you thinking of using? for the tracking of reports people have trouble building
16:12:54 <jventuro> pdurbin: I think we'd have to explore our options.  This is the first time we've discussed this idea.
16:13:07 <pdurbin> ok
16:13:15 <pdurbin> just wondering if you had something in mind
16:13:20 <jventuro> Unless you have a suggestion?:)
16:13:22 <chtrotter> pdurbin: Any suggestions?
16:13:45 * phasefx will write a reporting system for the reporting system
16:13:56 <bshum> phasefx++
16:13:57 <chtrotter> phasefx++
16:14:04 <pdurbin> oh, i dunno. i use request tracker and redmine at work
16:14:12 <jventuro> phasefx++
16:15:41 <jventuro> pdurbin: Thanks.  We'll look into those if there's interest in the community for this idea.
16:16:22 <jventuro> Anything else before I try to summarize this for the notes?
16:16:32 <pdurbin> ok. some other software might be better, of course
16:17:45 <jventuro> pdurbin: Sure.  Might as well explore what's out there though.
16:18:06 <chtrotter> #action chtrotter will start investigating ideas for possible tracking software for reports wishlist items, just in case the community agrees this is a worthwhile project
16:18:36 <jventuro> chtrotter++
16:19:13 <jventuro> OK, so the agenda will look something like this:
16:19:38 <jventuro> #info Agenda item 1: Introductions
16:19:48 <pdurbin> just use the software phasefx is gonna write :)
16:20:03 <jventuro> #info Agenda item 2: PINES Development Project
16:21:24 <jventuro> #info Agenda item 3: Possible RIG Project
16:21:38 <jventuro> Uh...I'm not sure what to call it :/
16:22:17 <jventuro> Report tracker?
16:22:45 <chtrotter> Reports Wishlist Tracker?
16:22:55 <chtrotter> ???
16:23:36 <chtrotter> Reporting Needs Tracker
16:24:03 <jventuro> I'll just explain the idea, and we can figure out what to call it later, I guess.
16:25:11 <jventuro> Reporting Needs Tracker is as good as anything for now :)
16:25:17 <phasefx> pdurbin: I didn't have the heart to mention that the existing reporter can report on its own usage :)
16:26:00 <pdurbin> :)
16:26:09 <jventuro> #info Agenda item 4: Wish List Review
16:26:45 * phasefx wouldn't be opposed to folks using launchpad, but neither is he opposed to something more dedicated
16:27:50 <jventuro> pdurbin: Yes.  This would be different, though.  It would a way for community members to share what reports they were having trouble building, so that other members could offer help.
16:29:23 <jventuro> phasefx: We may take you up on that if this goes forward. :)
16:29:59 <pdurbin> are the reports in a central place?
16:30:17 <jventuro> So now that we're WAY over time, how does that agenda look?  Anything else to discuss before we adjourn?
16:30:43 <chtrotter> Looks good to me!
16:30:48 <JennB> same here!
16:31:25 <jventuro> pdurbin: Not for the whole community, no.  There are some canned reports out there.
16:31:44 <pdurbin> ah. that'd be the place to start, i'd think
16:33:04 <jventuro> Facilitating the sharing of reports is one of our goals.  The problem is that everybody has different needs.  We find that even among the libs in our consortium.
16:33:28 <eeevil> pdurbin: it's a thorny problem, though, with local custom reporting sources being supported
16:33:40 <eeevil> pdurbin: and where they've been added, they get used a lot
16:33:42 <pdurbin> sounds like puppet modules
16:34:16 <JennB> Iike the idea of sharing--if something is a tad of then one can clone. at least its a start
16:35:44 <jventuro> I agree.  That's where I started learning how to build reports - by cloning the canned reports.
16:36:27 <jventuro> Those haven't been updated since 1.6 though, that I know of.
16:36:39 * jventuro could be wrong.
16:37:39 * chtrotter apologizes, but must excuse herself from the meeting.
16:38:27 <jventuro> I'll go ahead and adjourn, unless there is anything more to be said?
16:38:56 <jventuro> Good discussion.  I'm sure we'll be talking more on the topic of sharing at the conference.
16:39:40 <jventuro> #endmeeting