14:03:22 <kmlussier> #startmeeting Evergreen Web Team Meeting 2013-05-09
14:03:22 <kmlussier> Did I do that wrong?
14:03:22 <pinesol_green> Meeting started Thu May  9 14:03:22 2013 US/Eastern.  The chair is kmlussier. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:03:22 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:03:22 <pinesol_green> The meeting name has been set to 'evergreen_web_team_meeting_2013_05_09'
14:03:34 <kmlussier> pinesol_green: Good morning!
14:03:35 <pinesol_green> kmlussier: Go away, or I'll replace you with a very small shell script!
14:03:49 <jeff_> pinesol_green--
14:03:58 <kmlussier> #info Agenda is available at http://evergreen-ils.org/dokuwiki/doku.php?id=webteam:meetings:agenda:2013-05-09
14:04:24 <kmlussier> #topic Introductions
14:04:34 <kmlussier> #info kmlussier is Kathy Lussier, MassLNC
14:04:54 <bshum> #info bshum is Ben Shum, Bibliomation
14:05:04 <Rogan_> #info Rogan_ is Rogan Hamby, SCLENDS
14:05:10 <StephenGWills> #info StephenGWills Balsam Consortium
14:05:10 <moodaepo> #info moodaepo is Anoop Atre, ESI
14:05:29 <paxed> #info paxed is Pasi Kallinen, Regional Library of Joensuu, Finland
14:06:03 <jimcraner> #info jimcraner is Jim Craner, Galecia Group
14:06:06 <LBA> #info Lori Ayre, The Galecia Group
14:06:35 <hbrennan> #info Holly Brennan, Homer Public Library AK
14:07:07 <kmlussier> People can keep introducing themselves as we move through the agenda, but let's move on to the next topic.
14:07:23 <kmlussier> #topic Status of conversion of static web pages to WordPress
14:08:05 <kmlussier> During the Vancouver conference, we agreed to move the static pages of the web site to Wordpress to make it easier for people in the community to contribute.
14:08:14 <kmlussier> Who wants to provide an update on that?
14:08:21 <bshum> Well, I started this with copying all of the existing static pages to wordpress, and that is done, except for the downloads pages.
14:08:52 <bshum> For a brief time, I toyed with some themes before gmcharlt kindly reminded me that playing with the existing blog site while we were using it to announce security releases, etc. was a bad idea.
14:09:13 <bshum> Last I know, moodaepo was working on dumping a copy of the wordpress to spin up a test site or such?
14:10:22 <moodaepo> bshum: Yea I started on a local system but it's still in the works, was looking at skins to test a few paid ones out.
14:11:07 <bshum> Related topic, some of us have been working on how to transition the existing site infrastructure around so that it'll be easier to manage various pieces.
14:11:42 <bshum> Specifically, there was an idea to change the name for the wiki to use something like wiki.evergreen-ils.org/... instead of the current evergreen-ils.org/dokuwiki/...
14:11:55 <bshum> Hopefully in an effort to manage the various pieces more efficiently.
14:12:22 <Rogan_> I think I said I was personally in favor of that both for management and to make it clear that the wiki is a different kind of content.
14:12:31 <kmlussier> It sounds reasonable to me. Are there any downsides to using wiki.evergreen-ils.org?
14:13:38 <jimcraner> unified search?
14:13:43 <moodaepo> kmlussier: I don't see any.
14:13:47 <bshum> I think the only downside I had thought up at the time was dealing with legacy links from other sites or internally.
14:13:48 <dbs> Get redirects in place for all of the old bookmarks, links, etc
14:13:49 <jimcraner> are you still doing search via a Google widget?
14:13:55 <bshum> But yeah, redirects
14:14:03 <moodaepo> jimcraner: We can tell google search to search multiple sub-domains
14:14:10 <jimcraner> moodaepo, sweet!
14:15:12 <kmlussier> But redirects are something that can be managed somehow, right?
14:16:06 <Rogan_> some redirects are likely to go wonky but we can do a report of bad links with a search crawl and fix those
14:16:36 <Rogan_> manual labor to fix them
14:17:47 <kmlussier> bshum: Is this an idea you're just toying with now or is it a move you're recommending that we make?
14:17:51 <StephenGWills> Why can't apache rewrite work?
14:17:58 <jimcraner> can you do a search and replace in the underlying db?
14:18:12 <jimcraner> for manually created links?
14:19:04 <Rogan_> a lot of the time we can do search and replace kinds of fixes, if something is broken in a non-regular way we may have to look at it individually
14:19:10 <bshum> kmlussier: It's a recommended change that's in progress.  I'm just not sure if we should do it before or after or during.  (still figuring out the plan of attack)
14:19:35 <kmlussier> OK thanks!
14:20:09 <bshum> I was just thinking we ought to start a planning page or such to indicate what steps need to occur and when for a timeline of activity.
14:20:40 <kmlussier> bshum: Do you want to take that as an action item?
14:20:58 <bshum> Sure, I can start a page and start putting some ideas to it.
14:23:22 <kmlussier1> Sorry! Wireless went out for a second.
14:23:50 <StephenGWills> we waited :)
14:24:05 <StephenGWills> so that is a url migration plan page?
14:25:32 <kmlussier> #action bshum to start planning of transition to wiki.evergreen-ils.org
14:26:10 <kmlussier> #action moodaepo to continue working on test site
14:26:11 <kmlussier> Do we have anything else for that topic?
14:27:06 <kmlussier> #topic Recommendations from the 2011 Web Site plan that we should be incorporating into the Evergreen web presence
14:27:45 <StephenGWills> I saw a few things that, going forward, we want to keep in play.  User profiles, for instance
14:27:50 <kmlussier> During the Vancouver meeting, we also talked about the idea that, instead of doing a broad sweeping change of the web site, we might want to introduce some of the things from the web site plan incrementally.
14:29:21 <StephenGWills> so a couple of cool features were demoed in Jim's drupal site and/or the RSCEL site that we should not lose site of, imho
14:29:52 <kmlussier> StephenGWills: So when you say user profiles, are you thinking of it being a way to see who the people are in the Evergreen community?
14:30:18 <StephenGWills> That is how it is described in the Site Plan, yes.
14:31:31 <kmlussier> The two things that jumped out at me was a better way to manage a directory of Evergreen libraries since I think it's been difficult to keep up to date - http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen_libraries. And the idea that's been tossed around for years to have a place to share development ideas.
14:31:34 <LBA> The application is called EG Initiatives on the rscel.org site.  http://rscel.org/evergreen/about/projects
14:32:03 <LBA> The former application to which you refer that is.  :)
14:32:42 <kmlussier> LBA: Sure, so that was what I was thinking of as a better way to manage a directory of Evergreen libraries. I guess I wasn't thinking of it in terms of users.
14:33:42 <LBA> It was set up that way to facilitate communication between people and organizations.  Not really as a means to populate a map with individual locations.
14:33:57 <jimcraner> (The community_member::Evergreen_library relationship is always one of the stickiest parts of this problem :-)
14:34:38 <LBA> We could add latitude and longitude info easy enough though.  But it would just be for "HQ" not individual library systems (in consortia) nor branches (in a library system).
14:35:29 <Rogan_> I think a HQ of a system in a consortia is still appropriate to show scale.
14:35:36 <kmlussier> To be honest, I think the map adds an additional complication to maintaining things. At this point, I would be happy with an up to date list of Evergreen libraries with contact people.
14:35:56 <jimcraner> A map is a way to visualize data geographically
14:36:11 <bshum> Incrementally speaking, I think it helps if we focus on finding volunteers to work on various idea projects like these.
14:36:12 <LBA> One question for this group is how to incorporate a Drupal application into your existing Wordpress/Wiki environment....
14:36:16 <jimcraner> as long as visitors can sort/search for EG libraries in their nation, state/province, I think it's OK
14:36:20 <Rogan_> I do like the map because although it's more work I think the visual has more impact.
14:36:24 <bshum> Rather than getting too far with "it'd be cool if..." statements.
14:36:52 <Rogan_> bshum++ - just saying I hope some volunteers would want to do that :)
14:36:54 <kmlussier> I don't know that it has to be drupal, either, There may be other ways to maintain these things.
14:36:55 <kmlussier> But I'll let bshum finish.
14:37:07 <hbrennan> As an individual who tried to add my library to that map earlier this week.... I never did it. It was not straightforward, if there was even a way
14:37:08 <jimcraner> Telling the story of EG's global penetration with a map is a good idea Rogan_  -- but it can be done with an annually-updated "stick pushpins on a graphic of a map" visual much easier than an integrated webmap
14:37:30 <Rogan_> True.
14:38:13 <jimcraner> Or when there's a new consortium in Fakelandia using EG, somebody updates the "EG Around the World" graphic by just sticking a little EG logo on Fakelandia.
14:38:14 <kmlussier> So we have two ideas on the table. I think bshum's right, though. Do we have any volunteers willing to move forward on working on these specific projects?
14:38:22 <hbrennan> I do like the map because maps are fun to look at, especially with pushpins..
14:38:43 <kmlussier> It would be nice if we could first explore tools with our existing infrstructure to see if there is a way we can support what we currently need.
14:38:47 <hbrennan> but it needs to be easy to add
14:38:54 <jimcraner> (As a huge geonerd I can't believe I just argued against creating a cool interactive web map :-)
14:39:43 <StephenGWills> Apropos interactive EG map: Let's write a plugin that displays a bit of fluff with the word "YOP" popping out of it if enough libraries shout "we are here"?
14:40:33 <kmlussier> StephenGWills: Are you volunteering to work on the map? :)
14:40:39 <StephenGWills> yes
14:40:43 <LBA> I gotta run folks but Jim and I are willing to keep the various sites up until you decide what you want to do.  We won't be leading the charge on any new stuff but we're happy to maintain and/or help with migration of things....
14:40:56 <kmlussier> LBA++ Thanks!
14:41:43 <bshum> LBA++
14:41:49 <paxed> i wouldn't mind doing some minor improvements to the irc logs pages.
14:42:19 <bshum> paxed: Oh, good reminder...
14:42:34 <bshum> So yeah, the IRC logs are static pages that won't have a home if we move to Wordpress.
14:42:35 <kmlussier> StephenGWills: I just realized you actually first raised the idea of user profiles. Will that be part of your work on the maps or should it be a separate action item for another volunteer?
14:42:57 <bshum> I was considering moving that from what we have now to consider using a logging approach more like what Koha channel does with ilbot
14:43:12 <bshum> And then figuring out how to convert and jam all the past logs into the database used by ilbot.
14:43:13 * paxed hasn't done anything with wordpress, so wouldn't know how to integrate to that.
14:43:20 <paxed> and i don't know what koha does.
14:43:35 <bshum> But I got lost looking at the syntax of our log files vs. what we would need to get in order to insert them into the database side of things.
14:43:46 <StephenGWills> Actually I can see these items dovetailing since map data is a small portion of the member metadata
14:44:36 <jimcraner> StephenGWills++
14:44:38 <StephenGWills> so lets consider them steps in a project?  member definition, implementation, member info display, map meta data, map display?
14:46:15 <kmlussier> #action StephenGWills to work on member directory/map for web site.
14:46:18 <kmlussier> StephenGWills++
14:46:52 <bshum> paxed: Let's chat more after the meeting or whenever.  I'd be curious to know what sort of improvements you'd like to see.
14:47:11 <kmlussier> I think we can keep revisiting some of these ideas in future meetings, but I'm going to move on to the next topic unless there's any other discussion.
14:47:31 <StephenGWills> second the forward movement
14:47:59 <Rogan_> move forward +1
14:48:10 <kmlussier> Oh, and bshum, my last comment didn't get posted when I lost my internet. But I don't think it's a big deal if the IRC logs don't move to wordpress. But moving along...
14:48:28 <kmlussier> #topic The downloads page
14:48:34 <kmlussier> That's you again bshum?
14:49:22 <bshum> I suppose.  So basically, the thing that we'll need to do with Wordpress is highlight and show all the various things that you can download.
14:49:35 <bshum> While we can re-create what we have now, I wasn't sure if we wanted to explore alternatives.
14:49:44 <bshum> If only because the table structure always confused me, personally.
14:49:48 <bshum> I'm not sure how others felt.
14:49:51 <kmlussier> For reference, what we have now is: http://evergreen-ils.org/downloads.php
14:50:52 <hbrennan> Half our staff downloaded the wrong thing when we started
14:51:11 <bshum> Yeah that's a common confusion :(
14:51:20 <Rogan_> I don't love the current one.  I've downloaded the wrong thing my mistake and I know better.
14:51:29 <kmlussier> When you see numerically by version, are you saying 2.2 would be the furthest on the left? I think I prefer that the newest stable release is on the left if we go left-to-right.
14:51:38 <kmlussier> But maybe left-to-right isn't the best way.
14:51:58 <bshum> Well it's also hard to update with newest stable on the left.
14:52:12 <hbrennan> The bigger problem I see is having to go to the bottom of a column to download the client
14:52:17 <kmlussier> Or maybe we could use color coding as a visual cue. Something like green for the newest stable.
14:52:18 <bshum> Pretty much every time we've done it (for the last three or so releases) we end up copy/pasting columns around and it gets messy.
14:52:26 <hbrennan> Yes I like color coding!
14:52:48 <paxed> bshum: eek...
14:52:52 <StephenGWills> I can see putting the client link right up at the top
14:52:57 <bshum> I just figure we ought to explore new ideas about how to manage and show the downloads
14:53:06 <Rogan_> I like the color coding idea.  I'm not sure it matters if we go left right right left.  No swirls of course.
14:53:12 <StephenGWills> maybe a note to help non-techies understand that they WANT the client, not the server?
14:53:15 <paxed> or perhaps have a "current stable" as a separate table before the others
14:53:19 <jimcraner> I've always liked Drupal's color-coding: http://drupal.org/project/drupal#downloads
14:53:41 <hbrennan> If the word staff was added, that would probably make a world of difference
14:53:50 <hbrennan> "Download Staff Client"
14:54:04 <StephenGWills> nod.
14:54:18 <Rogan_> I would put the staff client at the very top thought.
14:54:23 <Rogan_> though.  I can't type today.
14:54:23 <hbrennan> There are many things in Evergreen that are called three or four different names depending on where you look
14:55:31 <hbrennan> Of course this is due to the ever-changing world of Evergreen, understandable, but it is something to keep in mind
14:56:07 <hbrennan> The label changes within Permissions and Library Settings can be quite funny.. but frustrating as well
14:56:43 <StephenGWills> I am seeing several different issues being discussed in this thread:  end user use of the page, admin/editor maintenance issues with the page and general esthetic design of the page.  all different topics.
14:57:45 <bshum> I might suggest that we find a volunteer to help coordinate those issues then.  Because all of them should be addressed as we work on creating the nextgen of that page in Wordpress.
14:58:19 <jimcraner> StephenGWills++
14:58:21 <kmlussier1> Do we have any volunteers for that?
14:58:48 <hbrennan> I'm not comfortable coordinating anything yet, but I can be a source for the newbie library issues we faced during migration and set up this year
14:59:01 <StephenGWills> I will volunteer to make the volunteers needed for … page :)
14:59:13 <kmlussier1> hbrennan: How about if we work together on that?
14:59:19 <hbrennan> Sure
15:00:22 <kmlussier> #action hbrennan to work on layout/design issues for downloads page.
15:00:26 <hbrennan> Woops, I need to cover the circ desk so my participation in this mtg will now be spotty
15:00:28 <kmlussier> #action kmlussier to work on layout/design issues for downloads page.
15:00:47 <kmlussier> Probably no spottier than mine has been with my spotty connection. Thanks hbrennan!
15:02:21 <StephenGWills> I have another meeting as well.  Please don't volunteer me for a lot of stuff in my absence?
15:02:43 <kmlussier1> Should we keep plugging through the agenda or should we table it for another meeting?
15:02:53 <kmlussier1> Actually, I do want to talk about conference web site today.
15:03:04 <StephenGWills> since we are doing this in IRC is there any chance we can do it again sooner than a month?  say a couple of weeks from now?
15:03:45 <StephenGWills> I would move to table agenda for another meeting so that I can attend but I can do it ad-hoc via IRC logs as well.  no worries
15:03:55 <StephenGWills> sorry. bye
15:04:26 <kmlussier1> OK - let' table most agenda items, but I'm going to do one last one so that I can move on the conference web site.
15:04:38 <kmlussier1> #topic 2014 Conference web site
15:04:49 <kmlussier1> #chair bshum
15:05:03 <bshum> It doesn't recognize you because you're not kmlussier :)
15:05:16 <bshum> Silly bot
15:05:23 <bshum> Bad_internet--
15:05:38 <kmlussier> #chair bshum
15:05:38 <pinesol_green> Current chairs: bshum kmlussier
15:05:49 <bshum> #topic 2014 Conference Web Site
15:05:52 <bshum> Carry on
15:05:53 <kmlussier> bshum++
15:06:18 <kmlussier> Traditionally, the conference web site has be done on a server belonging to the conference host.
15:06:35 <kmlussier> I'm just wondering if there's any reason why the Evergreen site can't also host the conference site.
15:07:06 <kmlussier> I'm making decisions now regarding where to host the conference site and wanted to explore it as an option.
15:08:08 <jimcraner> Is the conference site usually just an "info only" page or two?  Or are you hoping to have functionality as well?  (dynamic scheduling, online reg, etc.?)
15:08:16 <kmlussier> Is there any objections to doing that? Or reasons why it wasn't done in the past that I'm unaware of?
15:08:30 <Rogan_> So long as the people who need to do quick updates can do so I don't see why not, unless you want something big and new the community site can't do.
15:08:32 <kmlussier> jimcraner: No, we use a third party service for registrations.
15:08:48 <jimcraner> gotcha
15:09:22 <kmlussier> Rogan_: I'm not looking to do anything different from what other conference sites have done. announcements, schedules, links to the conference hotel, etc.
15:09:40 <Rogan_> I didn't think so.
15:10:56 <bshum> kmlussier: I'm +1 to hosting 2014 with the community, though I think it would help to plot out how to handle future site hosting as well.  (i.e. do we preserve for posterity?)
15:11:01 * moodaepo agrees with Rogan_
15:11:15 <bshum> Also, I think we need to follow up with csharp and PINES folks to find out what our server resources are like now.
15:11:21 <rfrasur> bshum++
15:11:34 <bshum> As is, I know we keep having issues with space/memory/whatever use
15:11:48 <bshum> And our list of things to do seems to be growing, not shrinking.
15:11:56 <kmlussier1> OK - I'll follow up with csharp then.
15:12:51 <bshum> fwiw, I asked csharp before the meeting about the community server that was mentioned during the last conference and he said things are still in motion for that.
15:13:01 <bshum> So we might have some options soon.
15:13:23 <kmlussier1> And, just to follow up on bshum's question that I missed because I dropped out (again), the keeping content for posterity was one of the things I liked about moving it to the community. A local org may decide to re-allocate space at a couple years down the road.
15:14:13 <kmlussier1> Does anyone feel that any of the other un-discussed agenda items need to be discussed today?
15:14:19 <rfrasur> was just in meeting presenting "what we learned" about Egcon2013...and referenced this year's conference website.
15:14:36 <bshum> I was going to add the rest of the topics to the meetbot as "deferred to next time"
15:14:46 <bshum> Though maybe we should take the twitter hashtag discussion to twitter :D
15:14:46 <kmlussier1> And what do people think about meeting more frequently than once a month. Personally, I'm a little stretched for time, but I'll go with the rest of the group.
15:15:02 <kmlussier1> I'm willing to give up the twitter hashtag discussion.
15:15:21 * kmlussier1 shouldn't add topics to agendas when I'm annoyed.
15:16:24 <moodaepo> kmlussier1: How about every 6 weeks?
15:17:47 <bshum> #info Follow-up with our kind hosts to find out whether we need more server resources to handle conference website content long-term
15:17:53 <bshum> #topic Next meeting?
15:18:09 <bshum> Maybe we should discuss it on the lists how to proceed with meetings
15:18:18 <bshum> Though my vote is once a month is fine for now for general meetings.
15:18:30 <bshum> Though we may proceed more rapidly with actions once we establish our working timeline.
15:18:44 <bshum> And meet accordingly.
15:18:50 <kmlussier1> A month or 6 weeks is fine with me.
15:18:50 <kmlussier1> bshum: Can you end the meeting for me. I've given up on trying to reclaim my rightful name.
15:18:50 <kmlussier1> Sure, I'll take that as an action item.
15:19:05 <kmlussier1> There's no reason why we can't have discussion in between meetings in IRC and the lists as well.
15:19:17 <bshum> #action kmlussier to start discussion about when to meet / how to meet / why to meet / and where to meet.
15:19:44 <moodaepo> kmlussier1++
15:20:16 <bshum> That's it for now then.  Thanks everybody for participating and helping out with the web team's discussions.
15:20:43 <bshum> #endmeeting