#evergreen: Developer Meeting 2013-06-12

Meeting started by bshum at 14:13:44 US/Eastern (full logs).

Meeting summary

  1. Introductions (bshum, 14:13:52)
    1. bshum = Ben Shum, Bibliomation (bshum, 14:14:07)
    2. phasefx = Jason Etheridge, Equinox (phasefx, 14:14:35)
    3. jeff = Jeff Godin, TADL (jeff_, 14:14:37)
    4. dbwells = Dan Wells, Hekman Library (Calvin College) (dbwells, 14:14:55)
    5. remingtron = Remington Steed, Hekman Library (Calvin College) (remingtron, 14:14:55)
    6. eeevil = Mike Rylander, ESI (eeevil, 14:15:04)
    7. senator = Lebbeous Fogle-Weekley, ESI (senator, 14:15:16)

  2. Action items from the last meeting (bshum, 14:16:51)
    1. 1. gmcharlt will put out another call for 2.5 road map items and start a 2.6 road map (bshum, 14:17:17)
    2. kmlussier = Kathy Lussier, MassLNC (kmlussier, 14:17:33)
    3. csharp = Chris Sharp, GPLS (csharp, 14:17:50)
    4. tsbere = Thomas Berezansky, MVLC (tsbere, 14:17:58)
    5. gmcharlt = Galen Charlton, ESI (gmcharlt, 14:18:09)
    6. DPearl = Dan Pearl, C/W MARS (DPearl, 14:18:51)
    7. ACTION: Start on the 2.6 development road map page (bshum, 14:18:59)
    8. 2. bshum to email lists about bug tracking changes (bshum, 14:19:10)
    9. paxed = Pasi Kallinen, Regional Library of Joensuu (paxed, 14:19:26)
    10. ACTION: bshum to summarize bug tracking based on feedback from developers (bshum, 14:19:31)

  3. GSOC reports (bshum, 14:20:03)
    1. laque (Dmitry Nechai) was accepted as the student for this year's GSOC. He'll be working on a library dashboard with stats, etc. (bshum, 14:20:39)
    2. Dyrcona and bshum are primary mentors and will be involved in mentoring the student as the summer progresses. (bshum, 14:21:26)

  4. OpenSRF release (bshum, 14:22:38)
  5. Evergreen releases (bshum, 14:24:04)
    1. dbs = Dan Scott, Laurentian University (dbs, 14:24:16)
    2. Wrapup email on 2.5-m1 - http://markmail.org/message/u6fgf2zqicuaskra (bshum, 14:25:08)
    3. 7/1 - suggested last day for targetting bugs/features at 2.5-m2 (bshum, 14:43:15)
    4. 7/2-7/12 - Suggested period to focus energy on reviewing/committing m2 (bshum, 14:43:27)
    5. dbwells working on whitespace cleanup; will do more tests and find others (bshum, 14:44:02)
    6. Maintenance releases are scheduled for June 19 (bshum, 14:47:32)
    7. Link to 2.3.8 targeted bugs: https://launchpad.net/evergreen/+milestone/2.3.8 (bshum, 14:48:56)
    8. Link to 2.2.10 targeted bugs: https://launchpad.net/evergreen/+milestone/2.2.10 (bshum, 14:49:10)
    9. Link to 2.4.1 targeted bugs: https://launchpad.net/evergreen/+milestone/2.4.1 (bshum, 14:50:10)

  6. Bug squashing (bshum, 14:53:18)
    1. ACTION: kmlussier to raise bug squashing day to the lists for further discussion/feedback (bshum, 15:06:26)


Meeting ended at 15:13:42 US/Eastern (full logs).

Action items

  1. Start on the 2.6 development road map page
  2. bshum to summarize bug tracking based on feedback from developers
  3. kmlussier to raise bug squashing day to the lists for further discussion/feedback


Action items, by person

  1. bshum
    1. bshum to summarize bug tracking based on feedback from developers
  2. kmlussier
    1. kmlussier to raise bug squashing day to the lists for further discussion/feedback


People present (lines said)

  1. bshum (76)
  2. dbwells (19)
  3. eeevil (18)
  4. kmlussier (13)
  5. rfrasur (10)
  6. gmcharlt (8)
  7. mrpeters (6)
  8. csharp (6)
  9. pinesol_green (5)
  10. senator (4)
  11. phasefx (3)
  12. paxed (3)
  13. dbs (3)
  14. kayals (2)
  15. DPearl (1)
  16. berick (1)
  17. jeff_ (1)
  18. remingtron (1)
  19. tsbere (1)


Generated by MeetBot 0.1.4.