14:00:52 <gmcharlt> #startmeeting Evergreen Oversight Board meeting, 20 June 2013
14:00:52 <pinesol_green> Meeting started Thu Jun 20 14:00:52 2013 US/Eastern.  The chair is gmcharlt. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:52 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:52 <pinesol_green> The meeting name has been set to 'evergreen_oversight_board_meeting__20_june_2013'
14:00:57 <StephenGWills> Early Onset Befuddlement?
14:01:01 <gmcharlt> #info Agenda can be found at http://evergreen-ils.org/dokuwiki/doku.php?id=governance:minutes:2013-6-20
14:01:10 <rfrasur> StephenGWills++
14:01:22 <gmcharlt> #topic Board member role-call; please use #info to identify yourselves
14:01:27 <StephenGWills> ls
14:01:34 <gmcharlt> #info gmcharlt = Galen Charlton, ESI
14:01:42 <kmlussier> #info kmlussier is Kathy Lussier, MassLNC
14:01:44 <Rogan> #info Rogan = Rogan Hamby, SCLENDS
14:01:52 <dbwells> #info dbwells = Dan Wells, Hekman Library (Calvin College)
14:01:58 <sborger> #info sborger = Shauna Borger, Indiana State Library
14:02:02 <yboston> #info yboston is Yamil Suarez - Berklee College of Music
14:02:07 <abneiman> #info abneiman is Andrea Buntz Neiman, Kent County Public Library
14:02:12 <StephenGWills> #info StephenGWills - Maine Balsam Consortium
14:02:16 <montgoc1> #info montgoc1 = Chauncey Montgomery, Consortium of Ohio Libraries
14:02:41 <rfrasur> #info rfrasur Ruth Frasur, Evergreen Indiana (Hagerstown Library)
14:04:20 <gmcharlt> thanks; we have a quorum of EOB members; also, since Dan Wells is here, I'll add an agenda item for him to give a Release Manager update
14:04:33 <gmcharlt> moving on
14:04:35 <gmcharlt> #topic Financial report
14:04:41 <gmcharlt> #info Galen has a pending request to update SSH keys to get access to it; will submit to mailing list when ready
14:05:18 <gmcharlt> not much to say until I send the details, other than that it's my understanding that all pending financial matters from the 2013 conference are closed
14:05:58 <gmcharlt> #topic Evergreen 2014 Conference Committee Report
14:06:13 <gmcharlt> kmlussier: anything to report?
14:06:55 <kmlussier> #info we are finalizing our sponsorship categories and will be sending a sponsorship package to the SFC soon for approval. Hopefully, we'll have something in time for ALA so that we can start talking to potential sponsors there.
14:07:39 <kmlussier> #info The programming committee has been considering alternate schedules for this year's conference and will be sending them out to get feedback from the greater community sometime soon.
14:07:49 <elfsts> Elfstrand joining sorry I'm late
14:07:59 <kmlussier> #info Still waiting on the final contract.
14:08:08 <kmlussier> That's all I have for now.
14:08:20 <gmcharlt> kmlussier++ # thanks
14:08:23 <gmcharlt> any questions?
14:08:50 <montgoc1> Curious about alternate schedules?
14:09:05 <abneiman> Also curious about this.
14:09:06 <montgoc1> Is that just how the sessions are laid out?
14:09:24 <kmlussier> montgoc1: Sure, we've been looking at different ways to handle the hackfest days and the final day.
14:09:58 <kmlussier> And we've also been thinking about the possibility of building longer tutorials into the schedule.
14:10:17 <montgoc1> Nice.
14:10:22 <Rogan> We're looking at doing a regional Evergreen conference and have had very similar thoughts.
14:10:26 <kmlussier> As an example, one of the potential schedules would have tutorials happening at the same time as the hackfest, and the interest group meetings happening alongside other programming.
14:10:52 <kmlussier> And there's been interest in having a full-day doc hackfest at the same time as the developer hackfest.
14:11:48 <kmlussier> Here are some of the sample schedules I pulled together, but it still a work in progress. https://docs.google.com/spreadsheet/ccc?key=0Ar4gDMUDwDXqdHBOZExuVVVBdUZEQ2Nob2VPLWVQU1E#gid=0
14:12:49 <gmcharlt> kmlussier: thanks
14:12:53 <gmcharlt> moving on
14:12:55 <gmcharlt> #topic Potential policy for adding support companies to Evergreen website
14:12:57 <abneiman> Thanks Kathy!  I really like the idea of having tutorials on hackfest day.
14:13:04 <gmcharlt> #info Discussion points are at http://list.evergreen-ils.org/pipermail/eg-oversight-board/2013-June/000502.html
14:13:11 <gmcharlt> #info Koha's policy is at http://koha-community.org/support/paid-support/how-to-get-listed/
14:13:34 <Rogan> Kathy, are you imagining something pretty close to the Koha one?
14:14:11 <Polo> I need to wipe my usr table, I actually need to wipe alot of things but I want to keep my bib records. We have about 80k records of patrons that were entered in incorrectly.
14:14:20 <kmlussier> Rogan: I think it makes a good starting point, but we might want to adapt some  things.
14:14:51 <kmlussier> Rogan: What are your thoughts on the Koha policy? Anything you like or don't like about it?
14:15:06 <Rogan> Pros: Very general, very simple, very non-judgemental.
14:15:37 <Rogan> Cons: Not much in the way of definition so value is there but some might see it as pretty limited.
14:15:57 <kmlussier> Rogan: Yes, I think it's important that it be non-judgemental. My concern is that we define what Evergreen services are. I just think there may be some vendors on our list that really don't provide Evergreen services.
14:16:14 <yboston> Polo:  right now we are having a meeting of the Evergreen board on this IRC channel. Do you mind asking your question in about an hour?
14:16:16 <kmlussier> But it's hard to take them off the web site when we don't have any guidelines or policy in place.
14:16:27 <emckinney> We will need a very specific definition of services.
14:17:02 <montgoc1> I agree that services need defined well.
14:17:16 <kmlussier> In some cases, the vendors don't even mention Evergreen on their web sites.
14:17:27 <Rogan> And services could be pretty broad.  Is writing an RFP an evergreen service when you help to write sole source letters because you have Evergreen experience?  Some would say yes and some no.
14:17:31 <elfsts> in the form why not have a list of services? Hosting, Training, Development, Migration, List of Evergreen Customers and links to their Evergreen Sites
14:18:05 <emckinney> What about all those peripheral device add-ons...3m and such
14:18:06 <yboston> We could start simple with our definition of services, while publicly reserving the right to make it more specific in the future.
14:18:30 <kmlussier> emckinney: I don't think peripheral devices belong there. That's not an Evergreen service. That's something that works with Evergreen.
14:18:33 <Rogan> I don't object to a list of defined services in principle but I am concerned about it being inclusive enough without being so vague as to go off the rails.
14:19:22 <Rogan> kmlussier: but what if a peripheral needs special setup with evergreen, like sorters
14:19:39 <Rogan> there is specialized knowledge and implementation experience with Evergreen
14:19:43 <StephenGWills> So, if we are not endorsing anyone, why put much work into helping them define their businesses?  Why not just provide a virtual cork board and let people pin their business card to it?  Word of mouth will do the rest won't it?
14:19:46 <emckinney> PINES asks 3rd party vendors to develop their own links to Evergreen.  3m and a few others have developed the crosswalks for our libraries.  I'm not insisting...just informing.
14:20:07 * gmcharlt notes that the Koha paid-support list does *not* list services; it just lists contact information
14:20:48 <emckinney> and the virtual corkboard becomes useless when you have to wade through those who do/do not provide actual services.
14:22:00 <rfrasur> Maybe a moderated cork board?
14:22:09 <montgoc1> If there were some broad service categories, that could perhaps help potential clients narrow the list down to those companies that best meet their needs.
14:22:12 <kmlussier> My thought is if everyone (or most of us) think it's a good idea to have some guidelines, then maybe a small group of us can work on it. It might also be good to get feedback from the vendor community.
14:22:32 <emckinney> How did we define who becomes a member of the Evergreen community?  Perhaps we could use something from that to be consistent. Looking now for the Oversight Board Rules of Governance.
14:22:58 <yboston> emckinney++
14:23:53 <Rogan> I'm ok with some guidelines but as is often the case the devil is in the details.  I worry about them being too narrow.
14:24:19 <kmlussier> Rogan: That's why I liked the Koha guidelines. It's very broad.
14:24:37 <Rogan> And when we start defining members of the community ... it's a sticky wicket.
14:24:45 <kmlussier> gmcharlt: Any idea on how well these guidelines work (or don't work) for Koha?
14:24:48 <StephenGWills> the nice thing about a virtual cork board is that it can support tagging which allows one to search the contacts by those keywords, maybe?
14:25:28 <Rogan> I like the Koha guidelines.
14:25:32 <kmlussier> We have such a small list of vendors. Tagging might be more useful once the community grows.
14:25:34 <gmcharlt> kmlussier: there is some history that has influenced the policy, which I won't go into here, but suffice it to say I think the Koha community finds real value in the requirement that listers link back to the website
14:25:37 <Rogan> Very broad, allow self identification.
14:26:07 <montgoc1> StephenGWills: I think that would work.
14:26:20 <Rogan> I don't mind some services guidelines but I'd still want some chance for the entity to define their own services.  200 word limit?  - not a specific request, just brainstorming
14:28:04 <kmlussier> A self-description certainly might be more useful to the user consulting this list.
14:28:05 <abneiman> I'm definitely in favor of the link-back to the project.
14:28:17 <gmcharlt> OK, is it fair to say that there's a general consensus that some sort of policy should be considered?  and if so, that there are folks willing to hash it out (e.g., on the EOB and other community mailing lists)?
14:28:36 <Rogan> I think this should be on the community mailing list ++
14:28:50 <kmlussier> +1
14:28:53 <emckinney> The verbiage from Rules of Gov was taken out.  I propose we go with something along the lines of "This list is intended to assist members of the community to find Evergreen service providers..."
14:29:28 <emckinney> +1 on that...send it to the community mailing list.
14:29:29 <kmlussier> gmcharlt: I volunteer.
14:29:44 <Rogan> I second Kathy volunteering.  :)
14:29:52 <emckinney> But will the webmasters really review? Should it be community policed?
14:30:07 <gmcharlt> kmlussier: sounds good.  Are you OK with an action item for you to report back at the next EOB meeting?
14:30:13 <kmlussier> Yup
14:30:15 <Rogan> We've talked about how we need more eyes on the web site, it could be a special group of volunteers, one or two.
14:30:34 <kmlussier> Anyone else want to hash this out with me?
14:30:47 <Rogan> I'll chat with you about it but I think the discussion should be open.
14:30:59 <gmcharlt> emckinney: since requests must be made to the Koha mailing list, that's were community review takes place; the Koha webmaster essentially just serves a secretarial role
14:31:02 <Rogan> I'll promise to help prompt people once you get the ball going and share my opinion.
14:31:18 <rfrasur> I'd be glad to help with the understanding that my know how is very limited.
14:31:20 <kmlussier> Rogan: Works for me.
14:31:57 <StephenGWills> Kathy, happy to chat as well.
14:32:22 <gmcharlt> #action kmlussier to kick off broader discussion of the support company listing policy and report back to the EOB at the July meeting
14:32:41 <emckinney> Kathy, one favor request.  Could you let us know when you post this to community?
14:33:04 <kmlussier> Sure. It probably won't happen until after ALA and my subsequent vacation.
14:33:27 <gmcharlt> kmlussier: would you prefer to report back during the August meeting, then?
14:34:06 <kmlussier> No, that gives a couple of weeks for discussion. I should have something to report.
14:34:20 <gmcharlt> OK
14:34:29 <gmcharlt> moving on
14:34:31 <gmcharlt> #topic Announcement: Conference call for discussing organizing testing efforts
14:35:00 <gmcharlt> sborger: you have the floor
14:35:15 <sborger> Rogan, Andrea and I are planning a conference call on July 2 to further discuss organizing test efforts.
14:35:41 <sborger> I figured that I had some very basic questions about where to get started and how to get my local staff involved so others probably do as well.
14:35:58 <sborger> We will come up with a plan and share it at the next board meeting.
14:36:24 <gmcharlt> #info Shauna, Rogan, and Andrea are planning a conference call on July 2 to further discuss organizing test efforts.
14:36:29 <gmcharlt> any questions for sborger?
14:36:37 <sborger> Let me know if you are interested in joining the conference call right away and keep in mind that we will most likely look for volunteers in the future as well.
14:37:35 <Rogan> And the goal is to expand involvement so some of it may seem simple but anything that furthers the community through engagement and the work is worthy I think.
14:38:18 <montgoc1> What time on July 2?
14:38:28 <rfrasur> I PMed this to Shauna, but then thought it should be asked in open.  Will the conference call be using actual phones or an online interface?
14:38:31 <Rogan> 2 PM EST
14:39:11 <gmcharlt> #info Please contact Shauna if you're interested in joining the conference call
14:40:31 <gmcharlt> ok, thanks sborger!
14:40:36 <gmcharlt> #topic Release manager update
14:40:42 <gmcharlt> dbwells: you have the floor
14:40:56 <dbwells> Thanks.  Nothing especially new to report, but I can recap what has happened so far.
14:41:09 <dbwells> #info We had to extend the deadline by a few days, but we did meet our goal of cutting open pull-requests for 2.5 in half (from 63 to 31) for the first 'm1' milestone.
14:41:29 <dbwells> #info Late last week we did the planned whitespace clean-up.  Rather than follow my original plan of doing it in phases, we did it all at once.  So far it appears to have gone without issue, but we should now consider doing the same for older branches to potentially relieve backport pain.
14:41:51 <dbwells> #info The next commit push ('m2') is planned for 7/2-7/12.  So far it is looking like the to-do pile will be smaller than for m1 (which is what we would hope for).  One thing I am learning is that it is generally tough to find good rally points during the summer, but several people did comment that having these deadlines was helpful, so I am hopeful we can keep things moving.
14:42:03 <dbwells> That is all.
14:42:09 <gmcharlt> dbwells++
14:42:13 <gmcharlt> any questions for hinm?
14:42:37 <Rogan> More of a comment: great job.
14:42:50 <kmlussier> Just a general comment. I've been very pleased with teh amount of communication with this release. Thanks Dan!
14:42:53 <kmlussier> dbwells++
14:42:57 <yboston> I just wanted to say thanks for trying out a new approach, not that the older approaches were bad
14:43:43 <dbwells> Thanks, all.  So far so good, but the only real test will be the actual release :)
14:43:53 <gmcharlt> thanks, again
14:43:54 <gmcharlt> moving on
14:43:56 <gmcharlt> #topic Grants and fundraising
14:44:02 <gmcharlt> #info Discussion points are at http://list.evergreen-ils.org/pipermail/eg-oversight-board/2013-June/000501.html
14:44:45 <Rogan> Any comments or questions on the discussion points?
14:45:03 <Rogan> To me the first goal would be soliciting feedback from the FSC.
14:46:11 <Rogan> Though we may want to have an idea of a goal before we talk to them so that we have something in broad strokes.
14:46:36 <Rogan> And it was pointed out that my fingers mangled up the letters so read that as Conservancy :)
14:46:59 <kmlussier> Rogan: I agree that contact with the SFC is a good first step. They may also have some general information on how other projects have done this.
14:47:31 <gmcharlt> Rogan: I can formally initiate the discussion with Bradley
14:48:33 * bkuhn is here (awoken by mention of his name) if you need any informal information now.
14:48:35 <Rogan> Are there any questions or comments about potential projects?  About potentially building off Loblolly?
14:48:35 * bkuhn reads backlog
14:49:51 <kmlussier> Rogan: I've long been interested in an IdeaTorrent-like site for the community. However, hosting a similar site for my own project, I've found it's good for generating ideas for smaller projects, but isn't as useful in making strategic decisions.
14:50:19 <kmlussier> And, as the EOB,  I think we really need to focus on long-term, strategic development.
14:50:22 <Rogan> kmlussier: That's a good observation.
14:50:35 <kmlussier> But it may be different on a community-wide scale.
14:50:57 * kmlussier isn't familiar with Loblolly.
14:51:19 <Rogan> I just worry about leaving out the community.
14:51:30 <gmcharlt> kmlussier: Rogan: is it fair to assume that the likes of IMLS and Mellon tend to prefer funding large, "splashy" projects as opposed to incremental ones?
14:51:38 <Rogan> Loblolly was the result of an IMLS planning grant awarded to .... GPLS if I remember correctly.
14:51:42 <bkuhn> Rogan: I just read the email you linked to.  Yes, Conservancy would be the right venue (per the FSA) for such things.  (Mozilla is a tough place to get funds from (we've gotten some funding, but wasn't easy and they generally only give targeted to things that directly impact Mozilla itself).  My best advice is for EOB to come up with a specific plan for work to be funded, and then Conservancy can help you hone that and pitch it aro
14:51:42 <bkuhn> You all probably know places that are likely to give grants for ILS's better than Conservancy does, though.
14:51:50 <Rogan> I would say that's fair Galen.
14:51:51 <kmlussier> Oh, I agree. The community definitely needs to have a strong voice in this.
14:52:05 <bkuhn> I can follow up with gmcharlt after the meeting.
14:52:08 * bkuhn reidles.
14:52:45 * kmlussier has Google loblolly and still can't find anything.
14:53:02 <Rogan> Loblolly brought in folks from talking book services programs all over the country.
14:53:18 <Rogan> I attended and we discussed ADA needs and tbs needs in open source ilses.
14:53:31 <kmlussier> Like focus groups?
14:54:35 <kmlussier> I wonder if holding several small focus group-like sessions via Google Hangouts might be effective.
14:54:38 <Rogan> Yep.  And input.  The grant was a fairly big one and some of the information was really useful in terms of putting some ADA needs and rural library stuff under the microscope.
14:54:53 <Rogan> I think big grant givers would be interested in those needs.
14:55:52 <Rogan> And we discussed Evergreen as a vehicle for that.  The rep from IMLS was very interested because they invest a lot in running a minimal TBS ILS every year.
14:56:12 <Rogan> For TBS services with no resources.  Evergreen with added functions would be far more robust.
14:56:30 <Rogan> And those functions would be awesome for home bound in public libraries.
14:57:48 <gmcharlt> cool
14:57:59 <gmcharlt> thus far, we have one action item
14:58:01 <gmcharlt> #action gmcharlt will formally contact Conservancy to kick off a discussion of grantwriting ideas
14:58:16 <gmcharlt> any quick questions for Rogan, as we're near the hour mark
14:58:55 <Rogan> Well, if there's no objection I will work with some of the other loblolly participants who are in the Evergreen community
14:58:58 <kmlussier> No questions, but maybe we can carry the discussion of how to identify development projects to the list.
14:59:06 <gmcharlt> kmlussier: +1
14:59:08 <Rogan> and look at writing up those ideas so that we can share it and all be on the same page.
15:00:04 <gmcharlt> great
15:00:06 <gmcharlt> so...
15:00:07 <gmcharlt> #topic Next meeting
15:00:14 <gmcharlt> #info Next meeting is scheduled for Thursday, 18 July 2013 at 2 p.m. EDT
15:00:40 <gmcharlt> (at which point hopefully those of us going to ALA will have recovered)
15:01:05 <gmcharlt> thanks, everybody!
15:01:06 <gmcharlt> #endmeeting