12:02:13 <kmlussier> #startmeeting Evergreen Web Team Meeting 2013-06-26.
12:02:13 <pinesol_green> Meeting started Wed Jun 26 12:02:13 2013 US/Eastern.  The chair is kmlussier. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:02:13 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic.
12:02:13 <pinesol_green> The meeting name has been set to 'evergreen_web_team_meeting_2013_06_26_'
12:02:16 <mrpeters> client gives DBD::Pg::st execute failed: ERROR: missing FROM-clause entry for table "c81eb2383728e04c5dfea5082027d800" LINE 17: HAVING "c81eb2383728e04c5dfea5082027d800"."id" <= '10' ^ at ./clark-kent.pl line 217.
12:02:25 <kmlussier> Sorry, I had to refresh my memory on the meetbot commands.
12:02:27 <mrpeters> oops....sorry, ignore me until after meeting
12:02:31 <eeevil> dbs: thanks. re phrases, those are separate from the tsquery stuff ... and with that, I'll hush for the meeting
12:02:32 <bshum> kmlussier++
12:03:24 <kmlussier> Agenda is available at http://evergreen-ils.org/dokuwiki/doku.php?id=webteam:meetings:agenda:2013-06
12:03:43 <kmlussier> We'll start with introductions.
12:03:52 <kmlussier> #info kmlussier is Kathy Lussier, MassLNC
12:04:09 <bshum> #info bshum is Ben Shum, Bibliomation
12:04:17 <Rogan_> #info Rogan is Rogan Hamby, SCLENDS
12:04:40 <rfrasur> #info rfrasur is Ruth Frasur, EG Indiana (Hagerstown Library)
12:05:12 <kmlussier> That's 4. I guess that's a quorum. ;)
12:05:21 <moodaepo> #info moodaepo is Anoop Atre (ESI)
12:05:33 * phasefx watches :)
12:05:43 <kmlussier> Feel free to keep introducing yourselves as we move on to the next agenda item
12:05:54 <kmlussier> #topic Action Items from Last Meeting
12:06:38 <kmlussier> #info bshum to start planning of transition to wiki.evergreen-ils.org
12:06:44 <kmlussier> bshum: any updates?
12:06:49 <bshum> Sure.
12:07:01 <bshum> So there's been some transition efforts underway for the past while.
12:07:29 <bshum> wiki.evergreen-ils.org is actually already setup as a new virtualhost entry and luckily for us dokuwiki wasn't set with any prepared paths.
12:07:32 <bshum> So it'll "just work"
12:07:47 <bshum> The big thing to do next is figuring out how to handle the top header.
12:07:51 <bshum> Since it still points back at the main site.
12:08:32 <bshum> My recommendation is that moving forward we have to 1) update the dokuwiki to the latest version, and 2) prepare a new theme with new header to distinguish the wiki from other sites used for Evergreen.
12:09:09 <moodaepo> bshum: As we've chatted I agree with your proposal. So +1
12:09:42 <kmlussier> So, for recommendation 2, the wiki would look different from other parts of the Evergreen site. Is that right?
12:09:58 <Rogan_> I like the idea of the wiki appearing different.
12:10:13 * rfrasur agrees with likiing that idea
12:10:14 <moodaepo> kmlussier: Correct.
12:10:15 <Rogan_> I think we've had issues with the two kinds of content getting confused in people's minds.  (and frankly with vendors)
12:10:32 <moodaepo> Rogan_: That was what bshum was thinking too.
12:10:50 <kmlussier> +1 on both recommendations from me.
12:11:00 <kmlussier> Are there any objections?
12:11:34 <bshum> Related to the new wiki site approach, we've done the same for several other components.
12:11:46 <bshum> (interjecting some update information while I'm still here)
12:12:02 <bshum> Specifially, the piwik installation was updated to new address webstats.evergreen-ils.org
12:12:11 <bshum> And new IRC logs will eventually be completed at irc.evergreen-ils.org
12:12:47 <bshum> Presently, the IRC logging only shows through June when it was first setup.  I'm working on porting all our old log content to the new log storage.
12:13:32 <bshum> The thinking here is finding the best tool for the job if we can, and also making the existing site to be less entangled to make it easier to replace.
12:13:52 <bshum> That's all from me.  Thanks folks, and stay tuned.
12:13:55 <kmlussier> bshum++
12:14:07 <Rogan_> bshum++
12:14:26 <kmlussier> bshum: to follow up with your 2 recommendations, do you need help from anyone or are you just going to move ahead with what you're doing?
12:15:10 <bshum> kmlussier: For the theme, I know that when we install the update for dokuwiki, it'll likely overwrite our existing theme style and we'll have to make a fresh one.  The big thing to decide is when to make the cutover.
12:15:29 <bshum> kmlussier: So the 2 recommendations will occur at the same time.
12:15:34 <bshum> Whenever we decide to do it.
12:15:49 <bshum> Though, the issue is that our existing website embeds wiki pages throughout.
12:16:07 <moodaepo> bshum: previously we have just upgraded the wiki at will this time the only difference will be the theme change
12:16:08 <bshum> So we probably don't want to do it without changing all the existing site pages first so that we're not embedding what we don't need.
12:16:09 <kmlussier> Is this something that needs to be done before cutting over to Wordpress for the main site?
12:16:46 <moodaepo> kmlussier: I'd say we should do it before the cut over to WP
12:16:56 <kmlussier> So I got that backwards, then.
12:17:19 <bshum> Maybe around the same time actually is what I was thinking.  I'd worry about updating all the existing site content to wrap around embedded wiki pages.
12:17:35 <bshum> The main site now uses several wiki pages in place of PHP pages.
12:17:36 <moodaepo> bshum: I don't recall any embedding..we can check again
12:17:56 <bshum> So if we alter the theme and remove the headers/menus, it'll be difficult for folks moving back and forth between pages.
12:17:57 <moodaepo> aah I see what you mean..it's not embedded but just in use
12:18:08 <bshum> Sorry, yes, in use.
12:18:16 <bshum> It looks seamless but that's just trickery.
12:18:51 <moodaepo> seamless_trickery++
12:18:52 <rfrasur> (I apologize for not interacting more.  phone call)
12:19:28 <kmlussier> Maybe we need to address the timing question, then, after we talk about the wordpress cutover (next action item.)
12:19:45 <Rogan_> sounds good
12:19:49 <bshum> +1
12:19:52 <moodaepo> kmlussier: I was thinking the same. +1
12:20:21 <kmlussier> #info moodaepo to continue working on test site
12:20:29 <kmlussier> Though I think bshum has been working on this one too.
12:20:34 <kmlussier> Who wants to give an update?
12:20:40 <bshum> I'm multi-tasking :)
12:20:41 <moodaepo> bshum has taken on doing a test site [ http://evergreener.net/ ] ..I've just been providing him with support right now. We did discuss plans on moving forward and will be emailing it to the list soon for feedback.
12:20:55 <moodaepo> bshum++
12:21:09 <kmlussier> It's pretty!
12:21:19 <bshum> The fun thing we learned while working on the wordpress site prototype is dealing with non-javascript-enabled browsers.
12:21:35 <bshum> There are lots of pretty themes, but not all of them function well without javascript-enabled.
12:22:03 <bshum> While not a complete dealbreaker, the hope was to avoid creating situations where some users might not get a functional website.
12:22:44 <kmlussier> So the next step is to e-mail the list? Is that bshum or moodaepo?
12:23:29 <moodaepo> kmlussier: I can do that if bshum doesn't raise his hands :)
12:23:39 <moodaepo> or even one hand :)
12:23:44 <kmlussier> moodaepo++
12:23:47 <bshum> I'd volunteer, but my email isn't trustworthy right now.
12:24:18 <kmlussier> #action moodaepo to e-mail link to test site to the list for feedback.
12:24:29 <kmlussier> moodaepo: That's the general list, right?
12:24:41 <Rogan_> I would say yes.
12:24:45 <moodaepo> kmlussier: Yup
12:25:02 <kmlussier> Anything else before we move on to the next action item?
12:25:18 <moodaepo> kmlussier: Should I tack on a cut off date discussion to that email?
12:26:03 <kmlussier> moodaepo: Probably not a bad idea. Give a couple of weeks for discussion?
12:26:15 <moodaepo> Ok
12:26:38 <kmlussier> #info StephenGWills to work on member directory/map for web site.
12:26:53 <bshum> Since Steve's not here, defer to next meeting?
12:26:56 <kmlussier> It looks like StephenGWills, isn't here today, so we'll need to defer that to the next meeting.
12:27:11 <kmlussier> Yeah, what bshum said.
12:27:15 <kmlussier> #action StephenGWills to work on member directory/map for web site.
12:27:28 <kmlussier> #info hbrennan and kmlussier to work on layout/design issues for downloads page.
12:27:40 <kmlussier> I also would like to defer that to the next meeting.
12:27:55 <kmlussier> #action hbrennan and kmlussier to work on layout/design issues for downloads page.
12:28:12 <kmlussier> #info kmlussier to start discussion about when to meet / how to meet / why to meet / and where to meet.
12:28:47 <kmlussier> My discussion on this was to basically say that we should use the last Doodle poll to set a regular meeting day. So that would be 12 p.m. EDT on the fourth Thursday of the month.
12:29:22 <kmlussier> However, there aren't many people here today. I don't know if it's because it's a bad meeting time or because people forgot.
12:29:26 <bshum> For the record, I will state now and forever that lunchtime noon meetings are not happy fit for me personally.
12:29:39 <bshum> And I wonder if we're missing pacific time folks from this meeting because of the "early" time
12:29:40 <kmlussier> Correction: fourth Wednesday of the month.
12:29:56 <rfrasur> bshum++
12:30:02 <Rogan_> I'm eating lunch during it but I can understand Ben's position.
12:30:19 * rfrasur just realized it was lunch time.
12:30:20 <kmlussier> I can't do a meeting later in the afternoon on the fourth Wednesday.
12:30:30 <kmlussier> Maybe we should try again with the next Doodle? :)
12:30:51 * kmlussier will refrain from adding a noon time block on the Doodle.
12:31:27 <kmlussier> Of course, 1 or 2 p.m. on the East Coast is noon somewhere else.
12:31:44 <moodaepo> kmlussier: I was just going to say..noon time PST? heh
12:31:59 <bshum> Heh, it's not a great argument for the noon time just for me.  :)
12:32:07 <kmlussier> #action kmlussier will send out another Doodle to schedule a regular meeting time.
12:32:12 <bshum> But I do think it's worth considering what works better for folks in the other timezones.
12:32:15 <bshum> If we can.
12:32:29 <bshum> It's sort of why we don't have community meetings in AM for EST.
12:32:31 <rfrasur> again, to the general list? kmlussier
12:32:52 <kmlussier> rfrasur: Yes, absolutely.
12:33:01 <kmlussier> Shall we move on to New Business?
12:33:09 <bshum> kmlussier++
12:33:23 <kmlussier> #topic Finding volunteers to be content editors and/or website librarians
12:33:41 <kmlussier> I think gmcharlt originally added that topic to the May agenda?
12:33:56 <Rogan_> Blaming it on gmcharlt is a good policy in general.
12:34:03 <Rogan_> But I may have been guilty as well.
12:34:06 <gmcharlt> heh
12:34:20 * rfrasur will blame gmcharlt after the meeting
12:34:40 <Rogan_> I'm willing to fill in a role in this capacity but we shouldn't be reliant on one or two people.  I'm not saying what the right size is though.
12:35:00 <rfrasur> When you refer to content editing, it seems like that could get a pretty broad amount of volunteerism depending on WHAT content is being edited.
12:35:20 <rfrasur> also, what does "website librarian" mean?
12:36:02 <moodaepo> rfrasur++
12:36:09 <gmcharlt> my general idea is that the website librarian (or whatever we choose to call the position) is somebody who takes responsiblity for the overall content
12:36:23 <kmlussier> When I put out an e-mail announcing the May meeting, I heard from a couple of people who were interested in pitching in on content. But it might be useful to have a list of specific areas where we need help.
12:36:26 <gmcharlt> i.e., does things like fixes typos across the board, makes text and style consistent
12:36:33 <Rogan_> A co-ordinator?  What I would call a managing editor?
12:36:52 <gmcharlt> but more importantly, actively looks for content to add and folks to write it
12:37:07 <rfrasur> ur....that's a TON of stuff
12:37:21 <gmcharlt> Rogan_: managing editor verging on editor-in-chief, perhaps
12:37:41 <rfrasur> I don't think that 1 or 2 people COULD do it justice on a part-time volunteer basis.
12:37:45 <Rogan_> But, so is any big project, that's why you need someone who takes a project manager like position for it.
12:37:51 <gmcharlt> but I'd figure that the actual role would depend on what whoever volunteers for it would be willing to do
12:38:00 <rfrasur> Rogan_:totally agree
12:38:17 <gmcharlt> and with the website as is .. I don't think the time committment would be onerous
12:38:51 <kmlussier> I think it's a good idea if we can find the right volunteer.
12:38:52 <gmcharlt> though obviously an  energetic web librarian/editor/WEB EMPEROR could do more
12:38:56 <Rogan_> I concur with the idea of an editor in chief and a few managing editors who coordinate volunteers.
12:39:03 <rfrasur> ohhh, web emperor
12:39:13 <rfrasur> with a sceptor
12:39:16 <rfrasur> hmm
12:39:19 <rfrasur> I dopn
12:39:27 <rfrasur> I don't think ANY of that is spelled right
12:39:33 <Rogan_> Kathy accepted 'el presidente for life' but that was just of the web team, not the web site itself so I suppose it's viable.
12:39:51 * kmlussier accepted web team meeting scheduler.
12:40:07 <Rogan_> semantics :)
12:40:29 <rfrasur> anyway, does this mean that a call for volunteers will go out for content editors and an emperor and then there'll be some meeting(s) to coordinate what that's actually going to mean?
12:40:30 <kmlussier> It sounds like the appropriate action item is for somebody to send an e-mail to the list making the position sound as appealing as possible.
12:40:30 <Rogan_> Anyway ... is that kind of organization what we're discussing?
12:41:01 <rfrasur> kmlussier++
12:41:04 <Rogan_> +1
12:41:08 <rfrasur> Rogan_:I think so?
12:41:13 <rfrasur> +1
12:42:06 <kmlussier> Who wants to send the message? gmcharlt? Rogan_?
12:42:13 <Rogan_> Any dissenting views on proceeding with proposing that structure and looking for volunteers?
12:42:23 <Rogan_> I'm willing to send the message.
12:42:31 <gmcharlt> +1
12:42:40 <kmlussier> Just one question first.
12:43:03 <kmlussier> Should we wait until we cut over to the WordPress site? When it will be easier for these content editors to make those updates?
12:43:25 <rfrasur> fwiw, I think so
12:43:31 <Rogan_> I think we should go ahead and solicit and let editors be aware of the process though they may not start until the cut over.
12:43:48 <moodaepo> kmlussier: +1
12:44:24 <rfrasur> kmlussier: +1
12:44:29 <kmlussier> So that's 2 for waiting and 1 for doing it right away?
12:44:40 <rfrasur> I think we can do both
12:44:58 * gmcharlt leans towards asking now
12:45:07 <bshum> I think it's worth asking for folks to start thinking it over.  But without a real site for them to work with / look at, it might be harder to visualize.
12:45:22 <gmcharlt> particularly if it turns up somebody who is already familiar with WP and who might have an opinion on permissions and plugins and so forth
12:45:25 <rfrasur> like Rogan described.  Do a call-out now letting potentials know that there'll be a transition and they may not begin until after the transition
12:45:25 <bshum> I say that as someone who started on the existing website by poking other folks with spelling corrections though :)
12:45:26 <Rogan_> Let's remember that the process of solicitation may take a while as people ask questions (and good people will ask questions before committing) so some lead time is good.
12:45:28 <kmlussier> Since Rogan_ volunteered, I have faith he can sell it the right way if he does it right away.
12:45:39 <rfrasur> bshum: that's true
12:45:52 <bshum> but it never hurts to ask.
12:45:54 <moodaepo> Rogan_++
12:45:57 <Rogan_> Not everyone jumps in as bravely as Ben. :)
12:46:01 <bshum> And asking in a broader forum seems like a good idea.
12:46:14 <rfrasur> bshum++
12:46:15 * bshum recalls past volunteer looking that didn't make it as far and wide, maybe.
12:46:23 <kmlussier> #action Rogan_ to send e-mail to general list seeking volunteers for content editors / website librarians.
12:46:49 <kmlussier> Rogan_: If you don't hear from anyone when you put out the call from volunteers, I can follow up with people who asked how they could help with the web site.
12:46:55 * bshum quietly whispers, "Or we cut over sooner than later, and we just throw people into the deep end now!"
12:46:55 <Rogan_> And I will outline what we're looking to do in broad strokes of how this is an opportunity for new blood who want to make a real impact on the community as well.
12:47:00 <rfrasur> I will say that whatever comes through the Open-ILS listserv with regard to this, I'll be sending through our consortium support listserv
12:47:31 <kmlussier> All of these e-mails to the general list makes we wonder if there's even a need for a web team list.
12:47:38 <kmlussier> But that can be an agenda item for another meeting.
12:47:46 <kmlussier> Anything else on this topic?
12:47:58 <bshum> Rogan_++
12:48:00 <rfrasur> (or the general listserv...not support...but yeah)
12:48:10 <rfrasur> Rogan_++
12:48:17 <kmlussier> Rogan_++ indeed
12:48:34 <kmlussier> #topic Future of the prototype sites (http://drupal.evergreen-ils.org/ & http://eg13.galecia.com/) and of http://rscel.org
12:48:45 <kmlussier> Lori asked me to add this topic to the agenda.
12:49:47 <Rogan_> The drupal site I think can go.  Personal opinion though I'm glad for the investigation and work that team did.
12:49:51 <Rogan_> It was very informative.
12:50:22 <kmlussier> bshum was noticing today that it looks like most of RSCEL has been taken down.
12:50:29 <moodaepo> kmlussier: I'd like to archive them. Even if it's not running live a copy of the sites would be good to have.
12:50:41 <rfrasur> moodaepo++
12:50:53 <moodaepo> kmlussier: Really? That's sad..considering public grant money was used to create that information.
12:51:09 <kmlussier> moodaepo: The directory is still there.
12:51:14 <Rogan_> RSCEL was a good idea but it's functions that are worth having should probably be discussed as part of the community site.
12:51:16 <kmlussier> link: http://rscel.org/
12:51:53 <kmlussier> I thought there was some useful content on RSCEL. But, now that it's not there, it's hard to know what we might want to carry over.
12:52:15 <Rogan_> I make a motion to archive them if we can but to let them rest in peace.
12:52:38 <kmlussier> Rogan_: The prototypes and rscel?
12:53:05 <kmlussier> Is there any new content on the prototypes that needs to be archived?
12:53:12 <Rogan_> Yes.  I think RSCEL had some good ideas but it wasn't well adopted and the specific content ... well, I'd start over.
12:53:48 <kmlussier> link: http://drupal.evergreen-ils.org/
12:54:10 <bshum> I don't think we need to keep the drupal prototypes around.
12:54:17 <kmlussier> link: http://eg13.galecia.com/
12:54:32 <bshum> The site map design I think is reflected in the documents on the webteam pages if I recall
12:54:45 <kmlussier> I would be in favor of archiving RSCEL (if it hasn't been done already), but letting the prototypes go.
12:55:14 <Rogan_> If we're confidant there's nothing to keep on the prototypes I'm fine with skipping archives of them.
12:55:26 <kmlussier> Though I do commend Lori for all the work she put into those prototypes.
12:55:27 <Rogan_> I trust Ben's judgement on that.
12:55:44 <moodaepo> kmlussier: Ok so if we can get the RSCEL content for archiving easily then let's do it if not oh well. I agree with bshum and your idea about letting the prototypes go.
12:56:11 <Rogan_> So, motion now amended to get rid of prototypes and archive RSCEL site.
12:56:16 <kmlussier> +1
12:56:28 <rfrasur> +1
12:56:48 <moodaepo> +1
12:56:55 <bshum> +1
12:57:22 <Rogan_> Since it's voting I guess I should +1 myself.
12:57:31 <Rogan_> +1
12:57:40 <kmlussier> #agree Ask Lori to archive RSCEL if it can be done easily and discontinue the prototype sites.
12:57:53 <kmlussier> Anything else on this topic?
12:58:21 <kmlussier> #topic 2014 Conference web site
12:58:54 <kmlussier> At the last meeting, I mentioned that I was interested in having the community web site host the 2014 conference web site.
12:59:49 <kmlussier> In talking to bshum, we were thinking we should hold off until the site is cut over to the WordPress site.
12:59:50 <moodaepo> kmlussier: Would you want to wait till the WP cutover is done?
13:00:31 <bshum> Just a matter of when things need to happen all around.
13:00:32 <moodaepo> I think that would influence the cut over date.
13:00:37 <kmlussier> So we were shooting for an August 1 date for the conference site, but I think that can be pushed back a bit to get the WordPress work done.
13:01:08 <kmlussier> But, yeah, we would need to launch it this summer.
13:01:45 <kmlussier> If that seems like too quick of a cutover time, I could always explore other avenues. But I do like the idea of the conference information being available on the community site.
13:02:18 * bshum likes "quick"
13:02:25 <bshum> But I live life dangerously.
13:02:37 * kmlussier likes "quick" took, but I'm not doing the work.
13:02:47 <moodaepo> kmlussier: How about in the email to be sent out I'll mention this date and how we think it's pretty realistic. With all the work bshum has done and both of us discussing the transition I think Aug 1st might be possible.
13:02:58 <phasefx> be nice if we could archive past conference sites too
13:03:15 <rfrasur> bshum: you're so dangerous
13:03:15 <kmlussier> moodaepo++ I like that idea.
13:03:26 <rfrasur> phasefx++
13:03:31 <moodaepo> phasefx++ I tried asking for archives while back but didn't hear back
13:03:33 <kmlussier> phasefx: Yeah, the ones that are still up.
13:03:52 <bshum> I'd agree about the scope of work, but think that we won't be able to fully flesh out the entire site in mockups before we move.  There is always going to be loose ends with content or content that needs revision.
13:04:14 <bshum> So I'd say once we know roughly the direction we need to head, we cut over and then work harder on the necessary content fixes.
13:04:20 <bshum> But I live life dangerously.
13:04:22 <moodaepo> Yes we should ask for the ones that are up.
13:05:04 <moodaepo> kmlussier: So I'll tack that on to the email and a +1 to host the conference website on the community site.
13:05:05 <kmlussier> OK, then, I'll hold tight on that front, and we'll look at making August 1 the target transition date.
13:05:25 <kmlussier> moodaepo and bshum: If there's any way the rest of us can help with this, please give us a shout out!
13:05:28 <bshum> +1 to conference page on the community site.
13:05:36 <rfrasur> kmlussier++
13:05:39 <bshum> Maybe not "conference site" per say
13:05:42 <bshum> :D
13:05:52 <bshum> But now I'm quibbling over language.
13:05:55 <kmlussier> We're 5 minutes past the hour mark? Anything else?
13:05:57 <bshum> Carry on, please.
13:06:30 <kmlussier> #endmeeting