14:01:02 <yboston> #startmeeting 2013-05-02 - DIG Monthly Meeting Evergreen Documentation Interest Group (DIG) Monthly Meeting.
14:01:02 <pinesol_green> Meeting started Thu Jul 11 14:01:02 2013 US/Eastern.  The chair is yboston. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:02 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:01:02 <pinesol_green> The meeting name has been set to '2013_05_02___dig_monthly_meeting_evergreen_documentation_interest_group__dig__monthly_meeting_'
14:01:17 <yboston> The agenda can be found here http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:dig_meeting_20130711-agenda
14:01:28 <yboston> #topic Introductions
14:01:37 <yboston> Please feel free to start introducing yourselves...
14:02:03 * yboston is Yamil Suarez @ Berklee college of Music - DIG meetings facilitator
14:02:36 * kmlussier is Kathy Lussier, MassLNC
14:03:32 * rfrasur rfrasur is Ruth Frasur, Hagerstown Library, Evergreen Indiana
14:03:34 * dbs is Dan Scott, Laurentian University - mostly lurking
14:03:54 * kateb is Kate Butler, Rodgers Memorial Library, NH
14:04:00 <bshum> bshum is Ben Shum, Bibliomation - also lurking (split with phone call)
14:04:17 <yboston> I will give introductions one more minute and then we can begin
14:05:33 <yboston> lets begin
14:05:54 <yboston> Kathy did you have anything to report on?
14:06:48 <kmlussier> Sorry. I don't have anything to report today. Still catching up from vacation.
14:06:58 <yboston> no worries
14:07:18 <yboston> I don't have anything to report either, been busy with conference work, etc
14:08:18 <yboston> unless there are lurkers that want to ask DIG members anything at this point, should we not address the new agenda until next meting (or maybe send out items to the list)
14:09:46 <kmlussier> yboston: I would be interested in talking about a DIG hack-a-way for 2013. Or perhaps just an action item that somebody send an e-mail to the list to start the dicussion.
14:10:05 <yboston> kmlussier: I can send something out
14:10:25 * rfrasur is also interested in this.
14:10:26 <yboston> kmlussier: id you want total a bit about it now?
14:10:43 <yboston> kmlussier:  did you want to talk about it a bit now?
14:10:59 <rfrasur> Is there any estimation of timing at this point or anything or is this the very beginning of the discussion?
14:11:08 <yboston> this is the very beguining
14:11:12 <rfrasur> okay
14:11:23 <kmlussier> Well, we had it in MA last year. People may prefer to host it somewhere else, but if there was interest in holding it in MA again, I could probably find meeting space since Berklee hosted it last time.
14:12:05 <yboston> for the record, Berklee can host again if we don't mind repeating the location
14:12:50 <kmlussier> For the record, I think one of the reasons we did it in MA last year is because several active DIG members are based here. But we also provided a Google Hangout for people to join remotely.
14:13:06 <kmlussier> The Google Hangout seemed to work well.
14:13:49 <rfrasur> I like the idea of the Google Hangout.  It may be difficult for those further abroad to handle two trips out east (in our case).
14:14:51 <kmlussier> Sure, I don't think I could travel out of state to a doc hack-a-way this year, but would be happy to join via a Hangout if it is hosted in another area.
14:15:10 <yboston> BTW, with my intern I used Dropbox to share the files she was converting to AsciiDoc, which we can use in combination with Google hang out
14:15:32 <dbs> I highly recommend getting people who plan to join via Google Hangout to go through a test run a few days before, just to ensure everyone's equipment is all good :)
14:15:44 <yboston> dbs: thanks
14:15:45 <rfrasur> dbs: very good point
14:16:00 <yboston> we can try it during a DIG meeting
14:16:06 <yboston> or part of one
14:16:59 <yboston> we can also try clustering in separate state / cities
14:17:18 <yboston> while still collaborating as a single group
14:17:19 <kmlussier> yboston: That's a very good idea.
14:17:33 <rfrasur> agreed
14:18:21 <yboston> I can send out an initial email to the list to get the conversation going
14:18:40 <yboston> #action Yamil can send out an initial email to the list to get the conversation going
14:19:07 <yboston> #action Yamil can send out an initial email to the list to get the conversation going on DIG hack-a-way
14:20:58 <yboston> BTW, I was just thinking we can start the hack-a-way ith an Asciidoc introduction
14:22:39 <kmlussier> yboston: It might be useful to do that as a Hangout On Air. You could then save it to YouTube.
14:22:57 <yboston> I have been looking into that
14:22:59 <yboston> thanks
14:23:21 <yboston> also, that is another way that people can at least listen in
14:25:13 <yboston> any other thoughts?
14:25:19 <yboston> should we talk about anything else?
14:25:55 <dbs> Suggestion: for those that monitor the Evergreen feedback email address, to loop back to DIG with questions that need answering
14:26:27 <dbs> (Example from this morning: a person asked if Evergreen offers a self-check... which it does, but we don't document where it lives)
14:26:59 <dbs> Not sure if there's anything formal to take away from that than, perhaps, asking feedback-monitoring people to shoot a note over to the DIG list?
14:27:32 <kmlussier> Do we have a good way of tracking documentation that's needed?
14:27:40 <dbs> (In the theory that if something is important enough for a person to dig up a feedback mailing address to ask a question, it deserves some level of priority)
14:28:17 <dbs> kmlussier: dunno, the wiki or launchpad bugs are options, but not sure if either is "good"
14:28:58 <yboston> I don't think we have a official way to keep track of missing docs. there are some launchpad bugs
14:29:00 <rfrasur> "good" may not necessarily be that important.
14:29:27 <kmlussier> Yeah, I was just looking at the bugs tagged with documentation. They don't get much attention.
14:29:28 <yboston> we could make a sort of "documentation wishlist" on the wiki
14:30:09 <yboston> looking over launchpad documentation bugs could eb something we do at the hack-a-way / conference
14:30:38 <rfrasur> kmlussier: isn't that mostly because most people looking at launchpad are there for the code rather than the documentation?  and couldn't that be addressed by educating non-developer community re: launchpad?
14:30:53 <kmlussier> It looks like there's a nice small one I might be able to manage.
14:31:39 <yboston> we can also set up a Google docs based form that feeds a spreadsheet to collect documentation needs / bugs
14:31:52 <kmlussier> rfrasur: Possibly, but it could also be the small number of volunteers and whether their skillsets match up with the areas that need documentation.
14:31:53 <yboston> or just teach folks how to submit bugs properly in launchpad
14:32:21 * kmlussier prefers Launchpad to setting up a new system.
14:32:22 <rfrasur> kmlussier: yboston: true on both points
14:32:40 <rfrasur> kmlussier: I agree about launchpad
14:33:28 <yboston> I would like to talk to the debs, that know launchpad much better than me, what workflow should we follow
14:33:52 <yboston> for example, any special tags we should use or avoid.
14:34:13 <yboston> s/debs/devs/
14:34:48 <kmlussier> bshum reminds me that the documentation outline was set up to serve this purpose. http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs_2.4:outline
14:34:49 <bshum> yboston: What sort of tags are you afraid of?
14:35:00 <bshum> It's not too structured, so I wouldn't overly stress about misusing launchpad.
14:35:36 <dbs> bshum: perhaps avoid "pullrequest"?
14:35:38 <yboston> bshum: I should have said "statuses"
14:35:50 <yboston> (fix cmmitted, etc)
14:36:13 <yboston> …importance, assigned to, ...
14:36:21 <yboston> or maybe just ignore all those at first
14:37:56 <dbs> Probably want to set to "Fix committed" once the change is committed, to keep those bugs from showing up on "stuff that needs to be done" reports
14:38:06 <bshum> dbs: Okay, pullrequest might be too specialized for that.
14:38:17 * dbs notes that Yamil is going to do all of the items on the 2.4 outline :)
14:38:29 <bshum> yboston: Personally I think tagging with "documentation" (which I think is an official tag) is sufficient to get the ball rolling.
14:38:44 <yboston> bshum:  seems fine to me
14:38:46 * kmlussier agrees with bshum
14:38:47 <bshum> yboston: As far as importance, I'm not sure if only wranglers can set that.
14:38:49 <dbs> bshum: yes, also, avoids crossing the streams (for reports like "open pullrequests for the next milestone")
14:39:16 <bshum> I know targets, etc can only be set by wranglers.
14:39:17 <kmlussier> dbs: So in answer to your question, I would say those feedback e-mails can be turned into LP submissions.
14:39:17 <yboston> dbs: Yamil's intern did all of the work, Yamil needs to proofread and fix some asciidoc weirdness still :(
14:39:34 <kmlussier> dbs: Do you think a DIG person should be monitoring that feedback address?
14:39:44 * kmlussier isn't volunteering, just wondering.
14:39:49 <yboston> kmlussier:  I was thinking that too
14:39:58 <yboston> kmlussier: too late :)
14:40:43 <dbs> kmlussier / yboston: not necessarily, although it doesn't hurt to be following feedback; there aren't many of us who actually _respond_ :)
14:41:29 <dbs> yboston: I grabbed the self-check action item on the outline; we don't want the old docs, 'cause that's the old self-check. I'll put in a few lines, good enough to get things going anyway
14:41:42 <yboston> I am thinking of sending out another email about how we have discussed using launchpad more formally to the DIG list
14:43:59 <yboston> BTW, I have almost dreamed of going back through the mailing list archive searching for the terms "docs" and "documentation" were folks mention stuff that is missing and turning that into a whishlist or perhaps now individual launched bugs
14:44:13 <yboston> (launchpad bugs)
14:44:45 <kmlussier> Heh, launched bugs. I like it. :)
14:44:56 <yboston> dbs: BTW, I want to make sure we are on the same page on that self check thing. can we chat after the meeting?
14:46:02 <yboston> #action send a email out to the DIG list about trying to use launchpad to collect request for missing docs and bugs in existing docs
14:46:31 <dbs> yboston: sure
14:47:25 <yboston> BTW, we are at the 47 minute mark for this meeting.
14:47:51 <yboston> any other comments on this topic or any another topics that you want to bring up?
14:47:59 <kmlussier> yboston: On you last agenda topic, Google doc sprint...
14:48:05 <yboston> go ahead
14:48:23 <yboston> perhaps I should be the one
14:48:28 <kmlussier> I don't know that projects are actually encouraged to re-apply for that. dbs might have more insight on that.
14:49:02 <yboston> I suspected that our options were limited, I just thought of it since I was thinking of what we did last year as DIG
14:49:03 <kmlussier> I think the idea was to give us the tools to learn how to do a doc sprint so that we could do it on our own.
14:50:19 <yboston> I just made a note to pick the brains of those that did participate in the doc sprint so we can apply it to this year's hack-a-way or next year's conference
14:54:13 <dbs> kmlussier: I think you're right, orgs are not expected to repeat
14:54:31 <yboston> dbs: good to know
14:54:40 <yboston> we need to change our org name :)
14:54:41 <dbs> well, they can and should repeat on their own, but don't expect Google assistance :)
14:54:49 <dbs> OpenSRF Doc Sprint!
14:54:54 <yboston> :)
14:55:04 <kmlussier> dbs: You can lead that one. :)
14:56:55 <yboston> We are getting close to the hour mark, any final thoughts or questions?
14:57:11 <kmlussier> Not from me.
14:57:23 <kmlussier> yboston++
14:57:36 <rfrasur> yboston++
14:57:41 <bshum> yboston++
14:57:52 <yboston> muchas gracias
14:58:09 <yboston> #endmeeting