13:59:32 <gmcharlt> #startmeeting Evergreen Developer meeting, 2013-07-16
13:59:32 <pinesol_green> Meeting started Tue Jul 16 13:59:32 2013 US/Eastern.  The chair is gmcharlt. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:59:32 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:59:32 <pinesol_green> The meeting name has been set to 'evergreen_developer_meeting__2013_07_16'
13:59:39 <gmcharlt> #info agenda is at http://evergreen-ils.org/dokuwiki/doku.php?id=dev:meetings:2013-07-15
13:59:54 <gmcharlt> #topic introductions
14:00:01 <gmcharlt> #info gmcharlt = Galen Charlton, ESI
14:00:04 <paxed> #info paxed = Pasi Kallinen, Regional Library of Joensuu
14:00:10 <eeevil> #info eeevil = Mike Rylander, ESI
14:00:11 <phasefx> #info phasefx = Jason Etheridge, ESI
14:00:19 <kmlussier> #info kmlussier = Kathy Lussier, MassLNC
14:00:47 <dbwells> #info dbwells = Dan Wells, Hekman Library (Calvin College)
14:01:15 <berick> #info berick Bill Erickson, ESI
14:02:05 <senator> #info senator = Lebbeous Fogle-Weekley, ESI
14:03:11 <gmcharlt> OK, thanks
14:03:19 <gmcharlt> #topic Action items from last meeting
14:03:51 <gmcharlt> #info action items were: (a) start on 2.6 road map; (b) bshum to summarize bug tracking based on dev feedback; (c) kmlussier to raise bug squashing day
14:04:17 <gmcharlt> no action to report on the 2.6 roadmap
14:04:18 <remingtron> #info remingtron Remington Steed, Hekman Library (Calvin College)
14:04:24 <gmcharlt> bshum: kmlussier: updates?
14:04:34 <gmcharlt> (I know that bshum is mostly not here)
14:04:46 <kmlussier> bshum isn't here at all actually.
14:05:02 <kmlussier> I need to defer my action item. I forgot I had an action item until yesterday.
14:05:47 <gmcharlt> OK, that was simple enough
14:05:54 <gmcharlt> #topic GSoC reports
14:06:05 <gmcharlt> any updates from the mentors?
14:06:33 <kmlussier> Before bshum had to leave, he mentioned that there is a working branch at http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/dmitriye/dashboard.
14:07:27 <gmcharlt> #info a WIP branch from the student available at http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/dmitriye/dashboard.
14:07:40 <gmcharlt> sounds like that's it
14:07:45 <gmcharlt> #topic QA topics
14:07:56 <gmcharlt> I think that item was from phasefx?
14:08:01 <phasefx> yes
14:08:43 <gmcharlt> phasefx: take it away, then :)
14:08:51 <phasefx> I have some code I'm wanting feedback on, kudos, etc ;)  And I'm hoping others may want to tie it into what we're doing now, etc.
14:09:01 <phasefx> http://git.evergreen-ils.org/?p=working/random.git;a=shortlog;h=refs/heads/collab/phasefx/wheezy_installer
14:09:49 <phasefx> basically, given a pristine debian wheezy installation, this will install and run Evergreen without any prompting, and then fire off the pgTAP tests we have, and potentially whatever tests we come up with that require a live environment
14:10:45 <phasefx> an area I'm really weak on is Buildbot, though it's not necessary for what I'm trying to do, it'd be nice to have some integration there
14:11:37 <phasefx> so, any thoughts, interest, comments, etc?
14:11:44 <phasefx> defer discussion to list?
14:12:12 <gmcharlt> phasefx: it's a good idea, but sounds like discussion will in fact need to be deferred
14:12:34 <eeevil> comment: +1
14:13:19 <berick> phasefx: would you accept patches for teaching the script to update an existing install and firing the tests again?
14:13:21 <gmcharlt> ok, moving on
14:13:24 <berick> if it doesn't do that already, that is
14:13:28 <gmcharlt> #topic OpenSRF release
14:13:40 <phasefx> berick: yeap.  it's mostly repeatable now
14:13:49 * berick nods
14:15:21 <gmcharlt> berick: does the multi-part message deprecation warrant a release?
14:15:28 <berick> gmcharlt: yes.
14:15:57 <berick> selfcheck is the main problem so far, since it's not run in xulrunner
14:16:19 <gmcharlt> OK
14:16:35 <gmcharlt> #action gmcharlt will cut OpenSRF 2.2.1 by Friday
14:16:40 <berick> gmcharlt++
14:16:46 <gmcharlt> moving on
14:16:55 <gmcharlt> #topic Evergreen 2.5 update
14:17:05 <gmcharlt> dbwells: the floor is yours
14:18:15 <dbwells> I sent an email update a few hours ago.  Basic summary is that everything is going well, and the release is still on track.  More details in the email: http://markmail.org/thread/zcxti4nkqkplo6uw
14:18:27 <gmcharlt> dbwells++
14:18:33 <berick> dbwells++
14:18:41 <dbwells> Also, thanks again to everyone who contributed.
14:18:56 <kmlussier> dbwells++
14:19:20 <gmcharlt> moving on
14:19:31 <gmcharlt> #topic Evergreen 2.4.1
14:19:58 <gmcharlt> which essentially boils down to, when can we have it?
14:20:02 <eeevil> will be concurrent with 2.3 and 2.2 releases, tomorrow (according the the calendar)
14:20:14 <senator> 2.2 is history
14:20:16 * berick confirms 2.3
14:20:25 <berick> long live 2.2
14:20:26 <eeevil> senator: fair enough
14:20:35 <gmcharlt> so 2.4.1 and 2.3.9 to be cut tomorrow?
14:20:56 <eeevil> there is production use of the fix from https://bugs.launchpad.net/evergreen/+bug/1200770 but I'd be happy if others looked
14:20:56 <pinesol_green> Launchpad bug 1200770 in Evergreen 2.4 "Search result rendering can crush the system" (affected: 1, heat: 6) [High,New]
14:21:02 <gmcharlt> and should we tag the 2.2 series on the downloads page as deprecated?
14:21:13 <eeevil> other than that, nothing burning for 2.4.1
14:21:18 <eeevil> gmcharlt: +1
14:21:51 <gmcharlt> #action berick and eeevil to cut 2.3.9 and 2.4.1 on 2013-07-17
14:22:14 <senator> gmcharlt: i believe so, re 2.2 deprecation. security releases possible through september, but that's it
14:22:37 <gmcharlt> #action gmcharlt will talk to bshum about updating display of 2.2 on the downloads page
14:23:02 <kmlussier> When dbs posted that agenda item, he also asked about an official 2.4 announcement. Is that something that should happen too or is it too late now?
14:23:45 <eeevil> kmlussier: concurrent with the 2.4.1 announcement?
14:24:10 <kmlussier> Sure, but I don't think we ever had an announcement saying 2.4 is out and here are all the new features we're getting.
14:24:17 <csharp> "and - oh yeah, 2.4.0 came out too"
14:26:04 <eeevil> kmlussier: I was planning to have a general "here's the new stuff in 2.4" part of of the announcement
14:26:19 <kmlussier> eeevil++
14:26:22 <eeevil> do we want a separate 2.4.0 post at this point?
14:26:33 <csharp> -1
14:26:35 <kmlussier> eeevil: I wouldn't think so.
14:26:45 <gmcharlt> eeevil: "what's new in Evergreen 2.4", perhaps
14:26:57 <eeevil> gmcharlt: sure ... I can make it separate
14:27:01 <eeevil> to highlight
14:27:07 <gmcharlt> highlighting++
14:28:18 <eeevil> thanks, also, to all the folks that have been backporting master bug fixes to 2.4 up to this point
14:28:42 <gmcharlt> OK, I think that's it for 2.4.x
14:28:50 <gmcharlt> #topic MassLNC performance evaluation
14:29:00 <gmcharlt> #info Update from kmlussier: http://markmail.org/message/6yzorevfs6xtnn2u
14:29:05 <gmcharlt> kmlussier: anything to add?
14:29:33 <kmlussier> Not much to add. I know everyone wanted to be kept in the loop during the evaluation, so I wanted to send out our plans before we got started in earnest.
14:29:58 <kmlussier> jsime and patnorton are here from OmniTI if anyone has any questions or thoughts on the plan thus far.
14:30:15 <kmlussier> s/plan/plans
14:30:58 <kmlussier> And we're looking forward to seeing what this evaluation turns up.
14:31:15 <patnorton> hello all - jsime is our technical lead on this initiative and i'm the project manager working with jon and the team
14:31:47 <csharp> patnorton: jsime: welcome!
14:31:59 <eeevil> kmlussier (or patnorton/jsime): one thing was unclear to me ... the "using tsearch over ilike" part
14:32:18 <eeevil> (and yes, welcome to our humble hamlet ;) )
14:32:57 <jsime> eeevil: in our initial pgbadger review of some of the production logs from MassLNC consortia, there were a few queries flagged using ILIKE comparisons
14:34:06 <jsime> the dyanmically generated bib-search query, which showed frequently in the report was using tsearch, of course
14:34:13 <eeevil> jsime: gotcha. those would very likely be left-anchored (indexed) searches of name columns ... for "real" search we do use tsearch
14:34:28 <eeevil> righto. thanks for the clarification
14:35:02 <dbwells> Maybe this was mentioned in earlier communications, but what is the estimated timeline for this project?
14:35:07 <jsime> it wasn't clear from that initial review if the use of ILIKE was more extensive, though, hence the flagging of it
14:35:23 <eeevil> jsime: very fair. thanks!
14:35:26 <jsime> np
14:36:05 <patnorton> dbwells - once we get moving with a fully functional test environment, approximately 2 − 2.5 months
14:36:15 <patnorton> environment should be available this week
14:36:20 <patnorton> i beleive
14:36:52 <dbwells> patnorton: sounds good, thank you
14:36:55 <kmlussier> Yes, we're hoping for this week unless tsbere tells me something differently.
14:38:15 <gmcharlt> anything else on this topic, or any last-minute topics?
14:38:19 <kmlussier> If anyone else has any other questions or comments, feel free to send them to the list.
14:39:44 <patnorton> kmlussier: thanks.  all: we will be in the channel daily going forward to be able to ask questions and share anything we find along the way
14:39:58 <phasefx> patnorton++
14:39:59 <kmlussier> patnorton++
14:42:08 <gmcharlt> ok, doesn't sound like anybody has additions to the agenda, so I'll go away and end the meeting
14:42:12 <gmcharlt> thanks, everybody!
14:42:15 <gmcharlt> #endmeeting