14:00:41 <yboston> #startmeeting 2013-08-01 - DIG Monthly Meeting Evergreen Documentation Interest Group (DIG) Monthly Meeting.
14:00:41 <pinesol_green> Meeting started Thu Aug  1 14:00:41 2013 US/Eastern.  The chair is yboston. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:41 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:41 <pinesol_green> The meeting name has been set to '2013_08_01___dig_monthly_meeting_evergreen_documentation_interest_group__dig__monthly_meeting_'
14:01:05 <yboston> The agenda can be found here http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:dig_meeting_20130801-agenda
14:01:18 <yboston> #topic Introductions
14:01:28 <yboston> Please feel free to start introducing yourselves...
14:01:39 * yboston is Yamil Suarez @ Berklee college of Music - DIG meetings facilitator
14:02:21 * rfrasur is Ruth Frasur @ Hagerstown Public Library - Evergreen Indiana
14:02:25 * kmlussier is Kathy Lussier, MassLNC
14:02:48 <dagreen> David Green, NC Cardinal
14:04:02 <yboston> I suspect that we will have a small gathering today
14:04:38 <yboston> #topic Updates from Content Coordinators
14:04:57 <kmlussier> Am I the only content coordinator here?
14:05:03 <yboston> kmlussier:  did you have something tot all about. I just saw
14:05:10 <yboston> you sent an email to the lsit
14:05:13 <yboston> list
14:05:24 <yboston> (yes I think you are the only one)
14:05:27 <kmlussier> yboston: That's not actually part of my report, but I just added it to the agenda under new business.
14:05:38 <kmlussier> If we have time to get to it.
14:06:04 <kmlussier> I don't have anything to report again as release coordinator, but it looks like we have a lot of discussion items under old and new business.
14:06:42 <yboston> we should have time to touch on on those topics, though I wished there were more of us here
14:06:52 <yboston> to join in the idscussion
14:07:34 <yboston> traditionally we would go over "old business" first, but today we can start on new items
14:07:38 <yboston> if you guys want
14:07:54 <rfrasur> whatever you all think is best.
14:08:11 <yboston> I say we go for new
14:08:24 <kmlussier> +1
14:08:32 <rfrasur> +1
14:08:47 <yboston> #topic Think of ways to increase participation, create an informal survey, training during a DIG hack-a-way, or online DIG training sessions between conferences (by Yamil)
14:09:20 <yboston> DIG activity has declined in the last 12 months
14:09:30 <yboston> and I want to make a push for more participation
14:09:54 <yboston> part of the reason why DIG participation is down
14:09:57 <rfrasur> I can throw in my two cents.
14:10:08 * rfrasur will wait
14:10:20 <yboston> is because some members were going through migrations in the last 12 motnhs
14:10:39 <yboston> and now some of those same members are active in the upcoming 2014 conference
14:10:46 <yboston> planning
14:11:34 <yboston> I want to offer some welcoming / training sessions for new members online, instead of waiting for the next conference.
14:11:56 <rfrasur> great idea
14:11:59 <yboston> also I guess we can try an informal survey to see what outsiders think about considering joining us
14:12:24 <yboston> this issue has come up in the Evergreen Oversite Board, which I am a part of
14:12:42 <yboston> we need to make it easier and more obvious for people to be able to contribute
14:12:46 <yboston> in general to EG
14:12:46 <kmlussier> I think that's a good idea. Also, if the training could be recorded for later streaming, people could benefit from it whenever they are available.
14:13:00 <yboston> and I think documentation on general is a simple way to contribute
14:13:15 <yboston> kmlussier:  I totally agree
14:13:16 <kmlussier> Also, I think it's a good idea to always stress that, although we prefer AsciiDoc, people can contribute in any format.
14:13:27 <kmlussier> We always say that, but it can't be overstated.
14:13:39 <kmlussier> rfrasur: What was your two cents?
14:15:05 <rfrasur> well, speaking as someone very new to broader community and with really only the limited perspective of using Evergreen as an end-user (and some vague understanding of tech lingo), I think, like both of you, that documentation can be a great entry point for just about anyone...
14:15:36 <kmlussier> I'm also interested in hearing what dagreen says as a potential new DIG member. :) BTW, welcome!
14:15:40 <rfrasur> with the understanding that there's a lot of trepidation coming into this environment
14:16:32 <rfrasur> even if someone could potentially contribute a lot....just knowing how to behave...and how to get around...and who does what and what needs to be done.
14:16:38 <rfrasur> It's VERY overwhelming.
14:17:21 <dagreen> Thank you, kmlussier, I echo rfrasur, and intend to join your IRC meetings until I am able to actively contribute.
14:18:00 <GHamelin> Hi everyone, I have just joined and have missed some of the conversation, but we are currently creating help files for version 2.4.1
14:18:16 <GHamelin> is this what people are looking for?
14:18:19 <dagreen> I will be doing documentation for our end users in NC Cardinal, and figured this would be the quickest way to contribute to the larger community.
14:18:25 <rfrasur> I am VERY committed to sticking with the nuts and bolts side of EG...so, I'm more willing to wade through and make mistakes and get embarrassed.  There are a lot more individuals, however, who could potentially be contributing but wouldn't be able to get past all that.
14:19:03 <rfrasur> GHamelin: yes...and more...and still more
14:19:11 <rfrasur> dagreen++
14:19:45 <GHamelin> the current format is text with screen captures
14:19:57 <kmlussier> GHamelin: I would say we're looking for anything that could fill in gaps at http://docs.evergreen-ils.org/.
14:20:35 <rfrasur> that's my two cents....well, one cent.  My other cent is I'm a pretty good evangelist...but I don't feel confident enough to start "spreading the gospel" of documentation at this point.
14:20:56 <rfrasur> confident in my own understanding, that is
14:20:57 <GHamelin> right now we are covering cataloguing, circulation, TPAC and keyboard shortcuts
14:21:52 <GHamelin> we should have them complete by September
14:21:59 <kmlussier> You know, I think what might help is that we don't have one clear list of what those gaps are. We have the spreadsheet from last year's DIG hackfest, and I have created a list of 2.4 features that need to be documented, but I think we might need some central clearinghosue.
14:22:46 <yboston> kmlussier:  I made a new version of the spreadsheet with my inter, but it is pretty messy. I can share it with you if you want.
14:23:01 <kmlussier> yboston: Sure.
14:23:10 <rfrasur> kmlussier: +1 - If someone just goes to that page and looks at the list...they don't know what to start picking at.
14:23:30 <yboston> GHamelin: BTW, at the beginning of this meeting I just brought up that I want to increase the DIG participation by adding new members
14:24:08 * rfrasur may not be a member
14:24:12 <rfrasur> I just kinda show up places.
14:24:23 <dbs> GHamelin: by "help files" you mean what gets shown when you press F1 in the staff client?
14:24:58 <GHamelin> no the help link that is currently empty in the right hand corner of Evergreen
14:25:28 <GHamelin> i have asked Equinox to set it up once we are done
14:25:34 <rfrasur> Ah hah!
14:25:53 <yboston> I never really noticed that menu there :(
14:26:20 <rfrasur> me either.  just gave it a try.  GHamelin++
14:26:40 <GHamelin> we also wanted to contribute to the community
14:26:41 <rfrasur> dbs - F1 in our staff client is check out...
14:27:11 <rfrasur> (will that change?)
14:27:22 <yboston> I would like to eventually steer the conversation back to bringing in new members, but I am glad to hear about StatCan's work
14:27:38 <GHamelin> i don't think I am a member
14:28:05 <yboston> DIG membership is a very loose concept
14:28:11 <GHamelin> ok
14:28:11 <Dyrcona> If DIG is like most other EG groups, all you have to do to be a member is show up.
14:28:20 <dagreen> Sign me up
14:28:21 <yboston> Dyrcona: exactly
14:28:21 <kmlussier> You only need to show up to be a member. :) Contributions help too.
14:28:35 <GHamelin> count me in
14:28:51 <kmlussier> yboston: You mentioned a survey. What kind of questions would you ask?
14:28:52 <rfrasur> yboston: I think the things you mentioned are a good idea.  I do also like the idea of an informal survey...and wouldn't mind to start putting one together.
14:28:58 <GHamelin> I have been lax in contributing to the authorities group
14:29:08 <GHamelin> which i intend to start on next week
14:29:10 <kmlussier> rfrasur++
14:29:25 * rfrasur tried to become a member of a family by showing up once - they weren't as accommodating as EG
14:29:27 <yboston> you fixed some auth bugs in the code, that is plenty of help :)
14:29:57 <yboston> in the survey, for example I wanted to ask what is keeping you from joining
14:30:24 <yboston> also, I wanted to put in questions that might actually "trick" folks into learning about us
14:30:28 <yboston> though this might not be a good idea
14:30:33 * rfrasur chuckles
14:30:53 <rfrasur> I'll avoid the words "trick," "coerce," and "brainwash"
14:30:54 <yboston> like "did you know that DIG membership is very informal, just need to show up: Yes  / NO"
14:31:27 <rfrasur> So, is the target audience people on the general listserv or is it broader?
14:31:42 <kmlussier> I would say general list.
14:31:54 <yboston> Instead of a survey I guess we can just send out an informative eamil asking for volunteers and soliciting suggestions from folks
14:32:12 <yboston> general list or even a blog post on our homepage
14:32:24 <yboston> EG home page (just a thought)
14:32:33 <Dyrcona> I'd go for both the mailing list and the blog post.
14:32:38 <kmlussier> yboston: I'm partial to the idea of a survey. We've done those e-mails in the past. One of the nice things about a survey is that people can be anonymous, so they may be more likely to respond.
14:32:42 <rfrasur> Dyrcona++
14:33:13 <rfrasur> kmlussier: I agree.  It's also REALLY easy to ignore an email that doesn't require anything beyond reading.
14:34:10 <yboston> BTW, we have reached the 30 minute mark on this meeting. So far so good
14:34:21 <rfrasur> I do think there can be an element of instruction included in the survey, but we also do want to know why people haven't joined.
14:34:43 <phasefx> just a pointer/reminder on the help feature GHamelin is talking about: http://evergreen-ils.org/dokuwiki/doku.php?id=scratchpad:custom_help
14:35:11 <yboston> I have some good ideas of why not, and I want to try to address some of them. of course I want to hear more ideas from people that are on the outside still
14:35:31 <yboston> One reason I believe is keeping folks from helping is that there
14:35:47 <yboston> are several things to overcome that seem overwhelming to beginners
14:35:51 <yboston> like using IRC
14:36:10 <yboston> like not seeing a vert simple an obvious list of "bite size" things to work on
14:36:12 <GHamelin> agreed
14:36:14 <rfrasur> yes...unless they may or may not have played Quake a long time ago.
14:36:36 <rfrasur> definitely with regard to the "bite size" things
14:36:59 <GHamelin> so once our files are complete, how do I submit to the community?
14:37:00 <yboston> I keep trying to steal ideas of how we try to recruit and train potential Google Summer of Code participants
14:37:07 <yboston> we being the EG developers
14:37:30 * rfrasur has ideas...but as usual...they're not practical or ethical
14:38:04 <kmlussier> GHamelin: When I started, I submitted by e-mailing docs to the DIG list.
14:38:14 <yboston> Fr example, I would be open to have a google hangout meeting or even conference call with a few folks to explain our procedures
14:38:43 <GHamelin> OK
14:38:49 <kmlussier> After I learned AsciiDoc, I started contributing through git. But I wouldn't expect all documenters to submit their documentation with git.
14:39:27 <GHamelin> training for AsciiDoc?
14:39:30 <kmlussier> yboston: I think the conference call idea is a good one. Just small interactions to go through the process would be helpful.
14:39:34 <gsams> of note, there is one person who was formally with NTLC who is frightened of participating in IRC
14:39:36 <rfrasur> (yay for good ideas!)
14:39:47 <gsams> just though I'd offer up that to yboston as extra proof
14:39:57 <yboston> gsams:  thanks!
14:40:10 <rfrasur> frightened...how so?  like overwhelmed by a diff interface? or privacy? or...
14:40:12 <gsams> formerly* not formally
14:40:28 <gsams> of embarrassing herself I think it was
14:40:38 <gsams> I honestly had the same problem just less so
14:40:38 <rfrasur> yeah, I think that's not unusual.
14:40:52 <gsams> I was willing to ditch it, she really isn't so much
14:41:03 <kmlussier> I don't think people need to necessarily participate in meetings either to be a DIG contributor. If it's clear what needs work and they have document to contribute, they could send it to the list without the meeting participation.
14:41:05 <yboston> Perhaps we should make a video tutorial on how to try IRC or combine a conference call with participants joining in with IRC
14:41:24 <yboston> we being the EG community i general (and me)
14:41:37 <GHamelin> yboston: good idea!
14:41:39 <rfrasur> yboston: I think that documenting about how to participate in the community is as important as documenting the software
14:41:52 <gsams> rfrasur++
14:41:57 <kmlussier> As with anything, it can be difficult to interact with a new community, and if you aren't comfortable with the medium, it's an additional barrier.
14:42:00 <rfrasur> especially since the software is dependent on the community
14:42:07 <rfrasur> kmlussier++
14:42:26 <gsams> I would also say that the more lines of communication the better(with the caveat that it's also more easily confusing)
14:42:36 <kmlussier> I created an IRC quick start guide a while back that might also be useful for people. http://evergreen-ils.org/dokuwiki/doku.php?id=community:irc-quick-start&s[]=irc&s[]=quick&s[]=start
14:42:41 <gsams> kmlussier++
14:43:47 <yboston> kmlussier: that page makes a huge difference
14:44:15 <dagreen> And maybe it's a workload issue, too. If it's true that any little bit helps, maybe show examples of just how little a bit is. Potential members may think they aren't helping unless they contribute a huge section.
14:44:29 <GHamelin> i for one will be reading this soon as i am green also
14:44:40 <yboston> but I think people are afraid to interrupts. Thinking out loud I would consider creating a half hour meeting on IRC just for beginners to join in and practice in a live scenario. or maybe just during the conference or hackfst
14:45:09 <rfrasur> yboston++
14:45:13 <kmlussier> yboston: I think this discussion feeds into your e-mail about using Launchpad to track documentation. We need a good way to track which documentation is needed, and bitesize tags might be good for new people just getting started.
14:45:24 <gsams> yboston: Those are all excellent ideas in my opinion.
14:45:35 <kmlussier> I'm not sure if LP is the right place to do it, but I think it's better than maintaining spreadsheets or wiki pages as we have in the past.
14:45:56 <rfrasur> I actually kinda like the idea of using LP...
14:46:31 <rfrasur> I know it's buggy and has it's own scare factor...but those are surmountable (sorry...sometimes you can't escape the big words)
14:46:41 <rfrasur> hmm, s/it's/its
14:46:49 <yboston> BTW, we are past the 45 minute mark
14:47:01 <kmlussier> yboston: But it's a great discussion! :)
14:47:19 <rfrasur> agreed :D
14:47:22 <yboston> absolutely, I just want to keep everyone aware of the time, in case they want to say something
14:47:38 <gsams> kmlussier: it really is, it pulled me away from trying to figure out how to install evergreen
14:48:00 <yboston> that is another online class I want to teach :)
14:48:33 * rfrasur envisions many video tutorials
14:48:50 <gsams> I'd love to be a guinea pig for learning sysadmin related stuff
14:49:10 <yboston> one mentality I want to adopt to try to make it easier for new comers to contribute
14:49:18 <yboston> is that of a trainer
14:49:20 <rfrasur> guinea_pigs++
14:49:32 <yboston> usually a trainer is not an expert on what they are teaching
14:49:44 <rfrasur> yboston: I think that's a very healthy way to approach it.
14:49:57 <yboston> but they have completely polished their training assignment to use every bit of the key concepts
14:50:18 <kmlussier> I'm envisioning a "How to Contribute to DIG" page that links to video tutorials on AsciiDOC and also does some nice links to LP bugs with a documentation tag.
14:50:20 <yboston> and avoiding examples that are confusing, and providing sample data that works really well with the training tasks
14:50:34 <yboston> kmlussier:  yes
14:51:33 <yboston> ON a side note, I think I want to suggest that we have a DIG "Open House"
14:51:50 <rfrasur> meaning?
14:51:54 <yboston> we need to clean up our "lobby" a bit (the contribute page)
14:52:07 <yboston> and host a meeting in IRC or google hangout or skype
14:52:24 <yboston> to get to talk to folks and answer questions and lead some training
14:52:38 <yboston> (just thinking out loud)
14:52:40 <kmlussier> yboston: All of your ideas are great. I say we should follow through with them all.
14:52:44 <kmlussier> yboston++
14:53:00 <rfrasur> yboston++ # just do everything!
14:53:10 <gsams> yboston++ what they said
14:53:11 <yboston> I never thought of that :)
14:53:57 <rfrasur> With regard to the contribute page...is there news on the new website rollout?
14:54:07 * rfrasur didn't go to the last meeting
14:54:55 <rfrasur> bshum?
14:55:48 <bshum> rfrasur: Right, so the new website.  I was originally thinking to put it up last night, but then I didn't want to disrupt the DIG meeting today.
14:55:57 <kmlussier> bshum++
14:56:00 <bshum> My plan was to poke it a bit more tonight.
14:56:31 <rfrasur> bshum++ # ask and ye shall receive and all that
14:56:38 <bshum> One thing that's going to happen for awhile is that we'll be "in transition" for a bit.  But I'll be trying to pick out more prominent ways of getting people around.  Like quick marking a link to the wiki, docs, etc.
14:56:46 <bshum> It'll be an ongoing process.
14:57:09 <dbs> rfrasur: sorry, I fell back on the paradigm of _every other piece of software in existence_ that uses F1 for help :)
14:57:12 <rfrasur> of course
14:57:27 <yboston> bshum:  I am out of the loop, what do you mean "getting people around. "
14:57:32 <yboston> (in the new site)
14:57:47 <kmlussier> Navigation?
14:57:50 <rfrasur> dbs++ #very glad it was that and not a change in function keys
14:58:16 <bshum> Right, as regards to navigation.
14:58:33 <bshum> With splitting apart the wiki from the rest of the website, navigation between sites will be a little different.
14:59:09 <yboston> bshum:  thanks
14:59:39 <rfrasur> bshum: ty :-)
14:59:40 <yboston> we have hit the our mark. we can wrap up or keep going a little bit longer. I would like to do a quick recap
14:59:44 <yboston> either way
15:01:29 <rfrasur> I'd say recap away
15:01:36 <GHamelin> me too
15:02:02 <yboston> #idea Peopel are interested in a survey, we can brainstorm on the list
15:02:14 <yboston> #idea We think we should clean up the DIG welcoming page and contributing page
15:02:25 <yboston> #idea We like to try online training for DIG procedures and Asciidoc.
15:03:03 <yboston> #idea (separate from DIG) I would like to offer experimentation time for beginners on the IRC channel
15:03:17 <yboston> thoughts?
15:04:28 <rfrasur> Are you refering to the Documentation list to brainstorm for the survey?
15:04:36 <kmlussier> Can I add an idea about using Launchpad for tracking doc needs or was there not a consensus on that?
15:04:55 <rfrasur> +1 for LP use
15:05:34 <kmlussier> #idea We think Launchpad may be a better way for tracking doc needs that new volunteers can begin work on.
15:05:50 <yboston> rfrasur: yes I meant the DIG list
15:05:51 * kmlussier also plans to respond to yboston's e-mail on that topic.
15:05:59 <GHamelin> +1 for all the ideas
15:06:24 <kmlussier> yboston: There are a lot of ideas here. Should some of us take some specific ideas to work on so that you aren't doing it all yourself?
15:06:35 <yboston> kmlussier:  sure
15:06:48 * kmlussier can work on DIG welcoming and contribution page if nobody else wants it.
15:06:49 * rfrasur will begin working up ideas for the survey
15:07:05 <kmlussier> So that I can wear my webteam and DIG hat at the same time. :)
15:07:10 <yboston> kmlussier:  about your ideas for launchpad, did you want to say smelting now or reply to my original email?
15:07:32 <rfrasur> kmlussier: I'd be willing to work with you on that.  If you'd give direction...or need help.
15:07:56 <rfrasur> on the welcome/contribution page, that is
15:08:17 <kmlussier> yboston: I was just thinking of supporting its use as the primary way to track our doc needs.
15:08:32 <yboston> kmlussier:  I see
15:09:45 <yboston> #action  kmlussier can work on DIG welcoming and contribution page if nobody else wants it.
15:09:58 <yboston> #action  rfrasur will begin working up ideas for the survey
15:10:49 <yboston> #action Ybsoton will work on preparing online DIG training: DIG procedures and AsciiDoc
15:11:22 <yboston> #action yboston as part of DIG and the EOB will try to promote some IRC training and experimentation opportunities for the community
15:11:42 <yboston> any other comments or questions?
15:11:46 <rfrasur> when we get there...(I know we actually past it already), I was wondering if there'd been a decision about a doc sprint this year...and if so, if there was a topic?
15:13:21 <yboston> rfrasur:  my understanding is that collectively DIG members want a doc sprint this year, though we don't always have a topic
15:14:04 <yboston> I was planning on wrapping up the meeting soon, just because we are past an hour and that is what we were planning to do, but I can keep going
15:14:22 <rfrasur> no, that's okay.  I was just curious where it was at.
15:14:33 <rfrasur> we can save it for next time.
15:14:41 <yboston> I also sent out an email to the DIG list about the doc sprint but got no replies so far
15:14:47 <kmlussier> I think we can wrap up. My agenda topic is getting discussion on this list, so it can continue there.
15:15:03 <yboston> ok folks, this was great
15:15:08 <kmlussier> yboston: I don't remember seeing that e-mail.
15:15:14 <rfrasur> yboston++
15:15:27 * rfrasur only just subscribed to the doc list today
15:15:32 <yboston> kmlussier:  that is concerning. i definitely wrote something, maybe I forgot to hit send
15:15:41 <rfrasur> a resend?
15:15:52 <yboston> I will resend
15:15:53 <kmlussier> Looking in the  archives now just to be sure.
15:16:09 <kmlussier> It's there. I just missed it. :)
15:17:01 <kmlussier> http://markmail.org/message/qrcxvwm5gaapfg2y
15:17:03 <yboston> I can resend it just the same, or just reply to it to get it going again?
15:17:31 <yboston> #endmeeting