13:01:19 <kmlussier> #startmeeting Evergreen Web Team meeting, 2013-08-15
13:01:19 <pinesol_green> Meeting started Thu Aug 15 13:01:19 2013 US/Eastern.  The chair is kmlussier. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:19 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:01:19 <pinesol_green> The meeting name has been set to 'evergreen_web_team_meeting__2013_08_15'
13:01:20 <graced> yes ma'am
13:01:35 <kmlussier> We need to get through this meeting in an hour because the EOB is meeting at 2 p.m.
13:01:43 <kmlussier> #info agenda is at http://evergreen-ils.org/dokuwiki/doku.php?id=webteam:meetings:agenda:2013-08-15
13:01:50 <gmcharlt> kmlussier++ # endurance
13:01:58 <kmlussier> #topic Introductions
13:02:00 <moodaepo> kmlussier++
13:02:08 <kmlussier> Everyone can introduce themselves with the #info command.
13:02:17 <kmlussier> #info kmlussier is Kathy Lussier, MassLNC
13:02:19 <gmcharlt> #info gmcharlt = Galen Charlton, Equinox
13:02:25 <moodaepo> #info moodaepo is Anoop Atre, ESI
13:02:32 <graced> #info graced is Grace Dunbar, Equinox Software
13:02:36 <kbutler> #info kbutler is Kate Butler, Rodgers Memorial
13:02:39 <RoganH> #info RoganH = Rogan Hamby, SCLENDS
13:02:50 <CarrieC> #info Carriec is Carrie Curie, PALS
13:02:50 <bshum> #info bshum is Ben Shum, Bibliomation
13:03:16 <rfrasur> #info rfrasur is Ruth Frasur, Hagerstown Library/Evergreen Indiana
13:03:56 <kmlussier> Ok, let's move on and people can keep introducing themselves as they arrive.
13:04:03 <afterl> #info afterl is Amy Terlaga (guest)
13:04:14 <kmlussier> #topic Action items from last meeting
13:04:32 <kmlussier> #info action items were (a) moodaepo to e-mail link to test site to the list for feedback, (b) StephenGWills to work on member directory/map for web site. (c) hbrennan and kmlussier to work on layout/design issues for downloads page. (d) kmlussier will send out another Doodle to schedule a regular meeting time.
13:05:01 <kmlussier> moodaepo: Your action item is up first. Anything to report?
13:05:32 <moodaepo> kmlussier: bshum is the man with the test server plan. I haven't emailed it out yet but if he gives the go ahead I will do so today.
13:05:51 <kmlussier> ok, bshum will be giving an update further down in the agenda.
13:05:54 <bshum> kmlussier: It's an old agenda item, we're probably past test server at this point.
13:06:06 <moodaepo> bshum++
13:06:36 <kmlussier> StephenGWills isn't here, so let's table his action item until we see him again.
13:07:26 <kmlussier> For my action items, I made contact with hbrennan on downloads page, but my vacation got in the way. We'll touch base and report back to the web team list.
13:07:45 <kmlussier> And I obviously sent a Doodle poll to set a date for this meeting. :)
13:08:04 <rfrasur> kmlussier++
13:08:09 <kmlussier> #info action item from last meeting Rogan_ to send e-mail to general list seeking volunteers for content editors / website librarians.
13:08:20 <kmlussier> Which he did - http://markmail.org/message/bekrw4m7w2ttnktf
13:08:40 <RoganH> It was not a marvel of modern literature but it accomplished the goal.
13:08:52 <RoganH> We've had some wonderful interest pop up, some of whom have joined us here today.
13:08:53 <kmlussier> And we can talk more about the content editors later in the meeting, but I see some new names here.
13:08:58 <kmlussier> Welcome!
13:09:48 <RoganH> When we get to the content section maybe introductions and discuss interests there?
13:09:54 <kmlussier> RoganH: I also received an e-mail from Gordana saying she is still interested, but wasn't able to attend today.
13:10:13 <RoganH> That's good, then.  Schedules won't always permit of course.
13:10:19 <kmlussier> #topic Update on Word Press conversion.
13:10:21 <kmlussier> bshum?
13:10:39 <bshum> So, the Wordpress conversion was supposed to happen at the end of July (two weeks ago)
13:11:01 <bshum> But I'll admit failure on my part to follow through due to varying circumstances.  (like broken internets and power outages)
13:11:19 <bshum> Along the way, I've been finding more things to convert and changeover as I go too.
13:11:20 <RoganH> Obviously, those are beyond your control.
13:11:43 <bshum> One thing that's still outstanding is dealing with meeting minutes, but I have some ideas on that which I presented to gmcharlt and moodaepo.
13:12:19 <bshum> The downloads page is still under construction, but I think we'll have to build something temporary based on existing conventions until kmlussier and hbrennan (and others?) work out some new ideas for that.
13:12:58 <hbrennan> I believe StephenGWills had ideas as well
13:13:51 <kmlussier> I haven't seen StephenGWills around lately, but he's on the web team list. Maybe if we kick off the discusison there, he'll chime in.
13:14:21 <RoganH> StephenGWills has been pretty busy.  I chatted with him last night so he is around and popping into IRC.
13:14:39 <bshum> In the meantime, I'd like to set a new transition date to aim for (and hopefully do)
13:14:58 <bshum> I'm working around some hectic scheduling of my own.
13:15:01 <kmlussier> bshum: What would be a good transition date?
13:16:01 <bshum> kmlussier: Realistically I'm going to beg for some leeway here and ask for perhaps next weekend.
13:16:20 <gmcharlt> +1 # no need to beg, though
13:16:22 <bshum> Like... err, August 25?
13:16:28 <RoganH> We're not under the gun, do you want to go into September?
13:16:37 <kmlussier> What gmcharlt said. You're volunteering your time - no begging required. :)
13:16:52 <rfrasur> bshum: RoganH's suggestion is good.  I'd also +1 for September
13:17:25 <kmlussier> September is good. The only thing we're under the gun for is the conference web page, which was waiting on the Wordpress conversion.
13:17:40 <RoganH> You have a lot on your plate, why don't you take some buffer room or do you feel like you need a tight deadline for masochistic reasons?
13:17:55 <rfrasur> kmlussier: When do you REALLY want the conference web page up?
13:17:56 <kmlussier> But if the conversion is a bigger time commitment than expected, we can pursue alternate plans for the conference web site if we have to.
13:18:48 <kmlussier> rfrasur: Well, our timeline said August 1. But, with the delay in the contrac signing, we wouldn't have been ready then anyway.
13:19:16 <rfrasur> gotcha.  Would September 1 be okay?
13:19:29 <kmlussier> But with program solicitations happening beginning of September and registration starting soon after, we'll really need something in September.
13:19:36 <kmlussier> Yes, September 1 works.
13:19:50 <rfrasur> bshum: does that give you comfortable cushion?
13:19:53 <bshum> Alright, I'll set myself a working date for then.
13:19:59 <kmlussier> bshum: Are there any things people can help with? I know moodaepo is already helping.
13:21:01 <bshum> kmlussier: Yes, moodaepo has been helpful.  I think too many cooks could complicate matters, but I'll probably be running some more transition questions out to folks.  I'll use the team list instead so that folks know what's happening perhaps?
13:21:04 <bshum> (and can contribute)
13:21:22 <kmlussier> Sounds good
13:21:23 <bshum> Oh, one tidbit of course
13:21:55 <bshum> I'm still playing around with finding more themes that'll work with Wordpress.
13:22:10 <bshum> The big thing that's been a stumbler has been finding ones that work with no-JS
13:22:37 <bshum> Though with Firefox 23 removing the option for no-JS and setting everybody back to using it, I have wondered about that limitation long-term.
13:23:05 <RoganH> I personally don't see many users living without JS.
13:23:10 <RoganH> Very, very few.
13:23:15 <bshum> Maybe given the new timeline, if moodaepo gets around to sending out the link to the test site, we can solicit ideas for improving the existing theme or picking some new ones.
13:23:43 <bshum> #link Link to current test site for notes: http://wp.evergreen-ils.org
13:23:45 <gmcharlt> I was one of the ones who had a expressed a non-JS concern -- but the main issue was that (IIRC) one of the initial themes that was tested *completely* failed to work without JS
13:24:09 <moodaepo> bshum: I can send out the link and maybe the couple of themes we've looked at also but require javascript for full functionality
13:24:16 <gmcharlt> as no, no content was rendered
13:24:17 <bshum> gmcharlt: Right, that was an unfortunate bad theme.
13:24:40 <kmlussier> I think it's fine to use a theme with javascript as long as it doesn't totally fail with no javascript.
13:24:48 <bshum> But I know I've ruled out tons of other themes because of tiny glitches with the menu rendering in no-JS browsers.
13:25:08 <bshum> If we're okay with some level of quirks, I guess that's my question.
13:25:16 <RoganH> I think so long as content is largely accessible but we lose some bells and whistles if JS isn't present I'm ok with that compromise.
13:25:17 <bshum> As long as it's not a blank page.  Of course.
13:25:18 <bshum> :D
13:25:29 <gmcharlt> bshum: I'm fine with some quirks, and I apologize if I inadvertantly pushed you down a garden path
13:25:43 <kmlussier> I think quirks are okay.
13:25:49 <RoganH> I think most designers expect Javascript and absolutely none will paint us into a corner.
13:26:21 <kmlussier> #agree New transition date for WordPress conversion is September 1.
13:26:38 <kmlussier> Anything else on the WordPress switchover?
13:27:19 <kmlussier> #topic Content editors / website librarians
13:27:27 <kmlussier> RoganH: Do you want to start us off on this topic?
13:27:41 <RoganH> I'd like to start off by welcoming our new participants.
13:28:08 <RoganH> I put out a call for fresh blood saying that this was a good place for people looking to contribute to make a real impact on the community.
13:28:28 <RoganH> One thing I asked each to do was think a little bit about what they would like to do on the website.
13:28:28 <georgerc> Hi. Sorry to pop in late. I'm George in La Conner, WA.
13:28:39 <RoganH> So, I'd like to give them a moment to introduce themselves.
13:28:58 <RoganH> And maybe say something about what their interests are and how they feel their skills will work as a part of the web team.
13:29:19 <RoganH> Don't be shy.  :)
13:29:29 <moodaepo> georgerc: Welcome and want to take RoganH up on introducing yourself :)
13:29:43 <georgerc> (thinking)
13:30:20 <georgerc> I'm interested in helping out wherever I can. My main strengths are in adding and updating content.
13:31:20 <RoganH> While folks are thinking I wanted to say that one of things we need to do, and will probably need to do on list is start divying up the web site to assign editors.
13:31:24 <bradl> just wanted to say we've come a long ways on the website --> http://web.archive.org/web/20041129173704/http://www.open-ils.org/
13:31:28 <bradl> yousa_guys++
13:31:49 <RoganH> Yousa is right. :)
13:31:57 <kmlussier> bradl++
13:32:02 <rfrasur> bradl++
13:32:11 <RoganH> And what the interests of the possible editors are will influence how we decide to do those divisions.
13:32:21 <CarrieC> Hi, I am new to evergreen (less than a year), so I have experience finding things with no ideas as to where they are (or were)
13:32:58 <moodaepo> Thanks georgerc CarrieC or anyone else?
13:33:07 <rfrasur> CarrieC++ #an essential skill
13:33:19 <kbutler> We just transitioned to Evergreen in May, so we are (at least I am) looking for ways to get involved with the community in general.
13:33:24 <hbrennan> hbrennan is Holly Brennan, Homer Public Library, Alaska
13:33:25 <georgerc> I'm new to libraries, so I'm not picky. I've done software documentation before, as well as some technical writing, so looking at a list of what needs to be done would be best for me.
13:33:41 <hbrennan> I have attended a few mtgs, but our library just went live with Evergreen in March
13:33:50 <RoganH> I have a proposal.
13:33:52 <graced> Since I am generally involved in development I think I can help with the developer-y areas and make things more lay-person friendly where necessary.  I can also assist with vendor page - in fact, I think I promised kmlussier I would do that.
13:34:03 <kbutler> One thing that has been hard for us is the scattered nature of some of the info.  It has been tough finding exactly what we want in many cases.
13:34:03 <hbrennan> I can contribute with my newbie view as well
13:34:18 <kmlussier> graced: Yes, you did. And I haven't forgotten. :)
13:34:19 <RoganH> I will come up with a completely arbitrary and only somewhat random way to divide up the site into editorial categories.
13:34:27 <RoganH> I can post that to the list and we can start picking it apart.
13:34:45 * graced will never escape kmlussier's grasp
13:34:58 <rfrasur> I like the "completely arbitrary" designation
13:35:20 <kbutler> RoganH: completely arbitrary is a legitimate starting place. :D
13:35:28 <RoganH> That would give us a starting place, however flawed it might (and is likely) be.
13:35:32 <kmlussier> RoganH: At the last meeting, was there a mention of one Super-Editor who would do the divvying with other content editors who take charge of certain spots?
13:35:44 <kmlussier> RoganH: Or are you volunteering to be that super editor.
13:35:47 <RoganH> kmlussier: yes, an editor in chief.
13:36:14 <RoganH> I will take that role if we need someone to organize but I don't feel an emotional attachment to the role.
13:36:53 <RoganH> And I think part of that should be trying to hold an ongoing dialogue with the community about the role and voice of the website.
13:37:01 <RoganH> Much like an editor in chief does with the owners of a paper.
13:37:31 <georgerc> That's a great idea. Is there a "how are we doing" page?
13:38:18 <RoganH> That's something we've talked about in broader strokes.
13:38:30 <RoganH> More introductory information, some PR / advocacy kind of element.
13:38:40 <RoganH> I'm of the opinion we should do more in that arena.
13:38:46 <hbrennan> Just a simple change to this line on the website would be good: For info, send email to webteam@evergreen-ils.org
13:38:58 <hbrennan> add "and questions/comments"
13:39:16 <rfrasur> good idea, hbrennan
13:39:35 <hbrennan> I don't want to use that email unless I feel I have important info to tell the group about
13:40:24 <georgerc> The less work they have to do the better, and more likely we'll get feedback.
13:41:18 <kmlussier> BTW - at this time, I think I'm the only person who receives e-mail from that address. Should we point people to the web team listserv instead?
13:41:28 <RoganH> +1 to sending the email to the listserv
13:41:36 <RoganH> So it can be a collaborative response.
13:41:46 <rfrasur> +1 also for sending to listserv
13:41:50 <graced> +1
13:41:54 <kbutler> +1
13:42:20 <kmlussier> OK, I'll update that page when we're done.
13:42:30 <rfrasur> I'm not sure the amount of burden that it is for you right now kmlussier, but hopefully with more people using it...it WOULD be...but won't be...providing it's going to listserv instead of your inbox
13:42:52 <RoganH> Hopefully we are going through a transition to get more people involved in every aspect.
13:43:04 <rfrasur> 'xactly
13:43:28 <hbrennan> Speaking of listservs, I found it hard to find the place to sign up
13:43:34 <kmlussier> Honestly, that was switched over to me a few weeks ago, and I've received nothing.
13:44:01 <hbrennan> It would be great to have one very small page with all the opportunities to sign up for lists
13:44:15 <hbrennan> without too much info on the groups
13:44:16 <RoganH> It's difficult, there is a list of the listservs but I don't think the web one is on it.
13:44:27 <RoganH> You can guess it and the url manually resolves.
13:44:34 <kmlussier> http://evergreen-ils.org/listserv.php
13:44:34 <hbrennan> I don't think I'm even on the Web one...
13:44:46 <kmlussier> Web team should be there.
13:44:59 <hbrennan> Ahhh.. I expected it to be with Contribute, not Communicate
13:45:54 <kmlussier> We have about 15 minutes left.
13:45:56 <bshum> It's there too
13:46:01 <georgerc> Web team is there, but how to join? (I only see archives)
13:46:35 <rfrasur> I think it's just a matter of sending an email with SUBSCRIBE in the subject...but that should be documented.
13:46:43 <hbrennan> Could this page be linked under Contribute as well? Reworded as "Sign up!" or something
13:46:45 <bshum> hbrennan: Under contribute --> join committees & working groups (which leads you to a wiki page, that leads you to the webteam wiki page, which has a link to the mailing list)
13:46:47 <kmlussier> georgerc: Ah, you're right.
13:46:53 <bshum> But that's something I hope to change in the near distant future.
13:47:09 <dbs> Also, the archives page leads to an about this list page which offers the subscribe form.
13:47:13 <kmlussier> The link should be changed to go to the main mailing list page as it does with the others.
13:47:17 <bshum> One of the goals of switching us to Wordpress was cleaning up and consolidating the menus
13:47:43 <bshum> kmlussier: That might be a remnant from when it was a private list controlled by the communications committee.
13:47:47 <dbs> Perhaps the web team was attempting to dissuage anyone from joining :)
13:47:49 * bshum whips a patch to fix that.
13:47:53 <georgerc> thanks, bshum. I have to hop off to open up the library. I'll join the list and look forward to the list of editing categories. Cheers!
13:47:54 <bshum> (later)
13:47:55 <rfrasur> dbs++
13:48:07 <bshum> Yeah, what dbs said :(
13:48:35 <rfrasur> a little bit Hansel and Gretel - a little bit Dorothy.
13:48:57 <kmlussier> Ok, I'm seeing one action item from this discussion for RoganH to break down the web site into editorial categories and send it out to the mailing list. Anything else we need to act on now?
13:50:07 <CarrieC> will we need to check that the subscribe link is on the website?
13:50:22 <kmlussier> #action RoganH will break down the web site into editorial categories and send it out to the mailing list.
13:50:22 <CarrieC> or has bshum made that happen already  :)
13:50:55 <kmlussier> If bshum hasn't made it happen already, I'm sure he will soon. :)
13:51:04 <RoganH> Bshum wrote a perl script to write a bash action to do that while we were still typing.
13:51:11 <kmlussier> I'm going to move on to the next topic since EOB will be here soon.
13:51:29 <kmlussier> #topic Hosting of Conference Web Sites
13:51:30 <rfrasur> bshum++ #bash action (whatever that is)
13:51:34 <kmlussier> RoganH: That's you again.
13:51:45 <RoganH> Quick: SEREC
13:51:53 <RoganH> south eastern regional evergreen conference
13:52:11 <RoganH> What I would like to do is host it on the community site off a subdomain, say souteast2014.open-ils.org
13:52:15 <RoganH> Any objection?
13:52:16 <hbrennan> Thank you for decoding that, RoganH
13:52:34 <RoganH> I would probably use the same template as the main site but maybe different colors and graphics.
13:52:37 <kmlussier> Can it be evergreen-ils.org?
13:52:45 <RoganH> And then keep with the community all the content archived there like presentations.
13:52:48 <kbutler> +1 for hosting. I was sad when I went to find a presentation from the 2012 international conf and the site was gone.
13:53:12 <RoganH> kbutler: I did too.  I think dbs did as well.
13:53:18 <RoganH> kmlussier: no objection
13:53:20 <rfrasur> I'd also like to see it with the evergreen-ils.org, but I really like the idea of the subdomain.
13:53:44 <RoganH> I'm just used to typing in open-ils.org as habit so I think of that url.
13:54:05 <RoganH> Using evergreen-ils.org is fine.
13:54:09 <kmlussier> I have no objections.
13:54:47 <RoganH> Do we need a vote?  :)
13:54:58 <gmcharlt> no objections to RoganH's proposal
13:55:17 <RoganH> No objections so I will assume it's a done deal.
13:55:18 <rfrasur> +1 to hosting the regional conference(s) website(s)
13:55:21 <kmlussier> I don't think we need a formal vote. It looks like everyone's okay with it.
13:55:38 <RoganH> +1 to everyone that agrees with me, about anything
13:55:45 <RoganH> I'm done.
13:55:53 <kmlussier> #topic Web Team Meeting dates
13:55:54 <rfrasur> :D
13:55:57 <kmlussier> Real quick.
13:56:06 <kmlussier> My plan was to use the Doodle to set the regular meeting date for the web team.
13:56:21 <hbrennan> I like Doodle +1
13:56:23 <kmlussier> However, if we continue to hold it on the 3rd Thursday of the month, we will always be bumping up against EOB.
13:56:39 <kmlussier> Which means we can never run over. Might be a good thing.
13:56:54 <RoganH> That would make it easier for me to remember, actually. :)  And less possible for my evil calendar to make me miss it.
13:56:56 <kmlussier> Should I take another stab at setting a regular meeting time so that we aren't so close to the EOB meetings.
13:57:09 <hbrennan> As the only Alaskan here, this time works for me
13:57:16 <gmcharlt> Alaska++
13:57:46 <RoganH> Seriously my calendar is possessed by a Babylonian trickster deity.  So, +1 to keeping it adjacent to the EOB.
13:57:47 * bshum isn't on the board, so the question is more for folks who are, I think.
13:57:50 <rfrasur> kmlussier: Maybe try another Doodle poll and see how the results come back...and go from there?  Maybe tweak it a little for time frame roominess?
13:57:52 <hbrennan> I'm flexible on days, but I can't go much earlier than 2pm Eastern
13:57:57 <kmlussier> RoganH, gmcharlt, and I are the only ones who need to be at both. I don't mind doing two meetings in a row.
13:57:59 <hbrennan> or 1pm
13:58:27 <kmlussier> rfrasur: Yeah, it was already tweaked for time zones. 1-4 p.m. EDT is what I was shooting for.
13:58:29 * rfrasur likes this time though
13:58:41 <kmlussier> Let's stick with this time then and just make sure we don't get chatty.
13:58:44 <kmlussier> And with that...
13:58:46 <bshum> +1
13:58:48 <kmlussier> #endmeeting