#evergreen: Developer Meeting 2013-08-27

Meeting started by senator at 14:04:22 US/Eastern (full logs).

Meeting summary

  1. Introductions (senator, 14:04:40)
    1. kmlussier is Kathy Lussier, MassLNC (kmlussier, 14:04:58)
    2. senator = Lebbeous Fogle-Weekley, Equinox Software (senator, 14:04:58)
    3. jeffdavis = Jeff Davis, Sitka (jeffdavis, 14:05:10)
    4. eeevil = Mike Rylander, ESI (eeevil, 14:05:11)
    5. RoganH = Rogan Hamby, SCLENDS (RoganH, 14:05:12)
    6. dbwells = Dan Wells, Hekman Library (Calvin College) (dbwells, 14:05:22)
    7. csharp = Chris Sharp, GPLS (csharp, 14:05:23)
    8. agenda is at http://evergreen-ils.org/dokuwiki/doku.php?id=dev:meetings:2013-08-27 (kmlussier, 14:05:24)
    9. remingtron Remington Steed, Hekman Library (Calvin College) (remingtron, 14:05:24)
    10. phasefx = Jason Etheridge, ESI (phasefx, 14:05:29)
    11. Dyrcona = Jason Stephenson, MVLC (Dyrcona, 14:05:35)
    12. jeff = Jeff Godin, Traverse Area District Library (TADL) (jeff, 14:05:39)
    13. bshum = Ben Shum, Bibliomation (bshum, 14:05:48)

  2. Action items from the last meeting (senator, 14:06:15)
    1. berick Bill Erickson ESI (berick, 14:06:25)
    2. paxed = Pasi Kallinen, Regional Library of Joensuu (paxed, 14:06:33)
    3. 1. gmcharlt was to cut opensrf 2.2.1 (senator, 14:06:48)
    4. ldwhalen = Liam Whalen, Sitka (ldwhalen, 14:07:35)
    5. ACTION: gmcharlt to release opensrf 2.2.1 soon(?) post-vacation (senator, 14:09:18)
    6. 2. berick and eeevil to release 2.3.9 and 2.4.1 (senator, 14:09:35)
    7. ACTION: csharp to test 2.4.2 rc so we can officialize it (senator, 14:11:28)
    8. last meeting's actual action items: (senator, 14:13:06)
    9. 1. start on 2.6 dev road map (senator, 14:13:14)
    10. 2. bshum to summarize bug tracking based on feedback from developers (senator, 14:14:40)
    11. the first set of previous meeting's action items were the right ones (senator, 14:16:51)
    12. ACTION: senator to find old incomplete action items to move forward (with help from the channel in making sure i get the right ones) ;-) (senator, 14:17:40)
    13. gsoc reports (senator, 14:17:50)
    14. student missing, doesn't look good (senator, 14:21:17)
    15. http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/dmitriye/dashboard (bshum, 14:21:57)
    16. see IRC logs for this date for link to work done before midterms (senator, 14:22:19)
    17. qa topics (senator, 14:23:11)

  3. qa topics (senator, 14:23:55)
    1. general interest in easing into qa practices demonstrated by phasefx, phasefx to hold hands with everyone, especially through the mailing list (senator, 14:29:39)
    2. ACTION: eeevil to commit a techref doc (senator, 14:30:02)

  4. db maintenance plan (senator, 14:32:03)
    1. ACTION: eeevil to put a more detailed plan on the mailing list to structure further discussion of pros and cons (senator, 14:42:44)

  5. hack-a-way 2013 plans (senator, 14:44:15)
    1. There are a total of 14 attendees + 2 from Calvin. (dbwells, 14:45:19)
    2. voluntary self-publication of attendee names here: http://evergreen-ils.org/dokuwiki/doku.php?id=dev:hackfest:hackaway-2013 (senator, 14:49:03)
    3. bshum and RoganH have the ideas and recent experience for running a G+ hangout for this kind of event (senator, 14:51:48)


Meeting ended at 14:58:27 US/Eastern (full logs).

Action items

  1. gmcharlt to release opensrf 2.2.1 soon(?) post-vacation
  2. csharp to test 2.4.2 rc so we can officialize it
  3. senator to find old incomplete action items to move forward (with help from the channel in making sure i get the right ones) ;-)
  4. eeevil to commit a techref doc
  5. eeevil to put a more detailed plan on the mailing list to structure further discussion of pros and cons


Action items, by person

  1. csharp
    1. csharp to test 2.4.2 rc so we can officialize it
  2. eeevil
    1. eeevil to commit a techref doc
    2. eeevil to put a more detailed plan on the mailing list to structure further discussion of pros and cons
  3. senator
    1. senator to find old incomplete action items to move forward (with help from the channel in making sure i get the right ones) ;-)


People present (lines said)

  1. senator (90)
  2. eeevil (41)
  3. phasefx (25)
  4. dbwells (23)
  5. csharp (20)
  6. Dyrcona (17)
  7. bshum (17)
  8. jeff (13)
  9. kmlussier (9)
  10. berick (8)
  11. pinesol_green (5)
  12. RoganH (3)
  13. ldwhalen (3)
  14. jeffdavis (2)
  15. remingtron (2)
  16. paxed (1)


Generated by MeetBot 0.1.4.