14:00:56 <yboston> #startmeeting 2013-09-05 - DIG Monthly Meeting Evergreen Documentation Interest Group (DIG) Monthly Meeting.
14:00:56 <pinesol_green> Meeting started Thu Sep  5 14:00:56 2013 US/Eastern.  The chair is yboston. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:56 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:56 <pinesol_green> The meeting name has been set to '2013_09_05___dig_monthly_meeting_evergreen_documentation_interest_group__dig__monthly_meeting_'
14:01:28 <yboston> The agenda can be found here http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:dig_meeting_20130907-agenda
14:01:38 <yboston> #topic Introductions
14:01:39 <yboston> Please feel free to start introducing yourselves...
14:01:39 * yboston is Yamil Suarez @ Berklee college of Music - DIG meetings facilitator
14:01:50 * krvmga is jim keenan, c/w mars
14:01:56 * rsoulliere is Robert Soulliere, Mohawk College
14:02:04 * rfrasur is Ruth Frasur, EG-IN/Hagerstown Library
14:02:38 * akilsdonk_ is Angela Kilsdonk, Equinox
14:02:57 * kbutler is Kate Butler, Rodgers Memorial
14:02:57 * kmlussier is Kathy Lussier, MassLNC
14:05:05 <yboston> I think we can proceed for now
14:05:42 <yboston> BTW, I just sent an email to the DIG list with some survey related links for a topic I want to address at some point
14:05:51 <krvmga> got it
14:06:21 <yboston> #topic Updates from Content Coordinators
14:06:21 <yboston> We will continue having the content corrdinators try out the "#topic" AND "#info" Meetbot commands for their reports
14:06:23 <yboston> So content coordinators, please use "#topic" for the first post/line of your report
14:06:24 <yboston> then use "#info" for every other chat post/line of your report.
14:06:26 <yboston> for example...
14:06:27 <yboston> #topic this is a test report first post/line
14:06:28 <yboston> #info this is a test report second post/line
14:06:29 <yboston> Again, for everyone else participating in the meeting, don't worry about using any Meetbot commands, participate normally
14:07:01 <kmlussier> Sorry, I don't have anything to report again. I've been really busy the past couple months with other activities.
14:07:31 <yboston> no worries, you are leading the way for the next conference among other things
14:07:33 <kmlussier> But with the 2.5 beta release on the horizon, I'm sure I'll have more to report at the next meeting. :)
14:07:54 <yboston> kmlussier:  are you going to the hack-a-way in September?
14:08:12 <kmlussier> yboston: Yes, I'll be there.
14:08:27 <yboston> me too
14:08:54 <yboston> rsoulliere:  did you have anything to comment on or report? it is OK if you don't
14:09:06 <rsoulliere> I have a little bit to report
14:09:12 <yboston> go ahead
14:09:12 <rsoulliere> #topic Conversion Coordinator Report
14:09:19 <rsoulliere> #info Generated a database schema doc for 2.4.
14:09:28 <rsoulliere> #info See: http://docs.evergreen-ils.org/2.4/schema/
14:09:37 <rsoulliere> #info  Moved the 2.2 docs link under "Older Versions" since it has been deprecated.
14:09:43 <rsoulliere> #info See: http://docs.evergreen-ils.org/
14:09:49 <rsoulliere> That is all.
14:10:03 <kmlussier> rsoulliere++
14:10:17 <rfrasur> wow
14:10:24 <rfrasur> rsoulliere++
14:10:27 <krvmga> rsoulliere++
14:10:35 <yboston> rsoulliere++
14:10:53 <rsoulliere> Does anyone have any feedback on the schema doc?
14:11:19 <yboston> not right now, but I will look at it later
14:11:28 <krvmga> i just started glancing at it
14:11:39 <rsoulliere> It used to be in tables included in the main docs, but I found it quite huge and increased the size of the documentation considerably.
14:11:59 <yboston> rsoulliere:  I do have a request for you if there are no other questions for you
14:12:14 <yboston> at this point
14:13:35 <yboston> rsoulliere:  So I would love to see a link to "Evergreen in action" information/PDFs from that page you just updated
14:13:58 <yboston> though "Evergreen in action" is slowly getting outdated, which is another topic
14:14:53 <rsoulliere> yboston, OK... true about the shelf-life of "EG in Action".
14:15:24 <yboston> what version did it target? EG 2.3?
14:15:31 <kmlussier> Yes, 2.3.
14:15:32 <krvmga> 2.3
14:15:41 <yboston> how time flies
14:15:47 <rsoulliere> A strategy to keep it updated long-term got lost in the shuffle.
14:15:58 <yboston> any other questions or comments for rsoulliere?
14:16:07 <kmlussier> On the Evergreen 2.4 doc needs, I identified the items that needed updating in Evergreen in Action.
14:16:09 <kmlussier> http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:2.4_needs
14:16:20 <yboston> kmlussier++
14:16:23 <rsoulliere> kmlussier++
14:16:45 <krvmga> kmlussier++
14:16:53 <kmlussier> There were only three items, but nobody has done documentation on those three items.
14:16:53 <yboston> we can definitely revisit updating "Evergreen in action" going forward
14:16:54 <rfrasur> kmlussier++
14:17:04 <kmlussier> I could probably do the Vandelay default Match set very easily.
14:18:07 <yboston> should we switch to "old business" or do we want to continue as we are for now?
14:19:57 <kmlussier> +1 to switching to old business.
14:20:38 <yboston> moving on
14:20:48 <yboston> #topic DIG hack-a-way planning
14:21:07 <yboston> there was some excellent feedback on the mailing list
14:21:23 <yboston> like doing the asciiDoc training before hand
14:21:41 <yboston> and shooting for November dates at this point
14:22:07 <yboston> any volunteers to wrangle dates?
14:22:16 <yboston> like set up a doodle poll?
14:22:38 <yboston> I can work on the asciidoc training, and would welcome collaborators
14:23:05 <rfrasur> I don't mind to set up a doodle poll, but I'd need a little more info
14:23:15 <krvmga> i was surprised i couldn't find any video tutorials.
14:23:25 <krvmga> that's why i offered to do some
14:23:27 <yboston> the internet will thank us later
14:23:40 <rfrasur> like, how long is it going to be?  has the location been nailed down?
14:23:41 <yboston> rfrasur:  what info can we provide to you?
14:24:07 <yboston> rfrasur:  the only time we did it
14:24:17 <rfrasur> are we aiming for a midweek? weekend?
14:24:19 <yboston> we met up at around 9:00 AM EST and wrapped up
14:24:26 <yboston> around 5 PM EST
14:24:32 <kmlussier> rfrasur: Definitely not a weekend.
14:24:42 <rfrasur> so, one day.  kmlussier++
14:25:00 <yboston> usually only some people can do a weekend
14:25:05 <yboston> or want to anyway
14:25:13 * rfrasur wouldn't want to
14:25:21 <yboston> me too
14:25:57 <yboston> rfrasur:  I would pick some single days in November
14:26:06 <yboston> that work for you, as a starting point
14:26:18 <rfrasur> Okay, will do.  I'll have it ready tomorrow.
14:26:36 <yboston> what out for  US Thanksgiving dates :)
14:27:10 <rfrasur> yep...and I'll look around to make sure there aren't international things we might not know about...and election day and all that jazz.
14:27:27 <yboston> now that I think about it, I could use some feedback on went to provide asciidoc training, like what day, time of day, etc?
14:27:54 <yboston> I also think, we might need more than one round of doodle polls to learn about special dates
14:27:55 <rfrasur> Do you want to wait until we get some feedback regarding the hackaway?
14:28:01 <yboston> the first time around
14:28:22 <rfrasur> okay
14:28:35 <rfrasur> so, we'll start purposefully broad and then narrow it with a second round.
14:29:41 <yboston> rfrasur:  my IRC client is messing up the order of responses, so I am not sure what you mean by waiting for feedback
14:30:21 <rfrasur> oh, do you want to wait until we get some feedback for the actual dates of the hackaway before you decide on dates for the asciidoc training?
14:31:06 <yboston> aha, yes that make sense
14:31:13 <yboston> (makes)
14:31:30 <rfrasur> I can have the first round poll out by Monday at the very latest....so you could have plenty of lead time.
14:31:43 <rfrasur> well...some lead time.
14:31:45 <rfrasur> :D
14:32:14 <yboston> #action rfrasur  will set up at least one doodle poll to find some dates
14:33:21 <yboston> #action yboston  will start preparing for asciidoc training, and collaborators, or Guinea pigs welcome
14:33:41 <yboston> rfrasur: thanks
14:33:53 <rfrasur> mp
14:34:01 <yboston> any other DIG hack-a-way comments, questions?
14:34:26 <yboston> Also, any other good suggestions that I missed front he mailing list comments?
14:36:41 <yboston> shall we move on to another "old business" topic for now?
14:36:46 <rfrasur> yep
14:36:49 <krvmga> yes
14:37:33 <yboston> #topic brainstorming on survey draft
14:38:00 <yboston> I just sent out a survey related email as this meeting started, I will quote it now
14:38:08 <yboston> In the DIG August meeting we talked about wanting to increase DIG  participation. One way to reach that goal that was brought up was creating a DIG survey to better understand reasons why more community members are not participating.
14:38:09 <yboston> A draft survey was created by Ruth, but I wanted to take a step back and make sure we are all on the same page of what we want the goals of the survey to be. I also found a couple of basic sites with tips on survey making I wanted to hare with DIG for this discussion. Feel free to add your own preferred sites about this topic.
14:38:10 <yboston> http://www.howto.gov/customer-experience/collecting-feedback/basics-of-survey-and-question-design
14:38:11 <yboston> http://help.surveymonkey.com/articles/en_US/kb/Design-Tips-How-to-create-and-administer-effective-surveys
14:38:12 <yboston> http://www.surveygizmo.com/survey-blog/designing-surveys/
14:39:23 <yboston> you can visit the links later, but I wanted to speak briefly about goals
14:39:46 <yboston> I had hoped to sue the survey to project some info about DIG, but it seems like that might be a bad idea
14:39:58 <yboston> to do within the survey questions
14:40:28 <rfrasur> yeah...that's generally the case.
14:40:30 <yboston> perhaps we can have a mini statement with some DIG misconceptions in the introductory paragraph
14:41:00 <krvmga> are there many misconceptions?
14:41:10 <yboston> yes, that there are
14:41:19 <yboston> strict membership requirements to join DIG
14:41:43 * rfrasur had that misconception
14:42:02 <krvmga> rly? oh myyyy
14:42:06 <yboston> others have explicitly expressed this to me before
14:42:14 <rfrasur> yeah...but I'm nosy, so it didn't last long
14:42:17 <kbutler> huh
14:43:00 <yboston> so  rfrasur  great draft  survey versions covered question geared to...
14:43:03 <rfrasur> I think the EG community, in general, is a little scary to outsiders.
14:43:08 <yboston> find out what misconceptions folks have about DIG
14:43:20 <yboston> and what is keeping community members from participating
14:43:46 <yboston> I am wondering if you should have the survey only focus on one of those, and just do some public relations on the other, etc
14:43:54 <yboston> or what ever you guys think?
14:44:12 <rfrasur> I'll link the survey.  hold on.
14:44:15 <yboston> I hope I am making sense to some of you?
14:45:06 <krvmga> is there a little list somewhere of low-hanging documentation fruit that beginners could do?
14:45:15 <krvmga> or should we make one?
14:45:32 <yboston> I don;t think so, but I have mentioned before that we need to make one
14:45:50 <rfrasur> https://docs.google.com/forms/d/1nbxmjny0-3xR4ZFTYY5alfwauwgtOntuchcpddQ3ot0/viewform There actually is a little blurb at the beginning (actually, a fairly big blurb)
14:45:52 <yboston> I think that is a big barrier to paritcipation
14:46:13 <kmlussier> krvmga: I think identifying low-hanging documentation fruit (and even high-hanging fruit) was one of the reasons we were having the Launchpad discussion. As a better way to identify what needs to be done.
14:46:31 <rfrasur> yeah, kmlussier is right.
14:46:43 <yboston> another issue is that although something could be called low hanging fruit in terms of documentation
14:47:00 <yboston> you might need to have access to the latex EG versions to properly handle that fruit
14:47:15 <yboston> or you might need a few technical chops, like knowing asciidoc to clean up small things
14:47:22 <rfrasur> yes
14:47:34 <yboston> we are a talented bunch, for being non-develoers :)
14:47:40 <yboston> (developers)
14:47:45 <kmlussier> Do we still have current versions of Evergreen on community servers?
14:48:00 <yboston> except Kathy who has learned to do almost all (docs and dev)
14:48:16 <yboston> I don't think so,
14:48:40 <kmlussier> Ha! I know very little dev. But thank you anyway. :)
14:48:48 <yboston> BTW, another requirement for a successful DIG hack-a-way is to have a test server at the ready with the concerto data set pre-loaded
14:48:58 <yboston> also for when we try hacking at the conference
14:49:24 <yboston> DIG needs to "run heavy" we finally get rolling
14:49:31 <yboston> when we finally get going
14:50:38 <kmlussier> I can ask edoceo about his community server. I find that he's usually very responsive if anyone has trouble accessing it.
14:51:06 <yboston> he has been in the past, absolutely
14:51:44 <kmlussier> But it might not be a bad idea to have a multiple communtiy server to have available if one is down.
14:51:59 <yboston> to recap, it will benefit us as we try to increase participation to have ...
14:52:14 <yboston> simple tasks for those that want to help, so they hit the ground running
14:52:24 <yboston> we need to have test servers with the most recent version
14:52:51 <yboston> we also need to tag the simple tasks so that we have those that can be addressed with a copy of Microsoft word to create documentation
14:53:05 <yboston> and those that require just a little bit of asciidoc, etc
14:53:31 <yboston> in other words, these are the are some of the reasons there so few of us :)
14:53:41 <yboston> at this point
14:53:44 <rfrasur> for now
14:53:53 <yboston> :)
14:53:54 <rfrasur> it'll get better
14:54:00 <kbutler> Yeah. I do think the #1 thing is to have a very clear on ramp with explicit ideas and steps.
14:54:14 * rfrasur agrees with kbutler
14:54:18 <yboston> yes, and I think it is a natural progression of having a bunch of self taught collaborators
14:54:40 <yboston> but now we need for some of use to adopt a "trainers mentality," to usher in the next wave
14:56:06 <yboston> I am now thinking of the medical school approach to surgeries, etc; see one, do one, teach one
14:56:21 <rfrasur> it seems like a pretty logical progression.
14:56:41 <rfrasur> and might also make pulling people into the community proper a little less necessary.
14:56:48 <yboston> I have seen the debs go through a similar process, for example teaching new members to cut releases
14:57:09 <yboston> they had to go back and write down their procedures to make them reproducible by others
14:57:21 <rfrasur> I mean, of course, we want them...but if we can go out and teach people in our spheres...they can do some stuff and we can act as trainers/mediators.
14:57:29 <yboston> BTW, we are at the 57 minute mark
14:58:06 <yboston> #idea (suggested) requirement for a successful DIG hack-a-way is to have a test server at the ready with the concerto data set pre-loaded
14:59:13 <kmlussier> As far as finding a place to list documentation needs, I would like to suggest that, unless somebody is willing to volunteer time to evaluate the project management options that are available and come up with a recommendation,  we use our existing community tool - Launchpad. Becauswe otherwise we're going to keep talking about it and never getting the needs posted.
14:59:13 <yboston> #idea prepare lists of documentation "low hanging" fruit for new comers and/or attendees tot he DIG hack-a-way
15:00:37 <rfrasur> kmlussier: +1 so at least there can be some movement on it.  If, down the road, a better management tool comes along, we can evaluate it then.
15:01:22 <yboston> for the record, we have used the wiki to list documentation needs and that makes sense to me. Docuemnation bugs I am totally fine that they remain in launchpad
15:01:50 <krvmga> i agree
15:01:56 <yboston> then again, if we want to put most things in Launchpad on the short term, I am fine with that oo
15:01:57 <yboston> too
15:02:57 <yboston> kmlussier:  refresh my memory, do we want to put all documentation needs, big, small, all ; in launch pad or only small ones and doc bugs? (in the original proposal)
15:03:47 <rfrasur> If it's possible to keep as much of it in one area as possible, I think that'd be best.
15:04:09 <krvmga> keep as much of it in one area as possible. yes.
15:04:39 <kmlussier> yboston: I think your original proposal was using LP for error reporting. I think I was expanding it. :)
15:05:03 <ldwhalen> senator: I am starting to work with United Library Services, to try and get some Sitka libraries up and running with EDI and Acq.  They need to know if we are using the X12 or Edifact standards.
15:05:04 <yboston> kmlussier:  actually it was used that way already
15:05:22 <senator> ldwhalen: edifact
15:05:38 <yboston> ldwhalen:  we are just wrapping up a community meeting
15:05:52 <senator> (sorry all)
15:06:07 <yboston> ldwhalen:  we will be done soon, and it might be easier to get your info in about 5 to 15 minutes from now
15:06:07 <rfrasur> (no worries)
15:06:20 <ldwhalen> my appoligies
15:06:28 <yboston> senator++
15:06:37 <yboston> ldwhalen:  none needed
15:07:14 <yboston> so I guess we should reply to Kathy's email to make our votes public so we can move forward as a gorup
15:07:17 <yboston> group
15:07:54 <yboston> should we start wrapping up, and recap and make final comments soon? I can keep going, but it has been an hour so far
15:08:05 <krvmga> i am okay.
15:08:36 <kmlussier> I actually need to finish up here, but don't let it stop the rest of you from discussing.
15:09:15 <rfrasur> I'm okay for a few more minutes.
15:09:20 <kbutler> I'm fine.
15:09:24 <yboston> lets shoot to wrap up, any final comments or questions?
15:10:11 <krvmga> no
15:10:39 <krvmga> yboston++
15:10:50 <rfrasur> yboston++
15:10:57 <kbutler> yboston++
15:11:59 <yboston> OK folks, talk to you guys later
15:12:02 <yboston> #endmeeting