13:02:58 <kmlussier> #startmeeting Evergreen Web Team meeting, 2013-09-26
13:02:58 <pinesol_green> Meeting started Thu Sep 26 13:02:58 2013 US/Eastern.  The chair is kmlussier. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:02:58 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:02:58 <pinesol_green> The meeting name has been set to 'evergreen_web_team_meeting__2013_09_26'
13:03:12 <kmlussier> #info agenda is at http://www.evergreen-ils.org/dokuwiki/doku.php?id=webteam:meetings:agenda:2013-09-26
13:03:21 <kmlussier> #topic Introductions
13:03:30 <bshum> #info bshum = Benjamin Shum, Bibliomation
13:03:32 <kmlussier> Everyone can introduce themselves with the #info command.
13:03:37 <gmcharlt> #info gmcharlt = Galen Charlton, Equinox
13:03:45 <kmlussier> #info kmlussier is Kathy Lussier, MassLNC
13:03:51 <RoganH> #info RoganH = Rogan Hamby, SCLENDS
13:03:55 <StephenGWills> #info Steve Wills, Paine (i mean Maine) Balsam Consortium.
13:04:09 * RoganH thinks he meant Paine
13:04:19 * StephenGWills looks skyward
13:04:34 <ericar> #info ericar is Erica Rohlfs, Equinox
13:05:14 <kbutler> #info kbutler is Kate Butler, Rodgers Memorial
13:05:23 <kmlussier> OK, moving on. Late arrivals can introduce themselves as they come in.
13:05:30 <kmlussier> #topic Action items from last meeting
13:05:40 <kmlussier> #info The one action item was RoganH will break down the web site into editorial categories and send it out to the mailing list.
13:05:46 <kmlussier> RoganH: Status?
13:05:54 <RoganH> I sent it.
13:05:59 <RoganH> No one replied.
13:06:09 <RoganH> I've relinked it in the agenda for today's meeting.
13:06:32 <kmlussier> OK, we'll discuss it later in the agenda.
13:06:45 <kmlussier> #topic Wordpress conversion
13:06:49 <RoganH> I'll chat about it some more then and we can mull over it.
13:07:12 <bshum> Well, the wordpress conversion happened
13:07:12 <kmlussier> bshum++ for the conversion to Wordpress!
13:07:32 <bshum> We're still cleaning things up and arranging things.  But kudos to everyone who's helped step into it already.
13:07:45 <bshum> And thanks to those who helped notice tiny corners we had missed.
13:07:48 <ktomita> #info ktomita = Kyle Tomita, Catalyst IT
13:08:01 <kmlussier> Are there any particular areas where others can help with cleanup?
13:08:12 <kmlussier> #info Wordpress conversion is done.
13:08:33 <kmlussier> #info bshum and others are doing cleanup.
13:08:34 <bshum> Well I think the big things for me is redesigning the "get involved" stuff so that it's not just a leftover from the old "communicate" page
13:08:40 <bshum> And dealing with the downloads page
13:09:19 <bshum> phasefx helped forward me a request to add back a "search" button to the website that looks up all the various page contents.  So that's something too.
13:09:22 <kmlussier> On the "get involved'" section, I was thinking it would be good to link to the committees page, since that's a great way to get involved. But should it be converted to a WordPress page first?
13:09:34 <RoganH> I think it should be, yes.
13:09:45 <RoganH> And reflect different ways for people to get involved rather than channels.
13:09:55 <RoganH> That means that some channels will be duplicated but that's OK.
13:10:19 <bshum> kmlussier: I would agree with that.  Getting us off the wiki pages and into Wordpress would be the most ideal.
13:10:20 <kmlussier> I can take that as an action item. That is, converting the committees page to a WordPress page
13:11:16 <kmlussier> #action kmlussier to convert committes page to a WordPress page so that it can be included in the "get involved" section.
13:11:23 <pinesol_green> [evergreen|Mike Rylander] Bi-directional authority enhanced bib browse - <http://git.evergreen-ils.org/?p=Evergreen.git;a=commit;h=d3b6548>
13:11:24 <pinesol_green> [evergreen|Mike Rylander] Some release notes for browse enhancements - <http://git.evergreen-ils.org/?p=Evergreen.git;a=commit;h=96e1a74>
13:11:25 <pinesol_green> [evergreen|Lebbeous Fogle-Weekley] Numbering upgrade script for auth-only-bib-auth-browse-signoff - <http://git.evergreen-ils.org/?p=Evergreen.git;a=commit;h=e1e4198>
13:12:17 <kmlussier> Anything else on the conversion before we discuss the downloads page further?
13:12:58 <kmlussier> #topic Evergreen downloads page
13:13:20 <kmlussier> This was an action item I took on at a previous meeting with hbrennan, but then neglected to follow up on. :(
13:13:29 <kmlussier> bshum: Do you want to talk about this?
13:13:48 <bshum> Sure, so
13:14:15 <bshum> For the downloads page, there'd been some talk about reorganizing the content there.  Specifically, I think we're thinking to move away from the weird table structure we'd been using up till now.
13:14:33 <bshum> By that I mean having three columns (from left to right, new to old versions)
13:14:42 <kmlussier> #link http://evergreen-ils.org/egdownloads/
13:14:44 <bshum> And changing that to be more accessible and/or relevant.
13:15:05 <RoganH> Are you talking about moving each version to it's own table, maybe newest at the top so they're less crowded together?
13:16:03 <bshum> RoganH: Well that's certainly an approach we could use
13:16:19 <bshum> I think the open question has been what's the best way of presenting the information in a meaningful way to end users.
13:16:37 <bshum> (and also cleaning up old links along the way, like the Mac stuff and Linux stuff, which are severely outdated)
13:17:17 <RoganH> I think we can get cleaner but better is going to be very subjective.  I've already betrayed my preference to move each version to it's own table.
13:17:17 <kmlussier> I think the structure RoganH suggests might be good.
13:17:30 <RoganH> I think it would be easier for people quickly trying to find what they're looking for.
13:17:33 <kmlussier> What I also think would be helpful is some color coding for the releases. Maybe green for stable releases.
13:18:12 <graced> #info graced is Grace Dunbar, Equinox
13:18:26 <RoganH> Red for beta or release candidates?
13:18:33 <kmlussier> graced: We already volunteered you for everything. :)
13:18:39 <graced> excellent!
13:18:53 <RoganH> graced: really, the Parsi translations were a step above and beyond on your part.
13:19:04 <kmlussier> RoganH: Yeah, I was thinking red or maybe yellow for use with caution.
13:19:04 <graced> well, I like to be thorough...
13:19:13 <RoganH> yellow might be too faint I tink
13:19:20 * kmlussier nods.
13:19:21 <RoganH> think.  <--- engrish good
13:19:25 <bshum> kmlussier: RoganH:  To be honest, I've never been a fan of color coding the releases too much.
13:19:34 <bshum> But that's just been my personal opinion.
13:19:38 <bshum> Happy to continue trying it.
13:19:42 <gmcharlt> color coding isn't accessible by itself
13:19:52 <RoganH> I have no strong feelings there, just bouncing of kathy's thought.
13:19:53 <gmcharlt> it can be used, but should be supplemented by text
13:19:57 <graced> Good point
13:19:58 <bshum> We used to use green for stable, red for unstable, yellow for RC, I think.
13:20:08 <kmlussier> Well, no, I wouldn't be used on its own. Definitely supplemented by text.
13:20:18 <RoganH> gmcharlt: I'm thinking more of the casual low vision user who needs strong contrast.
13:20:21 <bshum> And gray for deprecated.  Though in a recent conversation with gmcharlt, I think we shouldn't advertise old versions on the main downloads pages.
13:20:39 <RoganH> I agree with gmcharlt on that.
13:20:43 <gmcharlt> RoganH: yep, but there's colorblind users to consider as well
13:21:11 <gmcharlt> and while I'm spitballing -- I think the relevant OpenSRF installation instructions should be linked directly from the EG downloads page
13:21:12 <RoganH> gmcharlt: I agree.  And Red might be a bad choice for that reason, green too.
13:21:43 <bshum> +1 to gmcharlt's suggestion to put the OpenSRF stuff up front.
13:21:49 <RoganH> +1
13:21:53 <graced> +1
13:22:36 <RoganH> What we could do is do everything in black for all users and then put red or green blinking signs for those who aren't colorblind for "stable" and "test"
13:22:48 <RoganH> Then we will wish we couldn't see them.
13:23:14 * graced thinks Rogan misses Geocities
13:23:20 <kmlussier> bshum: So what do you need from us? Direction on layout for the page or would you like somebody to dive in to try reformatting the page?
13:23:22 * gmcharlt is glad that Mozilla has removed the blink tag, suddenly
13:23:29 <RoganH> Can I propose we try a stable arrangement separating out the versions and putting the opensrf content in?
13:23:29 * kmlussier is ignoring RoganH's suggestion.
13:23:50 <graced> Would mockups be helpful?
13:24:10 <bshum> kmlussier: Any outside assistance would be welcome as for both direction on layout and help diving in.
13:24:10 <kmlussier> graced: Are you volunteering to do mockups?
13:24:35 <graced> I am, I am also volunteering to give others access to our mockup software if they want
13:24:37 <bshum> If someone has a strong urge to help change it, I expect that'll just help get it done faster :)
13:24:52 <bshum> *faster than waiting for me to do it
13:25:16 <graced> bshum: I think you're doing a bang-up job considering the salary...
13:26:09 <RoganH> Ben has done a spectacular job.
13:26:22 <kmlussier> I want to move on to the next topic, so why don't we take graced up on her offer to do mockups. I'm familiar with the mock-up software, so I'm willing to pitch in as time allows.
13:26:25 <StephenGWills> Ben++
13:26:25 <RoganH> So, action item, graced will do mockups?
13:26:49 <kmlussier> #action graced to do mockups for downloads page.
13:27:09 <bshum> Sounds good to start with mockups and then move from there as it develops.
13:27:15 <kmlussier> graced: And if you're able to do them before the next meeting, don't hesitate to share them on the list. We can give feedback via e-mail as well.
13:27:23 <kmlussier> Anything else on the downloads page?
13:27:50 <kmlussier> #topic Accessibility color change
13:27:55 <kmlussier> RoganH?
13:27:56 <RoganH> Just a quick FYI really.
13:28:08 <RoganH> Galen and I did some tweaking so it's accessibility friendly.
13:28:11 <RoganH> a very dark green
13:28:13 <csharp> graced: re: geocities http://wonder-tonic.com/geocitiesizer/content.php?theme=2&music=6&url=evergreen-ils.org
13:28:21 * csharp is sorry to distract :-/
13:28:23 <RoganH> but he found a bug with the besting where it doesn't see the css added in the header
13:28:42 <graced> csharp++
13:28:49 <RoganH> so if we make css changes that way (rather than changing the underlying css files) we will need to test manually so to speak
13:28:57 <gmcharlt> csharp: my eyes!
13:29:07 <RoganH> this is so that updates don't break changes we make
13:29:09 <RoganH> that's all
13:29:38 <RoganH> #info csharp is going to heck for posting that link
13:29:59 <csharp> RoganH++
13:30:02 <kmlussier> OK, anything else on the color changes/css before moving on to the next topic?
13:30:08 <RoganH> nope
13:30:34 <kmlussier> #topic Merchandising page
13:30:37 <kmlussier> RoganH again.
13:30:53 <RoganH> very quick again - I added a section for links on the top banner
13:31:07 <RoganH> Right now it only has Evergreen in Action.
13:31:28 <RoganH> It will in the future have links to our Amazon and Zazzle content assuming that all survives it's own process.
13:31:38 <kmlussier> RoganH++
13:31:40 <RoganH> I wanted to give folks time to voice any questions or concerns.
13:31:49 <kmlussier> I hadn't noticed the new menu item.
13:31:58 <RoganH> It's been there about a week.  :)
13:32:12 <bshum> I saw it.  I should mention a quirk with the theme is that the actual listed top level doesn't link properly
13:32:14 <RoganH> I added it Friday while waiting for my plane last week (6 days).
13:32:22 <kmlussier> #info RoganH added merchandising to the top-level links of the Evergreen web site.
13:32:28 <bshum> So I've cheated by making a sub link go to the landing pages occasionally
13:32:45 <bshum> Like the "Overview" does for the "About Us" pointing back to the main page
13:32:51 <RoganH> I saw that but quickly found those workarounds too.
13:33:09 <bshum> But yes, RoganH++
13:33:24 <kmlussier> Does anyone have any concerns about the new link.
13:33:34 <kmlussier> I like it and am excited to see the new stuff that will be posted there. :)
13:33:54 <RoganH> We will talk about that more at the next meeting.
13:34:21 <kmlussier> #topic Discussion of roles / sections looking at papers for inspiration
13:34:43 <RoganH> OK.  I emailed out the link to a google doc for collaboration because I suspect not everyone has WIKI accounts.
13:34:52 <RoganH> And I've reposted it on the agenda.
13:34:58 <kmlussier> #link https://docs.google.com/document/d/1GJXaUJU4M_olIDH1KHLXCe9bNJIU0PzL8J5gVeXrDM4/edit?usp=sharing
13:35:22 <RoganH> We've had this talk for a while about should the web team be kind of anarchist where each person raises their hand to do as they like or should there be defined roles.
13:35:39 <RoganH> I'm a bit anarchist at heart but in the interest of exploring the other path I looked at how papers organize.
13:35:59 <RoganH> Newspapers have similar needs - they have regular sections, news, highlights, support communities, etc...
13:36:35 <RoganH> So that document is based off that.  And to be fair we have sections of the site and wiki that probably have been neglected by the 'do as thou will' approach.
13:37:09 <RoganH> And maybe we want the WIKI to be a more hands off thing from the web site and be more wild west.
13:37:27 <RoganH> I'm more comfortable now with that, now that the site and WIKI aren't so easy to confuse with each other.
13:38:29 <RoganH> I will put some more comments into the header of that document for context and put it on the agenda for the next meeting again.
13:38:39 <RoganH> And hopefully we can discuss it on list inbetween.
13:38:48 <kmlussier> My only comment with the document is that there are a lot of roles there. I know we had an issue with DIG for a while where we had more roles than volunteers to fill them. I'm concerned that might happen here too.
13:38:59 <RoganH> I think that's a very valid concern.
13:39:09 <kmlussier> Perhaps merging the managing editor with editor in chief might be a good place to start.
13:39:22 <gmcharlt> +1 # had exactly the same thought
13:39:24 <kmlussier> Oh, but you did mention that a bit in the document.
13:39:28 <RoganH> I did.
13:39:53 <kbutler> I think it's a good idea to have a range of smaller and larger roles for people with varying amounts of time.
13:40:00 <RoganH> Part depends on scope.  I also think about the web team's role in relationship to the wiki is critical because it changes the scope of duties quite a bit.
13:40:05 <kbutler> If someone has a lot of time they can combine some smaller roles or just do a bigger one.
13:40:33 <RoganH> And it impacts number of roles
13:41:12 <RoganH> Frankly, if the wiki is part of the web team's duties is quite a bit more complicated though at the same time it would be good to have at least one or two roles associated with flagging out of date content.
13:41:52 <gmcharlt> could define a separate wiki curator position
13:42:10 <gmcharlt> editor, janitor, etc.
13:42:34 <graced> I think that's a good suggestion - but we run into the same problem of not having enough people to fill the roles.
13:42:42 <StephenGWills> The wiki really should be an open space and perhaps, to some degree a place to draft info that is not vetted for the website yet?
13:42:42 <RoganH> gmcharlt: that's the direction I'm leaning in preference
13:43:07 <kmlussier> In looking at specific sections, I think DIG has traditionally taken on the role of mainining all the doc pages, and I think it would be appropriate to keep it there.
13:43:15 <RoganH> I think the wiki person's role would be to just flag out of date content and maybe keep up a wishlist of pages that need updating as they have time.
13:43:24 <RoganH> I think it has to be treated different from the website itself.
13:43:39 <RoganH> kmlussier: I agree and those are actively maintained.
13:44:16 <RoganH> If we change the scope of the wiki to be a different beast then the web site proper I think becomes easier to define roles for.
13:44:37 <kmlussier> We have about 15 minutes until the EOB needs our meeting space.
13:44:55 <RoganH> I'm happy to carry this thread onto email and doc editing.
13:45:22 <kmlussier> RoganH: Sure. I think you got some good suggestions on specific roles. Continuing on e-mail would be good.
13:45:32 <kmlussier> And then getting to the point of seeking volunteers for the specific roles. :)
13:45:57 <RoganH> We may need to put that off a little as this discussion develops but I'm OK with that.
13:46:15 <RoganH> And everyone, please jump in!
13:46:18 <kmlussier> #action RoganH to continue roles discussion via e-mail on the web team list.
13:46:42 <kmlussier> #topic Some ongoing tasks
13:46:45 <StephenGWills> the reasons I don't say much is because I am already volunteering for several things I have no time to deliver…  :(
13:47:01 <kmlussier> link: https://docs.google.com/document/d/1AvGW1NTJVM7y5MeokT6um3OjapOCUDqdDDTqpsQ03F0/edit?usp=sharing
13:47:14 <RoganH> not a lot to say here, just a list of discrete tasks that need to be done.
13:47:27 <RoganH> I've done a few already and as I have spare moments will do more but others can as well of course.
13:47:43 <RoganH> Trying to take some of the load off Ben here so he doesn't have to do every little thing :)
13:47:55 <gmcharlt> one thing I need to do and have mentioned is to get a couple pages arising from the EOB put up
13:48:01 <gmcharlt> the trademark policy to start, most notably
13:48:30 <RoganH> in the About Evergreen section?
13:48:40 <bshum> That sounds like a good place
13:48:43 <gmcharlt> yeah, I think that's a good place
13:48:55 <RoganH> I'll volunteer to do that and link to some good hi res and eps graphics there
13:49:03 <gmcharlt> actually, I was intended to do that
13:49:19 <gmcharlt> there are a couple technical changes to the wording of the policy that I have to dig through first
13:49:25 <gmcharlt> *intending
13:49:29 <kmlussier> I think this list of tasks is a great idea! I think it's hard for potential volunteers to know where to start, and this gives them a nice list to start with.
13:49:32 <kmlussier> RoganH++
13:49:56 <graced> RoganH++
13:50:03 <kmlussier> Should we ask people to add their names to a specific task? So that two people aren't working on the same thing.
13:50:18 <gmcharlt> kmlussier: +1
13:50:24 <RoganH> I think so.  And as Galen did, if you need to take over a task just edit it to show.
13:50:37 <RoganH> In this case I know why Galen is but otherwise adding a note about why would be good.
13:52:01 <RoganH> So, that's all for this.  I was hoping to have bite size items on here that anyone could start with.
13:52:06 <kmlussier> #info Volunteers who want to help with web site should add their name to the task they are planning to work on.
13:52:21 <ericar> Sorry, this is my first meeting. I'm not seeing this on the tasks, but do you need someone to identify out dated content on wiki page or do you want to hold off on that?
13:52:30 <RoganH> yes we do!
13:52:42 <RoganH> Do you want to volunteer to be a wiki janitor?
13:52:54 <kmlussier> IIRC, there was a convention for identifying outstated content on the wiki. I can't recall the details now.
13:52:57 <ericar> Awesome job title, yes.
13:52:59 <graced> It sounds so glamorous...
13:53:05 <gmcharlt> wiki librarian?
13:53:12 <RoganH> We can call it Editor if you like.  Curator?
13:53:28 <kbutler> weeder
13:53:30 <RoganH> Curator implies controlling what's published though, so does editor.
13:53:41 <RoganH> Wrangler?
13:53:42 <kmlussier> #info web team membes can also add new tasks to the list RoganH started.
13:54:10 <kmlussier> Terrible. My typo will show up in the minutes. :(
13:54:19 <RoganH> What ever it is Erica has volunteered so I'll add her to the roles page.  She has the duty of deciding what the position is called.
13:54:30 <kmlussier> ericar++
13:54:31 <gmcharlt> RoganH++
13:54:35 <gmcharlt> ericar++
13:54:41 <RoganH> ericar++
13:54:44 <bshum> ericar++
13:54:57 <kbutler> ericar++
13:55:19 <jeff> win 32
13:55:23 <jeff> er.
13:55:26 <kmlussier> We have 5 minutes during which web team/EOB members can take a rest between meetings. Anything else for today?
13:55:37 <pinesol_green> [evergreen|Dan Scott] Include auth browse docs in OPAC section - <http://git.evergreen-ils.org/?p=Evergreen.git;a=commit;h=639d435>
13:55:38 <pinesol_green> [evergreen|Dan Scott] Clean up minor doc problems - <http://git.evergreen-ils.org/?p=Evergreen.git;a=commit;h=a833b34>
13:55:38 <jboyer-isl> jeff: no swearing during the meeting.
13:55:39 <pinesol_green> [evergreen|Dan Scott] Fix doc typo in public interface setup section - <http://git.evergreen-ils.org/?p=Evergreen.git;a=commit;h=323b185>
13:55:53 <bshum> webteam_v2.0++
13:56:09 <kmlussier> OK. Next meeting is scheduled for October 17 then. Thanks all!
13:56:12 <kmlussier> #endmeeting