14:00:29 <yboston> #startmeeting 2013-09-05 - DIG Monthly Meeting Evergreen Documentation Interest Group (DIG) Monthly Meeting.
14:00:29 <pinesol_green> Meeting started Thu Oct  3 14:00:29 2013 US/Eastern.  The chair is yboston. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:29 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:29 <pinesol_green> The meeting name has been set to '2013_09_05___dig_monthly_meeting_evergreen_documentation_interest_group__dig__monthly_meeting_'
14:00:39 <yboston> The agenda can be found here http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:dig_meeting_20131003-agenda
14:01:02 <yboston> #topic Introductions
14:01:04 <yboston> Please feel free to start introducing yourselves...
14:01:14 * yboston is Yamil Suarez @ Berklee college of Music - DIG meetings facilitator
14:01:16 <kmlussier> #info kmlussier is Kathy Lussier, MassLNC
14:01:40 * rsoulliere is Robert Soulliere, Mohawk College
14:01:53 <remingtron> #info remingtron is Remington Steed, Hekman Library, Calvin College
14:02:18 <rfrasur_> #info rfrasur is Ruth Frasur, Hagerstown Library, Evergreen Indiana
14:02:35 <ElliotFriend> #info ElliotFriend is Elliot Voris, McCaslin Library, St. Louis Christian College
14:03:45 <bshum> #info bshum is Ben Shum, Bibliomation
14:04:20 <Michal_> Or maybe you think of Everegreen Live CD as in KOHA Live CD
14:04:23 <yboston> We can move on (my timer finished), late comers can introduce themselves as they arrive
14:04:59 <yboston> #topic Updates from Content Coordinators
14:05:37 <yboston> I see that we have both Robert and Kathy here, do you guys happen to have something to share?
14:05:47 <kmlussier> I've got a report.
14:05:52 <yboston> no worries id you don't
14:05:56 <yboston> go ahead kathy
14:05:59 <kmlussier> #topic Release Coordinator Report
14:06:07 <kmlussier> #info I have been reviewing the 2.5 release notes for content and completeness
14:06:17 <kmlussier> #info There are a number of new features that do not have release note entries. I have created release notes for some and plan to finish the rest by the end of the day tomorrow.
14:06:32 <kmlussier> #info Once the release notes are complete, I plan to identify features that need new documentation by submitting the doc needs in Launchpad.
14:06:56 <kmlussier> Just a note that, for now, I don't plan to do any LP entries for new features that came from Equinox since they already have people who are working on that documentation.
14:07:42 <kmlussier> Any questions?
14:07:56 <yboston> kmlussier++
14:08:05 <bshum> kmlussier++
14:08:20 <yboston> those items you add to LP could be stuff we could work on during the DIG hack-a-way
14:08:38 <kmlussier> Yes, I think that would be a great idea.
14:09:10 * kmlussier still has some things she needs to get in from 2.4. :P
14:10:14 <remingtron> kmlussier++
14:10:32 <yboston> if there are no question or comments at this point, we can consider moving on.
14:11:29 <yboston> OK, Robert did you have something to say talk about today?
14:11:38 <rsoulliere> I have a few items.
14:11:44 <rsoulliere> #topic Conversion Coordinator Report
14:11:51 <rsoulliere> #info A recent discussion on the general list made me wonder if I should convert and move these migrating patron documentation forward from 2.1:
14:11:58 <rsoulliere> #link http://docs.evergreen-ils.org/2.1/html/migratingpatrons.html
14:12:09 <yboston> (you read my mind)
14:12:15 <rsoulliere> I wrote this up a long time ago. Is it still useful?
14:12:16 <kmlussier> +1
14:12:25 <rsoulliere> I converted it today but just wanted to verify its usefulness before getting it into the repository.
14:12:27 <rfrasur_> +1
14:12:33 <ElliotFriend> I found it incredibly useful for our library
14:12:35 <yboston> I want to look at it and test it our, also good to know the author!
14:13:32 <rsoulliere> Another question...
14:13:32 <ElliotFriend> it was exactly what I needed to do, but I was focusing on the 2.4 docs
14:13:39 <rsoulliere> #help Is there an inventory of files needing conversion from docbook available somewhere and being maintained? I remember an inventory was created a while back at a DIG gathering.
14:13:53 <rsoulliere> remington brought this  to my attention.
14:14:31 <yboston> I am running behind, one thing you/DIG could try about the patron stuff, is to post your converted version (or the old one) to the dev list to see if they have some additions they would like to add that DIG could add for them
14:14:42 <yboston> (you = Robert)
14:15:30 <yboston> but i think it is probably fine as it is already, but that is the approach I had been taking when I was moving stuff from docbook to asciidoc (by checking with the debs before I converted to see if they had comments)
14:15:42 <yboston> about a list of what need to be converted
14:16:05 <yboston> I worked with an intern to look at conversions
14:16:31 <yboston> the spreadsheet we did at last years DIG hack-a-way confused me a bit
14:16:45 <yboston> so I ended up making a much more detail spreadsheet with the intern
14:17:05 <yboston> it is large and confusing and I have only shared it with two DIG people so far
14:18:18 <yboston> my list has some very useful information, but a lot of my observations of what has/has not been converted to asciidoc is focused on the "Section" levee and not necessary at the chapter level
14:18:41 <yboston> (I'll shut up for now so others can comment)
14:19:33 <remingtron> it seems like we basically need to look over the 2.1 docs online to see if anything valuable has been left out of the current docs, right?
14:19:42 * rfrasur is listening more than anything today.
14:20:07 <yboston> yes and no, I want to look at all version, not just 2.1
14:20:14 <kmlussier> remingtron: When we looked at it during last year's DIG hack-a-way, we went all the way back to 1.6
14:20:37 <kmlussier> Because there was a decent set of docs for 1.6, and there are several pieces that still haven't been moved up.
14:20:45 <remingtron> sure, that makes sense
14:20:53 <kmlussier> yboston: I think it would be useful to share that spreadsheet with everyone, even if it is somewhat confusing.
14:21:05 <yboston> with my intern I tried to move as much as aI could form 1.6
14:21:15 <remingtron> I think it would be best to set this project up in a way that we can collaborate
14:21:27 <yboston> since people found it so frustrating to have to look that far back for useful stuff
14:21:32 <remingtron> split up the docs versions and sections, and we can chip away at it until it's done
14:21:48 <yboston> remingtron: that sound fine to me
14:22:43 <yboston> I can share the spreadsheet with everyone as read only for now, and I can take time explaining my terminology at the hack-a-way or online/email
14:23:00 <remingtron> sounds like a good start
14:23:11 <kmlussier> yboston: Did everything your intern did make it into the doc repository?
14:23:12 <rsoulliere> yboston++
14:23:26 <yboston> sadly, nothing the intern did has made it in yet
14:23:57 <yboston> I wanted to do some basic proofreading first and have to volunteers that have been waiting for me to give them the files
14:24:21 <yboston> I've been too slammed, and I wanted to provide the original source of the converted documents for their comparison
14:24:32 <rsoulliere> Is what is being worked on documented in the outline online: eg. http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs_2.4:outline
14:24:37 <yboston> since some content comes from 1.6 others from 2.1, etc
14:25:12 <yboston> the intern stopped working fro me in June
14:25:25 <yboston> all her work was listed in the one link
14:26:49 <yboston> you posted
14:28:22 <kmlussier> yboston: If you want any help from any of us in getting those files out for review, just let us know. Even if you don't get the original source out there, other people might be able to do that for you. Because I know you're really busy. :)
14:29:33 <yboston> thanks, I had a chat with remingtron today and at the dev hack-a-way about it, so I think he can help me push this forward, and with the help of others
14:30:00 <kmlussier> yboston++ remingtron++
14:30:14 <rsoulliere> yboston++ remington++
14:30:37 <remingtron> yboston++
14:31:06 <yboston> this reminds me that I wanted to start an email thread to have DIG members start finding old stuff to convert to 2.5 at the DIG hack-a-way. though having access to my massive/confusing spreadsheet could help in this
14:33:43 <yboston> any other comments on this or Robert, do you want to mansion other points?
14:33:53 <yboston> (mention)
14:34:11 <rsoulliere> No, that is all for my report.
14:34:24 <yboston> rsoulliere++
14:34:39 <yboston> any other comments on what we were just discussing?
14:34:49 <kmlussier> rsoulliere++
14:35:20 <remingtron> rsoulliere++
14:35:21 <yboston> #action yboston ail share his spreadsheet with an inventory of documentation that needs to be moved to asciidoc
14:35:49 <kmlussier> yboston: Just wondering. Would it be easier to track those needs in Launchpad rather than doing it in the confusing spreadsheet? Since we've talked about adding other doc needs there.
14:36:09 <yboston> #action yboston will start an email thread about finding asciidoc conversion target for DIG hack-a-way
14:36:51 <yboston> the spreadsheet was for me to keep track of how the "prominence" of individual chunks of documentation
14:37:21 <yboston> For example, I used it to track each section of 1.6 to see if it moved to 2.0
14:38:14 <remingtron> I think whenever we discover a section of docs that went missing, we could document it with a launchpad bug
14:38:17 <yboston> and I checked each section of 2.0 to see if it moved to 2.4, etc
14:38:35 <yboston> remingtron: exactly
14:38:49 <kmlussier> Yes, that makes sense. Thanks!
14:38:51 <yboston> the spreadsheet s for low level research, LP can be used for aissignments
14:39:49 <rfrasur> yboston: yes
14:40:06 <rsoulliere> I had a question about how to ensure new features in release notes make it into the docs going forward?
14:40:18 <rsoulliere> E.g. LDAP configuration is covered in the 2.2 release notes... but never again.
14:40:33 <yboston> I never thought of that
14:40:49 <yboston> I smell another spreadhseet
14:40:50 <kmlussier> I thought everything was automatically moving up now that the docs live with the rest of the code.
14:41:14 <ElliotFriend> I've run into that issue a few times, for various features
14:41:58 <rfrasur> yboston, are you able to upload that spreadsheet into gdrive so we can take a quick look?
14:42:12 <kmlussier> Or are these things that are mentioned in Release Notes, but never get put into the core documentation?
14:42:19 <yboston> it is already a gdrive spreadsheet, I will share it after the meeting
14:42:36 <rsoulliere> I thought release notes were different since they are new features and should not be repeated in later version? They become old news ;-)
14:42:51 <rfrasur> okay
14:42:57 <kmlussier> rsoulliere: Sure, I think I was misunderstanding your initial question.
14:43:09 * rfrasur must be misunderstanding as well.
14:43:58 <yboston> this could be another parallel fast for the DIG hack-a-way
14:44:12 <remingtron> it sounds like some things from release notes should also be added to the main docs
14:44:13 <yboston> to inventory what has or has not been documented form the older release notes
14:44:22 <kmlussier> rsoulliere: It's a good question. I tried to more clearly identify those doc needs during the last release by doing this - http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:2.4_needs. But, as you can see, not everything got a volunteer to work on docs.
14:44:34 <yboston> (task not fast)
14:44:58 <rfrasur> remingtron, if the new feature is going to impact how people use EG, it'll live on and should have updated documentation, yeah?
14:45:17 <ElliotFriend> rfrasur++
14:45:33 <remingtron> rfrasur: that's my opinion, yes
14:45:34 <rfrasur> it's one thing if it's a security fix or something...but another if it changes how people interact with the software
14:45:42 <remingtron> right
14:45:43 <kmlussier> But, as I was going through the 2.5 release notes, I was trying to identify features that were already more fully documented as part of the release notes. There were a couple of things I was planning to move into the core docs.
14:45:54 <rfrasur> kmlussier++
14:46:00 * rfrasur is back on the rails
14:46:29 <kmlussier> For example, Dyrcona had good release notes for his PhoneList work and tsbere has basic docs for his floating work. It should probably just go in as is and then a DIG person can improve upon it if they think it's needed.
14:47:03 <remingtron> kmlussier: I think your "2.4 needs" wiki page is a good method and should be repeated for 2.5
14:47:10 <yboston> that sounds reasonable to me
14:47:38 <yboston> I like those wiki pages, even if we shift some of the info to LP too
14:47:42 <kmlussier> remingtron: Do you think the wiki page is a good method or Launchpad? I was thinking it might be more easily tracked in Launchpad.
14:47:52 <kmlussier> Or, as yboston, just said, I can hit both.
14:48:01 <remingtron> kmlussier: right, just realised that
14:48:12 <remingtron> let's try launchpad
14:48:28 <remingtron> sure, or both while we transition
14:48:28 <yboston> BTW, me and remingtron recently updated the info on the DIG wikipages, and now there is an empty page for the 2.5 release
14:49:00 <yboston> I just like having high level info on the wiki, then maybe the more specific stuff can go on LP
14:49:01 <remingtron> http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs_2.5:outline
14:49:02 <rfrasur> I think there's value in both the wiki and LP.  The wiki is a good overview document.
14:50:17 <rsoulliere> I like the wiki as well, especially for reviewing documentation structure and organization.
14:50:19 <yboston> BTW, we are at the 50 minute mark
14:51:51 <yboston> I wanted to talk about the DIG hack-a-way nefpre we wrap up, if that is OK
14:51:53 <yboston> ?
14:52:07 <yboston> before we wrap up, sorry for my spelling
14:52:59 <rfrasur> I have a question after you yboston...just a short one
14:53:10 <yboston> go ahead
14:54:09 <rfrasur> well, I'm on the front page of the dokuwiki where the roadmap links are located.  I personally like how the different EG versions are linked right there.
14:55:02 <rfrasur> Under the documentation & resources heading, would it possible to have the documentation for the various versions listed in a similar way?  Including that needs list?
14:55:28 <rfrasur> or not...or are those things compiled in some place that I'm just not finding in a timely manner?
14:55:29 <yboston> it was down in the past, i thought
14:56:17 <rfrasur> What was down?  Down as in not working?
14:57:13 <yboston> sorry "done in the past"
14:58:35 <remingtron> currently, there's a section called "Documentation & Resources" just under the evergreen versions
14:59:56 <remingtron> most of those docs links are very old
15:00:04 <rfrasur> right
15:00:45 <rfrasur> in my mind, that'd be the place to put links to the documentation wiki page(s)
15:01:06 <rfrasur> (this is a longer question than I'd anticipated)
15:01:17 <kmlussier> rfrasur: Sorry, just catching up. You're talking about the links on the wiki page? http://wiki.evergreen-ils.org/doku.php
15:01:29 <remingtron> rfrasur: good thought, I'll put some thought into that section
15:01:38 <yboston> we should probably continue this topic on the mailing list, since we just hit the hour mark, and I wanted to talk briefly about the DIG hack-a-way
15:01:52 <rfrasur> kmlussier: yes remingtron++
15:02:03 * rfrasur listens to yboston
15:02:25 <yboston> #topic DIG hack-a-way
15:02:27 <yboston> any comments or questions about locations? so far I can host a dozen folks at Berklee, and ESI can host too
15:03:17 <rfrasur> I'm going to be talking with our state library as a possible host site for a satellite group
15:03:17 <yboston> start could be at 9:30 AM EST, to give us time to settle in. Some of us can host google hang outs for those working from afar
15:03:24 <yboston> feel free to add ideas to the DIG hack-a-way wiki page, or bring stuff up on the list
15:03:30 <ElliotFriend> I'd likely not be able to get away, I'm assuming participating online is viable?
15:03:34 <yboston> http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:dig_hack-a-way
15:03:44 <rfrasur> ElliotFriend: yes.
15:03:46 <kmlussier> ElliotFriend: Yes, we used Google Hangouts last time.
15:04:03 <ElliotFriend> rfrasur: kmlussier thanks
15:04:38 <rfrasur> yboston: do you have a better idea of when to do asciidoc tutorial session?
15:04:45 <yboston> for example, doing an inventory of what documentation from older release notes that has not made it in to the docs could be good to be done form afar
15:05:05 <yboston> about asciidoc training...
15:05:06 <yboston> I will host a Google hangout for asciidoc trainign (unless the techonlogy does not work for me). I will do a doodle poll to find a good date
15:05:40 <rfrasur> yboston++
15:05:59 <yboston> if it does not work on Google hang out, I wilt try to record the training and then post it to YOutube, I can then host a Q and A session on google hang out before the DIG hack-a-way
15:06:08 * rfrasur needs to go help a young lady w/ a research project.
15:06:14 <yboston> rough agenda for asciidoc session woudld be
15:06:15 <yboston> - FAQ about DIG
15:06:16 <yboston> - Asciidoc training
15:06:17 <yboston> - walk through on converting a MS word document into asciidoc
15:06:27 <kmlussier> yboston: If possible, I think it would be best if we could try to do any kind of inventories before the hack-a-way so that we can focus on creating documentation during the actual event.
15:06:42 <ElliotFriend> kmlussier++
15:06:47 <remingtron> +1
15:07:17 <yboston> that is why I wanted to start an email thead about finding documentation targets this week
15:07:18 <kmlussier> I would be willing to take on going through old Release Notes.
15:07:44 <yboston> I can add a read only link to my huge spreadsheet
15:08:18 <remingtron> we have some good action items forming here
15:09:08 <yboston> #action yamil will post a doodle poll for finding a date for asciidoc training
15:09:21 <yboston> #action yboston will post a doodle poll for finding a date for asciidoc training
15:09:38 <yboston> any other final comments (I don't want to go too past the hour mark)
15:11:22 <yboston> anything else for now?
15:11:37 <kmlussier> Nothing from me.
15:11:46 <ElliotFriend> none here
15:11:56 <remingtron> one question
15:12:18 <yboston> go ahead
15:12:53 <remingtron> we will try to have the already-converted but not yet proofread docs for the hackaway, yes?
15:13:04 <remingtron> like, made available for people to help with by the hackaway?
15:13:17 <yboston> the ones my intern worked on?
15:13:21 <remingtron> yes
15:13:31 <yboston> yes
15:13:45 <remingtron> cool, thanks, that's it from me
15:14:24 <yboston> BTW, one thing that need to be done is that I pull together a huge amount of docs about cataloging that is in no particular order. someone at the hack a away can come up with a smarter order of the sections
15:14:51 <yboston> unless there ano other questions I will close out the meeting
15:15:48 <yboston> #endmeeting