#evergreen: 2013-10-15 - October Developers meeting

Meeting started by kmlussier at 13:06:24 US/Eastern (full logs).

Meeting summary

    1. berick Bill Erickson, ESI (berick, 13:07:08)
    2. csharp Chris Sharp, GPLS (csharp, 13:07:17)
    3. Agenda is at http://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2013-10-15 (kmlussier, 13:07:23)
    4. jeff Jeff Godin, TADL (jeff, 13:07:33)
    5. phasefx Jason Etheridge, ESI (phasefx, 13:07:34)
    6. eeevil Mike Rylander, ESI (eeevil, 13:07:37)
    7. senator Lebbeous Fogle-Weekley, ESI (senator, 13:07:42)
    8. dbwells Dan Wells, Hekman Library (Calvin College) (dbwells, 13:07:59)
    9. ldwhalen Liam Whalen, BC Libraries Coop (ldwhalen, 13:08:00)
    10. kmlussier is Kathy Lussier, MassLNC (kmlussier, 13:08:11)
    11. remingtron Remington Steed, Hekman Library (Calvin College) (remingtron, 13:08:16)
    12. RoganH, SCLENDS (RoganH, 13:08:21)
    13. bshum = Ben Shum, Bibliomation (bshum, 13:08:38)

  1. Action Items from Last Meeting (kmlussier, 13:09:08)
    1. [extra old action item from summer doldrums] Start on the 2.6 development road map page (kmlussier, 13:09:35)
    2. http://wiki.evergreen-ils.org/doku.php?id=faqs:evergreen_roadmap:2.6 (kmlussier, 13:10:56)
    3. [extra old action item ” ” ”] bshum to summarize bug tracking based on feedback from developers (kmlussier, 13:11:27)
    4. Bmagic = Blake GH, MOBIUS (Bmagic|2, 13:13:08)
    5. ACTION: bshum to summarize bug tracking based on feedback from developers (kmlussier, 13:19:31)
    6. [extra old action item ” ” ”] kmlussier to raise bug squashing day to the lists for further discussion/feedback (kmlussier, 13:19:55)
    7. kmlussier posted message to the dev list today http://georgialibraries.markmail.org/thread/22six3nkgbhr3f3t (kmlussier, 13:20:32)
    8. gmcharlt to release opensrf 2.2.1 soon(?) post-vacation (kmlussier, 13:21:40)
    9. gmcharlt to release 2.2.1 this week (gmcharlt, 13:21:57)
    10. csharp to test 2.4.2 rc so we can officialize it (kmlussier, 13:22:38)
    11. gmcharlt will cut both OpenSRF 2.2.1 (to include the multipart fix) and OpenSRF 2.3.0 (to include the new signal-handling and control script stuff) this week (gmcharlt, 13:26:03)
    12. 2.3.0 will be recommended to run with EG 2.5, but 2.2.1 will be compatible as well. (kmlussier, 13:28:14)
    13. senator to find old incomplete action items to move forward (with help from the channel in making sure I get the right ones) - Done! (kmlussier, 13:28:48)
    14. eeevil to commit a techref doc explaining how to build pgTAP test (kmlussier, 13:29:32)
    15. ACTION: eeevil to commit a techref doc explaining how to build pgTAP test (kmlussier, 13:31:51)
    16. ACTION: o publish detailed plan about freezing baseline schemas between EG releases and using deprecates/supersedes in database upgrade scripts. This will go on the mailing list and the thread should structure further discussion of pros and cons of eeevil's plan. (kmlussier, 13:32:08)

  2. Evergreen release info (kmlussier, 13:33:16)
    1. 2.5 RC1 is uploaded. Release notes will be uploaded shortly. (kmlussier, 13:36:20)
    2. AGREED: dbwells will pull back RC1 and incorporate memory leak patches. Sign-off from other testers will be appreciated. (kmlussier, 13:46:22)

  3. Update on OmniTI Performance Work (kmlussier, 13:49:24)
    1. OmniTI began its performance evaluation for Evergreen last month. As most of you have seen, depesz has been looking at the longest-running queries from the C/W MARS server and finding ways to optimize them. (kmlussier, 13:49:45)
    2. They will be taking a different approach to the staff client evaluation than originally planned. With the consensus last month to move away from XULRunner and towards a web-based client, it didn't make sense to evaluate the viability of continuing with XULRunner. (kmlussier, 13:50:05)
    3. Instead, jsime has been looking at the way the client is communicating with the backend to determine if there are ways this communication can be optimized when moving to a web-based client. (kmlussier, 13:50:29)

  4. Discuss freezing of master during beta/RC phase (kmlussier, 13:58:19)
    1. AGREED: There will be no version branch until x.x.0 is tagged. There will be a feature freeze for master between beta and x.x.0. (kmlussier, 14:06:52)


Meeting ended at 14:08:06 US/Eastern (full logs).

Action items

  1. bshum to summarize bug tracking based on feedback from developers
  2. eeevil to commit a techref doc explaining how to build pgTAP test
  3. o publish detailed plan about freezing baseline schemas between EG releases and using deprecates/supersedes in database upgrade scripts. This will go on the mailing list and the thread should structure further discussion of pros and cons of eeevil's plan.


Action items, by person

  1. bshum
    1. bshum to summarize bug tracking based on feedback from developers
  2. eeevil
    1. eeevil to commit a techref doc explaining how to build pgTAP test
    2. o publish detailed plan about freezing baseline schemas between EG releases and using deprecates/supersedes in database upgrade scripts. This will go on the mailing list and the thread should structure further discussion of pros and cons of eeevil's plan.


People present (lines said)

  1. kmlussier (60)
  2. dbwells (20)
  3. berick (18)
  4. gmcharlt (18)
  5. eeevil (18)
  6. csharp (17)
  7. bshum (16)
  8. pinesol_green (5)
  9. jsime (4)
  10. jeff (3)
  11. moodaepo (3)
  12. phasefx (2)
  13. senator (2)
  14. remingtron (1)
  15. RoganH (1)
  16. Bmagic|2 (1)
  17. sylvar (1)
  18. ldwhalen (1)


Generated by MeetBot 0.1.4.