#evergreen: November 12, 2013 developer meeting

Meeting started by gmcharlt at 14:02:01 US/Eastern (full logs).

Meeting summary

    1. Agenda is http://evergreen-ils.org/dokuwiki/doku.php?id=dev:meetings:2013-11-12 (gmcharlt, 14:02:09)
    2. gmcharlt = Galen Charlton, Equinox (gmcharlt, 14:02:23)
    3. csharp = Chris Sharp, GPLS (csharp, 14:02:28)
    4. jeffdavis = Jeff Davis, Sitka (jeffdavis, 14:02:40)
    5. Dyrcona = Jason Stephenson, MVLC (Dyrcona, 14:02:42)
    6. bshum = Ben Shum, Bibliomation (bshum, 14:02:45)
    7. kmlussier = Kathy Lussier, MassLNC (mostly lurking today) (kmlussier, 14:02:49)
    8. senator = Lebbeous Fogle-Weekley, Equinox (senator, 14:02:57)
    9. DPearl = Dan Pearl, C/W MARS (DPearl, 14:02:57)
    10. jeff = Jeff Godin, Traverse Area District Library (TADL) (jeff, 14:03:01)
    11. dbwells = Dan Wells, Hekman Library (Calvin College) (dbwells, 14:03:02)
    12. remingtron = Remington Steed, Hekman Library (Calvin College) (remingtron, 14:03:03)
    13. phasefx2 = Jason Etheridge, ESI (phasefx2, 14:03:10)
    14. berick Bill Erickson, ESI (berick, 14:03:31)
    15. ldwhalen = Liam Whalen, Sitka (ldwhalen, 14:04:08)

  1. Action items from last meeting (gmcharlt, 14:04:52)
    1. OpenSRF 2.2.1 was released (gmcharlt, 14:07:01)
    2. ACTION: gmcharlt needs to cut OpenSRF 2.3-beta already (gmcharlt, 14:07:12)

  2. Evergreen releases (gmcharlt, 14:09:28)
    1. Evergreen 2.5.0 is out! (gmcharlt, 14:09:37)

  3. Releae manager for 2.6 (gmcharlt, 14:16:25)
    1. http://libmail.georgialibraries.org/pipermail/open-ils-dev/2013-November/009149.html (gmcharlt, 14:20:50)

  4. Proposal: make 2.6 a stability release and putting new development into 3.0 (gmcharlt, 14:26:08)
    1. dbs = Dan Scott, Laurentian University (LATE) (dbs, 14:35:29)
    2. eeevil = Mike Rylander, ESI (also late) (eeevil, 14:35:57)
    3. RoganH = Rogan Hamby, SCLENDS (RoganH, 14:40:31)
    4. rfrasur = Ruth Frasur, Evergreen Indiana (rfrasur, 14:43:01)
    5. Discussion of the proposal to be moved to open-ils-dev (gmcharlt, 14:49:52)

  5. Requiring automated tests for new code/database modifications. (gmcharlt, 14:49:56)
    1. http://evergreen-ils.org/meetings/evergreen/2013/evergreen.2013-08-27-14.04.log.html (dbs, 14:56:08)
    2. VOTE: Voted on "Shall pgTAP test cases (where applicable) be required for new commits starting with 2.6?" Results are, Yes: 10, Postpone: 1 (gmcharlt, 15:10:43)
    3. AGREED: pgTAP test cases (where applicable) are required for new commits start with 2.6 (gmcharlt, 15:11:08)


Meeting ended at 15:12:34 US/Eastern (full logs).

Action items

  1. gmcharlt needs to cut OpenSRF 2.3-beta already


Action items, by person

  1. gmcharlt
    1. gmcharlt needs to cut OpenSRF 2.3-beta already


People present (lines said)

  1. gmcharlt (49)
  2. Dyrcona (41)
  3. eeevil (29)
  4. berick (25)
  5. jeff (21)
  6. bshum (21)
  7. csharp (14)
  8. dbs (13)
  9. dbwells (12)
  10. phasefx2 (11)
  11. pinesol_green (9)
  12. kmlussier (5)
  13. jeffdavis (5)
  14. rfrasur (4)
  15. RoganH (4)
  16. senator (4)
  17. DPearl (3)
  18. remingtron (3)
  19. ldwhalen (1)
  20. phasefx_ (1)


Generated by MeetBot 0.1.4.