13:03:42 <kmlussier> #startmeeting 2013-11-21 Web Team meeting
13:03:42 <pinesol_green> Meeting started Thu Nov 21 13:03:42 2013 US/Eastern.  The chair is kmlussier. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:03:42 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:03:42 <pinesol_green> The meeting name has been set to '2013_11_21_web_team_meeting'
13:03:57 <kmlussier> #info Agenda is available at http://evergreen-ils.org/dokuwiki/doku.php?id=webteam:meetings:agenda:2013-11-21
13:04:09 <kmlussier> #topic Introductions
13:04:21 <kmlussier> Please introduce yourselves with the #info command.
13:04:30 <kmlussier> #info kmlussier is Kathy Lussier, MassLNC
13:04:37 <graced> #info graced is Grace Dunbar, Equinox
13:04:52 <gvitez> #info gvitez is Gordana Vitez Niagara Evergreen Consortium
13:06:06 <kmlussier> Small turnout today and no Rogan.
13:07:21 <gvitez> Do we need a certain number of participants? Or is it not that formal?
13:07:28 <kmlussier> But the two people with action items are here, so I suppose we can continue and see if others show up.
13:07:40 <graced> ericar is in training, she may be able to join in a bit, depending on how the training goes.
13:08:10 <kmlussier> gvitez: It's not that formal, but it might be difficult to discuss the web site roles without Rogan since he's really been taking charge of that process.
13:08:37 <kmlussier> I know bshum is in a meeting right now too.
13:08:49 <kmlussier> #topic Action items from last meeting
13:09:23 <kmlussier> graced: Any progress with the downloads page?
13:09:46 <graced> unfortunately, no, I've had trouble carving out the time
13:09:58 <graced> I will redouble my efforts to get that done.
13:10:21 <kmlussier> #info graced will defer her action item to upload the downloads page to look like her mock-ups until the next meeting.
13:10:54 <kmlussier> #info kmlussier will defer her action item to explore options for the "Learn More" buttons on the Evergreen home page until the next meeting.
13:11:10 <kmlussier> Sorry folks. I've been swamped this month. :(
13:11:45 <graced> I think that's a theme for many of us.
13:11:50 <gvitez> I'm afraid I don't know how I can contribute with the tech aspects of the site
13:12:20 <graced> there's always value in design - or just pointing to what needs to be fixed.
13:12:32 <kmlussier> gvitez: Now that the site has been converted to WordPress, there isn't as much need for help with the tech aspects.
13:13:01 <kmlussier> gvitez: Like graced mentioned, I think there is help needed with design issues or with content.
13:13:31 <gvitez> I can do that.
13:14:45 <kmlussier> gvitez: Have you seen the spreadsheet that Rogan has put out regarding potential roles for the web site?
13:16:08 <gvitez> kmlussier: I have. I think I can help with editing.
13:16:28 <kmlussier> #link https://docs.google.com/document/d/1AvGW1NTJVM7y5MeokT6um3OjapOCUDqdDDTqpsQ03F0/edit?usp=sharing
13:17:05 <gvitez> kmlussier: there was call for someone to work on mini-conference info and I'd like to contribute in that regard.
13:18:15 <kmlussier> gvitez: Yes, I think both of those will be helpful. The only mini-conference I can think of that's coming up is the one Rogan is planning. But it might be good to think of what might be useful in a mini-conference section and how it might be set up.
13:18:32 <kmlussier> I expect the organizers of the conference would be responsible for the more specific information.
13:19:27 <gvitez> Niagara has had a number of them, I think 4? and I can contribute with how to set one up. In case there are people considering but not sure about logistics.
13:20:00 <kmlussier> OK, great! I'll add that as an action item for your then. :)
13:20:47 <gvitez> Sounds good! I was starting to worry that I was a dead weight!
13:20:53 <kmlussier> #action gvitez to create page on logistics for setting up a mini-conference.
13:21:20 <kmlussier> gvitez: We're fairly new to organizing the web site responsiblity in this way, so I think it's taking time for everyone to find their niche for contributions.
13:21:50 <kmlussier> I don't want to say definitively that you are now mini-conference section editor in case Rogan has heard from other people.
13:22:08 <kmlussier> Since Rogan isn't here, I'm going to jump to the one item of new business. Maybe he'll wander in by the time we're done.
13:22:25 * kmlussier knows he needs to here soon for the EOB meeting.
13:23:08 <kmlussier> #topic Page for listing proposed development projects, etc.
13:23:23 <kmlussier> #link http://list.evergreen-ils.org/pipermail/evergreen-web-team/2013-November/000450.html
13:23:47 <kmlussier> kbutler mentioned the idea for a page to track proposed development projects, and it's something that the web team has talked about many times before.
13:24:11 <graced> kmlussier: I really support this idea but I fear that this is going to be a lot of work to keep up with
13:24:22 <kmlussier> graced: Sure
13:24:42 <graced> I think some decisions would need to be made as to criteria
13:24:43 <kmlussier> In the past, I think the web team got stuck on finding the best platform to track these things. They were looking for a solution similar to Idea Torrent.
13:25:25 <kmlussier> One of my questions is what type of projects would be put there. Just ones where people are seeking development partners? Or should they include others too?
13:25:28 <graced> Hmmm... does this then make the "Wishlist" in Launchpad moot?
13:26:06 <kmlussier> graced: Well, I don't know. I put a lot of wishlist projects in Launchpad, but I never put our big development projects there.
13:26:15 <graced> I guess I want to know what the purpose of the page is - for things people want or things that people want and are willing to commit funds to.
13:26:18 <gvitez> Could the development projects be broken down into wishlist, seeking funding, prelim...categories like that?
13:26:25 <graced> I would think it was the latter.  But I'm often wrong.
13:26:45 <graced> gvitez: absolutely.  But that's a lot of maintenance work.
13:27:12 <kmlussier> If it's just for things people want, then we would absolutely need some good platform to manage it.
13:27:14 <gvitez> graced: good point. I'm not a huge fan of maintenance. :)
13:27:20 <graced> :-)
13:27:50 <kmlussier> I had once posed the idea of extending Launchpad for this purpose, but I think there is also the problem of over-extending Launchpad to do too many things that it's not meant to do.
13:28:10 <graced> How about we start with RFPs and projects that have at least some funding.  And see how that goes... we can always add to it later if it seems manageable.
13:28:30 <kmlussier> If it were just a place to track a) projects that are seeking development partners and b)things that people are seeking quotes for, I could see it starting on the wiki.
13:29:25 <kmlussier> AFAIK, MassLNC is the only site currently seeking development partners for a project. graced: Do you know of any others?
13:29:30 * csharp pops in for a second
13:29:42 <graced> Kent is, too
13:29:50 <kmlussier> csharp: Welcome!
13:29:55 <graced> For the MetaRecord return to the TPAC
13:30:04 <graced> hey csharp!
13:30:10 <kmlussier> graced: Great! The two projects are closely related then.
13:30:15 <gvitez> There is the inventory development?
13:30:28 <gvitez> Early stages but there is interest, I think.
13:30:28 <csharp> I think a personnel role is missing here - rather than focusing on a software platform for managing projects on the web, should there be a community development project manager in place?
13:30:40 <graced> Rogan was seeking funding partners but I think SCLENDS is going to dedicate funds to a staff client re-write instead
13:30:52 <csharp> (beyond the scope of the web team I know, but just asking)
13:31:08 <graced> csharp: How do you see that role ?
13:32:10 <csharp> well, ideally it would be a person paid by the Evergreen project to manage the funding/logistics of projects spread across multiple stakeholders
13:32:11 <gvitez> graced: Thanks for the info. I'll touch base with Rogan on that.
13:32:28 <csharp> in reality, it would probably need to be a volunteer with a lot of time to devote to it
13:32:33 <graced> gvitez: I know they plan to return to that project, even if they're tabling it for now.
13:33:29 <kmlussier> csharp: Sounds great! But I'm concerned the community might be short on volunteers with a lot of time. :)
13:33:38 <csharp> yeah, I know :-/
13:33:51 <graced> But it's a goal to aspire to!
13:33:57 <kmlussier> But I also think this idea would fit in with the one of today's EOB agenda items.
13:34:32 <csharp> I think it might be something to keep in mind since there is definitely a desire to share information about project collaboration
13:35:07 <graced> Well we can certainly start with putting it on the wiki so it is all in one place.
13:35:19 <csharp> and nothing so far has "stuck" (except launchpad, though we don't use that for larger projects either)
13:35:19 <graced> it being the information about developmetn projects
13:35:27 <csharp> graced: I agree
13:35:45 <kmlussier> And restricting it as described above? Active RFP's or projects that have some funding?
13:35:46 <csharp> it's already there, no administrative overhead/learning curve, etc.
13:36:00 <graced> kmlussier: I think so... at least for now
13:36:08 <graced> I'm happy to work on that.
13:36:39 <kmlussier> csharp: Yes, the using what's already there is key. I think the reason this idea has never moved forward is because we keep wanting to do it with something that we don't have the tuits to implement.
13:36:51 <csharp> exactly
13:36:52 <kmlussier> graced: I can work on it with you, if you don't mind.
13:36:58 * kmlussier has a lot of content to add.
13:37:00 <graced> the more the merrier
13:37:26 <kmlussier> And I might want to stick the content up there soon. :)
13:37:44 <graced> kmlussier: agreed, the sooner the better
13:38:51 <kmlussier> #action graced and kmlussier to work on wiki page to track development projects that are part of active RFP's as well as projects seeking funding partners.
13:39:07 <kmlussier> Anything else on that topic?
13:39:22 <kmlussier> #topic Editor roles
13:39:54 <kmlussier> I think I'm actually going to defer this topic since I don't have a good handle on what our next steps are.
13:40:14 <kmlussier> Oh, wait. I spoke too soon. RoganH is here!
13:40:27 <RoganH> Yeah, sorry I'm out sick today and lost track of time.
13:40:33 <bradl> do trumpets sound when RoganH enters the room? Yes.
13:40:34 <RoganH> But did intend to log in!
13:40:41 <kmlussier> bradl++
13:41:02 <RoganH> Catch me up?
13:41:14 <kmlussier> RoganH: We just started the editor roles topic. Do you have anything to say about it? Or do you want to defer it to the next meeting when you're feeling healthier?
13:41:39 <RoganH> We can defer it.  I sent out a simplified sort of framework for roles and didn't get feedback.
13:41:47 <RoganH> I'll be honest in that I have mixed feelings.
13:42:02 <RoganH> Part of me likes the slightly chaotic people just grab the work approach we have done.
13:42:16 <RoganH> It feels very organic and FLOSS-y to me.
13:42:24 <RoganH> But I know that some folks want more structure.
13:42:51 <kmlussier> RoganH: BTW, gvitez mentioned above she would be interested in taking charge of a mini-conferences section.
13:43:13 <RoganH> So, my big question for others would be how do they feel?
13:43:35 <RoganH> This kicked off with a discussion about responsibility and me volunteering to make a proposal but it's not one I feel personally attached to.
13:43:41 <RoganH> It was meant just for discussion.
13:43:43 <graced> RoganH: I feel like maybe some of the roles are too big?
13:43:47 <kmlussier> RoganH: One big plus to the roles is that it gives a tangible task to people who don't know how to get started with helping out.
13:44:10 <gvitez> kmlussier: it helped me find a way to help.
13:44:26 <RoganH> graced: The original proposal had them be more narrow and people wanted them lumped together into fewer roles.
13:44:28 <graced> IF someone said to me: You're in charge of the downloads page and the about us page, I'd know what I had to do.  The roles as is, to me, feel a bit big.
13:44:38 <kmlussier> I've always felt comfortable with the organic and FLOSS-y approach, and I'll probably continue to work on the web site in that fashion no matter what happens with roles.
13:44:45 <graced> RoganH: That was weeks ago, I've already forgotten it.  :-D
13:44:54 <RoganH> graced: :)
13:45:04 <RoganH> kmlussier: I feel that way too.
13:45:41 <RoganH> And I do think we need ways to bring folks in and give them manageable tasks.
13:45:46 <kmlussier> I think graced has a good point about the roles being too big. It might be best to give potential volunteers a few pages that we know need help.
13:45:50 <RoganH> But maybe the roles isn't the way to do that.
13:45:59 <kmlussier> At the same time, to do that, we still need an editor who knows what those pages are.
13:46:00 <graced> Perhaps we can all just ID pages we want to work on so we're not stepping on each others' toes?
13:46:06 <gvitez> If I can say this, for those who are already well-established in the Evergreen community, that way works well. But if you're new or hesitant, it's a little overwhelming?
13:46:28 <RoganH> graced: From the original discussion I don't think it was so much toe stepping as making sure some things got done.
13:46:29 <kmlussier> gvitez: I totally agree. It was very overwhelming for me at first too. :)
13:46:52 <graced> RoganH: That too
13:46:57 <kmlussier> And I though it was more of a way to make it easier for people to know how they could contribute. :)
13:47:18 <RoganH> kmlussier: that too
13:47:44 <RoganH> In fact I think those were the two real goals, making sure things got done and helping people become contributors.
13:47:54 <RoganH> And maybe the roles aren't the right way to go about that.
13:48:28 <RoganH> Maybe we should approach the site as more like a block of code and look at contributions like code work.
13:48:52 <graced> But not use those words lest we scare people off
13:48:52 <gvitez> Giant to-do list? Check off what you've fixed or added?
13:48:58 <RoganH> It breaks down a bit because we can't give access to anyone and just review the code like git.
13:49:09 <RoganH> graced: agreed
13:49:19 <kmlussier> RoganH: You know. I really think that Google docs is a good first start. It clearly identifies areas that need work and allows people to claim an area.
13:49:32 <RoganH> gvitez: basically
13:49:40 <RoganH> kmlussier: which was part of the reason I started it
13:49:47 <kmlussier> And anyone can add to it if they see something else that needs to be done.
13:50:10 <RoganH> I think we should brainstorm how to expand that concept and how to welcome people into the pool and get them up to speed.  Kind of like what the docs folks are doing.
13:51:00 <graced> RoganH: Agenda item for the next meeting?
13:51:08 <RoganH> Maybe we move not to launchpad but somekind of to do app or a google spreadsheet doc
13:51:21 <RoganH> graced: yes, but hopefully some listserv communication in between
13:51:34 <kmlussier> Does somebody want to take an action item for the listserv message?
13:51:38 * kmlussier stares at RoganH
13:51:38 <gvitez> google spreadsheet is super easy.
13:51:46 <RoganH> ok, ok, I'll do it
13:52:12 <graced> RoganH++
13:52:14 <RoganH> I'll summarize this discussion and throw out a few possibilities to kick off discussion.
13:52:24 <kmlussier> #action RoganH to start listserv discussion about expanding the idea of Google document to track web site needs.
13:52:40 <kmlussier> RoganH: And I'll try to provide feedback this time when you send the message. :)
13:52:58 <RoganH> And I want to coin FLOSS-y as a term (though someone else probably already has).
13:52:59 <kmlussier> Anything else anyone wants to bring up before the EOB members descend on IRC?
13:53:23 <kmlussier> #action kmlussier to send earlier meeting reminders for now on.
13:53:48 <kmlussier> gvitez: Thanks for coming! I'm glad you could make it!
13:54:03 <kmlussier> #endmeeting