14:00:39 <yboston> #startmeeting 2014-01-09 - DIG Monthly Meeting Evergreen Documentation Interest Group (DIG) Monthly Meeting.
14:00:39 <pinesol_green> Meeting started Thu Jan  9 14:00:39 2014 US/Eastern.  The chair is yboston. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:39 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:39 <pinesol_green> The meeting name has been set to '2014_01_09___dig_monthly_meeting_evergreen_documentation_interest_group__dig__monthly_meeting_'
14:01:15 <yboston> The agenda can be found here http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:dig_meeting_20140109-agenda
14:01:28 <yboston> #topic Introductions
14:01:49 <yboston> Please feel free to start introducing yourselves...
14:01:53 * remingtron is Remington Steed, Hekman Library, Calvin College
14:01:58 * yboston is Yamil Suarez @ Berklee college of Music - DIG meeting facilitator
14:02:12 * rfrasur is Ruth Frasur, Hagerstown Library, Evergreen Indiana
14:02:17 <yboston> kmlussier warned that she will not be ble to make it today
14:02:41 <yboston> (Happy new year to everyone)
14:02:44 <remingtron> looks like a small meeting
14:02:55 <eeevil> bshum: oh, the 2.4.5 RC is gold, just needs to be moved into place. never got a "tested, works" from anyone, which is why I didn't just push it out
14:03:06 <rfrasur> (happy new year as well)
14:03:09 * eeevil hushes for the dig meeting. sorry
14:03:39 <yboston> I will wait one more minute before starting our (small) meeting
14:04:17 <remingtron> do we have enough members to make any decisions? or should we postpone?
14:04:23 <remingtron> or is it just not that formal?
14:04:48 <rfrasur> remingtron, it's not that formal, but it is a very small group.
14:04:57 <yboston> I guess we are too few to make any major decisions, though there are no written rules
14:05:12 * kmlussier is Kathy Lussier, MassLNC, but probably be only able to lurk today. :(
14:05:34 <rfrasur> IMO, there's some pretty important stuff on the agenda.
14:05:57 <yboston> We can decide as a (small) group how to proceed.
14:06:12 <remingtron> let's see how far we get
14:06:18 <rfrasur> +1
14:06:29 <yboston> I am fine with just brainstorming for a bit or just asking each other questions for a bit. or we can try to reschedule
14:06:50 <yboston> on the thought of rescheduling, we can ask on the list if we should try a different time/day to meet going forward in case it helps others to participate
14:07:10 <yboston> though perhaps changing the date/time might not make much of a difference.
14:07:25 <remingtron> do you think we should try the doodle scheduling approach that the devs use?
14:07:36 <remingtron> at least once to see if people respond
14:07:37 <rfrasur> I'm not sure that's the issue at this point, yboston
14:08:08 <rfrasur> remingtron, I think that's actually been done in the past.  I'm not against it.
14:08:11 <yboston> remingtron: I don;t mind a poll, even if we end up with the same time
14:08:24 <yboston> rfrasur:  what do you mean?
14:08:41 <rfrasur> Maybe we used a doodle poll for something other than the DIG meeting.
14:09:09 <rfrasur> I was thinking it was used for something related to DIG though.  Oh, it might have been the hackaway.  Pardon, I'm a little foggy today.
14:09:36 <remingtron> no worries. for today, looks like we don't have any content coordinators around, right?
14:09:46 <yboston> looks like we don't
14:10:29 <remingtron> should we brainstorm our way through the agenda items then?
14:10:42 <rfrasur> yep
14:11:08 <yboston> I am OK with that, specially to start fleshing stuff out for the next meeting
14:11:24 <yboston> we can also throw in another agenda item to explore increasing meeting participation
14:11:43 <yboston> like a doodle poll (etc) to see what time works for most folks
14:11:49 <remingtron> sounds good
14:12:36 <rfrasur> Should that be an action item then?  creating a doodle poll (why did they have to name it doodle?  seriously).
14:13:34 <yboston> yes, we can try a doodle poll for next months meeting, just to see if it increase participation, and we could also ask for general feedback on the meting time going forward
14:13:51 <remingtron> sounds like a good action item to me
14:14:19 <yboston> would either of you like to set up the poll and send out the email?
14:14:53 * rfrasur chuckles at the silence.
14:15:00 <rfrasur> Yeah, I'll do it.
14:15:52 <remingtron> rfrasur++
14:15:54 <rfrasur> Should we have another near the end of this month?
14:16:12 <yboston> you can bounce ideas off of me before sending it out, if that helps
14:16:19 <remingtron> rfrasur: another....meeting?
14:16:24 <yboston> another poll or meeting?
14:16:44 <rfrasur> yes...another meeting.  Since this one is sparcely attended but there are some fairly important things on the agenda.
14:17:08 <remingtron> ah, right. sure, +1 to that idea
14:17:09 <rfrasur> It'd stink to have to wait until next month.
14:17:26 <yboston> I am fine with another meeting this months, but
14:17:57 <yboston> should we have a poll for just the next meeting, and /or a poll to find another time to meet monthly besides the first Thursday of the month?
14:18:00 <rfrasur> (I wonder how many people are going to ALA MW)
14:18:48 <rfrasur> Well, how about we just do one at a time.  We can talk about it more at the next meeting which will hopefully add some new/more voices to the discussion.
14:18:58 <remingtron> I agree
14:19:10 <yboston> works for me
14:19:31 <rfrasur> Okay, I'll put that together this today or tomorrow at the latest.
14:19:37 <yboston> thanks!
14:19:50 <rfrasur> mp
14:20:12 <yboston> #action rfrasur will create a doodle poll for finding alternate January meeting time
14:20:30 <yboston> rfrasur++
14:21:01 <yboston> do we want to switch to talking about new or old business? or something else?
14:21:55 <rfrasur> I'm reading through the agenda and there's a lot that really requires more input from people who aren't here.
14:22:23 <yboston> that makes sense
14:22:29 <remingtron> yboston: want to update us on your intern's converstion stuff?
14:22:48 <rfrasur> I guess I have have a question and comment about the hackaway.  well, two.  Remingtron asked one of them though :)
14:22:58 <remingtron> any progress from people who started proofreading
14:23:41 <yboston> there might be some confusion on that old agenda time regarding the intern. I do now have a new intern, that agenda item refers to the older interns work that you guys have looks at altready
14:24:03 <yboston> and I have not been able to do anything with that work since the hack-a-way. been to busy with EG conference work
14:24:33 <remingtron> okay. I added the link to : http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:2.5_needs
14:24:34 <yboston> I would like to say, I want to start doing something with what we started in the last hack-a-way next week
14:25:29 <remingtron> yboston: I added some things to the "Old/Missing Sections" section on that wiki page
14:25:32 <rfrasur> Yeah, I feel like I've been stalled with because of non-Evergreen stuff.
14:25:38 <rfrasur> remingtron++
14:25:50 <yboston> thanks
14:25:54 <remingtron> feel free to add status messages to those items
14:26:12 <rfrasur> (oh good grief) stalled with hackaway progress on documentation
14:26:42 <remingtron> rfrasur: thanks for finishing your thought! I was mighty confused.
14:27:04 <rfrasur> oy vey.  and it still barely made sense.
14:27:14 * rfrasur points and grunts
14:27:31 * remingtron is fluent in grunt
14:27:47 <yboston> ha
14:27:54 <rfrasur> excellent
14:28:22 <remingtron> yboston: will  your new intern be doing anything with Evergreen docs?
14:28:36 <yboston> sadly, I just found out I am NOT getting an intern
14:28:50 <remingtron> oh...sorry to bring that up.....
14:28:55 <yboston> no problem
14:29:12 <rfrasur> well, that stinks
14:29:16 <yboston> I will try to find the time so I can contribute more to the docs
14:29:25 <yboston> I will start with what we were working on at the hack-a-way
14:29:51 <remingtron> sounds like we have a few sections that are mostly ready to add to master, right?
14:30:21 <yboston> from the hack-a-way, yes
14:30:53 <yboston> remingtron: we can set up a time to review what can be put in
14:30:57 <yboston> to master
14:31:00 <yboston> from the hack-a-way
14:31:05 <yboston> and what still needs work
14:31:36 <remingtron> sounds good, I like keeping track of progress on those things
14:31:43 <yboston> thanks
14:31:50 <remingtron> helps us know where to focus our efforts
14:33:10 <yboston> I guess off the top off my head, my new year's goals for DIG would be to finish off the hack-a-way work, then focus on increasing DIG participation, and trying to get as much work done during the conference
14:33:24 <yboston> ith some training or "open house" thrown somewhere in between
14:34:01 <rfrasur> I like the idea of an open house during the conference.
14:34:22 <remingtron> I won't be able to attend the conference, but I'll do my best to be virtually connected
14:34:34 <rfrasur> I'm also interested to see if there's a DIG component to the regional conference that Rogan's doing.
14:34:35 <yboston> actually, I was thinking right before the conference, just to get people pre-trained, but during is perfectly fine
14:34:51 <rfrasur> yboston: that too.
14:35:30 <remingtron> I'd vote for one or two training things before the conference, to give people a chance to prepare for lots-of-work-during-conference
14:36:00 <remingtron> also, I've been collecting bitesize docs bugs, so I'll try to post those to LP soon
14:36:10 <yboston> rfrasur: I gotta remember to ask Rogan, but then again, who from DIG is going?
14:36:22 <rfrasur> or instead...whichever.  Something that's easy for people to learn about the documentation and how to participate.
14:36:56 <yboston> I am writing this stuff down
14:36:57 <rfrasur> I dunno that anyone from DIG is going.  There should be though.  It's an important part of EG
14:37:19 <yboston> #idea offer pre-conference DIG training or even during the conference
14:37:32 <rfrasur> It's a major part for the end user (good grief - preaching to the choir)
14:38:43 * kbutler gets back from helping with ereader questions and reads back.
14:38:54 <rfrasur> kbutler++
14:39:09 <yboston> are either of you going to Rogan's conference?
14:39:09 <yboston> #idea find out if any DIG members are attending the Rogan organized regional conference, to help spread DIG
14:40:06 <remingtron> I'm not planning on it
14:40:23 <kbutler> I am not. It's not in my neck of the woods.
14:40:35 <yboston> Neither was I because of my budget, but maybe in the future
14:40:50 <rfrasur> I haven't seen recent information about it.  In my case, probably not this year.  I wouldn't be a good rep anyway since I don't have much more than basic info/knowledge with documentation.
14:40:55 <yboston> MAybe I can speak about DIG remotely?
14:41:36 <rfrasur> I'm not sure.  Maybe RoganH can give some guidance or feedback at a later time.
14:42:01 <yboston> i'll check in with him later
14:42:52 <kbutler> One stumbling block I keep running into when I find a doc need is that... I don't know how to use it. That's why I was looking for documentation.  But I'd like to /help/ make the documentation. Is there a way to identify people who might help with questions about specific modules?
14:42:54 <yboston> #action yboston will ask Rogan about some type of DIG participation in the regional conference, however small
14:43:19 <rfrasur> kbutler: I think that's pretty common.
14:43:44 <rfrasur> It's one thing to write the stuff, but then what?  who?  when?
14:43:52 <yboston> We can try teaming up, and focusing in one section
14:44:12 <rfrasur> kbutler, are you going to the conference?
14:44:33 <kbutler> I am, yeah.
14:44:36 <yboston> this two person or more team, specially a new DIG member and a veteran member can work together
14:44:39 <rfrasur> okay, good
14:44:48 <rfrasur> yboston, that's a good idea
14:44:49 <kbutler> yboston: That's a good idea.
14:44:58 <rfrasur> jinx
14:45:03 <remingtron> kbutler: you mean, who should you talk to if you find a problem in the Serials module and don't know what it should be? or do you mean don't know the technology side of fixing it?
14:45:05 <kbutler> yboston: It would be nice if we could also manage to get a developer in there for consultation
14:45:35 <yboston> that is one fun thing that we did at the hack-a-way
14:46:01 <yboston> what I have down in the past, I do some research , pull the most important questions together and email the developers.
14:46:04 <rfrasur> Yes, especially on some of the more obscure things.  I know that bshum has functioned in both capacities - developer and DIG
14:46:14 <kbutler> remingtron: More along the lines of 'I'm looking for how to customize these receipts and the documentation is missing/old/incomplete'
14:46:25 <rfrasur> and kmlussier and several others actually
14:47:04 <kbutler> So then I think 'I could fix these docs' but I can't really because I don't know the correct info.
14:47:19 <remingtron> ah, I see.
14:48:07 * kmlussier isn't a developer
14:48:20 <yboston> compare to us yes :)
14:48:21 <rfrasur> no, but you know some stuff
14:48:21 <remingtron> seems like you could just ask for a developer's help on IRC, right?
14:48:31 <rfrasur> remingtron: good point
14:48:43 <kmlussier> But I have found that if you tell developers that you are asking the questions so that you can create documentation, they are more than happy to answer your questions.
14:48:51 <remingtron> that's probably the fastest way to get a knowledgeable answer
14:50:00 <yboston> I can also understand that IRC can be intimidating, and then asking developers can be intimidating to
14:50:44 <yboston> too
14:51:37 <remingtron> that's true, though kbutler has already proven fearless
14:51:47 <yboston> I can offer my help to help craft questions for developers, I kinda speak their language (though not very fluent in Perl yet)
14:51:57 <kbutler> ha! Hardly so. :)
14:52:07 <rfrasur> It's probably more intimidating for the people who aren't here right now ;)
14:52:21 <yboston> rfrasur: probably
14:52:35 <yboston> BTW< we are at the 52 minute mark
14:53:26 <kmlussier> Depending on the area you are documenting, questions posted to the general list might help too. There are a lot of non-developers who might know how things work, but who haven't had a chance to contribute to the docs.
14:53:40 <yboston> kmlussier: absolutely true
14:54:21 <yboston> one observation I had from the hack-aw-ay was that I have a lot of personal workflows for working on documentation, that are ironically not documented anywhere
14:54:57 <remingtron> sounds like that's a pretty good recommendation then: ask on the general list and/or IRC, and state that you are asking in order to improve the docs
14:54:57 <yboston> I got a chance to explain some of these wok flows to the hack-a-way participants, but we did not document them, they are so far just oral traditions
14:55:41 <kbutler> Yeah.  It's just a matter of formulating the questions.
14:55:56 <rfrasur> I think it'd be worth documenting your workflows.  It'll provide ease of entry for others.
14:55:56 <yboston> remingtron: I also feels that is helps if you offer a draft of how you would write the docs with some blanks, so that when a developr/knowlegeable user responds they have something to just edit to get you a reply
14:56:27 <remingtron> yboston: I agree, we should document your workflows
14:56:31 <remingtron> how about on the wiki?
14:56:45 <yboston> the wiki would be the perfect place
14:57:58 <yboston> #idea document workflow for creating/editing DIG documentation on wiki
14:58:40 <yboston> I do mention one or two of these informal workflows in my training resonation, but I should put them somewhere on the wiki. I believe remingtron update some already
14:58:59 <remingtron> yboston: you might want to edit or borrow from : http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:how-to-contribute-documentation
14:59:47 <remingtron> one last question, then I have to leave
15:00:18 <yboston> remingtron: yes, that is the stuff you updated recently
15:00:24 <remingtron> does anyone have feedback or ideas for the DIG style guide (draft)?
15:00:25 <remingtron> http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:dig_style_guide
15:01:08 <rfrasur> not at this point
15:01:15 <yboston> I might have some feedback on how to format "code / bash" commands, but I need to do some research first
15:01:54 <yboston> I need look into how many formatting styles are currently used all over the docs for bash or other code, don't think we have been consistent this whole time
15:02:03 <yboston> or maybe we have?
15:02:08 <kbutler> not right now. I haven't done enough to come up with any.
15:02:21 <yboston> BTW, we are slightly past the 1 hour mark
15:03:18 <remingtron> okay, if any of you use the style guide and find something confusing or have other suggestions, you can edit the page or email the DIG list
15:03:35 <yboston> remingtron: thanks again for putting that together
15:03:42 <remingtron> you're welcome
15:03:44 <kbutler> remingtron++
15:03:55 <yboston> should we wrap up?
15:04:02 <remingtron> sounds good to me
15:05:02 <yboston> any fins thoughts?
15:05:08 <yboston> any final thoughts?
15:06:05 * rfrasur waves
15:06:09 <rfrasur> yboston++
15:06:37 <yboston> OK folks, see you at the alternate January meeting or next month
15:06:49 <yboston> #endmeeting