#evergreen: 2014-01-10 - Developer Meeting

Meeting started by bshum at 13:09:20 US/Eastern (full logs).

Meeting summary

    1. Agenda: http://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2014-01-10 (bshum, 13:09:44)

  1. Introductions (bshum, 13:09:49)
    1. bshum = Ben Shum, Bibliomation (bshum, 13:09:56)
    2. gmcharlt = Galen Charlton, ESI (gmcharlt, 13:09:58)
    3. Dyrcona = Jason Stephenson, MVLC (Dyrcona, 13:10:08)
    4. jeff = Jeff Godin, Traverse Area District Library (TADL) (jeff, 13:10:13)
    5. dbs = Dan Scott, Conifer (dbs, 13:10:21)
    6. DPearl = Dan Pearl, C/W MARS (DPearl, 13:10:22)
    7. senator = Lebbeous Fogle-Weekley, ESI (senator, 13:10:26)
    8. RoganH = Rogan Hamby, SCLENDS (RoganH, 13:10:30)
    9. = Liam Whalen, Sitka (ldwhalen, 13:10:43)
    10. eeevil = Mike Rylander, ESI (eeevil, 13:11:12)
    11. berick Bill Erickson ESI (berick, 13:11:13)
    12. kmlussier = Kathy Lussier, MassLNC (kmlussier, 13:11:33)

  2. Past action items (bshum, 13:12:29)
    1. dbwells = Dan Wells, Calvin College (dbwells, 13:12:57)
    2. ACTION: bshum to summarize bug tracking based on feedback from developers (bshum, 13:13:49)
    3. ACTION: gmcharlt to cut OpenSRF 2.3-beta next week (bshum, 13:15:07)
    4. ACTION: eeevil to publish detailed plan about freezing baseline schemas between EG releases and using deprecates/supersedes in database upgrade scripts. This will go on the mailing list and the thread should structure further discussion of pros and cons of eeevil's plan. (bshum, 13:16:15)
    5. branch with pgTAP tests and Encode fixes is in https://bugs.launchpad.net/evergreen/+bug/1242999 (dbs, 13:16:34)
    6. ACTION: dbwells to review bug 1242999 (bshum, 13:17:10)

  3. OpenSRF releases (bshum, 13:18:11)
    1. See above for OpenSRF 2.3 beta. (bshum, 13:18:41)

  4. Evergreen releases (bshum, 13:20:22)
    1. ACTION: bshum to fix up the 2.4.5 and set 2.4.6 milestones in LP (bshum, 13:21:29)
    2. eeevil plans to cut 2.4.6 next Wednesday (2014-01-15) for next monthly maintenance release. (bshum, 13:22:15)
    3. cutoff for targetting bugs for inclusion in 2.6.0-alpha is next Thursday (1/16) (dbwells, 13:22:33)
    4. Dyrcona offers to dbwells help on 2.5 maintaining (follow up on this) (bshum, 13:29:37)

  5. Evergreen 2.6 discussions (bshum, 13:29:44)
    1. ACTION: dbs will write up the release notes as promises in bug # 1261939 for per-library TPAC pages (dbs, 13:35:24)
    2. ACTION: bshum to set new calendar entries for 2.6 milestone events and give access to dbwells to dev calendar. (bshum, 13:40:24)

  6. Technical feedback on staff client prototype (bshum, 13:42:08)
    1. Prototype wrap-up report: http://yeti.esilibrary.com/dev/pub/web-staff-report.html (bshum, 13:44:17)

  7. OS support (bshum, 14:04:11)
    1. ACTION: bill to open opensrf LP websocket ticket with current info (berick, 14:08:09)


Meeting ended at 14:27:32 US/Eastern (full logs).

Action items

  1. bshum to summarize bug tracking based on feedback from developers
  2. gmcharlt to cut OpenSRF 2.3-beta next week
  3. eeevil to publish detailed plan about freezing baseline schemas between EG releases and using deprecates/supersedes in database upgrade scripts. This will go on the mailing list and the thread should structure further discussion of pros and cons of eeevil's plan.
  4. dbwells to review bug 1242999
  5. bshum to fix up the 2.4.5 and set 2.4.6 milestones in LP
  6. dbs will write up the release notes as promises in bug # 1261939 for per-library TPAC pages
  7. bshum to set new calendar entries for 2.6 milestone events and give access to dbwells to dev calendar.
  8. bill to open opensrf LP websocket ticket with current info


Action items, by person

  1. bshum
    1. bshum to summarize bug tracking based on feedback from developers
    2. bshum to fix up the 2.4.5 and set 2.4.6 milestones in LP
    3. bshum to set new calendar entries for 2.6 milestone events and give access to dbwells to dev calendar.
  2. dbs
    1. dbs will write up the release notes as promises in bug # 1261939 for per-library TPAC pages
  3. dbwells
    1. dbwells to review bug 1242999
    2. bshum to set new calendar entries for 2.6 milestone events and give access to dbwells to dev calendar.
  4. eeevil
    1. eeevil to publish detailed plan about freezing baseline schemas between EG releases and using deprecates/supersedes in database upgrade scripts. This will go on the mailing list and the thread should structure further discussion of pros and cons of eeevil's plan.
  5. gmcharlt
    1. gmcharlt to cut OpenSRF 2.3-beta next week


People present (lines said)

  1. bshum (92)
  2. berick (48)
  3. dbs (35)
  4. eeevil (25)
  5. gmcharlt (23)
  6. dbwells (21)
  7. Dyrcona (21)
  8. jeff (15)
  9. ldwhalen (15)
  10. csharp (13)
  11. RoganH (10)
  12. pinesol_green (5)
  13. jboyer-isl (5)
  14. kmlussier (4)
  15. rfrasur (3)
  16. DPearl (1)
  17. egbuilder (1)
  18. senator (1)


Generated by MeetBot 0.1.4.