13:00:56 <kmlussier> #startmeeting 2014-01-16 Web Team meeting
13:00:57 <pinesol_green> Meeting started Thu Jan 16 13:00:56 2014 US/Eastern.  The chair is kmlussier. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:57 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:00:57 <pinesol_green> The meeting name has been set to '2014_01_16_web_team_meeting'
13:01:15 <kmlussier> #info Agenda is available at http://evergreen-ils.org/dokuwiki/doku.php?id=webteam:meetings:agenda:2014-01-16
13:01:34 <kmlussier> #topic Introductions
13:01:41 <kmlussier> Please introduce yourselves with the #info command
13:01:44 <bshum> #info bshum = Ben Shum, Bibliomation
13:01:53 <kmlussier> #info kmlussier = Kathy Lussier, MassLNC
13:01:57 <RoganH> #info RoganH = Rogan Hamby, SCLENDS
13:02:02 <CarrieC> #info Carriec=Carrie Curie, PALS
13:02:04 <ElliotFriend> #info ElliotFriend = Elliot Voris, St. Louis Christian College
13:02:35 <kbutler> #info kbutler = Kate Butler, Rodgers Memorial Library
13:03:17 <kmlussier> OK, others can introduce themselves as they wander in.
13:03:30 <kmlussier> #topic Action items from the last meeting
13:03:53 <kmlussier> #info graced to update the downloads page to look like her mock-ups.
13:04:11 <kmlussier> According to Grace's e-mail, she was waiting to hear if there was any feedback on Alexey's e-mail.
13:04:26 <kmlussier> #link http://list.evergreen-ils.org/pipermail/evergreen-web-team/2013-December/000455.html
13:04:49 <CarrieC> Alexey is not able to be here, either
13:06:40 <kmlussier> Does anybody have any general feedback on whether graced should proceed as planned? Or should I just push for feedback on the webteam list?
13:07:33 <bshum> I don't have any new ideas at the moment.
13:07:44 <bshum> So I guess I'd be curious to get more feedback on the lists.
13:08:03 * kmlussier will try to solicit feedback on the lists and come up with some of my own feedback too.
13:08:10 <bshum> (I actually don't remember reading this email at all, so I have to re-read and get the attachment viewed)
13:08:42 <kmlussier> #action kmlussier will push for feedback on the lists for new ideas on downloads page so that graced can proceed.
13:09:10 <kmlussier> #info kmlussier to explore options for the “Learn More” buttons on the Evergreen home page.
13:09:17 <kmlussier> I won't be able to get to this until after the conference.
13:09:32 <kmlussier> If anyone else wants to look into it, I welcome the help. Otherwise, it will have to wait.
13:10:39 <RoganH> I think it's fine waiting.
13:10:41 <kmlussier> #action kmlussier to look into options for the "Learn More" buttons post-conference.
13:11:08 <ericar> #info ericar = Erica Rohlfs, Equinox
13:11:41 <kmlussier> #info gvitez to create page on logistics for setting up a mini-conference.
13:11:49 <kmlussier> It sounds like gvitez will be unable to participate in web team meetings until July, but it will be a nice project waiting for her when she returns.
13:11:57 <kmlussier> Best of luck to her in getting her MLIS!
13:12:17 <kmlussier> #action graced and kmlussier to work on wiki page to track development projects that are part of active RFP's as well as projects seeking funding partners.
13:12:33 <kmlussier> I've been waiting on working on that action item until I"m done working on some upcoming dev projects MassLNC will be funding.
13:12:42 <kmlussier> Should be done by the next meeting.
13:12:53 <kmlussier> #info RoganH to start listserv discussion about expanding the idea of Google document to track web site needs.
13:13:16 <RoganH> Well, I sent out two pieces of communication since the last meeting.
13:13:35 <RoganH> One, discussed the different forms of collaboration we could use and another this week summarizing and looking for more input.
13:13:51 <RoganH> The only feedback I got gave positive input to using a help desk approach.
13:14:11 <RoganH> But there doesn't seem a consensus as to what.  The two products suggested are respectively project management and collaboration tools.
13:14:39 <RoganH> I don't think either quite matches what we need to let people grab tasks, prioritize them, etc... without a lot of overhead.
13:15:14 <kmlussier> RoganH: You thought http://osticket.com/ might work, right?
13:15:16 <RoganH> I've been looking at one called OS Ticket right now.  It's an open source product and seems robust.  But, do we want another piece of infrastructure?
13:15:27 <RoganH> kmlussier: you typed faster than me :)
13:15:47 <RoganH> Right now I'm feeling fairly warm and fuzzy towards it.
13:15:48 <kmlussier> No, you typed 5 lines before I was able to type that one. :)
13:15:52 <bshum> Fwiw, I'm not a huge fan of osticket.
13:16:08 <bshum> And as for adding yet another piece to the infrastructure, I'm more than skeptical.
13:16:12 <RoganH> bshum: I take it you've used it.  What were it's drawbacks?
13:16:18 <ElliotFriend> The more accounts, passwords, and infrastructure there is, the higher the bar seems to be for new participants, it seems.
13:16:27 <bshum> Unless someone really champions whatever you're using and takes ownership, I don't think it's a good idea.
13:16:45 <kmlussier> The alternative to adding another piece of infrastructure is to use existing infrastructure (Launchpad) to support web team needs.
13:16:48 <RoganH> The barrier for entry for new people on the web team is pretty high right now since they don't know how to get tasks as well.
13:16:50 <kmlussier> Do we really want to go there/
13:17:02 <bshum> RoganH: Officially, it functions, unofficially, I just never liked how the code was put together.  It was a dead project for awhile, but since has revitalized somewhat.
13:17:31 <RoganH> bshum: We use it York county and find it robust for our help desk needs though I admit they are pretty straight forward.
13:17:50 <bshum> [off] We use it for Biblio's helpdesk tracking, and there's enough quirks maintaining it (buggy email triggers, lack of customized fields, too much hackery) that I'm convinced we need other solutions.
13:18:23 <bshum> [off] But that's not my department's job anymore to work on that.
13:18:47 <RoganH> I haven't had those issues but we may be doing different things in that regard.
13:19:11 <RoganH> Well, our fall back if we don't do a help desk, which on list the only responses were positive to, is launchpad or Google Doc.
13:19:13 <bshum> I'm not opposed to adopting that solution if that's what's desired.  I'm just going to politely decline being the admin responsible for maintaining it.  :)
13:19:25 <ElliotFriend> I think the Google Doc that I saw a little while back did a pretty good job at letting people know what needs to be done, and letting them claim that
13:19:32 <ElliotFriend> simple, straight-forward, and accessible
13:20:14 <kmlussier> I woudl be happy with using the Google Doc for now. Most people have used Google docs and should be able to dive right in.
13:20:14 <ElliotFriend> Although, a wiki page could do the same thing
13:20:24 <RoganH> ElliotFriend: it has some distinct limitations which we ran into even for the few tasks we were using it for, that's the challenge with using collaboration tools for task management but folks can decide to live with that
13:20:40 <kmlussier> RoganH: What were some of the limitations?
13:20:52 <kbutler> a spreadsheet might be better than a straight up doc
13:22:04 <ElliotFriend> kbutler+
13:22:46 <RoganH> kmlussier: its hard to articulate but where people were adding on top of each other ran into some confusion especially when things were closing out as replies instead of closing task since the collaboration assumed it was resolved when it wasn't
13:22:59 <RoganH> kbutler: it might
13:23:25 <kmlussier> For some reason, I remembered it being in a spreadsheet. Yes, Google spreadsheet is what I meant.
13:23:29 <kmlussier> kbutler++
13:24:44 <kmlussier> Would somebody be willing to set up a Google spreadsheet to track tasks?
13:24:54 <kmlussier> And let's see how it goes?
13:25:21 <ElliotFriend> I'm willing to volunteer
13:25:31 <kmlussier> ElliotFriend++
13:25:46 <kmlussier> Is there any information you need to help you get started?
13:26:15 <ElliotFriend> I'm just not sure what info would be needed for each task...
13:26:26 <kbutler> ElliotFriend++
13:26:35 <ElliotFriend> date reported, task, assignee, comments, what else?
13:26:40 <ElliotFriend> due date?
13:26:47 <kmlussier> Status
13:27:36 <ElliotFriend> Alright, I'll flesh it out and report back how things are going
13:27:54 <kmlussier> #action ElliotFriend to set up Google spreadsheet to track web site tasks.
13:27:55 <ElliotFriend> I'm sure as I get going, required "fields" will become more obvious
13:28:31 <kmlussier> The last action item was for me to send out earlier meeting reminders. Which I did for once.
13:28:41 <kmlussier> One successfully completed action item for me.
13:28:43 <kmlussier> Let's move on.
13:29:02 <kmlussier> #topic Evergreen library directory/map
13:29:17 <kmlussier> #link http://markmail.org/message/wbnartqe63vxxpdb
13:29:36 <kmlussier> So this question came up at last month's EOB meeting and then in a subsequent discussion.
13:30:08 <kmlussier> We've often talked about a way to better handle the listing of Evergreen libraries. And people are interested in bringing the Evergreen map back.
13:30:35 <kmlussier> Creating an Evergreen map is a lot of work, so I think it would be best if it could be generated from some kind of directory.
13:30:58 <kmlussier> As I mentioned in that e-mail thread, I did find several directory plugins for Wordpress that work with Google maps.
13:31:13 <kmlussier> But it's tricky, because we really need some kind of hierarchy built into the directory.
13:31:46 <kmlussier> I think we would want consortia to be listed in the directory, with the individual libraries listed for each consortium.
13:32:14 <kmlussier> But the consortia should also be listed alongside those single planting libraries.
13:32:39 <kmlussier> Is there any interest to look into this further?
13:33:11 <ericar> I've received quite a number of responses so far to that email. I think that I have added/edited all who responded. I have been trying to list out the branches, in anticipation for the structure you mention.A few people wrote me about their desire to see the EG map, but no  bites on volunteering to help with it.
13:33:35 <kmlussier> ericar++
13:33:40 <StephenGWills> still interested…but still busy :(  I did this for EIFL a few years ago.
13:33:51 <kmlussier> Thanks for taking on the task of updating the wiki page. It was long overdue.
13:33:59 <bshum> Indeed, ericar++
13:34:00 <jeff> The subject interests me. What kind of timeline do people have in mind?
13:34:19 <bshum> jeff: Sometime between now and whenever?  :)
13:34:29 <kmlussier> What is this thing you call a timeline?
13:34:42 <RoganH> timeline--
13:35:03 <kmlussier> Seriously, though, I think just having somebody who is interested in pursuing it and also has the time to do it is a big step in the right direction.
13:35:26 <StephenGWills> I was planning on being in the GIT session at the conf and hoped to learn then how to interact with our wp?
13:35:47 <kmlussier> StephenGWills: I don't think you need to know GIT to interact with our wp.
13:35:53 * rfrasur listens
13:36:09 <kmlussier> jeff: Would you be willing to explore what options are availlable in WordPress and report back at the next web team meeting?
13:36:10 <StephenGWills> no?  i assumed we did.
13:36:13 <kmlussier> As a first step.
13:36:20 <jeff> It interests me enough to make time. I'll make some inquiries here to ensure that there's no conflict.
13:36:51 <jeff> kmlussier: Are web team meetings usually monthly?
13:37:17 <kmlussier> jeff: Yes. Execept when I fall down on the job.
13:37:30 * dbs notes that with the auto-generated libraries page branch, we would not be far off from requiring only a URL for a live installation to get all of the addresses of every branch, as well as the current version of evergreen being run
13:38:05 <jeff> dbs: That kind of thing is indeed what I had in mind. Are you interested in collaborating? :-)
13:38:07 <dbs> (apologies for jumping in)
13:38:11 * bshum rubs his hands evil-like, "yes, dbs, yes...."
13:38:26 <dbs> jeff: sure. even with you!
13:38:33 * RoganH thinks bshum needs a monocle and persian cat.
13:38:48 <kmlussier> OK, I smell an action item.
13:39:18 <kmlussier> #action jeff and dbs to collaborate on ways to generate an Evergreen libraries directory.
13:39:27 <kmlussier> jeff++ dbs++
13:39:32 <kmlussier> You guys are awesome!
13:39:44 <ericar> So, should I stop updating the roster on the wiki then?
13:39:45 <dbs> Standard disclaimer applies: karma increment us _after_ we deliver something
13:39:50 <kmlussier> Anything else before we move on to the next agenda item?
13:40:14 <dbs> ericar: keep it going until we have something, please :)
13:40:32 <kmlussier> Agreed. Especially since we didn't set a timeline. :)
13:40:51 <kmlussier> #topic Evergreen conference pages
13:41:42 <kmlussier> A while back when we first talked about moving the 2014 conference page to the community web site, there was a suggestion to move previous conferences to the community web site as well.
13:41:58 <kmlussier> I'm not sure how to do this, but I think it's a good thing if we can do this.
13:42:40 <kmlussier> Do others think it's a good thing? If so, is there anyone with the interest, time and ability to move things over.
13:42:55 <ElliotFriend> Does some kind of page already exist somewhere for the previous conferences? On the wiki?
13:43:09 <kbutler> I agree with moving it there. It's a shame to let that info disappear.
13:43:10 <CarrieC> some are on the wiki, others a conference sites hosted by one of the hosts
13:43:19 <kmlussier> ElliotFriend: They each maintained an independent site.
13:43:28 <kmlussier> But there are wiki pages with links to handouts.
13:43:41 <CarrieC> and some of the old sites are gone, now
13:44:05 <ElliotFriend> How long have conferences been going on?
13:44:27 <CarrieC> 2009
13:44:41 <kmlussier> Yes, most conference hosts eventually decide to let the domain lapse. Moving the content to the community site would guarantee that the content sticks around.
13:45:17 <kmlussier> At this time, the only existing sites I'm aware of are from the conferences in Decatur and Vancouver. But I think a backup was made of Indianapolis?
13:46:05 <kmlussier> I can also put an e-mail out to the list for further discussion.
13:46:30 <ericar> FWIW, I still think the wiki is clunky for this information. Also, Vancouver conference is not on the wiki.
13:46:44 <kbutler> Would we want to do anything in particular to the info as we move it, or just basically replicate it on the community website?
13:47:21 <kmlussier> I think the most important info to maintain is the handouts/presentations. If that's all we can do.
13:47:51 <kmlussier> As a current organizer, it's also useful to maintain all that other information because you like to see what other conferences have done. But it's not as necessary.
13:48:08 <CarrieC> this is what Yamil Suarez did for 2012 on the EG wiki: http://wiki.evergreen-ils.org/doku.php?id=conference:2012
13:48:20 <ElliotFriend> I would think replicating it as closely as we can would be a good goal, being some years removed from the actual event
13:48:49 <kmlussier> #link http://wiki.evergreen-ils.org/doku.php?id=conference:2012
13:48:52 <dbs> Doesn't have to be a wiki, necessarily; could be an rsynced section of the website with static pages or WARC if you want to go crazy :)
13:49:11 <kmlussier> OK, we need to wrap up soon, so I'm going to bring this discussiong to the list.
13:50:11 <kmlussier> #action kmlussier to stat discussion to the list on web site from previous eg conferences.
13:50:46 <kmlussier> FWW, I'm willing to serve as a web team liaison for the next planning time to make sure they have everything they need to use the community web site for the next conference.
13:50:52 <kmlussier> s/time/team
13:51:10 <kmlussier> #topic Web team facilitator
13:51:41 <kmlussier> At the last eg conference, I volunteered to serve as the meeting facilitator to help smooth the transition after our previous fearless leader moved on.
13:52:27 <kmlussier> However, I dont' think I'll be able to continue in this role. At the 2014 conference, I'm hoping we might be able to find somebody else to facilitate the meetings.
13:52:50 <kmlussier> So I"m just putting the idea out there now so that people can start thinking about the possiblity of taking on this role.
13:53:17 <kmlussier> Maybe we can have a small meeting at the conference and elect somebody there. :)
13:54:04 <kmlussier> #help Need to find a volunteer to lead webteam meetings starting in April 2014.
13:54:09 <kmlussier> Anything else before we wrap up?
13:54:42 <kmlussier> #endmeeting