#evergreen: 2014-02-12 Developer Meeting

Meeting started by jeff at 14:06:30 US/Eastern (full logs).

Meeting summary

    1. Agenda is at: http://evergreen-ils.org/dokuwiki/doku.php?id=dev:meetings:2014-02-12 (jeff, 14:06:43)

  1. Introductions (jeff, 14:06:56)
    1. jeff is Jeff Godin, Traverse Area District Library (TADL) (jeff, 14:07:10)
    2. phasefx is Jason Etheridge, Equinox (phasefx, 14:07:27)
    3. dbwells is Dan Wells, Hekman Library (Calvin College) (dbwells, 14:07:37)
    4. remingtron is Remington Steed, Hekman Library (Calvin College) (remingtron, 14:07:39)
    5. senator is Lebbeous Fogle-Weekley, Equinox (senator, 14:08:02)
    6. eeevil is Mike Rylander, ESI (eeevil, 14:08:54)
    7. ldwhalen is Liam Whalen, Sitka (ldwhalen, 14:09:18)
    8. agenda: http://evergreen-ils.org/dokuwiki/doku.php?id=dev:meetings:2014-02-12 (jeff, 14:09:25)
    9. berick Bill Erickson, ESI (berick, 14:09:33)
    10. gmcharlt is Galen Charlton, ESI (gmcharlt, 14:09:33)
    11. jeffdavis is Jeff Davis, Sitka (jeffdavis, 14:09:51)

  2. Past Action Items (jeff, 14:09:51)
    1. ACTION: bshum to summarize bug tracking based on feedback from developers (jeff, 14:10:25)
    2. kmlussier is Kathy Lussier, MassLNC (kmlussier, 14:10:26)
    3. gmcharlt is writing up release notes for OpenSRF 2.3-beta, will cut today (jeff, 14:10:58)
    4. ACTION: eeevil After 2.6.0 is cut, eeevil to publish detailed plan about freezing baseline schemas between EG releases and using deprecates/supersedes in database upgrade scripts. This will go on the mailing list and the thread should structure further discussion of pros and cons of eeevil's plan. (jeff, 14:11:50)
    5. dbs is late, also Dan Scott, Laurentian University (dbs, 14:12:46)
    6. ACTION: dbwells to backport bugfix for Encode.pm (bug 1242999) issues to rel_2_5, feedback requested on backporting to earlier releases (jeff, 14:15:35)
    7. https://bugs.launchpad.net/evergreen/+bug/1242999 (jeff, 14:15:38)
    8. bshum has fixed up the 2.4.5 and set 2.4.6 milestones in LP (jeff, 14:16:21)
    9. ACTION: bshum to go through and update the bug statuses to "fix released" for things that are done in milestones for 2.4.5 and 2.4.6 (jeff, 14:16:40)
    10. dbs has written up the release notes as promised in bug # 1261939 for per-library TPAC pages (jeff, 14:17:08)
    11. http://git.evergreen-ils.org/?p=Evergreen.git;a=commit;h=46f49173b6a08f4c7b755de728edbe6bafb9879a (jeff, 14:17:15)
    12. bshum has granted dbwells access to dev calendar so that RM milestone dates can be added (jeff, 14:18:08)
    13. http://www.google.com/calendar/embed?src=tfm2bbqnt7q890jidnqe3u29j4%40group.calendar.google.com&ctz=America/New_York (jeff, 14:19:05)
    14. ACTION: dbwells to add RM dates to dev calendar (jeff, 14:19:57)
    15. berick has opened OpenSRF LP bug with current websocket info (jeff, 14:20:36)
    16. https://bugs.launchpad.net/opensrf/+bug/1268619 (jeff, 14:20:38)

  3. Google Summer of Code (GSoC) 2014 (jeff, 14:21:27)
    1. AGREED: We'll be taking a break from participation in GSoC for this year (jeff, 14:31:38)

  4. Release Info - OpenSRF (jeff, 14:32:06)
    1. OpenSRF 2.3 beta to be cut later today (jeff, 14:32:45)

  5. Release Info - Evergreen (jeff, 14:34:34)
    1. 2.6 beta review period is underway, and is scheduled to conclude on the 18th. Alpha awards have been awarded. (dbwells, 14:35:57)
    2. http://permalink.gmane.org/gmane.education.libraries.open-ils.general/9189 Evergreen 2.6 Alpha - Summary and Awards (jeff, 14:37:35)
    3. https://launchpad.net/evergreen/+milestone/2.6.0-beta1 63 bugs targeted for Evergreen 2.6 Beta (jeff, 14:38:00)

  6. PostgreSQL 9.3 support (jeff, 14:38:55)
    1. several aspects of PostgreSQL 9.3 that break Evergreen (jeff, 14:39:46)
    2. AGREED: Evergreen 2.6 will support PostgreSQL 9.3 (PostgreSQL 9.3 issues to be considered release blockers for Evergreen 2.6) (jeff, 14:50:32)
    3. Further strategy on resolving PostgreSQL 9.3 issues will take place in the existing LP bugs, and/or in irc and on the dev list (jeff, 14:54:07)
    4. ACTION: dbwells to summarize Evergreen 2.6 aspects of PostgreSQL 9.3 support in future 2.6 RM reports (jeff, 14:55:32)

  7. Evergreen Hackfest Plans (jeff, 14:55:40)
    1. ACTION: jeff to start dev:hackfest:eg2014 wiki page and announce on dev list, solicit ideas and further discussion (jeff, 15:00:25)


Meeting ended at 15:01:22 US/Eastern (full logs).

Action items

  1. bshum to summarize bug tracking based on feedback from developers
  2. eeevil After 2.6.0 is cut, eeevil to publish detailed plan about freezing baseline schemas between EG releases and using deprecates/supersedes in database upgrade scripts. This will go on the mailing list and the thread should structure further discussion of pros and cons of eeevil's plan.
  3. dbwells to backport bugfix for Encode.pm (bug 1242999) issues to rel_2_5, feedback requested on backporting to earlier releases
  4. bshum to go through and update the bug statuses to "fix released" for things that are done in milestones for 2.4.5 and 2.4.6
  5. dbwells to add RM dates to dev calendar
  6. dbwells to summarize Evergreen 2.6 aspects of PostgreSQL 9.3 support in future 2.6 RM reports
  7. jeff to start dev:hackfest:eg2014 wiki page and announce on dev list, solicit ideas and further discussion


Action items, by person

  1. bshum
    1. bshum to summarize bug tracking based on feedback from developers
    2. bshum to go through and update the bug statuses to "fix released" for things that are done in milestones for 2.4.5 and 2.4.6
  2. dbwells
    1. dbwells to backport bugfix for Encode.pm (bug 1242999) issues to rel_2_5, feedback requested on backporting to earlier releases
    2. dbwells to add RM dates to dev calendar
    3. dbwells to summarize Evergreen 2.6 aspects of PostgreSQL 9.3 support in future 2.6 RM reports
  3. eeevil
    1. eeevil After 2.6.0 is cut, eeevil to publish detailed plan about freezing baseline schemas between EG releases and using deprecates/supersedes in database upgrade scripts. This will go on the mailing list and the thread should structure further discussion of pros and cons of eeevil's plan.
  4. jeff
    1. jeff to start dev:hackfest:eg2014 wiki page and announce on dev list, solicit ideas and further discussion


People present (lines said)

  1. jeff (72)
  2. dbs (24)
  3. gmcharlt (22)
  4. dbwells (14)
  5. eeevil (14)
  6. pinesol_green (11)
  7. bshum (10)
  8. ldwhalen (5)
  9. berick (4)
  10. phasefx (4)
  11. jeffdavis (2)
  12. remingtron (2)
  13. senator (2)
  14. kmlussier (1)
  15. jl- (1)


Generated by MeetBot 0.1.4.