14:01:55 <jeff> #startmeeting 2014-04-08 - Developer Meeting
14:01:55 <pinesol_green> Meeting started Tue Apr  8 14:01:55 2014 US/Eastern.  The chair is jeff. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:55 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:01:55 <pinesol_green> The meeting name has been set to '2014_04_08___developer_meeting'
14:02:19 <jeff> #info Agenda is at http://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2014-04-08
14:02:29 <jeff> #topic Introductions
14:02:36 <jeff> #info jeff is Jeff Godin, Traverse Area District Library (TADL)
14:02:39 <berick> #info berick Bill Erickson, ESI
14:02:50 <RoganH> #info RoganH Rogan Hamby, SCLENDS
14:02:57 <kmlussier> #info Kathy Lussier, MassLNC
14:03:03 <gmcharlt> #info Galen Charlton, ESI
14:03:17 <dbs> #info Dan Scott, Laurentian University
14:03:18 <bshum> #info Ben Shum, Bibliomation
14:03:24 <dbwells> #info dbwells = Dan Wells, Hekman Library (Calvin College)
14:03:31 <remingtron> #info remingtron = Remington Steed, Hekman Library (Calvin College)
14:03:37 <eeevil> #info eeevil is Mike Rylander, ESI
14:04:00 <jeff> While people are making introductions, a small PSA: if you've not read and digested the OpenSSL security advisory from yesterday, go do that instead. Debian Squeeze is unaffected, but if you're running Wheezy or most LTS versionf of Ubuntu, you're probably in need of an openssl upgrade and Apache restart.
14:04:00 <dkyle> #info
14:04:12 <gmcharlt> jeff++
14:05:45 <jeff> #topic Past Action Items
14:05:49 <jeff> #action bshum to summarize bug tracking based on feedback from developers
14:06:04 <jeff> (based on bshum's status, this is deferred -- anything else to add, ben?)
14:06:23 <bshum> Since we decided at the conference to stick with LP, nothing new on that.  Other than it will get done.
14:06:28 <jeff> thanks!
14:06:32 <jeff> #info eeevil After 2.6.0 is cut, eeevil to publish detailed plan about freezing baseline schemas between EG releases and using deprecates/supersedes in database upgrade scripts. This will go on the mailing list and the thread should structure further discussion of pros and cons of eeevil's plan.
14:06:43 <jeff> eeevil: I'm guessing that's holding on 2.6.0 being cut?
14:06:48 <eeevil> aye
14:06:52 <jeff> #action eeevil After 2.6.0 is cut, eeevil to publish detailed plan about freezing baseline schemas between EG releases and using deprecates/supersedes in database upgrade scripts. This will go on the mailing list and the thread should structure further discussion of pros and cons of eeevil's plan.
14:06:59 <jeff> #info dbwells to backport bugfix for Encode.pm (bug 1242999) issues to rel_2_5, feedback requested on backporting to earlier releases
14:06:59 <pinesol_green> Launchpad bug 1242999 in Evergreen "Encode.pm 2.54 breaks database functions (naco_normalize, maintain_control_numbers, others)" (affected: 1, heat: 12) [High,Fix committed] https://launchpad.net/bugs/1242999
14:07:14 <dbwells> #info done
14:07:36 <jeff> #info bshum to go through and update the bug statuses to ?fix released? for things that are done in milestones for 2.4.5 and 2.4.6
14:07:55 <jeff> bshum: done and done?
14:08:15 <bshum> Yes, though dbwells++ for getting us the LP bugmaster account now for that stuff
14:08:24 <jeff> dbwells++ bshum++
14:08:29 <jeff> #info done
14:08:33 <jeff> #info dbwells to add RM dates to dev calendar
14:08:55 <dbwells> #info done, but in a lazy and lackluster fashion
14:09:16 <jeff> #info dbwells to summarize Evergreen 2.6 aspects of PostgreSQL 9.3 support in future 2.6 RM reports
14:09:30 <jeff> i think that's been addressed as well, and 9.3 blockers dealt with, yes?
14:09:36 <dbwells> yes
14:09:42 <jeff> #info done!
14:09:44 <jeff> #info jeff to start dev:hackfest:eg2014 wiki page and announce on dev list, solicit ideas and further discussion
14:10:07 <jeff> #info not done, no longer relevant
14:10:25 <dbwells> I didn't even know that was an action item :) http://evergreen-ils.org/dokuwiki/doku.php?id=dev:hackfest:eg2014
14:10:36 <jeff> (my fault -- it was my action item!)
14:10:52 <dbwells> Well, it was what it is
14:10:59 <jeff> #topic Release info - OpenSRF
14:11:12 <jeff> gmcharlt: want to cover this?
14:11:13 <gmcharlt> #info OpenSRF 2.3.0 is now available
14:11:19 <jeff> gmcharlt++
14:11:40 <dbwells> gmcharlt++
14:12:13 <gmcharlt> my general thinking is to not pour much effort into rel_2_3 -- specifically, only cut a 2.3.1 if a major bug warrants it, or if timing of Debian Jessie warrants it
14:12:22 <gmcharlt> and focus on 2.4.0 for the early summer
14:12:28 <jeff> #info OpenSRF 2.3.0 required for Evergreen 2.6, functionality release that introduces a new control script, osrf_control, and significantly improves one?s ability to stop, start, reload, and manage OpenSRF services. It also adds the ability to run multiple OpenSRF instances simultaneously on a single server.
14:12:42 <gmcharlt> and provisionally, it looks like the big chagnes for 2.4.0 will be
14:12:45 <jeff> #link http://evergreen-ils.org/documentation/release/OpenSRF/RELEASE_NOTES_2_3_0.html OpenSRF 2.3.0 Release Notes
14:12:46 <gmcharlt> - web sockets support
14:12:55 <gmcharlt> - acting on the CORS support pullrqeuest
14:13:06 <gmcharlt> - removal of osrf_ctl.sh
14:13:34 <gmcharlt> - general improvements relfecting higher Perl versions in distros and stricter C compiler settings
14:14:16 <jeff> #info OpenSRF rel_2_3 branch maintenance-only, focus is on 2.4.0 for early summer 2014: web sockets, CORS, removal of deprecated osrf_ctl.sh, improvements for recent Perl versions and stricter C compiler settings
14:14:20 <gmcharlt> a question for the peanut gallery - is anybody inclined to look at the PHP client library pullrequest and try to beat it into shape?
14:15:06 <eeevil> gmcharlt: also, hopefully, improved chunking/bundling, to avoid some currently required ejabberd config changes
14:15:17 <gmcharlt> eeevil: thanks, I knew I'd missed something
14:15:20 <jeff> I can give the PHP client pullrequest a look-see, and solicit others to do so as well.
14:15:23 <jboyer-isl> I'd rather it be taken behind the barn, but my distaste for php isn't strictly rational.
14:15:40 <Dyrcona> gmcharlt: I looked at the PHP and thought it was in the wrong base repo.
14:15:43 <jeff> #info OpenSRF 2.4 also to focus on improved chunking/bundling, to avoid some currently required ejabberd config changes
14:16:28 <Dyrcona> My memories of it are fuzzy as that was last year sometime before my brain turned to mush.
14:16:45 <jeff> #action jeff to review OpenSRF bug 1109301 for consideration, may solicit the review of others as well
14:16:45 <pinesol_green> Launchpad bug 1109301 in OpenSRF "New submission for a client library in php for openSRF" (affected: 1, heat: 6) [Wishlist,Triaged] https://launchpad.net/bugs/1109301
14:16:55 <gmcharlt> jeff++
14:16:57 <jeff> anything else for OpenSRF release news?
14:17:06 <gmcharlt> not from me
14:17:32 <jeff> #topic Release Info - Evergreen
14:17:36 <bshum> gmcharlt++ # nice summary of cool things to come
14:18:13 <jeff> #info Evergreen 2.6 release status
14:18:19 <jeff> dbwells: over to you!
14:19:14 <dbwells> I my goal is to make as few commits as we can to get to 2.6.0 as soon as possible.
14:19:40 <dbwells> Here is a list of outstanding bugs for .0 https://bugs.launchpad.net/evergreen/+milestone/2.6.0
14:19:40 <pinesol_green> dbwells: Error: malone bug 2 not found
14:19:56 <dbwells> uh, okay
14:19:58 <jeff> #link https://bugs.launchpad.net/evergreen/+milestone/2.6.0 Outstanding bugs targeted at Evergreen 2.6.0
14:20:13 <bshum> Well that was unexpected
14:20:27 <dbwells> 8 of those 10 bugs are really simple polishing bugs
14:20:45 <dbwells> 2 are big problems which are effectively blockers.
14:21:03 <jeff> #info Blockers
14:21:06 <dbwells> 1 was just added a few hours ago
14:21:18 <jeff> #link https://bugs.launchpad.net/evergreen/+bug/1304559 acq and cataloging loader broken in 2.6-rc
14:21:18 <pinesol_green> Launchpad bug 1304559 in Evergreen "acq and cataloging loader broken in 2.6-rc" (affected: 3, heat: 18) [Critical,Confirmed]
14:21:26 <jeff> #link https://bugs.launchpad.net/evergreen/+bug/1303940 Bogus data can lead to null values, breaking indexing
14:21:26 <pinesol_green> Launchpad bug 1303940 in Evergreen "Bogus data can lead to null values, breaking indexing" (affected: 2, heat: 10) [High,New]
14:21:46 <jeff> those two, right?
14:21:58 <kmlussier> Not that I consider it close to critical, but is there any chance bug 1301567 could get in 2.6.0? It makes the MVF work a little more useful.
14:21:58 <pinesol_green> Launchpad bug 1301567 in Evergreen "Catalog needs more format icons" (affected: 1, heat: 8) [Undecided,New] https://launchpad.net/bugs/1301567
14:22:14 <dbwells> Yes, thanks jeff.  I had 2.6.0 provisionally on the calendar for tomorrow.
14:22:43 <dbwells> Then 2.6.1 just two week after that.
14:24:09 <dbwells> kmlussier: I'll take a look at that bug.  I don't think I considered it because it wasn't targetted at all.
14:24:13 <jeff> are the blockers likely to push 2.6.0 past tomorrow?
14:24:30 <asimon> eeevil:  TY.  I think that this function will work.
14:24:39 <kmlussier> dbwells: Yes, looks like I fogot to do that. I can target it now.
14:25:00 <dbwells> kmlussier: thank you!
14:25:20 <eeevil> I'll raise my hand for 1304559 ... I think dbwells is on the right track in the bug comment
14:25:26 <bshum> fwiw, we added the icons kmlussier mentions in the branch to our test system and it seemed fine.  So I'd be happy to push things along.
14:25:28 <gmcharlt> jeff: I think 1303940; since it looks like Dyrcona has reviewed it and given a (virtual) signoff, I'll do a final test and push it today
14:25:36 <gmcharlt> s/1303940/1303940 is/
14:26:02 <dbwells> jeff: I guess we'll see :)
14:26:03 <Dyrcona> I'd like to see some thought given to dbwells' suggestion on 1303940.
14:26:06 <gmcharlt> (and look at dbwells comment)
14:26:11 <Dyrcona> heh
14:26:48 <jeff> #info Evergreen 2.6.0 provisionally on calendar for tomorrow, April 9 with 2.6.1 to follow two weeks later.
14:27:44 <jeff> Anything more to add on 2.6?
14:28:07 <dbwells> no, I think we are good
14:28:09 <jeff> dbwells++ # RM2.6
14:28:10 <bshum> dbwells++ # wrangling and moving things forward
14:28:11 * gmcharlt issues final reminder re bug 1302113
14:28:11 <pinesol_green> Launchpad bug 1302113 in Evergreen 2.6 "acknowledgments in release notes" (affected: 1, heat: 6) [Undecided,New] https://launchpad.net/bugs/1302113
14:28:22 <kmlussier> dbwells++
14:28:29 <gmcharlt> namely, now's your chance to push any final ack updates to the collab branch
14:28:46 <Dyrcona> dbwells++
14:29:03 <jeff> #info Please review the acknowledgements for Evergreen 2.6 and make any additions/updates
14:29:18 <jeff> #link https://bugs.launchpad.net/evergreen/+bug/1302113 bug 1302113 - acknowledgments in release notes
14:29:18 <pinesol_green> Launchpad bug 1302113 in Evergreen 2.6 "acknowledgments in release notes" (affected: 1, heat: 6) [Undecided,New]
14:29:22 <dbwells> eeevil: I did a very quick test of subbing in record_attr_flat for record_attr in vandelay._get_expr_push_jrow().  So far, nothing exploded, but I haven't tested it very hard yet.
14:29:59 <jeff> #info Evergreen 2.5 bug fixes?
14:30:26 <jeff> dbwells: you're still wearing the release maintainer hat for 2.5, correct?
14:30:30 <eeevil> dbwells: that will work fine, I'm only concerned about performance ... my plan is to look directly at the vector
14:31:00 <dbwells> eeevil: that would be even better
14:31:12 <dbwells> jeff: yes
14:32:16 <dbwells> jeff: I don't have much to say about though, other than to say the maintenance release was skipped for March, but is planned for the regular date next week.
14:32:50 <jeff> #info Evergreen 2.5 maintenance release planned for April 16
14:32:59 <jeff> dbwells++ # double duty
14:33:10 <jeff> #info Evergreen 2.4 - final release?
14:33:25 <eeevil> I'll align that with dbwells' next week
14:33:48 <eeevil> after pushing in as many fixes as we can safely
14:34:15 <jeff> #info Final planned Evergreen 2.4 maintenance release scheduled for April 16
14:35:16 <jeff> eeevil, dbwells: any specific things that either of you would like to call attention to in terms of things that you'd like more testing/eyeballs on for any of the above releases?
14:35:49 <dbwells> jeff: nothing I can think of, thanks
14:36:11 <eeevil> nothing specific
14:37:41 <jeff> moving on!
14:37:55 * bshum hijacks the agenda
14:37:59 <jeff> before we move on to "Feedback for New Features Under Development
14:38:32 <jeff> ", I wanted to stick in an agenda item for bshum's RM 2.7 proposal, since that's where the "feedback for new features" part of the meeting idea came from (iirc)
14:39:00 <jeff> #topic New Business
14:39:16 <jeff> #info Release Manager proposal for Evergreen 2.7
14:39:58 <bshum> #link RM 2.7 email - http://markmail.org/message/b23u62e6rhebjkhk
14:40:37 <bshum> So as promised at the in-person dev meeting, I did do a short writeup of some of the general plans or ideas on the table for 2.next (or 2.7 or whatever we're going to call it)
14:41:42 <bshum> I was curious if we have any further feedback on that before we get started with laying out the next steps.
14:43:07 <kmlussier> It all looks great to me.
14:43:10 <kmlussier> bshum++
14:43:41 <dkyle> item 1 from that is why I'm here
14:44:03 <dkyle> plus just looking to get involved again in general
14:44:13 <jeff> I like a number of aspects about the proposal, especially those aspects that deal with communication, focused bug efforts, and deprecation / removal of dead things. :-)
14:44:16 <jeff> bshum++
14:44:16 <jeff> dkyle++
14:44:18 <kmlussier> dkyle++
14:45:12 <bshum> Yeah, regarding deprecation, I think that'll be one of the things we'll have to make a point to announce broadly as gmcharlt suggested in the email thread.
14:45:22 <dkyle> so.. do we mention new features at this point?
14:45:27 <bshum> I know one of the other things we talked about removing is all the leftover code from JSPAC.
14:45:52 <jeff> I don't have notes from the dev meeting in-person at the conference, but bshum's email states that we intended to vote on RM proposals during this dev meeting. Do we intend to do that here, on the list, or are we holding off for now?
14:46:46 <jeff> Looking at the last time we did this, we voted on open-ils-dev.
14:47:23 <dbwells> bshum++ # plan looks good
14:47:39 <jeff> if there's no objection or further comment, I'll give myself an action item for calling for a RM vote on open-ils-dev within the next few days.
14:48:48 <kmlussier> dkyle: We should be getting to that agenda item shortly.
14:49:01 <jeff> #action jeff to call for RM 2.7 vote on open-ils-dev within the next few days
14:49:11 <jeff> #topic Feedback for New Features Under Development
14:49:12 <dbwells> bshum: my only suggestion would be to schedule at least one bug wrangling day in the April/May window.  The bugs pile up fast without somebody banging the drum.
14:49:25 <jeff> #info Metabib display fields
14:49:34 <bshum> dbwells: That's probably a good idea.  I was thinking about early May myself.
14:49:36 <jeff> #link https://launchpad.net/bugs/1251394 Metabib Display Fields
14:49:36 <pinesol_green> Launchpad bug 1251394 in Evergreen "Metabib Display Fields" (affected: 3, heat: 14) [Undecided,New] - Assigned to Bill Erickson (erickson-esilibrary)
14:49:46 <dbwells> bshum: cool, sounds good
14:50:36 <bshum> So I added that as an example of a bug that's been lost in the wilds that probably should see the light of day during 2.next as part of these feature discussion part of the agenda.
14:51:21 <jeff> Metabib Display Fields has benefit for the staff client, reporting, and more. I'm very excited to see it get attention. :-)
14:51:28 <bshum> What I should have done was to email the list ahead of time to ask folks to weigh in on these kinds of bugs.
14:51:44 <bshum> Just a nudge forward kind of thing.
14:51:52 <dbwells> I'll take the blame for any delay on the display fields stuff.  I through a big monkey wrench in, then completely turned my attention to 2.6 management and forgot all about it.
14:52:11 <bshum> I'll try to do that next time.  And I highly encourage other folks to bring up bugs that are important to them to the attention of the group and me (assuming I win the vote ;))
14:52:51 <jeff> bshum: going forward, how much time do you envision spending on new feature attention in dev meetings, and what would you like to see happen in this portion of the meeting?
14:53:01 <dbwells> I think berick's approaching of simply materializing the display fields during ingest is a tried-and-true path.
14:53:13 <jeff> bshum: General "hey! this is coming! feedback welcome!", or something else?
14:54:36 <bshum> jeff: That's a good summary for my part of it.  I mainly would like to see more early communication if possible of ideas / plans for development; especially with regards to 2.next.  I'd like to make sure that we're aware of any potential game-changers before we get too far along.
14:54:57 <kmlussier> I think a general "feedback is welcome" is useful to make sure big changes receive proper attention before anyone starts coding.
14:54:58 <jeff> berick++ eeevil++ dbwells++ work so far on Metabib Display Fields
14:55:11 <bshum> The time requested would be for that sort of "this is coming!" but also if we needed to hash out a specific area, there's always room too for that in the regular chat day or post-meeting.
14:56:51 <jeff> #info Smart Float
14:57:09 <jeff> #link http://markmail.org/message/736mp25legftvjld [OPEN-ILS-DEV] Smart Float: Self balancing floating collections
14:57:43 <dkyle> yeah, Smart Float, was looking for any interest, collaboration, and how to go about maybe getting it rolled into a release
14:58:03 <dkyle> should I put something on LP?
14:58:07 <jeff> dkyle: do you have a launchpad account, and have you had a chance to open a wishlist bug for Smart Float?
14:58:09 <gmcharlt> dkyle: yes
14:58:43 <dkyle> jeff: I do. I did create a working branch last week, but no wishlist item yet
14:59:25 <jeff> dkyle: if you can create a launchpad bug against Evergreen with a link to the working branch, etc, that's going to enable the feature to be targeted at an upcoming release. give a shout in here if you run into any issues or have questions.
14:59:39 <jeff> dkyle: judging from the list conversations, people were interested and i think some had some feedback.
14:59:40 * bshum will keep an eye out for it too
14:59:49 <dkyle> jeff: will do, thanks.
14:59:57 <jeff> dkyle++ grpl++
15:00:35 <jeff> #link https://launchpad.net/evergreen/+milestone/2.next bugs currently targeting Evergreen 2.next
15:01:09 <jeff> I'd encourage everyone to review the bugs currently listed there, and to offer feedback, provide review, or even target new bugs.
15:01:31 <jeff> Since we've hit the 3 PM mark, I'm inclined to leave it at that unless anyone else has something they'd like to go over.
15:02:03 <bshum> Just a small thing, berick++ for getting good feedback from the community on the path for the web client work.
15:02:08 <jeff> Does anyone else have a specific upcoming new feature they'd like to bring attention to, or a non-new-feature topic for the meeting?
15:02:41 <jeff> berick++
15:02:48 <jeff> #link http://wiki.evergreen-ils.org/doku.php?id=dev:browser_staff:dev_notes Browser Staff Client Development Notes
15:03:15 <jeff> I would also encourage everyone to read up on the work being done on the web based staff client, and to offer feedback in the various mailing list threads.
15:03:47 * berick is always happy to respond to questions, etc.
15:03:54 <jeff> pester berick!
15:04:22 <jeff> #endmeeting