14:00:37 <yboston> #startmeeting 2014-05-01 - DIG Monthly Meeting Evergreen Documentation Interest Group (DIG) Monthly Meeting.
14:00:37 <pinesol_green> Meeting started Thu May  1 14:00:37 2014 US/Eastern.  The chair is yboston. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:37 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:37 <pinesol_green> The meeting name has been set to '2014_05_01___dig_monthly_meeting_evergreen_documentation_interest_group__dig__monthly_meeting_'
14:00:47 <yboston> The agenda can be found here http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:dig_meeting_20140501-agenda
14:00:58 <yboston> #topic Introductions
14:00:59 <yboston> Please feel free to start introducing yourselves...
14:01:10 * yboston is Yamil Suarez @ Berklee college of Music - DIG meeting facilitator
14:01:11 <remingtron> #info remingtron is Remington Steed, Hekman Library (Calvin College)
14:01:29 <remingtron> (note, if  you use #info, then it shows up better in the MeetBot minutes)
14:01:38 <yboston> #info yboston is Yamil Suarez @ Berklee college of Music - DIG meeting facilitator
14:02:01 <kbutler> #info kbutler is Kate Butler, Rodgers Library (Hudson, NH)
14:02:04 <rsoulliere> #info /me is Robert Soulliere, Mohawk College
14:02:15 <jihpringle> #info jihpringle is Jennifer Pringle, Sitka Support (BC Libraries Cooperative)
14:02:35 <rfrasur> #info rfrasur is Ruth Frasur, Hagerstown Library (Evergreen Indiana)
14:02:59 <hbrennan> #info Holly Brennan, Homer Public Library, Alaska
14:03:10 <rsoulliere> #info rsoulliere is Robert Soulliere, Mohawk College 2nd try ;-)
14:04:19 <yboston> as we wait for everyone to introduce themselves, should we start talking about the EG 2.6 release notes?
14:04:25 <yboston> or another topic?
14:04:49 <remingtron> maybe we should start with coordinator reports, since we haven't done that in a while
14:05:57 <yboston> OK
14:06:08 <yboston> who would like to go first?
14:06:15 <rsoulliere> I have a couple of items.
14:06:23 <rsoulliere> #topic Conversion Coordinator Report
14:06:32 <yboston> go ahead
14:06:41 <rsoulliere> #info Evergreen Documentation for 2.6 is up and available now and pulling for the rel_2_6 branch.
14:07:02 <rsoulliere> #info Note that the documentation processing is a bit finicky and asciidoc errors may hold back processing of pages you have edited. They may also prevent the PDF file from being produced.  Testing asciidoc syntax before pushing is recommended.
14:07:49 <rsoulliere> #info I sent out a question to the mailing list regarding retiring "Evergreen in Action" on Lulu?
14:07:57 <rsoulliere> #link http://list.georgialibraries.org/pipermail/open-ils-documentation/2014-April/001645.html
14:08:11 <rsoulliere> Any suggestions?
14:08:47 <remingtron> do we have access to the purchase history?
14:09:20 <kbutler> Given that it's out of date, it seems logical to take it down. But will/should/does anyone want to update it?
14:11:07 <rsoulliere> The software freedom conservancy group was managing the financial details of sales.
14:11:18 <remingtron> yeah, since 2.3 is no longer supported, I think we should take it down
14:11:48 <yboston> I agree, since I would eb a fraid of somone paying for something that is out of date.
14:11:56 <rsoulliere> Yeah, that what I was thinking.
14:11:58 <yboston> without realizing it
14:12:15 <remingtron> rsoulliere: do you have the ability to remove it from Lulu?
14:12:52 <rsoulliere> Yes, I can "retire" it so it it no longer available.
14:12:58 <yboston> BTW, if we want we can try a mini vote with those that are hear (using +1 or -1), but I think the consensus is pretty clear
14:13:10 <rfrasur> +1
14:13:20 <remingtron> do we need to ask the authors and/or oversight board folks?
14:13:22 <yboston> also, the content will continue to be available for free under FLOSS manuals(?)
14:14:29 <yboston> remingtron: to be nice and to establish precedent
14:14:42 <rsoulliere> yboston: exactly, and the free electronic versions will still be available from other sources for those needing a copy for sentimental reasons.
14:15:22 <yboston> but since this version is quite old and the risk of someone paying for something without realizing that is out of date, makes me want to act immediatly
14:15:29 <kbutler> +1
14:15:36 <jihpringle> +1
14:15:48 <yboston> a quick heads up to the authors shoudl not take long.
14:16:11 <remingtron> yboston: yeah, for good measure.
14:16:17 <yboston> so we might need a volunteer to pull the Lulu content and to contact the authors
14:16:25 <remingtron> dbs: are you around? quick question about removing EG in Action book from lulu
14:16:27 <yboston> I mean two seperate volunteers
14:16:50 <yboston> BTW, rsoulliere can you take care of removing it from Lulu by yourself?
14:17:13 <rsoulliere> Yes, I can and will remove it.
14:18:25 <yboston> BTW, is it definitive that all of the content from it has already been put in the main docs? I thought there were chinks missing. (this could be simple task for DIG newcomers to verify.)
14:18:53 <yboston> sorry, that shoudl say "chunks"
14:19:14 <remingtron> yboston: Sounds like a good ToDo task for the list: http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:todo
14:20:22 <remingtron> I think we should at least email the authors and EG oversight board folks and give a few days for them to respond before we remove the book from lulu.
14:21:04 <yboston> remingtron: I am updating that wiki page now
14:21:13 <rsoulliere> OK, I will wait until I get the official thumbs up.
14:21:26 <remingtron> rsoulliere: you want to email people then?
14:22:05 <rsoulliere> I can email the authors... What is the process for the Oversight Board... Anyone here on that board?
14:22:14 <yboston> I am on the board
14:22:35 <rsoulliere> yboston: could you get the OK from them?
14:22:37 <yboston> There is a mailing list, and anyone can subscribe to it
14:23:36 <yboston> I will talk to them, again perhaps just to set good precedents
14:24:12 <remingtron> Yeah, we have the power to act, but it's good to communicate with all who may care
14:24:24 <yboston> #action yboston will ask the EG oversight board if they mind that the book EIA is pulled fromt he Lulu account
14:24:58 <rsoulliere> OK, that is all I had in my report.
14:24:59 <yboston> #action rsoulliere will email the authors of EIA to ask if they mind that the book EIA is pulled fromt he Lulu account
14:25:13 <yboston> thanks rsoulliere
14:25:17 <yboston> rsoulliere++
14:25:25 <remingtron> rsoulliere++
14:26:14 <yboston> the other report woudl normally be kathy, but I don't think she is here now
14:26:39 <remingtron> yeah, I don't see her on the channel right now
14:26:55 <yboston> should we switch to the release notes or something else?
14:27:52 <remingtron> sure, this could be a quick vote, unless people have feedback
14:27:57 <remingtron> here's my email proposal
14:28:04 <remingtron> http://markmail.org/message/apb55ar3pooih4ql
14:29:10 <remingtron> I'd like to present this at the next Dev meeting for developer feedback
14:29:15 <remingtron> what does everyone think?
14:30:36 <yboston> I think it is a fine idea, though not sure how often there will be developer time to get extra documentation this way
14:31:03 <yboston> but I think having a place to place draft documentation would be good, before having to worry exactly where ti should fit
14:31:05 <remingtron> we've already had a few devs submit longer docs as release notes
14:31:35 <yboston> good to know
14:31:36 <remingtron> not sure how often it would be useful, but could at least clarify some confusion I've heard
14:31:47 <yboston> good to know again
14:32:01 <rsoulliere> +1
14:32:08 <jihpringle> I think having the definitions of normal docs vs. release notes is helpful
14:32:12 <yboston> it could be a good place for DIG and developers to collaborate on stuff
14:32:32 <yboston> at least new features
14:33:21 <remingtron> any other thoughts?
14:34:06 <rsoulliere> For draft documentation, you could upload an asciidoc file without linking to it in the  root.txt file. Perhaps file name could be prefixed with "draft"? Then it could be reviewed without being processed.
14:34:30 <remingtron> rsoulliere: good idea
14:35:21 <yboston> though it makes me think if there are already some asciidoc files lingering out there that have never been linked?
14:35:25 <remingtron> I guess it could also be added to a branch like other development
14:35:28 <yboston> kinda like using a sperate folder at first
14:36:27 <yboston> just realized we did not start a new Meetbot  "topic"
14:36:46 <yboston> #topic remingtron proposal for release notes
14:36:56 <yboston> BTW, for those that arrived after the start of this meeting, here is the agenda and a link to todays IRC log to catch up with us
14:37:03 <yboston> http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:dig_meeting_20140501-agenda
14:37:21 <yboston> http://irc.evergreen-ils.org/evergreen/2014-05-01
14:37:49 <yboston> any other suggestions? should we vote on the proposal?
14:38:06 * rfrasur needs to run.
14:38:11 <yboston> of course the developers also have to approve it
14:38:22 <rsoulliere> remintron: right, branching is better. Having floating draft doc files could really bloat the repositories.
14:39:08 <remingtron> okay, let's vote on whether I take this to the next dev meeting
14:39:15 <yboston> OK
14:39:25 <yboston> +1
14:39:27 <rsoulliere> +1
14:39:31 <jihpringle> +1
14:40:11 <remingtron> cool, I'll add it to the dev meeting agenda
14:40:21 <yboston> excelent
14:40:34 <yboston> shall we talk about the EG 2.6 todos?
14:40:51 <yboston> or something else. note that we have 20 minutes untilt he hour mark
14:41:54 <remingtron> yeah, let's jump to 2.6 progress reports
14:42:17 <yboston> Here is the list http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:2.6_needs
14:42:47 <remingtron> jihpringle: kbutler: how's it going with your chosen tasks?
14:42:59 <remingtron> any pitfalls you need help getting past?
14:43:12 <kbutler> I am not done yet, but hopefully tomorrow I have time to work on it (and finish up.)
14:44:33 <jihpringle> I have partial documentation but still need to put in the screenshots - I'm hoping to have time to do them early next week
14:44:46 <remingtron> ericar: Just in time, we're talking about EG 2.6 task progress
14:45:32 <remingtron> jihpringle: kbutler: great, feel free to ask the list for help if you need anything, or when you finish, and we can push it into master
14:45:59 <jihpringle> will do
14:46:24 <remingtron> Looks like 3 tasks have been completed and pushed to master already, that's great!
14:46:33 <yboston> BTW, I just finsihed yesterday, and I almost forgot to backport to the 2.6 branch. Thankfully I ran into the email remingtron sent out recently reminding us of the backporting
14:46:57 <kbutler> definitely
14:47:04 <remingtron> yboston: yes, thanks for the reminder again, I have to backport mine still.
14:47:36 <yboston> this was a great trial run of the complete workflow
14:48:09 <remingtron> ericar: any updates on ESI's docs for 2.6?
14:48:58 <ericar> they are complete and just need to be committed to the repository.
14:49:47 <remingtron> great! ericar++
14:50:06 <yboston> ericar++
14:50:09 <yboston> BTW, should those that are "done" sign up for the still unassigned 2.6 items OR team up to help/collaborate with those that have not fisnished yet?
14:50:16 <yboston> also, I was looking over the release notes, and their might be up to three unassigned doc needs that need to be listed for 2.6
14:50:57 <remingtron> yboston: feel free to add things to the 2.6 todo list wiki page
14:51:05 <yboston> for example, the disabling of auto suggest and the deprecation of 'classic_current_circ'
14:51:07 <yboston> OK
14:52:11 <remingtron> I can commit to another task to complete by next month's DIG meeting
14:52:18 <yboston> so can I
14:52:34 <remingtron> anyone else want to commit to a 2.6 feature task?
14:53:14 <remingtron> or does anyone have questions about this process?
14:53:20 <yboston> or find a partner to commit to a 2.6 feature task?
14:53:34 <remingtron> right, I'm willing to partner with anyone
14:53:55 <yboston> me too
14:54:37 <remingtron> hbrennan: I don't want to pick on you, just wondering if you have any thoughts or questions you'd like to share?
14:55:41 <yboston> #action yboston will add more missign features from the 2.6 release ntoes that need documentation
14:56:09 <hbrennan> remington: Being honest, I'm just lurking, at best. I was startled when my browser just started flashing :)
14:56:25 <remingtron> hbrennan: no problem, lurkers are welcome. :)
14:56:58 <krvmga> is this a good time to add a little note?
14:57:14 <remingtron> krvmga: sure! docs related, right?
14:57:22 <hbrennan> remington: Being at the circ desk isn't making it easy to keep up
14:57:36 <hbrennan> remingtron I mean
14:57:43 <remingtron> hbrennan: those patrons are important folks
14:57:58 <krvmga> i've put up nearly three dozen patron-centric documents at http://www.cwmars.org/content/using-online-catalog
14:58:18 <krvmga> everyone should feel free to steal whatever is useful to them
14:58:35 <krvmga> i'll be putting up more in the next week
14:58:50 <jihpringle> krvmga++
14:59:02 <yboston> krvmga++
14:59:09 <yboston> BTW, one suggestion is to check-in on the DIG list two weeks from now, and then see what was finsished by then, to see if we can declare victory over 2.6 so we can shoot for either 2.7 features and older faetures to document for next meeting
14:59:33 <remingtron> krvmga++
14:59:57 <krvmga> the docs at cwmars are for 2.4 but they will all be updated and added to when we go to 2.5 at the beginning of June
15:00:15 <krvmga> the patron docs, that is
15:00:30 <remingtron> yboston: good idea, I can email a 2.6 progress report to the list in two weeks
15:00:55 <yboston> do you want to add a meetbot action item or should I?
15:00:58 <remingtron> krvmga: thanks for sharing your work
15:01:04 <krvmga> yw :)
15:01:23 <remingtron> yboston: go ahead and add the action, I think it only works for the person running the mtg
15:01:39 <yboston> as a test, give it a shot
15:02:55 <yboston> start with #action
15:02:57 <remingtron> #action remingtron will send a 2.6 docs progress report to the DIG list in two weeks
15:03:32 <yboston> I think that should work, but Iw ill make a dup action to be safe
15:03:38 <yboston> #action remingtron will send a 2.6 docs progress report to the DIG list in two weeks
15:03:41 <remingtron> yboston: thanks
15:04:08 <yboston> we are slightly past the hour mark. any more pressing topics or questions?
15:04:39 <remingtron> one quick idea for future consideration
15:04:56 <yboston> BTW, if we follow the current meeting schedule, the next meeting would be June 5th
15:04:59 <yboston> go ahead
15:05:11 <remingtron> #idea I think we should consider planning a DIG hack-away for after 2.7 beta is ready but before 2.7 is officially released
15:05:54 <yboston> sure, but I can't remember when that would roghly fall on, like around September?
15:06:11 <remingtron> yeah, around then
15:06:31 <remingtron> is anyone present vaguely interested?
15:06:39 <yboston> I am interested
15:06:47 <remingtron> it would mostly mean doing some focused Docs work to help get 2.7 docs finished on time
15:06:58 <kmlussier> I'm interested (sorry I'm late.)
15:07:02 <yboston> though we have to watch out not to conflict with the dev hack-a-way
15:07:09 <yboston> in case some want to attend both
15:07:10 <remingtron> may or may not mean being physically at the same location
15:07:19 <yboston> absolutely
15:07:31 <jihpringle> bshum's schedule has 2.7 beta being released Aug 7th and then the RC Sept 4th
15:07:44 <jihpringle> as his general timeline
15:07:50 <remingtron> okay, we can discuss that more later, just wanted to plant the idea
15:07:57 <yboston> no problem
15:08:06 <yboston> anything else from anybody else, even lurkers :)
15:08:44 * krvmga makes scratching sounds on the wall.
15:08:50 <krvmga> rats in the walls
15:09:13 <yboston> going once?
15:09:42 <yboston> going twice?
15:09:53 <krvmga> yboston++
15:10:02 <yboston> #endmeeting