14:07:31 <jeff> #startmeeting 2014-05-19 - Developer Meeting
14:07:31 <pinesol_green> Meeting started Mon May 19 14:07:31 2014 US/Eastern.  The chair is jeff. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:07:31 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:07:31 <pinesol_green> The meeting name has been set to '2014_05_19___developer_meeting'
14:07:36 <jeff> #topic Introductions
14:07:48 <jeff> #info jeff is Jeff Godin, Traverse Area District Library (TADL)
14:07:59 <Dyrcona> #info Dyrcona is Jason Stephenson, MVLC
14:08:03 <tsbere> #info tsbere is Thomas Berezansky, MVLC
14:08:12 <DPearl> #info DPearl is Dan Pearl, C/W MARS
14:08:14 <remingtron> #info remingtron is Remington Steed, Hekman Library (Calvin College)
14:09:09 <eeevil> #info eeevil is Mike Rylander, Equinox
14:09:10 <jeff> #link http://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2014-05-19 Agenda
14:09:19 <jeff> (forgot to link that first!)
14:09:41 <csharp> #info csharp is Chris Sharp, GPLS (mostly absent today, but will read the logs)
14:09:51 <phasefx> #info phasefx is Jason Etheridge, Equinox
14:09:56 <RoganH> #info RoganH is Rogan Hamby, SCLENDS
14:10:45 <jeff> #topic #topic Past Action Items
14:10:52 <jeff> #action bshum to summarize bug tracking based on feedback from developers
14:10:56 <gmcharlt> #info gmcharlt is Galen Charlton, Equinox
14:11:05 <jeff> #info bshum reports this is done-ish
14:11:07 <Dyrcona> I don't believe bshum is her.
14:11:14 <Dyrcona> here
14:11:28 <jeff> #link http://wiki.evergreen-ils.org/doku.php?id=dev:bug_wrangler:faq Evergreen Bug Wrangler FAQ
14:12:13 <jeff> Dyrcona: *nod* -- bshum and kmlussier were unexpectedly unable to participate in today's meeting
14:12:37 <jeff> Any questions about the bug wrangler faq, etc -- see bshum, or ask on the list. :-)
14:12:46 <jeff> #action jeff to review OpenSRF bug 1109301 for consideration, may solicit the review of others as well
14:12:46 <pinesol_green> Launchpad bug 1109301 in OpenSRF "New submission for a client library in php for openSRF" (affected: 1, heat: 8) [Wishlist,Triaged] https://launchpad.net/bugs/1109301 - Assigned to Jeff Godin (jgodin)
14:13:16 <jeff> #info Reviewing (barely), haven't sought feedback/review from others yet. If you're interested, let me know here (now, later) or on the bug.
14:13:26 <jeff> #info jeff to call for RM 2.7 vote on open-ils-dev within the next few days
14:13:28 <berick> #info berick Bill Erickson, ESI
14:13:59 <jeff> #info Call for RM vote (and actual vote) Done! Congrats to Ben Shum, 2.7 RM. :-)
14:14:02 <jeff> bshum++
14:14:38 <Dyrcona> I made my thoughts known on that bug, IIRC.
14:14:56 <jeff> Dyrcona++ yes, thanks!
14:15:20 <remingtron> jeff: did we skip the action item about eeevil's baseline schema thing?
14:15:43 <jeff> remingtron: I did! Thanks for the catch!
14:15:50 <jeff> #action eeevil After 2.6.0 is cut, eeevil to publish detailed plan about freezing baseline schemas between EG releases and using deprecates/supersedes in database upgrade scripts. This will go on the mailing list and the thread should structure further discussion of pros and cons of eeevil's plan.
14:15:57 <jeff> eeevil: anything to report?
14:16:11 <eeevil> jeff: just that I've still got to do that :)
14:16:29 <jeff> #info pending
14:16:47 <jeff> #topic Release info - OpenSRF
14:17:12 <gmcharlt> #info gmcharlt is now thinking mid-summer for an OpenSRF 2.4.0
14:17:55 <jeff> gmcharlt: same likely new features as previously mentioned?
14:17:58 <gmcharlt> more testers for bericks web sockets patches would be great
14:17:59 <gmcharlt> jeff: yes
14:18:06 <jeff> #info OpenSRF rel_2_3 branch maintenance-only, focus is on 2.4.0 for mid summer 2014: web sockets, CORS, removal of deprecated osrf_ctl.sh, improvements for recent Perl versions and stricter C compiler settings
14:18:39 <jeff> #info More testers for WebSockets branch would be great
14:18:51 <jeff> #topic Release info - Evergreen
14:19:50 <jeff> #info Evergreen 2.4.7 released May 8, final planned release in 2.4 series
14:20:13 <jeff> #info Evergreen 2.5.4 released April 23
14:20:29 <jeff> #info Evergreen 2.6.0 released April 15
14:20:56 <jeff> eeevil++ 2.4
14:21:00 <jeff> dbwells++ 2.5
14:21:02 <jeff> dbwells++ 2.6
14:21:15 <jeff> eeevil: any parting words for 2.4? :-)
14:21:31 <eeevil> Evergreen is dead; long live Evergreen!
14:21:34 <jeff> dbwells: anything of note regarding 2.5 and 2.6 planned releases?
14:21:37 <gmcharlt> eeevil++
14:21:43 <remingtron> #info dbwells says 2.6.1 will probably be released this week
14:21:56 <jeff> dbwells++ remingtron++
14:22:05 <jeff> #topic New Business
14:22:14 <jeff> #topic Brief Discussion abour Release Notes
14:23:11 <jeff> There's a bit in the agenda regarding this, and having read it before the meeting it looks good, reasonable, and makes sense.
14:24:21 <berick> agreed
14:24:35 <jeff> I like the idea of DOCS_NEXT, and the clear distinction between what goes into release notes and what becomes documentation.
14:25:28 <jeff> DIG++ kmlussier++ remingtron++ yboston++
14:25:38 <jeff> anyone I'm missing there that should get credit? :)
14:25:58 <remingtron> I think that's the main crew for this blurb
14:26:14 <remingtron> #info developers can send any feedback to the DIG email list
14:27:02 <jeff> good deal. I don't think DOCS_NEXT exists yet -- is someone going to take care of creating that, and possibly putting the summary contained on the agenda into more prominent place... either in the repo or on the wiki or...
14:27:40 <remingtron> I can work on that with dbwells before 2.next gets too far
14:27:56 <remingtron> (and/or with the other DIG folks)
14:29:13 <jeff> # topic Feedback for New Features Under Development
14:29:14 <jeff> er
14:29:16 <jeff> #topic Feedback for New Features Under Development
14:30:34 <jeff> This is intended for discussion of (as it says on the tin) new features under development. First come, first discussed.
14:33:47 <jeff> I'll give a few minutes for anyone to start discussion of new features in development, or alternately any other New Business -- then I think we'll adjourn.
14:37:08 <berick> maybe not the right context, but RoganH, what's the latest on the hackaway?
14:37:49 <RoganH> Right now I've had one tentative offer to host.  I can't say where but myself and the person offering both are concerned about the distance for many attendees.
14:38:22 <RoganH> So, I hope I get more offers.  I know one or two others are discussing at their organizations offering but aren't ready to say "we want to" yet.
14:38:37 <jeff> RoganH: For anyone interested in hosting, can you re-iterate the requirements and expectations for a hackaway host?
14:38:49 <RoganH> Sure.
14:39:06 <RoganH> It's a low key event so we look for help arranging lodging though participants pay themselves.
14:39:22 <RoganH> We need a meeting space with good power and wifi and the chairs can't be too painful.
14:39:32 <RoganH> Providing caffeine is a bonus.
14:40:05 <RoganH> Those are really all we need.  We avoid fancy hotels and expensive venues looking to focus on giving the devs time to work together.
14:40:35 <jeff> Thanks for the recap.
14:40:41 <RoganH> We generally have 10 - 20 attendees so it's not huge.
14:40:53 <jeff> Anyone with anything else for the meeting?
14:41:46 <jeff> #endmeeting