15:01:30 <yboston> #startmeeting 2014-06-05 - DIG Monthly Meeting Evergreen Documentation Interest Group (DIG) Monthly Meeting.
15:01:30 <pinesol_green> Meeting started Thu Jun  5 15:01:30 2014 US/Eastern.  The chair is yboston. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:30 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:01:30 <pinesol_green> The meeting name has been set to '2014_06_05___dig_monthly_meeting_evergreen_documentation_interest_group__dig__monthly_meeting_'
15:01:38 <yboston> The agenda can be found here http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:dig_meeting_20140605-agenda
15:01:55 <jeff> including comments from mpeters, jboyer-isl, hbrennan and kmlussier :-)
15:02:07 <jeff> er. sorry. enjoy the meeting!
15:02:07 <yboston> #topic Introductions
15:02:08 <yboston> Please feel free to start introducing yourselves...
15:02:08 <yboston> #info yboston is Yamil Suarez @ Berklee college of Music - DIG meeting facilitator
15:02:27 <hbrennan> I'm on the circ desk now so I'm going to be quiet. Thanks everyone!
15:02:47 <remingtron> #info remingtron is Remington Steed, Hekman Library (Calvin College)
15:02:57 <kmlussier> Wow. I don't even remember that bug.
15:03:04 <kmlussier> #info kmlussier is Kathy Lussier, MassLNC
15:03:07 <bshum> #info bshum is Benjamin Shum, Bibliomation
15:03:22 <kbutler> #info kbutler is Kate Butler, Rodgers Memorial Library
15:05:10 <yboston> BTW, I was going to try to emulate the developer meetings sty;e for today, apologies in advance
15:05:25 <remingtron> yboston: no worries, go for it
15:05:46 <yboston> they usually start with past items, so I will start listing them for us to decide if we should address it now, shelve it, or push it to next meeting
15:05:58 <yboston> #action Think of ways to increase participation, create an informal survey, training during a DIG hack-a-way, or online DIG training sessions between conferences (by Yamil)
15:05:58 <yboston> #action brainstorming on survey draft (Yamil)
15:06:08 <yboston> oops
15:06:14 <yboston> #topic past agenda items
15:06:20 <yboston> #action Think of ways to increase participation, create an informal survey, training during a DIG hack-a-way, or online DIG training sessions between conferences (by Yamil)
15:06:21 <yboston> #action brainstorming on survey draft (Yamil)
15:07:06 <yboston> we have not covered this in a while, should we shelve it for next week or put it in the back burner (some wiki page) in th meantime?
15:07:19 <remingtron> we had lots of participation at the April meeting right after the conference
15:07:26 <remingtron> I'm sure that's normal
15:07:43 <yboston> we can decide to revisit this issues after we finsish with 2.6?
15:07:52 <remingtron> yes, I agree
15:08:17 <remingtron> that will hopefully be our next meeting, right?
15:08:32 <kmlussier> remingtron: Yes, absolutely! :D
15:09:07 <remingtron> alright, let's push it off to next meeting
15:09:08 <yboston> I was thinking the august meeting,
15:09:16 <yboston> but the next one is fine
15:09:17 <remingtron> ah, that's probably wise
15:09:42 <yboston> quick vote on July vs August?
15:09:56 <remingtron> August
15:10:10 <yboston> August
15:10:22 <remingtron> (unless no one shows up for our July mtg)
15:10:27 <remingtron> :)
15:11:00 <yboston> the next meeting woudl fall on Thursday July 3rd, which might be bad for some
15:11:08 <yboston> we can pick a different date to meet in July
15:11:30 <remingtron> right, given American Independence Day, July 4
15:11:34 <kbutler> not July3++
15:11:34 <bshum> August seems fine to me. :)
15:11:53 <remingtron> next meet July 10?
15:12:00 <kmlussier> I won't be around July 3.
15:12:08 <kmlussier> Or the 10th.
15:12:23 <yboston> three votes for August and none for July are good enough to move on?
15:12:31 <kmlussier> +1
15:12:45 <remingtron> yes, should we decide the next meeting date now, or at end of meeting?
15:13:00 <yboston> I would rather ask on the list
15:13:05 <remingtron> sounds fine
15:13:07 <yboston> to get more peopel to particiate
15:13:36 <yboston> #action move the agenda items on increasing DIG participation and the survey to the Agust meeting
15:14:03 <yboston> #action ask on the DIG mailing list for an alternate July meeting date
15:14:17 <yboston> may I move on?
15:14:18 <kmlussier> yboston: Who is taking that last action item?
15:14:54 <yboston> #action yboston will ask on the DIG mailing list for an alternate July meeting date
15:14:59 <yboston> (thanks)
15:15:01 <kmlussier> yboston++
15:15:04 <remingtron> great
15:15:33 <yboston> #info Including technical information in end-user docs - http://markmail.org/message/twcwas7r4yuavxcq (by Kathy)
15:15:50 * jeff looks up
15:15:51 <yboston> I think we have a general consensus on this
15:15:59 <kmlussier> Oops, I forgot to take that item off of the agenda.
15:16:19 <kmlussier> Did you want to add the action item I suggested in the e-mail?
15:16:24 <jeff> can you summarize the general concensus or point to where it was previously summarized?
15:16:32 <yboston> of course after kmlussier takes it off the agenda, we can always revisit at a future date
15:16:35 <jeff> consensus, even.
15:16:52 * kmlussier looks.
15:17:15 <kmlussier> http://georgialibraries.markmail.org/thread/7vkqwo5hkqcaxg6n
15:17:21 <yboston> should we move on, or does anyone have aby comments?
15:17:29 <kmlussier> the consensus  from that discussion was that people preferred to gather all of the  information about a particular feature (technical, administrative, end  user) into one place.
15:17:34 <jeff> kmlussier++ thanks
15:17:34 <yboston> #link http://georgialibraries.markmail.org/thread/7vkqwo5hkqcaxg6n
15:18:09 <yboston> #action kmlussier will remove the agenda item for tec docs from the agenda for the next meeting
15:18:17 <yboston> *tech
15:19:07 <yboston> may I move on? (sorry, want to blow through old stuff, feel free to tell me to slow down)
15:19:09 <kmlussier> #action kmlussier will add to the DIG style guide info on gathering technical and end user info in one place.
15:19:19 <remingtron> yboston: go right ahead
15:19:23 <kmlussier> +1 to moving on.
15:19:31 <yboston> #info Post conference DIG hackfest discussion
15:19:40 <yboston> # 1) remaining work to be finished
15:19:52 <yboston> #info ideas for next year's conference
15:20:14 <remingtron> I believe the main focus was on bringing old missing docs into current docs, which has been postponed until we get 2.6 finished, right?
15:20:24 <remingtron> (the focus of the hackfest, that is)
15:20:38 <yboston> yes, I was about to say this is another good thing to postpone until August
15:20:50 <remingtron> yes, I agree
15:20:57 <kbutler> I agree re: postponing
15:21:22 <kmlussier> +1
15:22:13 <yboston> #action yboston will move action item about finishing DIG 2013 hackfest work to August meeting agenda
15:22:32 <yboston> #action yboston will move action item about finishing DIG 2014 hackfest work to August meeting agenda
15:22:54 <yboston> I think we can ignore the brainstorming for now
15:23:32 <yboston> will move on (?)
15:23:43 <remingtron> go ahead
15:23:50 <yboston> #info Reminder to use (and keep improving) the DIG AsciiDoc Style Guide
15:24:10 <remingtron> just wanted to remind people that it exists
15:24:24 <remingtron> feel free to edit, improve, etc.
15:24:30 <yboston> we could move this to that page about our general todos?
15:24:42 <remingtron> yes, great idea
15:24:48 <remingtron> I'll do that
15:25:09 <yboston> should I create the action item for you or do you want to do it?
15:25:10 <remingtron> #action remingtron will move style guide reminder to DIG ToDo page
15:25:13 <yboston> nice
15:25:16 <remingtron> thanks
15:25:20 <yboston> moving on
15:25:35 <yboston> #info Discuss if we should pick a new monthly day and time for DIG to meet (Yamil)
15:26:03 <yboston> we have had OK attendace so far since after the conference. I think the IRC practice helped a bit
15:26:24 <yboston> we can postpone this for a while, maybe part of the outreach to the general comunity
15:26:39 <remingtron> summer is tricky, what if we try using Doodle to schedule the next meeting or two?
15:26:41 <yboston> *community
15:26:58 <yboston> we can try with the July meeting
15:27:15 <kmlussier> +1
15:27:18 <yboston> I can set up the doodle
15:27:58 <yboston> I will pick 2 or 3 PM for several days in the first two weeks of July (?)
15:28:28 <kbutler> +1
15:28:32 <remingtron> maybe just pick one week
15:28:45 <yboston> BTW, I am picking afternoons to help make it easy on West coast folks.
15:28:57 <yboston> yes, I can start with one week only for now
15:29:07 <yboston> will pick the second week of july
15:29:12 <remingtron> sounds good
15:29:16 <kmlussier> The week of July 7?
15:29:28 <kmlussier> I'll be out that week, but I can always miss a meeting. :)
15:29:34 <yboston> yes, July 7th, unless that is bad for you
15:29:48 <remingtron> if it's bad for others, we can always change weeks
15:30:03 <yboston> Is the first week any worse?
15:30:23 <remingtron> I think so, because of 4th of July
15:30:42 <yboston> I will do the first two weeks (a few days in both)
15:30:52 <remingtron> sounds fine
15:31:15 <yboston> @action yboston will set up a doodle poll for scheduling the July DIG meeting
15:31:15 * pinesol_green yboston will set up a doodle poll for scheduling the July DIG meeting
15:31:27 <yboston> #action yboston will set up a doodle poll for scheduling the July DIG meeting
15:31:52 <yboston> #New DIG Workflow: Document all new 2.6 features by July 1, and all new future version features by the time the version is released.
15:31:58 <yboston> #info New DIG Workflow: Document all new 2.6 features by July 1, and all new future version features by the time the version is released.
15:32:14 <yboston> #info 1. To review: All members choose 1-3 new features to document each month, emailing the list with questions and calls for help.
15:32:26 <yboston> #info 2. Assignments: Everyone choose another 1-3 remaining new features for the next month
15:32:45 <yboston> #info 3. Progress Reports: How did this month go? Suggestions for improving the workflow? Tough features that need special attention?
15:33:50 <remingtron> #link http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:2.6_needs&#cataloging
15:34:00 <remingtron> oops, ignore the "cataloging" part
15:34:07 <yboston> kbutler was working on something, and I am sorry I did not have an abswer for your question
15:34:09 <remingtron> #link: evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:2.6_needs
15:34:31 <kmlussier> I expect to have mine complete by July 1.
15:34:39 <kbutler> I took the silence as an 'nope, this isn't documented yet' response.
15:34:55 <remingtron> kbutler: you were correct!
15:35:09 <kbutler> Adding that in means I'm not done yet but I should be done by the deadline. :)
15:35:10 <kmlussier> kbutler: I find that often happens when I'm documenting something that seems to be a small task.
15:35:13 <yboston> kbutler: I started doing a low level text search of the raw docs, but I did not get far enough to get you an answer
15:35:37 <yboston> (I checked out the repo and just used "grep -i standing")
15:36:56 <yboston> I think there is one or two things that are new in 2.6 that are not in my list, but I need to verify and list them on this list. I think they might be simple enough that I can maybe docuemnt them myself by th edeadline
15:37:12 <yboston> (I looked at it a month ago and don't remmeber what I saw)
15:37:16 <kbutler> thanks to everyone who looked.
15:37:25 <remingtron> kbutler: do you want any help, or want to handle it yourself?
15:38:13 <kbutler> I think I'm ok, but if anyone has thoughts on where it should go within the documentation I would be happy to hear them.
15:38:24 <kbutler> But I will send that to the list.
15:39:36 <remingtron> my only suggestion is to do a quick Google search, which will hopefully turn up wiki pages, email conversation, Evergreen blogs, etc. which might help
15:39:48 <kbutler> good idea
15:40:27 <remingtron> I grabbed another todo item today, should be done soon.
15:40:52 <yboston> There are also docs by the BC and Indianapolis libraries that might cover it, for example
15:41:01 <yboston> BTW, another side project for us is to move that content to the main docs
15:41:24 <kmlussier> All of it? Or just the parts that aren't already covered by the docs?
15:41:40 <yboston> I meant the parts that we are missing
15:41:47 <remingtron> yboston: we should add an action of "prioritize missing or external docs to add in"
15:42:17 <yboston> for example, in the general to dos page?
15:42:52 <remingtron> sure!
15:43:17 <yboston> can you take care of that one?
15:43:21 <yboston> or somebody else?
15:43:25 <remingtron> I'll do it
15:43:53 <remingtron> #action remingtron will start a prioritized list of missing or external docs to bring in
15:44:25 <yboston> BC libraries mentioned they want to help with integrating their content with us
15:44:34 <remingtron> great!
15:44:55 <yboston> btw, we are at the 45 minute mark, we are doing well
15:45:09 <kbutler> integrated content++
15:45:26 <yboston> do we want to stay on this topic a little longer or move on?
15:45:57 <remingtron> haven't heard much progress from Jennifer or Elliot
15:46:01 <yboston> Do we have any ESI folks that could comment on their 2.6 doc progress?
15:47:08 <kmlussier> yboston: They usually introduce themselves at the beginning when they're here.
15:47:32 <yboston> I know, but I was wondering if they showed up on the later side :)
15:48:33 <yboston> BTW, at this point we only have to "new" agenda issues to discuss. SHould I move on, with the assumption that we can keep talking about 2.6 on the list?
15:49:35 <remingtron> sure, I'll send another progress requst to the list
15:49:51 <remingtron> #action remingtron will email the DIG list for a progress report
15:49:56 <yboston> thanks
15:50:10 <yboston> #topic Early plans for updating documentation for new web-client (Yamil)
15:50:23 <yboston> this has been discussed a bit on the list so far
15:50:53 <yboston> on one hand we can do too much at this time while the client is so rapidly evolvimg
15:51:03 <yboston> (can't do)
15:51:55 <kmlussier> I think we should take the approach remingtron recommended for new features. If a piece of the web client is ready at release time, then it should be included as new features to document by the general release deadline.
15:51:59 <yboston> I suspect a version of the browser client could appear in 2.7 with very limted functional
15:52:11 <remingtron> kmlussier++
15:52:19 <kbutler> kmlussier++
15:52:28 <yboston> remingtron++ kmlussier++\
15:53:18 <yboston> I think that for now that is enough to cover ont his topic, but I am open to talking more about it now too
15:53:51 <remingtron> sounds fine for now
15:54:15 <kbutler> not much can be done until there are firmer plans for a release date
15:54:26 <yboston> moving on
15:54:31 <yboston> #info Do we need to plan a DIG hack-a-way for before Evergreen 2.7 is released?
15:55:11 <yboston> for the record, DIG hack-a-way have been held around October/November, but we do not need to stick to that
15:55:26 <yboston> we can also postpone this dicsussion until a future meeting
15:55:38 <remingtron> can we get a quick vote of interest?
15:55:39 <yboston> perhpas, depending on how well we do with 2.6
15:56:02 <yboston> first can we determine a rough date for when 2.7 might come out?
15:56:14 * kmlussier looks at bshum
15:56:30 <bshum> The dates are on the calendar already
15:56:35 <bshum> I plan to stick to them.
15:56:36 <yboston> I should have emphasized "might"
15:56:46 <yboston> let me look
15:57:03 <remingtron> Sept 18 for 2.7.0 Final
15:57:15 <remingtron> August 7 -- 2.7 beta
15:57:26 <kmlussier> So August 7 is when we know what we need to document.
15:57:29 <remingtron> DIG can do most of our work once beta is out
15:57:34 <remingtron> yup
15:58:21 <yboston> I am up for a DIG hack-a-way before Sept 18 for 2.7.0 Final
15:58:34 <remingtron> me too
15:59:03 <kbutler> me too
15:59:42 <yboston> do we want/can we start working on it before the beta?
16:00:08 <remingtron> sure, we can document features as they get committed
16:00:09 <kmlussier> Sounds like a good idea.
16:00:12 <remingtron> starting now
16:00:27 <yboston> Also, I can host folkt at Berklee again, but we can try somewhere else too
16:00:34 <remingtron> who wants to watch the git logs and make a list for us?
16:00:41 * kmlussier can do that.
16:00:54 <remingtron> kmlussier++
16:00:58 <yboston> my concerd is that there is no 2.7 branch yet (or is there)
16:01:15 <yboston> I thought some things that are in master, in theory, might not make it to 2,7
16:01:17 * kmlussier commits to documenting any MassLNC-sponsored billing features if and when they make it in.
16:01:32 <kmlussier> yboston: No, if they are in master, they will make it to 2.7
16:01:37 <bshum> Correct.
16:01:52 <bshum> master is basically what will become 2.7 till we branch it.
16:02:56 <yboston> OK, tha tmakes sense
16:03:00 <yboston> *that
16:03:46 <yboston> so should that mean that we might not want to focus much on older missing stuff until October?
16:04:07 <yboston> or maybe just that most of us will focus on 2.6/2.7 and a few of us can focus on older/missing stuff
16:04:08 <bshum> Thing is, things will always change
16:04:20 <yboston> (BTW, we are at a little past the hour mark)
16:04:36 <bshum> But how much of it might change a lot with the web client coming up?  At the very least, screenshots.
16:04:52 <bshum> But that's like... way past 2.7 :)
16:05:15 <remingtron> I think the majority of our time should go toward new stuff, but some old priority stuff should get done too
16:05:57 <remingtron> 70-80% new features, the rest on filling in the gaps in the docs
16:06:10 <remingtron> (that's % of our time)
16:06:11 <yboston> I think as we get better at documenting, we can do both more easily
16:07:00 <remingtron> great, I think we got through everything on the agenda!
16:07:15 <yboston> so should we create an action item for adding something to the august agenda to start working on 2.7?
16:07:34 <remingtron> yes
16:08:27 <yboston> #action yboston will add an agenda item to the august meeting to have DIG start looking at 2.7 new features
16:09:11 <yboston> we are past the 1 hour mark, and we have quickly goen over all the agenda items
16:09:18 <yboston> shoudl we wrap it up for today?
16:09:33 <kmlussier> yboston++ #Making it through all the agenda items!
16:09:35 <remingtron> I think so
16:09:41 <remingtron> yboston++!
16:10:11 <yboston> thanks everyone, to be continued
16:10:15 <yboston> #endmeeting