#evergreen: Evergreen Developer Meeting - 2014-06-12
Meeting started by bshum at 14:05:07 US/Eastern
(full logs).
Meeting summary
- Introductions (bshum, 14:05:14)
  - bshum = Ben Shum, Bibliomation (bshum,
    14:05:20)
- DPearl1 is Dan Pearl from C/W MARS Inc.
    (DPearl1,
    14:05:22)
- kmlussier = Kathy Lussier, MassLNC (kmlussier,
    14:05:33)
- RoganH = Rogan Hamby, SCLENDS (RoganH,
    14:05:34)
- dbwells = Dan Wells, Hekman Library (Calvin
    College) (dbwells,
    14:05:57)
- remingtron is Remington Steed, Hekman Library
    (Calvin College) (remingtron,
    14:06:00)
- Agenda:  http://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2014-06-12
    (bshum,
    14:06:00)
- dkyle Doug Kyle, Grand Rapids Public
    Library (dkyle,
    14:06:06)
 
 
- Past action items from last meeting (bshum, 14:09:00)
  - eeevil After 2.6.0 is cut, eeevil to publish
    detailed plan about freezing baseline schemas between EG releases
    and using deprecates/supersedes in database upgrade scripts. This
    will go on the mailing list and the thread should structure further
    discussion of pros and cons of eeevil's plan. (bshum,
    14:09:11)
- eeevil = Mike Rylander, ESI (eeevil,
    14:09:35)
- dbwells' plan:  http://markmail.org/message/tl5d3tnupq2istx7
    (bshum,
    14:10:48)
- gmcharlt = Galen Charlton, ESI (gmcharlt,
    14:11:10)
- HELP: Get more
    responses and ideas sent to list about future Evergreen upgrade
    strategy. (bshum,
    14:11:59)
 
 
- OpenSRF release (bshum, 14:13:40)
  - gmcharlt aiming for an OpenSRF 2.4 release
    after ALA (bshum,
    14:14:57)
- Get more testing of the websocket work started
    by berick, see https://bugs.launchpad.net/opensrf/+bug/1268619 and
    others (bshum,
    14:15:48)
 
 
- Evergreen maintenance releases (bshum, 14:18:17)
  - 2.5.5 and 2.6.1 are out (dbwells,
    14:19:14)
- https://bugs.launchpad.net/evergreen/+bugs?field.searchtext=&orderby=-importance&search=Search&field.status%3Alist=NEW&field.status%3Alist=CONFIRMED&field.status%3Alist=TRIAGED&field.status%3Alist=INPROGRESS&field.status%3Alist=INCOMPLETE_WITH_RESPONSE&field.status%3Alist=INCOMPLETE_WITHOUT_RESPONSE&assignee_option=any&field.assignee=&field.bug_reporter=&field.bug_commenter=&field.subscriber=&field.structural_subscriber=&field.
    (bshum,
    14:22:14)
- Next maintenance releases due out on 6/18/14.
    Core committers and other reviewers, please make best effort to look
    at bugs and sign-off on work. (bshum,
    14:24:01)
 
 
- Evergreen 2.7 update (bshum, 14:25:07)
  - Today (6/12) was the new date to assign first
    milestones for major work to be considered for 2.7. (bshum,
    14:25:45)
- dbs, Laurentian University (dbs,
    14:32:40)
 
 
- The Hack-A-Way potential location (bshum, 14:42:05)
  - hackaway poll
    http://doodle.com/qzzfem72ixntitnv (RoganH,
    14:42:31)
 
 
- Other Mentions (bshum, 14:48:17)
  - dbs brought up phabricator as a potential
    replacement for LP, etc. (bshum,
    14:48:36)
- Wikimedia blog post about their move:  http://blog.wikimedia.org/2014/06/10/on-our-way-to-phabricator/
    (bshum,
    14:49:01)
- change floating back to bool: https://bugs.launchpad.net/evergreen/+bug/1319919.
    wonder if there is agreement on this? (dkyle,
    14:52:05)
 
 
- Feedback for New Features under development (bshum, 14:55:41)
  - Conditional Negative Balances -
    https://bugs.launchpad.net/evergreen/+bug/1198465 (bshum,
    14:56:15)
- ACTION: dbwells to
    review and comment on conditional negative balance bug:
    https://bugs.launchpad.net/evergreen/+bug/1198465 (bshum,
    15:06:09)
- ACTION: kmlussier to
    work on summary of bug to list and gather more feedback to move
    forward (bshum,
    15:06:29)
 
Meeting ended at 15:09:42 US/Eastern
(full logs).
Action items
  - dbwells to review and comment on conditional negative balance bug: https://bugs.launchpad.net/evergreen/+bug/1198465
- kmlussier to work on summary of bug to list and gather more feedback to move forward
Action items, by person
  -  dbwells 
    - dbwells to review and comment on conditional negative balance bug: https://bugs.launchpad.net/evergreen/+bug/1198465
 
-  kmlussier 
    - kmlussier to work on summary of bug to list and gather more feedback to move forward
 
People present (lines said)
  - bshum (88)
- berick (23)
- RoganH (21)
- kmlussier (14)
- dbwells (14)
- pinesol_green (8)
- dbs (7)
- eeevil (5)
- jeff (4)
- gmcharlt (3)
- hbrennan (3)
- dkyle (2)
- DPearl1 (2)
- jeffdavis (1)
- remingtron (1)
Generated by MeetBot 0.1.4.