13:01:02 <gmcharlt> #startmeeting Evergreen Web Team meeting, 18 June 2014
13:01:02 <pinesol_green> Meeting started Wed Jun 18 13:01:02 2014 US/Eastern.  The chair is gmcharlt. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:02 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:01:02 <pinesol_green> The meeting name has been set to 'evergreen_web_team_meeting__18_june_2014'
13:01:08 <gmcharlt> #link http://wiki.evergreen-ils.org/doku.php?id=webteam:meetings:agenda:2014-06-18 Agenda
13:01:15 <gmcharlt> #topic Introductions
13:01:19 <gmcharlt> #info Galen Charlton, ESI
13:01:35 <bshum> #info Ben Shum, Bibliomation
13:01:54 <jeff> #info Jeff Godin, Traverse Area District Library (TADL)
13:02:06 <ericar> #info Erica Rohlfs, ESI
13:02:12 <kmlussier> #info Kathy Lussier, MassLNC
13:03:37 <gmcharlt> #topic Action items from previous meetings
13:03:48 <gmcharlt> first up - gdunbar will proceed with the redesign of the downloads page
13:04:04 <gmcharlt> unless gdunbar chimes in now, I'll assume it should just be carried over to the next meeting
13:04:22 <kmlussier> graced^^
13:05:23 <gmcharlt> ok...
13:05:50 <gmcharlt> similarly, I haven't yet poked at the "learn more" buttons issue, although path forward seems clear: a minor tweak to the theme itself
13:06:27 <gmcharlt> #action (carry-over) gdunbar will proceed with the redesign of the downloads page
13:06:37 <gmcharlt> #action (carry-over) gmcharlt will investigate options for the “learn more” buttons
13:06:47 <gmcharlt> next up, the proposed developments projects page
13:07:11 <gmcharlt> kmlussier: thanks for that note to open-ils-general yesterday
13:07:37 <gmcharlt> have you gotten any feedback yet?
13:07:43 <kmlussier> I think graced has some projects she'll be adding to that page this week.
13:07:53 <kmlussier> No feedback yet.
13:09:22 <gmcharlt> ok
13:09:24 <gmcharlt> kmlussier++
13:09:26 <gmcharlt> graced++
13:09:28 <gmcharlt> next up
13:09:38 <gmcharlt> ericar to work with jeff and dbs on the Evergreen libraries directory
13:10:15 <gmcharlt> ericar: jeff: any progress?
13:10:17 <ericar> jeff replied to my email and I dropped the ball. I also need to update the roster
13:11:15 <jeff> tuit shortage on everyone's part, I'd imagine. If anyone has data outside what's on the wiki at http://wiki.evergreen-ils.org/doku.php?id=evergreen_libraries, I'd be interested in it.
13:11:35 <ericar> I like kmlussier suggestion of buddypress
13:11:39 <jeff> i.e., does anyone have the KML files mentioned here: http://www.molyneux.com/EGmaps/ or can anyone point me at the dumps of the old RSCEL site?
13:11:53 <bshum> jeff: The KML files are in the git repo for Evergreen_Website
13:12:09 <jeff> bshum++ thanks!
13:12:17 <bshum> jeff: See the "maps" directory
13:12:22 <gmcharlt> #info the KML files from http://www.molyneux.com/EGmaps/ are in the Evergreen_Website Git repo
13:12:36 <kmlussier> I think Anoop had the dumps from RSCEL
13:12:48 <ericar> jeff: there are more libraries that need to be added to that roster :)
13:12:55 <jeff> ericar: good to hear! :-)
13:13:00 <jeff> ericar++
13:13:10 <gmcharlt> ericar: so as a short-term action item, you'll add them at some point?
13:13:31 <ericar> gmcharlt: yes
13:13:44 <gmcharlt> #action ericar to add more libraries to the current roster
13:14:03 <gmcharlt> and more broadly, hopefully tuits will start appearing again after ALA
13:14:30 <gmcharlt> ok
13:14:44 <gmcharlt> moving on, the discussion of previous conference websites
13:15:41 <gmcharlt> #link http://list.evergreen-ils.org/pipermail/evergreen-web-team/2014-June/000508.html Query about previous conference websites
13:16:20 <gmcharlt> kmlussier: from my POV, it would be enough of a win to put up a page that nicludes the handouts, the schedule, and the conference logo
13:16:34 <bshum> I didn't get to reply the list, but stating now that I'd generally prefer getting content moved and not moving towards mirroring the entire original conference sites.
13:16:45 <bshum> +1 to gmcharlt's short list
13:17:05 <kmlussier> If that's all that needed, then I think that's something I can work on.
13:17:31 * gmcharlt pounces
13:18:16 <gmcharlt> #action kmlussier to create pages with handouts, schedule, logo etc. from the previous conference (as material is/becomes available)
13:19:16 <gmcharlt> #action (carry-over) gmcharlt will coordinate with the EOB regarding the trademark policy page
13:19:23 <gmcharlt> next up - the how to use LP page
13:19:28 <gmcharlt> ericar?
13:19:56 <ericar> in progress then will send to bshum
13:20:03 <gmcharlt> yay!
13:20:04 <gmcharlt> ericar++
13:20:09 <bshum> ericar++
13:20:55 <ericar> will be complete before next meeting, because I want to get it done
13:21:26 <gmcharlt> #action ericar will complete the how to use LaunchPad page and give it to bshum to put up
13:21:47 <gmcharlt> next up, the FAQs
13:21:49 <gmcharlt> phasefx?
13:23:45 <gmcharlt> ok, moving on
13:23:50 <gmcharlt> #action (carry-over) phasefx will work on the FAQs
13:23:54 <gmcharlt> next up, site search
13:24:23 <gmcharlt> bshum?
13:24:28 <bshum> Oh right
13:24:39 <bshum> So I added some basic details on the agenda on what we have right now
13:24:52 <bshum> For the moment what I've done is to add a right side widget for the Google Custom Search Engine
13:24:58 <gmcharlt> #info The Google Custom Search Engine box is now on the main index page, with results being added to a white area right above the blog posts.
13:25:11 <bshum> And then I customized the index page to include a spot for the results snippet
13:25:31 <bshum> So results come in to fill the space above the blog posts, when you do use the CSE widget
13:26:08 <bshum> I tried a couple other variations -- popup over the site (which didn't work with certain elements on the page) or results under the widget, but it's too narrow for results to view cleanly.
13:26:31 <bshum> I didn't like how it worked with a mobile view (the results appear above the search widget due to how it's organized)
13:26:42 <bshum> But it's one small step back in the right direction.
13:27:21 <bshum> For now, it only resides on the index page as we get some more general feedback on how it works
13:27:35 <gmcharlt> what is included in its index?
13:28:03 <bshum> Let's see
13:28:06 <bshum> IRC
13:28:17 <bshum> the wiki, mailing lists for docs, dig, general
13:28:28 <bshum> The git site
13:28:40 <kmlussier> documentation
13:28:52 <bshum> Right, docs
13:28:56 <kmlussier> the blog
13:29:04 <bshum> Err, maybe not docs...
13:29:22 <bshum> I thought it covered it, but now I'm not 100% sure which engine I attached :)
13:29:23 <gmcharlt> the Git site? gitweb doesn't hold up all that well against crawling
13:29:25 <bshum> There's been a few
13:29:27 <kmlussier> Oh, maybe not blog either. I was just reading the tabs on the search results page, but there's nothing there.
13:30:14 <kmlussier> Is there any chance the other discussion lists could be added? The ones that are not open-ils lists?
13:30:32 <bshum> Probably
13:30:44 <bshum> I guess we need to tinker with the Google custom search engine settings
13:31:04 <kmlussier> There's a RSCEL tab too. Probably could be taken down. :)
13:31:43 <jeff> the lists included currently are: open-ils-documentation, eg-oversight-board, open-ils-commits, opensrf-commits, open-ils-general, and open-ils-dev
13:31:58 <jeff> bshum: i can assist with tweaking/testing CSE settings if you like
13:32:00 <bshum> Oh, good, jeff is an admin too
13:32:10 <bshum> Yeah I was just trying to remember who has access to the CSE
13:32:10 <gmcharlt> bshum: for the sake of avoiding the bus factor, could you write up somewhere where and how one goes about tweaking CSE?
13:32:26 * dbs is an admin too, he thinks
13:32:48 <dbs> yup.
13:32:48 <bshum> Yes, phasefx owns it, dbs, jeff, and I are admins.  (Anoop too)
13:33:55 <gmcharlt> ok
13:34:12 <gmcharlt> #action bshum et all will tweak the Google CSE settings
13:34:34 <kmlussier> bshum++
13:34:34 <dbs> *poof* docs are now part of the search engine
13:34:40 <kmlussier> It's so nice to see the site search back.
13:34:45 <gmcharlt> #info requested changes include: making sure that all EG mailing lists are indexed as well as the blog
13:34:52 <gmcharlt> dbs++
13:35:02 * phasefx is late to the party
13:35:03 <kmlussier> dbs++ #It's like magic!
13:35:06 <ericar> dbs++
13:35:21 <dbs> RSCEL is gone
13:35:30 <gmcharlt> cool
13:36:47 <frank> hi all, Could someone tellme how can I update the cover image resource in my TPAC?, I already upload the correct image to openlibrary.org, but the change doesn´t apply yet
13:36:50 <jeff> wiki is in there twice, but that's as it should be for now. getting google to notice and prefer the wiki hostname over the old /dokuwiki/ subdir is probably worth doing also.
13:37:20 <jeff> ~sorrymeeting | frank
13:37:20 <pinesol_green> frank: Hi! Welcome to the Evergreen ILS support channel!  We're in a meeting right now, so we'll ask you to hold your questions until we're done.  Thanks!
13:37:27 <bshum> Likewise if we ever get all the IRC logs consolidated / uniform
13:38:04 <frank> pinesol_green: oh sorry, I didn´t know
13:38:04 <pinesol_green> frank: http://www.firstpersontetris.com/
13:38:05 <pinesol_green> frank: I am only a bot, please don't think I'm intelligent :)
13:38:33 <gmcharlt> phasefx: can you speak regarding the FAQs?
13:38:35 <jeff> bshum: Especially now that it's more common to link from bug comments to irc logs, we should try to ensure that links aren't broken in any future consolidation.
13:38:42 <phasefx> gmcharlt: I have done nothing since the last meeting with them
13:38:55 <jeff> heck, the logs even link to themselves now. :-)
13:38:55 <gmcharlt> ok
13:38:58 <phasefx> they're probably worth putting up as is, but they can have more
13:39:20 <gmcharlt> well, nothing like spurring incremental improvement
13:39:38 <dbs> FAQ: When will the FAQ be updated?
13:39:42 <gmcharlt> folks - thoughts on phasefx going ahead and putting up what he has now?  IIRC, he made draft avaialble for review last meeting
13:40:05 <phasefx> for reference: http://evergreen-ils.org/dokuwiki/doku.php?id=phasefx:faq
13:42:28 <kmlussier> I think he can put up what he has now as long as number 7 is either answered or removed.
13:42:57 <phasefx> yeah, I can remove the skeletal bits from "production"
13:43:03 <gmcharlt> +1
13:43:11 <bshum> +1
13:43:42 <jeff> +1
13:45:00 <gmcharlt> ok
13:45:07 <gmcharlt> phasefx: do you have the tuits in the near term?
13:45:28 <phasefx> gmcharlt: yes, but may need a point in the right direction re: wordpress, menus, etc.
13:45:42 <gmcharlt> phasefx: cool; I can help with that
13:45:51 <phasefx> excellent
13:46:06 <gmcharlt> #action phasefx will put up the completed FAQ entries
13:46:27 <gmcharlt> then for the final action item
13:46:41 <gmcharlt> I have indeed pinged RoganH about his idea for the support page
13:46:49 <gmcharlt> *cough* did so today
13:47:41 <gmcharlt> ok
13:48:03 <gmcharlt> before we look at the task spreadsheet, are there any new topics folks would like to bring up?
13:50:31 <gmcharlt> ok
13:50:39 <gmcharlt> so, from the task list
13:51:52 <gmcharlt> kmlussier: regarding the get involved page? any progress to report?
13:52:04 <gmcharlt> bshum: similarly regarding the old IRC logs?
13:52:26 <bshum> gmcharlt: Haven't had time to poke at the IRC log migration/consolidation quite yet.
13:52:29 <kmlussier> No progress to report today, but I'm really excited to work on it when I have the tuits.
13:52:42 <gmcharlt> we need to find a tuit mine ;)
13:52:52 <bshum> I think what I'm likely to do there is chat with the other web admins about how we plan to provision new VMs
13:53:04 <gmcharlt> ah, good idea
13:53:06 <bshum> And work on migrating/upgrading our logging infrastructure to something new.
13:53:16 * bshum hates squeeze :)
13:53:32 <gmcharlt> #action bshum to kick off a discussion with the other server admins regarding VMs & OS upgrades
13:53:33 <bshum> But more realistically, I'd like to expand our offerings if we can.
13:55:54 <gmcharlt> any other last minute topics?
13:57:23 <gmcharlt> ok
13:57:27 <gmcharlt> thanks everybody!
13:57:30 <gmcharlt> #endmeeting