14:00:24 <yboston> #startmeeting 2014-07-02 - DIG Monthly Meeting Evergreen Documentation Interest Group (DIG) Monthly Meeting.
14:00:25 <pinesol_green> Meeting started Wed Jul  2 14:00:24 2014 US/Eastern.  The chair is yboston. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:25 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:25 <pinesol_green> The meeting name has been set to '2014_07_02___dig_monthly_meeting_evergreen_documentation_interest_group__dig__monthly_meeting_'
14:00:33 <yboston> The agenda can be found here http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:dig_meeting_20140702-agenda
14:00:44 <yboston> #topic Introductions
14:00:45 <yboston> Please feel free to start introducing yourselves...
14:00:53 <yboston> #info yboston is Yamil Suarez @ Berklee college of Music - DIG meeting facilitator
14:01:08 <remingtron> #info remingtron is Remington Steed, Hekman Library (Calvin College)
14:01:11 <kmlussier> #info kmlussier is Kathy Lussier, MassLNC
14:01:15 <bshum> #info bshum is Ben Shum, Bibliomation
14:01:15 <kbutler> #info kbutler is Kate Butler, Rodgers Memorial Library (NH)
14:01:18 <rsoulliere> #info /me is Robert Soulliere, Mohawk College
14:01:26 <rsoulliere> #info rsoulliere is Robert Soulliere, Mohawk College
14:02:51 <yboston> (I will wait a few more seconds before starting)
14:03:31 <yboston> OK, lets start
14:03:54 <yboston> #topic any DIG memeber reports?
14:03:59 <yboston> *member
14:04:16 <rsoulliere> I can go
14:04:26 <yboston> go ahead
14:04:28 <rsoulliere> #topic Conversion Coordinator Report
14:04:38 <rsoulliere> #info  I updated the 2.5 upgrade instructions a few minutes ago.  Updatesd in the repo so should show up tomorrow in the official docs.  I hope to get the 2.6 upgrade instructions done in the next day or two.
14:04:52 <rsoulliere> Beginning next week, I will be away until September so I will miss the August meeting.
14:05:04 <rsoulliere> That is all. : -)
14:05:13 <yboston> rsoulliere++
14:05:36 <yboston> Kathy, did you have anything to report?
14:05:54 <kmlussier> Sorry, I wandered off for a minute. Sure.
14:06:05 <kmlussier> #topic Release Coordinator Report
14:06:32 <kmlussier> #info Nothing new to report, but I do intend to update the release notes with links to the documentation for new features.
14:06:45 <kmlussier> I basically was waiting to see if new docs would be added before moving forward.
14:06:48 <kmlussier> That's all I have.
14:06:58 <yboston> kmlussier++
14:07:25 <yboston> At this point I suggest we move to "old business"
14:07:49 <remingtron> Is there any old business?
14:08:08 <yboston> as stated in the agenda, we had the entry to finsih work on 2.6 new features
14:08:39 <remingtron> ah yes, that counts as old business
14:09:15 <yboston> #topic Old Business
14:09:56 <yboston> #topic New DIG Workflow: Document all new 2.6 features by July 1, and all new future version features by the time the version is released.
14:09:57 <yboston> #info To review: All members choose 1-3 new features to document each month, emailing the list with questions and calls for help.
14:09:58 <yboston> #info Progress Reports: How did this month go? Suggestions for improving the workflow? Tough features that need special attention?
14:09:59 <yboston> #info Assignments: Everyone choose another 1-3 remaining new features for the next month
14:10:30 <yboston> (Remington was right, this was actually listed as "priority business")
14:10:49 <yboston> any comments on our overall progress, or indiviudal progress?
14:10:53 <kmlussier> #link http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:2.6_needs
14:11:00 <remingtron> well, now that we cleared out "old business", we don't need "priority business"
14:11:36 <remingtron> I finished my marc_export docs and pushed them in, so I'm free to help others finish up
14:11:55 <kmlussier> I still need to do one more thing for my task on the removal of open-ils.ingest service. gmcharlt steered me in the right direction for updating a doc that included it as an opensrf service.
14:12:18 <kmlussier> I'm also free to help somebody, but not until I return from vacation on the 14th.
14:12:25 <kbutler> I finished 2 of the 3 places where I needed to put the info about the new settings for staff initials. I sent it to the mailing list (today) but they haven't come through yet.
14:13:29 <yboston> kbutler: which list did you use?
14:13:41 <kbutler> The docs list
14:13:52 <kmlussier> kbutler: Did you send it recently? I usually find my e-mail goes out on the list very quickly.
14:14:07 <yboston> I don't remember seeing it either
14:14:12 <kbutler> It's been a bout 30 or 45m at this point I think? A while. I haven't seen it.
14:15:17 <yboston> I just checled MarkMail and I on't see it.
14:15:24 <yboston> *don't
14:15:52 <yboston> kbutler: I would suggest you resend it and perhaps forward it to some of us so we can have a look at it.
14:15:59 <kbutler> Sure.
14:16:19 <kbutler> our mail server has been screwed up this week so it's entirely possible it's stuck somewhere. :P
14:16:21 <yboston> did you want to some questions now? or maybe near the end of the meeting?
14:16:34 <yboston> did you want to ASK some questions now?
14:17:20 <yboston> (or after the meeting, I can stay on IRC to help as much as I can
14:18:08 <yboston> I just wanted to add that I was able to add a nice section on basic usage of the OPAC, as a way to add info on the 2.6 WCAG feature
14:18:22 <remingtron> yboston++
14:18:46 <yboston> it was some work my intern did, and I added some "search URL" stuff that I had planned to add
14:18:52 <yboston> yay for deadliens
14:19:43 <kbutler> yboston++
14:19:47 <kmlussier> yboston: Was that info taken from the old 1.6 docs?
14:20:14 <yboston> I think so, but I think it also existed in 2.0
14:20:25 <kmlussier> yboston++
14:20:51 <yboston> now that I am getting a hang of the Git backporting, I think I can start putting a dent on adding the work the intern did
14:21:05 <kmlussier> yboston++
14:21:37 <yboston> any other comments or questions about the 2.6 new features? I wish that we had some ESi folks here, but according to their poll votes, they would not make it at this time
14:21:44 <remingtron> yboston: as you do, please add them to the DONE list here:
14:21:45 <remingtron> http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:todo
14:22:28 <remingtron> akilsdonk: do you have a minute to give us an update on ESI docs for 2.6 features?
14:22:48 <remingtron> we'll see if she has time to chime in
14:22:49 <yboston> I need to first add a listing of what the intern worked on, which is somewhere on the DIG wiki, and link it to the todo page
14:23:26 <kmlussier> FWIW, I don't think the EDI documentation jpringle signed up for pertains to a new 2.6 feature.
14:23:41 <kmlussier> At least, I can't recall any new EDI features in 2.6.
14:23:55 <yboston> #action yboston will update general DIG to do list page with the work doen for 2.6
14:24:12 <akilsdonk> remingtron: the ESI docs for 2.6 are written, we just need to commit them to the repository.
14:24:35 <akilsdonk> we can have them in next week.
14:24:48 <remingtron> akilsdonk: great! thanks for the update
14:24:55 <yboston> BTW, for those joining us late, feel free to introduce yourselves and check out the conversation log  http://irc.evergreen-ils.org/evergreen/2014-07-02#i_108936
14:25:05 <yboston> to catch up
14:26:06 <yboston> OK, we are at almost the half-way point.
14:26:40 <yboston> Should we continue more on the 2.6 ew features, or move to something else ?
14:26:58 <remingtron> I haven't heard anything from Elliot about his task in a while
14:27:34 <remingtron> I'll check in with him over email and make sure it gets reassigned if needed
14:27:45 <remingtron> how about we discuss plans for 2.7 and the web staff client?
14:27:45 <yboston> should one of us email him directly to help him out?
14:28:08 <yboston> thanks
14:28:40 <yboston> #action remingtron will check in on Elliot to see if he needs help with documenting "User Editor: “Update Expire Date” button "
14:29:48 <yboston> for a moment, can we go back to the Jenifer feature, so it might not be a 2.6 feature?
14:30:03 <yboston> "EDI account set up"
14:30:56 <remingtron> I probably added that from the preview of the release notes
14:31:03 <remingtron> was it a mistake in the release notes perhaps?
14:31:11 <remingtron> left over from 2.5 or something?
14:31:20 <kmlussier> AFAIK, there is nothing new to the EDI accounts. I don't think it was in the release notes either.
14:32:16 <yboston> we can pick a volunteer to cofirm if it was and take it out, perhaps then also start the 2.7 DIG new feature list with it
14:32:30 <yboston> I can start a page for 2.7
14:33:06 <kmlussier> If you look at the history for that wiki page, there was no mention of EDI account setup until Jennifer added it as a task.
14:33:07 <remingtron> based on wiki history, jihpringle added that task and assigned herself to it
14:33:18 <remingtron> kmlussier: right-o
14:33:53 <yboston> We can email her and coordinate to put that entry in 2.7 or the general to do page
14:33:56 <kmlussier> yboston: I look at that interface all the time. I can confirm with 99.9 percent certainty that it isn't new.
14:34:17 <kmlussier> Or, I should say, doesn't have anything new on it.
14:34:28 <yboston> kmlussier: 99.9% coming fom you is good enough for me
14:34:32 <remingtron> sure, no need to wait on that task. let's move on to 2.7
14:35:13 <yboston> I can take care of both, creating new page and moving the content
14:35:21 <remingtron> I think we should get an early start on documenting the web staff client interfaces
14:35:25 <remingtron> yboston++
14:35:52 <remingtron> web staff circ screens seem mostly operational now
14:35:58 <yboston> #action yboston will move EDI entry from 2.6 DIG new features and put it in a new 2.7 DIG new features page; also email Jenifer to warn her
14:37:25 <yboston> remingtron: I would like to run that by Bill to see if what he recommends
14:37:40 <remingtron> yboston: sounds wise
14:37:41 <yboston> in terms of what UI we should stay away from or which ones should stay similar
14:38:29 <yboston> I gues we can start with a new section under "using the OPAC" dedicated to the new client , with proper warnings
14:38:47 <yboston> that it is still in pre-realse form
14:38:53 <yboston> *release
14:39:21 <kmlussier> Under using the OPAC?
14:39:24 <remingtron> yboston: good point, we don't want to release any docs before the web interface is released
14:39:37 <yboston> I am sorry, under "using the staf client"
14:39:48 <kmlussier> Ok, that sounds better. :)
14:40:19 <kmlussier> I'm worried that things may still change as people offer feedback and testing begins.
14:40:23 <yboston> in theory we could do it as part of an index with warnings that this is pre-release features or we can in theory create a new Git branch for syaf client documentation to be merged later?
14:41:13 <remingtron> yeah, we could work in a collab branch and update things if they change
14:41:16 <yboston> BTW, kbutler I see your email now
14:41:41 <kbutler> yboston you may be the only one. :)
14:42:27 <yboston> remingtron: yes, Git collab branch sounds like a good idea
14:42:36 <kmlussier> I don't see it.
14:43:34 <yboston> so I see a few things that we need to assign volunteers for right now
14:43:47 <remingtron> yboston: I'll setup a collab branch and a bug report for work on the web staff client
14:44:03 <yboston> remingtron: that was the first one, save me some typing
14:44:16 <kbutler> kmlussier: looks like your email server decided it was spam (I got a bounceback).
14:44:42 <yboston> remingtron: no matter what Bill says, it will be very god pracitce for Git to create and use a collab branch
14:44:56 <yboston> but let us know what he says at this point, if that is OK with you
14:45:24 <yboston> sorry, that should have said, it would be very good practice for us DIG members to use a collab branch
14:45:47 <remingtron> yboston: yes, I'll ask Bill and make sure DIG knows what he recommends
14:45:48 <yboston> the other dangling issue is to help kate
14:46:10 <yboston> I can help her since it has to do with documenting older features, which I want to work on
14:46:26 <yboston> remington: BTW< should I make the "action: or do you want to do it?
14:47:12 <remingtron> I think you have to make the actions for them to stick
14:47:37 <yboston> #action yboston will help kbutler with her 2.6 task "Add granular settings for requiring staff initials for notes. "
14:47:46 <yboston> OK
14:47:59 <kbutler> Thanks yboston
14:48:42 <yboston> #action remingtron will reach out to Bill about what we can start documenting of the new browser staff client; also will experiment with setting up a Git collab brnach to work on
14:49:25 <yboston> BTW, should we add an agenda item to follow up on lingering 2.6 issues for next meeting?
14:49:55 <kmlussier> Sure, why not?
14:50:30 <yboston> #action yboston add item to April's DIG meeting agenda about following up on ligering 2.6 new features work
14:50:55 <yboston> so we are at the 50 minute mark
14:51:12 <remingtron> yboston: you mean August's meeting?
14:51:23 <yboston> darn it
14:51:52 <yboston> #action yboston add item to August DIG meeting agenda about following up on ligering 2.6 new features work
14:52:25 <remingtron> on to new business?
14:52:26 <yboston> does anyone have any questions they would like to ask, specially does that have not spoken yet? A quick conversation about 2.7?
14:52:54 <yboston> I was thinking of skipping new business for next meeting because of the time
14:53:03 <yboston> or putting it up on the mailing list
14:53:25 <kmlussier> I don't think there's much we can do for 2.7 until new features start going in.
14:53:50 <remingtron> kmlussier: I think there is a lot we could do with the web staff client
14:53:56 <yboston> are there any features that are "guaranteed" to be in so far?
14:54:07 <remingtron> at least scoping out how much will need to be changed in the docs
14:55:00 <remingtron> it might mean reading over all the circ UI docs
14:55:04 <kmlussier> remingtron: Sure, I was thinking of the features unrelated to the web client.
14:55:18 <remingtron> kmlussier: right, then I agree
14:55:33 <yboston> bshum: hypothetically are there any features that are "guaranteed" to be in  2.7 so far? so we can start trying to prepare the docs already
14:56:03 <yboston> bshum: it might be way to early for alost any new 2.7 feature, but wondering if something was definetly going
14:56:11 <yboston> *almost
14:57:02 <yboston> I guess, we can look into working on older features while we wait for the 2.7 features to be finalized
14:57:39 <yboston> I can send an email to the list to slect amonst ourselves some older features to work on, hopefull we can get newcomers involved too
14:58:28 <remingtron> yboston: yeah, let's focus on older features and web staff client updates now, then hopefully switch to new features as they come
14:58:39 <yboston> OK
14:58:46 <kmlussier> yboston: This list will give you an idea of what might be eligible for 2.7 http://bit.ly/1qyGrOx
14:59:02 <kmlussier> But until the code is tested, I don't think there's any guarantee that anything will definitely make the cut.
14:59:20 <yboston> thanks
14:59:48 <yboston> kmlussier: yes, without testing nothing should be guranteed
15:00:11 <kmlussier> So should we each commit to 1 to 3 features from the 2.5 list between now and the next meeting?
15:00:19 <yboston> you read my mind
15:00:34 * kmlussier is psychic. :)
15:00:55 <remingtron> +1
15:01:02 <kbutler> +1
15:01:03 <yboston> #action yboston start a thread on DIG mailing list on targeting small older docuemntation tasks for the month of July; like working on 1 to 3 features from the 2.5 list between now and the next meeting?
15:01:32 <remingtron> we're making progress! I'm so excited!
15:02:12 <yboston> it is 3:01 PM EST, any last thoughts or do we want to keep going?
15:02:29 <yboston> also, kbutler I am free to chat after the meeting if you want
15:02:34 <remingtron> I think we're ready to finish
15:02:37 <yboston> though I need to review your email carefully first
15:02:45 <kbutler> Sure. I'll be around for a bit.
15:02:46 <yboston> I think so too, but always like to offer a choice
15:03:16 <yboston> #endmeeting