#evergreen: Evergreen Developer Meeting - 2014-07-28

Meeting started by kmlussier at 15:07:55 US/Eastern (full logs).

Meeting summary

    1. Agenda is available at http://evergreen-ils.org/dokuwiki/doku.php?id=dev:meetings:2014-07-28 (kmlussier, 15:08:17)

  1. Introductions (kmlussier, 15:08:22)
    1. kmlussier is Kathy Lussier, MassLNC (kmlussier, 15:08:41)
    2. jeff is Jeff Godin, Traverse Area District Library (TADL) (jeff, 15:08:45)
    3. eeevil == Mike Rylander, Equinox Software (eeevil, 15:08:45)
    4. bshum is Ben Shum, Bibliomation (bshum, 15:08:50)
    5. Dyrcona is Jason Stephenson, MVLC (Dyrcona, 15:08:53)
    6. phasefx = Jason Etheridge @ ESI (phasefx, 15:08:54)
    7. gmcharlt = Galen Charlton, ESI (gmcharlt, 15:08:55)
    8. dbs is Dan Scott, Laurentian University (dbs, 15:09:05)
    9. dbwells is Dan Wells, Hekman Library (Calvin College) (dbwells, 15:09:09)
    10. RoganH = Rogan Hamby, SCLENDS (RoganH, 15:09:09)
    11. Dpearl1 is Dan Pearl, C/W MARS Inc. (DPearl1, 15:09:12)
    12. berick Bill Erickson, ESI (berick, 15:09:13)
    13. ldw = Liam Whalen, Sitka (ldw, 15:09:18)

  2. Action Items from Last Meeting (kmlussier, 15:11:07)
    1. dbwells to review and comment on conditional negative balance bug:https://bugs.launchpad.net/evergreen/+bug/1198465 (kmlussier, 15:11:24)
    2. csharp is Chris Sharp, GPLS (csharp, 15:13:20)
    3. ACTION: kmlussier and others to make time to test the latest branch. (kmlussier, 15:22:47)
    4. ACTION: dbwells to work on display ideas for negative balance branch (kmlussier, 15:23:09)

  3. OpenSRF release (kmlussier, 15:24:15)
    1. ACTION: jeff and csharp to test websockets work by the end of this week. (kmlussier, 15:29:50)
    2. ACTION: gmcharlt to cut alpha of OpenSRF the middle of next week (week of Aug. 4th) (kmlussier, 15:30:14)

  4. Evergreen maintenance releases (kmlussier, 15:31:16)
    1. 2.6.2 and 2.5.6 were released on 7/7 (dbwells, 15:31:56)
    2. AGREED: next round of point releases will be scheduled for August 7 (kmlussier, 15:50:05)

  5. Evergreen 2.7 release (kmlussier, 15:51:32)
    1. 2.7.0 alpha1 was cut and available from downloads page on Evergreen website (bshum, 15:53:10)
    2. 2.7.0 beta1 cutoff date is August 7, 2014 (next Thursday) (bshum, 15:53:34)
    3. https://bugs.launchpad.net/evergreen/+bug/1347774 (kmlussier, 15:58:37)
    4. any new features for 2.7 should have a pullrequest tag by July 31. (kmlussier, 16:06:10)
    5. HELP: We need volunteers to test and push code for 2.7 (kmlussier, 16:06:30)
    6. http://markmail.org/message/i52gh26swaewnqzo (kmlussier, 16:10:28)

  6. Bug Squashing Days (kmlussier, 16:10:39)
    1. ACTION: kmlussier to move Sandbox discussion to dev list (kmlussier, 16:18:29)

  7. Web client's circulation module preview for Evergreen and websockets for OpenSRF (kmlussier, 16:19:42)
    1. ACTION: berick to add an LP bug for web based circ client with notes on pre-reqs and a list of existing client interfaces that need special attention. (kmlussier, 16:28:59)


Meeting ended at 16:30:11 US/Eastern (full logs).

Action items

  1. kmlussier and others to make time to test the latest branch.
  2. dbwells to work on display ideas for negative balance branch
  3. jeff and csharp to test websockets work by the end of this week.
  4. gmcharlt to cut alpha of OpenSRF the middle of next week (week of Aug. 4th)
  5. kmlussier to move Sandbox discussion to dev list
  6. berick to add an LP bug for web based circ client with notes on pre-reqs and a list of existing client interfaces that need special attention.


Action items, by person

  1. berick
    1. berick to add an LP bug for web based circ client with notes on pre-reqs and a list of existing client interfaces that need special attention.
  2. csharp
    1. jeff and csharp to test websockets work by the end of this week.
  3. dbwells
    1. dbwells to work on display ideas for negative balance branch
  4. gmcharlt
    1. gmcharlt to cut alpha of OpenSRF the middle of next week (week of Aug. 4th)
  5. jeff
    1. jeff and csharp to test websockets work by the end of this week.
  6. kmlussier
    1. kmlussier and others to make time to test the latest branch.
    2. kmlussier to move Sandbox discussion to dev list


People present (lines said)

  1. kmlussier (80)
  2. bshum (58)
  3. eeevil (39)
  4. gmcharlt (32)
  5. berick (25)
  6. jeff (23)
  7. Dyrcona (15)
  8. dbwells (14)
  9. csharp (11)
  10. pinesol_green (9)
  11. hopkinsju (3)
  12. ldw (3)
  13. phasefx (2)
  14. RoganH (2)
  15. DPearl1 (2)
  16. dbs (2)
  17. vlewis (1)
  18. hopkinsju_ (1)
  19. yboston (1)


Generated by MeetBot 0.1.4.