14:00:33 <yboston> #startmeeting 2014-08-07 - DIG Monthly Meeting Evergreen Documentation Interest Group (DIG) Monthly Meeting
14:00:33 <pinesol_green> Meeting started Thu Aug  7 14:00:33 2014 US/Eastern.  The chair is yboston. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:33 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:33 <pinesol_green> The meeting name has been set to '2014_08_07___dig_monthly_meeting_evergreen_documentation_interest_group__dig__monthly_meeting'
14:00:49 <yboston> The agenda can be found here http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:dig_meeting_20140807-agenda
14:01:07 <yboston> #topic Introductions
14:01:07 <yboston> Please feel free to start introducing yourselves...
14:01:17 <yboston> #info yboston is Yamil Suarez @ Berklee college of Music - DIG meeting facilitator
14:01:21 <remingtron> #info remingtron is Remington Steed, Hekman Library (Calvin College)
14:01:29 <kmlussier> #info kmlussier is Kathy Lussier, MassLNC
14:02:02 <jihpringle> #info jihpringle is Jennifer Pringle, BC Libraries Cooperative
14:02:26 <RoganH> #info RoganH = Rogan Hamby, SCLENDS
14:02:55 <yboston> btw, a fewminutes ago I updated the meeting agenda and pasted last  meeting's agenda items for us to quickly review during this meeting
14:03:07 <yboston> at this link http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:dig_meeting_20140807-agenda
14:03:15 <yboston> #link http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:dig_meeting_20140807-agenda
14:03:48 <Christineb> #info Christineb is Christine Burns, BC Libraries Cooperative
14:04:28 <yboston> My timer went off, so I wil start
14:04:52 <yboston> #topic old business - last meeting's action items
14:05:19 <yboston> #info yboston is Yamil Suarez @ Berklee college of Music - DIG meeting facilitator
14:05:38 <yboston> action: yboston will update general DIG to do list page with the work doen for 2.6
14:05:58 <yboston> I did some opdating, but I need to add info on the ESI controbutions
14:06:08 <yboston> (sorry for spelling)
14:06:27 <kmlussier> yboston: We know what you're sayind.
14:06:32 <yboston> any comments on this old action item?
14:06:41 <remingtron> are the ESI contribs all in master?
14:06:55 <yboston> I put htem all in master
14:07:01 <yboston> tpp
14:07:03 <yboston> too
14:07:20 <yboston> I have not finished fixing the issues in Erica's docs
14:07:34 <yboston> just fixed one so far, where she used a curly apostrophe
14:07:51 <yboston> still trying to fix all the other hidden characters
14:07:56 <yboston> for the record...
14:08:10 <yboston> I pushed a bunch of ESI docs yesterday
14:08:30 <yboston> remingtron today noticed that the docs did not get built last night
14:08:39 <yboston> because the new docs had some issues
14:09:29 <remingtron> let me know if you need any help fixing those. I am available tomorrow
14:09:31 <yboston> I will work on fixing the issues with those docs, and the concern is that until they are fixed the master and 2.6 docs will not be created tonight either
14:10:08 <yboston> makes me want to automatically cache the previous day's good docs for when this happens
14:10:44 <remingtron> I think the previous day's good docs stay live
14:11:01 <remingtron> I don't think it produces broken docs or anything like that
14:11:15 <yboston> I think the PDF's might not get made
14:11:20 <remingtron> it just quits and says "never mind, I'll try again tomorrow"
14:11:42 <remingtron> right, I think nothing new gets made, but it doesn't break the live docs, I believe
14:11:48 <yboston> the PDF link gives a 404 right now
14:11:51 <yboston> for 2.6
14:11:55 <remingtron> oh, not good
14:12:22 <remingtron> however, the pdf is not very usable these days, so it's not a high priority to me. anyone else use it?
14:12:24 <yboston> I thought you knew :(
14:12:44 <yboston> You can do full text searches quite nicely on PDFs
14:12:51 <yboston> that is one reason I look at it
14:12:51 <kmlussier> remingtron: I never use it, but I generally don't like PDF.
14:13:27 <kmlussier> remingtron: Why do you say it isn't very usable. Is it something about the way we create our docs?
14:13:29 <yboston> the epub file look fine, not sure if it is new or not
14:14:06 <remingtron> kmlussier: the pdf is hundreds of pages long, often screenshots are too large for the page
14:14:22 <remingtron> it isn't terrible, so maybe it's plenty usable
14:14:27 <kmlussier> remingtron: Good to know. I'll have to look at it sometime.
14:15:04 <kmlussier> I wonder if we could split the PDF into different sections. Make it a little more manageable.
14:15:52 <yboston> should we table that discussion (PDFs) for later or should we continue on it now?
14:16:05 <kmlussier> yboston: Table it for later
14:16:14 <remingtron> yeah, let's table it
14:16:24 <remingtron> good call
14:16:36 <yboston> should I make it an action item or do either of you want to just get back to us on it?
14:16:59 <remingtron> kmlussier: important to you? or should we forget it till it comes up again?
14:17:00 <yboston> we can make a long term goals list somewhere on the wiki?
14:17:14 <remingtron> yboston: good idea
14:17:21 <remingtron> I'll make that wiki page!
14:17:28 <kmlussier> Sounds like a good long term goal.
14:17:28 <remingtron> because I love wikis!
14:17:37 <yboston> I would tie the issue of screenshot size to the DIG style guide
14:17:38 <kmlussier> remingtron++ #wiki love
14:17:39 <yboston> work
14:18:26 <yboston> so I can assign the craetion of a long term goal wiki page to remingtron?
14:18:37 <remingtron> yes
14:19:06 <yboston> #action remingtron will create a DIG long term goals wiki page and will include ideas for improving PDFs
14:19:27 <yboston> last thing I will say on the earlier topic is that ...
14:19:56 <yboston> also, remingtron, dbs and I talked today on IRC about making plans to have a seperate server to build docs earlier in the day to catch build errors
14:20:13 <yboston> of course this is another good long/short term goal
14:20:32 <yboston> will move to the rest of the old action items, if that is OK
14:21:26 <remingtron> great, thanks for keeping us on track
14:21:29 <yboston> action: remingtron will check in on Elliot to see if he needs help with documenting "User Editor: “Update Expire Date” button "
14:22:04 <remingtron> yup, I ended up doing it, basically just new screenshots and a little note
14:22:09 <remingtron> it's in 2.6 and master now
14:22:12 <kmlussier> remingtron++
14:22:35 <yboston> remingtron++
14:22:58 <yboston> anything else to add? comments/questions from anybody else?
14:23:35 <yboston> moving on
14:23:41 <yboston> action: yboston will move EDI entry from 2.6 DIG new features and put it in a new 2.7 DIG new features page; also email Jenifer to warn her
14:24:08 <yboston> mostly done, but I don't think the email said I was moving the content, which I did
14:24:34 <kmlussier> jihpringle: Is it really a new feature for 2.7 or is it documenting something that's always been there?
14:24:59 <jihpringle> when I looked at EG it turns out it was documenting something that had always been there
14:25:11 <jihpringle> it's done, I just haven't submitted it yet
14:25:20 <kmlussier> Ah, ok. Thanks for the clarification.
14:25:43 <yboston> lets us know if you need any help
14:26:01 <remingtron> jihpringle: whenever you want to share it, just send the files or links to the email list and we can coach or help you through the process
14:26:01 <yboston> anything else to add? comments/questions from anybody else?
14:26:05 <jihpringle> will do, thanks and apologizes for the delay
14:26:17 <yboston> no problem at all
14:26:19 <remingtron> jihpringle: no worries, thanks for your work!
14:26:22 <remingtron> jihpringle++
14:26:37 <kmlussier> jihpringle++
14:26:51 <yboston> action: yboston will help kbutler with her 2.6 task "Add granular settings for requiring staff initials for notes. "
14:27:18 <yboston> I worked on this, but we are not done.
14:27:34 <yboston> Thankfully, Kate contacted us today before I could get her to give us an update
14:27:47 <yboston> "I will not be able to make the DIG meeting today.  So, my report is that I haven't made any appreciable progress on the new piece of documentation I was working on. Our summer reading programs end this week so things should finally calm down enough for me to get on to it."
14:28:18 <yboston> I will follow up with in the next few weeks
14:28:32 <remingtron> do you know what is missing?
14:28:49 <remingtron> her branch seems to have the release notes part
14:28:49 <yboston> I think there might be a need
14:29:13 <yboston> for a section that talks about the basics of the patron "messages" UI, for her to add a small note
14:29:40 <remingtron> ok
14:29:42 <yboston> I started searching to see if any documentation existed by doing a raw grep, but I never finsihed analyzing my results
14:30:11 <remingtron> FYI, the docs has a google search now, which does pretty well at searching all version of the docs
14:30:17 <yboston> I looked at it briefly today, and noticed something promising
14:30:45 <yboston> remingtron: I keep forgetting to sue that nice feature, and your recommendations means a lot
14:30:58 <yboston> #action yboston will help kbutler with her 2.6 task "Add granular settings for requiring staff initials for notes. "
14:31:08 <yboston> will move on...
14:31:18 <yboston> action: remingtron will reach out to Bill about what we can start documenting of the new browser staff client; also will experiment with setting up a Git collab brnach to work on
14:31:29 <yboston> (btw, we are at the 30 minute mark)
14:32:07 <remingtron> http://markmail.org/thread/7qhj665rk5vaag65
14:32:12 <remingtron> that's my message to the DIG email list
14:33:13 <yboston> this could be a great way for DIG newcomers to help out, or at least get some practive
14:33:33 <yboston> since you can just use a web browser, and not need to install software
14:33:43 <remingtron> I agree! I'm looking for a volunteer to poke around Bill's test version of the web client and try editing a current doc to reflect the new web interface.
14:34:15 <remingtron> https://bill-dev2.esilibrary.com/eg/staff/login?route_to=%2Feg%2Fstaff%2Fcirc%2Fpatron%2Fsearch
14:34:29 <yboston> do we want to email folks on the general list to get them interested in helping?
14:34:46 <remingtron> sure, I can do that
14:34:59 <yboston> are there any folks right now watching this meeting that would like to help out?
14:35:18 <yboston> you can contact any of us off the IRC channel if you prefer
14:36:26 <yboston> how is this? action: remingtron will ask for volunteers to help with docuemnting the new browser staff client on the general EG list
14:36:40 <remingtron> perfect
14:36:57 <yboston> #action remingtron will ask for volunteers to help with documenting the new browser staff client on the general EG list
14:37:11 <yboston> anything else to add? comments/questions from anybody else?
14:37:39 <yboston> action: yboston add item to August DIG meeting agenda about following up on ligering 2.6 new features work
14:37:48 <yboston> we have mostly addressed this already, I think?
14:38:16 <yboston> last one...
14:38:18 <yboston> action: yboston start a thread on DIG mailing list on targeting small older docuemntation tasks for the month of July; like working on 1 to 3 features from the 2.5 list between now and the next meeting?
14:38:45 <yboston> I never got a chance to do this one, will push to next meeting or further if we thinkwe will be too busy with EG 2.7 work
14:38:59 <yboston> thoughts?
14:39:38 <remingtron> hard to tell yet, since 2.7 beta is today, we don't have release notes yet
14:39:53 <remingtron> I'd say push it to next meeting for now
14:40:02 <yboston> that is what I needed, hard to facilate a meeting and use my brain at same time :)
14:40:14 <remingtron> understandable!
14:40:40 <yboston> #action yboston start a thread on DIG mailing list on targeting small older docuemntation tasks for the month of August; like working on 1 to 3 features from the 2.5 list between now and the next meeting?
14:40:49 <yboston> on to new business
14:41:35 <yboston> #topic DIG needs to start looking at 2.7 new features
14:41:53 <yboston> S skipped to this one, becuase of what remingtron just mentioned
14:42:01 <kmlussier> I went through LP bugs last week to remind devs to add release notes where they were missing.
14:42:26 <kmlussier> I was planning tomorrow to set up a wiki page similar to the ones from past releases to identify new features that need documentation.
14:42:56 <yboston> so far I have been able to create release notes for two features that two developers worked on. was nice to work witht he devs
14:43:12 <yboston> and getting so much better at git int he process
14:43:23 <remingtron> yboston++ #working with devs
14:43:37 <remingtron> kmlussier++ #making the feature list
14:43:42 <kmlussier> IIRC, our goal this time is to try to get the docs done by the full release. Is that right?
14:43:44 <yboston> kmlussier++
14:44:11 <remingtron> kmlussier: yes, if we can!
14:44:20 <remingtron> and getting closer to our goal each release
14:44:26 <kmlussier> Looking at the dev calendar, that's September 18.
14:44:30 <yboston> kmlussier: that is what I understood, and we got somewhat close to 100% with 2.6
14:44:42 <remingtron> sooo....do we need a DIG hack-a-way before then?
14:44:53 <kmlussier> remingtron: Might not be a bad idea.
14:45:04 <yboston> I am open to it
14:45:12 <remingtron> otherwise, I suggest more frequent DIG meetings
14:45:28 <kmlussier> remingtron: Would those be working DIG meetings?
14:45:29 <remingtron> (could be shorter, just progress updates and encouragement)
14:45:54 <kmlussier> Ah, I see. That could work too. But I think the benefit of a DIG hack-a-way is that you set aside the time to work on docs.
14:45:56 <yboston> should it be after the bug day (forgot name)?
14:46:18 <yboston> bug squashing day?
14:46:23 <jihpringle> I think so, some of those bugs may end up in 2.7
14:46:41 <remingtron> well, bugs won't usually affect the docs
14:46:49 <yboston> let me clarify
14:47:10 <yboston> some new fixes / fetures might not make it in until bug squashing day
14:47:11 <kmlussier> For scheduling purposes, I think it would be easier to do it after Bug Squashing Day. Probably early September?
14:47:24 <yboston> because the features needed testers
14:47:46 <kmlussier> New features can't go into the release after today.
14:48:04 <yboston> my bad, then just bug fixes
14:48:24 <yboston> hard to keep this in my head in the heat of the moment
14:49:20 <yboston> note the dev hack-a-way is the week of 22nd in September
14:50:30 <yboston> to recap: we are debating when to have the DIG hack-way, timed to help us finish EG 2.7
14:50:51 <yboston> and after today there is a freeze on new features making it into 2.7
14:51:08 <kmlussier> OK, so it looks like we need 2 action items here? One for me to identify 2.7 doc needs and another for someone to do a Doodle poll for a DIG hack-a-way?
14:51:34 <yboston> my brain was slowly moving to that conclusion
14:52:03 <remingtron> are any of you going to the developer hack-a-way?
14:52:17 <yboston> I am
14:52:32 <remingtron> I don't think I can make it
14:52:55 <remingtron> wondered if it's a good or bad idea to have DIG hackaway the same day
14:52:56 <yboston> how are these... action:  kmlussier(and others) identify 2.7 doc needs and add to the 2.7 wiki page
14:53:04 <bshum> Fwiw, this year, I voted towards making the Hack-A-Way after the expected release date for 2.7.0 so that we would avoid having developer interests affect 2.7's final outcome.
14:53:26 <bshum> If you want docs ready for 2.7, then doing it earlier, like late August / early September seems like a better date range to me.
14:53:43 <remingtron> +1
14:53:53 <bshum> Late August will give more time to stablize everything in 2.7 and get more test servers going for doc purposes too, I would assume.
14:53:55 <RoganH> fwiw, as well, that was part of my goal for the scheduling the hack-a-way as well based on discussion at the conference
14:54:44 <kmlussier> Sorry, it looks like I dropped out for a second. I prefer to keep dev and doc hack-a-ways separate.
14:54:56 <yboston> #action kmlussier(and others) identify 2.7 doc needs and add to the 2.7 wiki page
14:55:25 <yboston> I need to work on more dev work, and I can't help run DIG things at the same time
14:55:58 <yboston> though I will gladly help with docs during the dev hack-a-way
14:56:48 <yboston> who would liek to set up a poll and email the DIG list about scheduling the DIG dev hack-a-way?
14:57:08 <yboston> and thanks to bshum and RoganH for their feednack
14:57:14 <yboston> *feedback
14:57:38 <yboston> (I am glad most of you have gotten emails from me and heard me speak when I am not in a hurry)
14:57:59 <kmlussier> LOL. It's part of the medium.
14:58:53 <jihpringle> I can set up the poll and email the list - are we agreed on sometime in first two weeks of September?
14:59:59 <yboston> we might be able to use the thrid week of September too?
15:00:15 <yboston> at least the early part of that third week if need be
15:01:01 <jihpringle> k, I'll put out dates between Sept 3rd and Sept 17th
15:01:11 <yboston> jihpringle: I can provide dates that I can host folks in our confrence room
15:01:31 <yboston> though I expect most will work remotely
15:01:45 <jihpringle> that's great
15:01:56 <kmlussier> yboston: If there are dates that won't work for your conference room, I could probably find anyother place in MA that could host.
15:02:30 <yboston> #action jihpringle will set up a doodle poll and email the DIG list to coordinate a DIG hack-a-way tageting EG 2.7 feaures before its officail release
15:03:05 <yboston> #action yboston , kmlussier  and others will send dates when they can host folks for the DIG hack-a-way
15:03:17 <jihpringle> are libraries closed in the US on Patriot Day? (looking at the holidays on my calendar)
15:03:18 <yboston> BTW, we are right past the one hour mark
15:03:25 <remingtron> sorry, had a phone call, I'm back now
15:03:39 <kmlussier> jihpringle: We're closed on Labor Day. First Monday of the month.
15:03:52 * kmlussier doesn't know if it's the same day.
15:03:55 <jihpringle> but not third Monday of Sept
15:04:31 <kmlussier> No, the third Monday of the month isn't a holiday here.
15:04:43 <yboston> For the record, Patriot Day (Sept 11) not to be confused witht the local New England holiday of "PatriotS Day," the day in April the run the Boston Marathon
15:05:06 <jihpringle> thanks, Patriot's Day is what come up with I googled
15:05:32 <jihpringle> just didn't want to offer a day most people woulnd't be available on
15:05:46 <yboston> did we want to start wrapping up the meeting? any final comments or questions?
15:06:08 <remingtron> jihpringle++ #making the poll
15:06:19 <yboston> jihpringle+
15:06:25 <yboston> jihpringle++
15:06:34 <yboston> also
15:06:39 <yboston> remingtron++
15:07:02 <remingtron> plus's all around!
15:07:23 <remingtron> I forgot, we need cake to celebrate getting 2.6 documented!
15:07:30 <remingtron> @dessert
15:07:30 * pinesol_green grabs some Banana Puddin' for remingtron
15:07:31 <yboston> since meeting remingtron at last year's dev hack-a-way, DIG has made a lot of progress
15:07:56 <remingtron> since meeting yboston last year, life has been awesomer
15:08:11 <yboston> thanks, too bad you can't make it this year, but we can figure out a way so that we can still collaborate
15:08:29 * remingtron shares Banana Puddin' with everyone
15:08:48 <yboston> besides high fives, any last thoughts?
15:09:31 <remingtron> everybody watch the email list
15:09:43 <yboston> OK ending the meeting
15:09:45 <remingtron> and we'll get rolling on 2.7
15:09:55 <remingtron> yboston++
15:10:07 <yboston> #endmeeting